14:59:50 <regXboi> #startmeeting neutron_northbound
14:59:50 <odl_meetbot> Meeting started Fri Sep 25 14:59:50 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:59:50 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:50 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
14:59:55 <regXboi> #chair flaviof edwarnicke
14:59:55 <odl_meetbot> Current chairs: edwarnicke flaviof regXboi
15:00:02 <regXboi> #topic roll call and agenda bashing
15:00:05 <regXboi> #info regXboi
15:00:13 <edwarnicke> #info edwarnicke
15:00:15 <flaviof> #info flaviof
15:00:19 <yamahata> #info yamahata
15:00:24 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.289.2F25.29 agenda in usual place
15:01:11 <regXboi> #info apologies for no meeting last week - regXboi was at hematologist for daughter
15:01:45 <john-a-joyce> #info john_a_joyce
15:02:09 <regXboi> we'll give a few more minutes for folks to gather up and all to look at the agenda
15:02:22 <regXboi> and for regXboi to correct something :)
15:05:11 <regXboi> ok...
15:05:18 <regXboi> #topic action items from last meeting
15:05:31 <regXboi> #info edwarnicke, flaviof, regXboi to look at bug 3990
15:05:41 <regXboi> I've not had a chance to look at this - anybody else?
15:05:58 * flaviof did
15:06:05 <flaviof> in that particular case, it is oom
15:06:06 <regXboi> although I am thinking this is j7 related and I have a topic on that later :)
15:06:19 <regXboi> ok, maybe not then
15:06:22 <flaviof> right, the real issue is jdk7 race
15:07:03 <regXboi> so I have colindixon looking up the reference to see if we have decided to not support j7 in Be
15:07:11 <flaviof> if you look at log for 3990, you will see "java.lang.OutOfMemoryError: PermGen space^M"
15:07:21 <regXboi> regXboi summons colindixon to hopefully provide reference
15:07:40 <regXboi> flaviof: so I'm going to merge this into the j7 discussion later - ok?
15:08:06 <flaviof> regXboi: ack. good plan.
15:08:12 <regXboi> moving on then
15:08:31 <regXboi> #info this item folds into merge/verify job instability topic later
15:08:39 <regXboi> #info 2.  yamahata to check and comment on bug 4026
15:08:51 <yamahata> I did. It was fixed.
15:09:09 <regXboi> yamahata: ack and thank you!
15:09:17 <yamahata> During test, I found another bug in ovsdb routemgr. I filed it as another bug
15:09:26 <regXboi> #info item fixed, but dependent bug for ovsdb routemgr has been filed
15:09:42 <regXboi> #info 3. yamahata to add test cases to PS 26266 and 26267
15:09:48 <regXboi> #info that one is done because ...
15:09:55 <regXboi> #info 4. regXboi to review and merge 26266 and 26267 once test cases are in place
15:10:02 <regXboi> #info regXboi did that one this morning :)
15:10:09 <yamahata> thank you for review.
15:10:24 <regXboi> you are very welcome - thank you for doing the heavy lifting
15:10:36 <flaviof> regXboi: +1 on that ty
15:10:41 <regXboi> #info 5. yamahata to fix up https://git.opendaylight.org/gerrit/#/c/25500/
15:10:56 <regXboi> #info this has been done and the patch is in the list for looking at later
15:11:00 <yamahata> I uploaded a new patch. But it needs one more patch probably.
15:11:19 <regXboi> ack - I think we are going to need a fair number of rebases when 24042 lands
15:11:38 <regXboi> #info 6. regXboi to look at adding out of order IT tests to catch other issues like bug 4188
15:11:48 <regXboi> I haven't done this - I was spending time on 24042 so...
15:11:51 <regXboi> #action regXboi to look at adding out of order IT tests to catch other issues like bug 4188
15:12:10 <regXboi> #info 7. edwarnicke to work with BGPVPN and GBP projects about getting their dependency on NN into their JJB configs so that integration on merge is handled correctly
15:12:17 <regXboi> #info this is done - I saw the patches merge :)
15:12:21 <regXboi> thanks, edwarnicke
15:12:22 <edwarnicke> regXboi: :)
15:12:33 <regXboi> #info 8. regXboi to schedule network to device map patch set at top of list for 9/18 meeting
15:12:39 <regXboi> we didn't meet 9/18 so this didn't happen
15:12:53 <regXboi> I'm going to schedule it for 10/2 because we've got bigger fish to fry today
15:12:54 <regXboi> so
15:13:01 <regXboi> #action regXboi to schedule network to device map patch set at top of list for 10/2 meeting
15:13:11 <regXboi> #topic Merge and verify Job Instability
15:13:17 <flaviof> regXboi: can you elaborate on what that is?
15:13:34 <flaviof> re: device map patch
15:13:34 <regXboi> flaviof: that is Wojeich's patch
15:13:44 <flaviof> ah, ok.
15:13:46 <regXboi> to map devices to networks
15:13:51 <regXboi> or something like that
15:13:57 <flaviof> understood
15:14:04 <regXboi> #info We are seeing org.opendaylight.yangtools.binding.data.codec.impl.MissingClassInLoadingStrategyException on org.opendaylight.yangtools.binding.data.codec.impl.MissingClassInLoadingStrategyException way too much w.r.t the merge and j7 verify jobs
15:14:19 <regXboi> #info now, regXboi has not seen this with j8 and j7's EOL was 5/2015
15:14:33 <regXboi> #info regXboi has asked colindixon if ODL is supporting j7 for Be
15:14:43 <edwarnicke> regXboi: Ah
15:14:44 <edwarnicke> regXboi: Wait
15:14:45 <regXboi> #link https://git.opendaylight.org/gerrit/27434 Change Berrylium neutron jobs to use j8
15:14:52 <flaviof> my only ’concern’ with gerrit 27434 is that it will mask race issue that jdk 8 is not exposing.
15:14:52 <edwarnicke> regXboi: I may have an idea of the underlying cause (maybe)
15:15:01 <flaviof> we could be lucky and it is a idk 7 only problem, in which case it still remains a problem for stable/lithium.
15:15:06 <flaviof> edwarnicke: say more!!!!
15:15:09 <edwarnicke> That sounds suspiciously like we may be failing to correctly declare our dependencies on our models in our impl
15:15:11 <regXboi> edwarnicke give me a second to finish up first
15:15:14 <edwarnicke> (in the capabilities section)
15:15:27 <regXboi> #info link is pending patch .... however....
15:15:50 <regXboi> #info edwarnicke thinks it may be an issue with model dependency declarations in the implementation
15:15:56 <edwarnicke> #undo
15:15:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ba97d0>
15:16:02 <regXboi> ok edwarnicke correct that :)
15:16:06 <edwarnicke> I just checked, we are not making the mistake I suspected
15:16:29 <regXboi> #info edwarnicke thought it might have been an issue with model dependency declarations in the implementation, but sadly it was not
15:16:34 * edwarnicke has another theory
15:16:48 * regXboi has sudden visions of Anne Elk
15:17:01 <edwarnicke> It may be related to random bundle load order stuff with when neutron-spi loads
15:17:14 <flaviof> edwarnicke: I can readily reproduce this isse in my system, which is running jdk7.
15:17:47 <edwarnicke> flaviof: Hmm... any more data to add then?
15:18:11 <regXboi> so folks, I'm happy to have folks fix this, but if we aren't supporting j7, the patch is still valid :)
15:18:14 <flaviof> edwarnicke: that is the thing, until recently we had no -Dkaraf.debug, but now we do
15:18:23 <flaviof> just that I have not gone back and tried to poke around.
15:18:36 <regXboi> flaviof: can we action you with that?
15:18:38 <regXboi> :)
15:18:40 <edwarnicke> flaviof: Thank you for getting the -Dkaraf.debug in :)
15:18:45 <flaviof> still, I and far from being good at maven deps stuff, so your help would be huge
15:19:01 <edwarnicke> flaviof: One warning though, race conditions often evaporate under debug :(
15:19:04 <flaviof> edwarnicke: np. kudos are on you and skitt
15:19:12 <regXboi> #action flaviof, edwarnicke to use -Dkaraf.debug to see if they can get more information on this problem
15:19:32 <flaviof> regXboi: +1
15:19:49 <regXboi> #info to see if it is j7 specific or if it may later bite us w.r.t j8
15:20:01 <regXboi> ok, let's move on :)
15:20:06 <regXboi> #topic open patch sets
15:20:17 <regXboi> #info note: some of these are -1 because of the above problem :(
15:20:28 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/24042/ reversion yang model
15:20:37 <regXboi> this is *finally* ready to go
15:20:51 <regXboi> modulo the above problem :(
15:21:27 <regXboi> so if folks could look at it that would be great
15:21:55 <regXboi> and we'll have to let all the dependent projects know that they have to update because this *WILL* break downstream
15:22:08 <regXboi> some downstreams are already broken, but this will take them all out :)
15:22:42 <regXboi> #link https://git.opendaylight.org/gerrit/24598 Addressed review comments, added remaining APIs.(Added yang, APIs, Transcriber for L2gateway)
15:22:44 <flaviof> regXboi: ack. better sooner then later.
15:22:57 <regXboi> I've not had a chance to look at the above
15:23:00 <regXboi> so I can't comment on it
15:23:41 <flaviof> looks to me that it needs to be rebased still
15:23:47 <regXboi> other than to say that it will need a rebase after 24042 merges
15:23:50 <flaviof> the gerrits it was waiting on are merged
15:23:58 <flaviof> ack
15:24:10 <regXboi> I'm going to -1 it to say it should wait for 24042
15:24:23 <flaviof> regXboi: +1
15:24:31 <regXboi> so done
15:24:53 <regXboi> #link https://git.opendaylight.org/gerrit/26711 BGPVPN: Added yang, api and transcriber for BGPVPN
15:25:41 <regXboi> so I'd like to hear Thomas' feedback
15:25:47 <regXboi> but otherwise I think this can go in
15:25:55 <regXboi> it doesn't look like it will need an obvious rebase
15:26:22 <regXboi> does anybody here know Thomas?
15:26:29 <regXboi> and could reach out directly?
15:26:46 <vthapar> Prem [vpnservice PTL] has been in touch with him
15:26:49 <vthapar> will let him know
15:27:03 <regXboi> ack and thanks
15:27:34 <regXboi> #link https://git.opendaylight.org/gerrit/25500 Bug 4354 - neutron tenant_id doens't contain '-'(dash)
15:27:53 <regXboi> where are we on this?
15:28:28 <yamahata> It fixes 4354 itself. I need to test with tempest.
15:29:05 <regXboi> ok, I'll wait on those results - if you could update with them that would be great
15:29:23 <regXboi> #action yamahata to test https://git.opendaylight.org/gerrit/25500 with tempest and report results
15:29:34 <regXboi> lastly (for today)
15:29:55 <regXboi> #link https://git.opendaylight.org/gerrit/27334 - this is in merge conflict
15:30:28 <yamahata> I'll rebase it.
15:30:41 <regXboi> and I'm really nervous about exposing transaction chains outside of the transcriber - edwarnicke, your thoughts?
15:31:19 <edwarnicke> regXboi: I am a bit nervous about that too... yamahata ... why are you exposing them? (curious to understand your reasoning ;) )
15:32:01 <yamahata> So it shouldn't be exposed to northbound? Okay.
15:32:29 <edwarnicke> yamahata: Note: That's not a hard and fast rule, just a gut feel.  If you have some useful reason why you think its a good idea, I'd be more than happy to hear it ;)
15:32:44 <yamahata> I though transaction chain  is for optimization.
15:33:14 <yamahata> I didn't have strong reason. I did because it can be optimized...
15:34:28 <regXboi> well, I asked because it felt like layer violation, but like edwarnicke, if there is a good reason, I can be convinced
15:34:56 <edwarnicke> regXboi: I don't have a good reason, but my normal instincts when someone smart (like yamahata ) does something that doesn't make sense to me is to seek to understand ;)
15:35:14 <edwarnicke> yamahata: optimized how?
15:35:15 <regXboi> edwarnicke; we are saying the same thing
15:35:18 <yamahata> I'm fine with dropping 27334
15:35:19 <odl-casey> Morning everyone.
15:35:47 <regXboi> yamahata: I'm not looking to drop it yet
15:35:56 <regXboi> I'm trying to understand what it buys us
15:36:03 <regXboi> because I don't yet see it
15:36:10 <yamahata> I wasn't sure at which layer to use transaction chain. transcriber or northbound. So I put patches to get feedback.
15:36:18 <regXboi> ah
15:36:21 <odl-casey> Omitting my obvious voice-to-text fail of you're / your in the email I just sent to the discuss list...  can I ask everyone a favor?
15:36:51 <odl-casey> Can I ask that everyone update their ODL Identity information?
15:36:56 <odl-casey> Pretty please. :)
15:37:00 <odl-casey> https://identity.opendaylight.org/carbon/userprofile/index.jsp?region=region5&item=userprofiles_menu
15:37:26 <yamahata> The feedback seems chain should be done at transcriber. not northbound. Right?
15:38:07 <flaviof> hey odl-casey ! good to hear from ya.
15:38:29 <regXboi> yamahata: that would be the obvious choice
15:38:32 <odl-casey> flaviof: Hi.  :)
15:38:41 <odl-casey> How's it going?
15:39:31 <yamahata> okay
15:40:19 <regXboi> but if we find that having chains at the northbound helps us in some way, then I can be talked into it
15:41:30 <regXboi> I think we can move on to...
15:41:39 <regXboi> #topic ML2 ODL driver rewrite
15:41:46 <regXboi> can someone summarize the mail thread?
15:42:45 <regXboi> #link https://lists.opendaylight.org/pipermail/neutron-dev/2015-September/000368.html start of ML2 ODL driver rewrite mail thread
15:42:57 <asomya> Attempt to solve the full sync and out of sync issues between neutron and opendaylight
15:43:21 <asomya> by using a journaled thread that syncs and retries atomic operations
15:44:46 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:NeutronDriverOverhaul wiki page on topic
15:45:00 <regXboi> is the wiki page up to date with the ML thread?
15:45:31 <regXboi> and my bottom line is where do we go next?
15:45:32 <yamahata> Yes. At least I tried to make it so.
15:45:52 <regXboi> yamahata: thx
15:46:26 <john-a-joyce> there current changes are good and probably complete in many regards
15:46:43 <john-a-joyce> but the full sync case was still work in progress
15:46:56 <asomya> regxboi: A WIP review has been posted that i'm updating regularly
15:47:17 <john-a-joyce> I don't think the seq# scheme we came up with last week is robust enough
15:47:23 <yamahata> For test framework, rui has started to look into it.
15:47:40 <yamahata> for seqnum, we need to give it a consideration/discussion.
15:47:51 <regXboi> asomya: link?
15:47:51 <flaviof> folks: does this cover any reqs in regards to clustering? or is that a further todo?
15:47:52 <asomya> https://review.openstack.org/#/c/222409/
15:47:53 <john-a-joyce> yes - we should try to break this in 3
15:48:04 <john-a-joyce> the current changes - full sync and test
15:48:21 <regXboi> #link https://review.openstack.org/#/c/222409/ WiP networking-odl refactor patch
15:48:22 * flaviof concerned about support for multiple ODLs from networking-odl
15:48:28 <regXboi> asomya: thx
15:48:32 <john-a-joyce> from our presepctive it needs to cover clustering
15:48:47 <asomya> flaviof: one of the use cases we are attempting to tackle is multiple ODL's and multiple neutron servers
15:49:00 <flaviof> john-a-joyce: asomya: ack. ty!
15:49:12 <john-a-joyce> flaviof - maybe we have a different definition of cluster
15:49:39 <john-a-joyce> I think initially it is multiple neutron servers and a single ODL
15:49:58 <john-a-joyce> but multi-odl handled as an addition
15:50:51 <flaviof> john-a-joyce: right. for Be, there is lots of work to have multiple ODLs, so networking-odl needs to be changed to that somehow.
15:51:06 <regXboi> so... we made progress, but we'll schedule more time for this next meeting
15:51:22 <regXboi> #action regXboi to include topic in 10/2 meeting along with updated from minutes/log
15:51:25 <colindixon> ok, I’m looking for the java 7 stuff
15:51:31 <asomya> flaviof: Are multiple ODl's separate endpoints from a neutron driver perspective?
15:51:32 <flaviof> but, right; not point in putting the carriage in fron tof the horses
15:51:45 <regXboi> #info discussion of refactor in meeting logs, so read there
15:51:55 <regXboi> colindixon: hi and thx
15:52:03 <flaviof> asomya: yeah, multiple ODL_MGRS
15:52:06 <regXboi> all: I have a hard stop at the top of the hour
15:52:23 <regXboi> so, please continue this on the ML because I want to provide some open mike time
15:52:23 <asomya> flaviof: Ah ok, we haven't accounted for that case, assumed a single endpoint
15:52:42 <regXboi> #topic Open Mic
15:53:08 <regXboi> does anybody have any topics to bring up that *weren't covered elsewhere?
15:53:16 <regXboi> if not, then we can go back to the previous topic :)
15:53:23 <vthapar> there was a follow up item from ovsdb meeting
15:53:35 <regXboi> flaviof: ^^^^^ ?????
15:53:37 <vthapar> it was about SNAT support.
15:54:02 * flaviof trying to recall ....
15:54:02 <regXboi> so I saw the ML item and just didn't understand it at all
15:54:23 <flaviof> vthapar: got link?
15:54:25 <vthapar> question was if we can leverage DVR's L3 SNAT agent to do SNAT for us.
15:54:32 <regXboi> um
15:54:47 <regXboi> so... my advice is not to - imho, DVR isn't ready for primetime yet
15:55:02 <flaviof> ah, yeah... that is more of a question for neutron folks on the openstack, but it does not hurt to ask here
15:55:04 <vthapar> https://lists.opendaylight.org/pipermail/ovsdb-dev/2015-September/002004.html
15:55:18 <regXboi> #link https://lists.opendaylight.org/pipermail/neutron-dev/2015-September/000405.html mail about DVR and SNAT
15:55:29 <regXboi> vthapar: sorry, but I'm going to use the neutron-dev link
15:55:45 <regXboi> flaviof is exactly correct
15:55:49 <vthapar> regXboi: ack. I copy pasted the first one that came up.
15:56:39 <yamahata> In order to use l3 agent, odl_l3.py needs modification.
15:56:42 <vthapar> we *may* need some changes in odl-l3 plugin.
15:56:59 <flaviof> the question is can neutron be used with L3plugin that delegates SNAT to O/S l3 agent, and the 'rest' to ODL-L3.
15:57:07 <regXboi> uh
15:57:09 <yamahata> it wouldn't big change.
15:57:11 <regXboi> I so wouldn't do that
15:57:15 <regXboi> but that's mho
15:59:18 <regXboi> folks - I have to go - flaviof, edwarnicke: can you please close the meeting?
15:59:30 <regXboi> or are we done?
15:59:45 <flaviof> regXboi: i gtg too... i think we may be done... for now.
15:59:54 <regXboi> ok... then let's wrap it up for now
15:59:57 <regXboi> thanks all!
16:00:00 <regXboi> #endmeeting