14:59:58 <regXboi> #startmeeting neutron_northbound
14:59:58 <odl_meetbot> Meeting started Fri Oct  9 14:59:58 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:59:58 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:58 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:00:01 <yamahata> hello
15:00:09 <regXboi> #chair edwarnicke, yamahata, flaviof
15:00:09 <odl_meetbot> Current chairs: edwarnicke flaviof regXboi yamahata
15:00:10 <edwarnicke> yamahata: Congratulations :)  Welcome to the club :)
15:00:16 <edwarnicke> #info edwarnicke
15:00:18 <yamahata> thanks!
15:00:22 <yamahata> #info yamahata
15:00:25 * regXboi grants chair powers to yamahata :)
15:00:26 <edwarnicke> *so* happy to have you :)
15:00:28 <regXboi> #info regXboi
15:00:40 <regXboi> #topic roll call (already started)
15:00:44 <regXboi> #undo
15:00:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1942890>
15:00:49 <regXboi> #topic roll call and agenda bashing
15:00:55 <flaviof> #info flaviof
15:01:15 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda in the usual place
15:01:32 <regXboi> well we've got quorum - and then some :)
15:01:41 <regXboi> #topic annoucements
15:01:49 <regXboi> #info M3 was 10/1 - we should file ASAP
15:01:49 <flaviof> edwarnicke: +1
15:02:09 <regXboi> we were called out yesterday at the TSC, and I (admittedly) was grumpy about it
15:02:27 <regXboi> so we *really* ought to file our M3 status ASAP
15:02:50 <regXboi> I will take this action item on to do by COB today
15:03:01 <regXboi> #action regXboi to file M3 by COB 10/9
15:03:18 <regXboi> #info Congratulations to Isaku on being named a committer!
15:03:25 <regXboi> it's well deserved :)
15:03:36 <regXboi> and lastly
15:03:57 <regXboi> folks, I've been reassigned at IBM, so I no longer have time to allocated to ODL
15:04:00 <regXboi> so...
15:04:03 <yamahata> Thank you so much
15:04:13 <regXboi> #info regXboi is resigning as NN PL effective COB 10/9
15:04:33 <regXboi> so... who wants the job :)
15:04:35 <edwarnicke> regXboi: Thank you so much for your service
15:04:39 <edwarnicke> regXboi: You've been a great PTL :)
15:04:45 * edwarnicke ducks
15:05:41 <regXboi> #action flaviof, edwarnicke, yamahata to decide who will be NN PL
15:05:52 <regXboi> I'll let you all figure it out :)
15:05:57 <edwarnicke> regXboi: You still get a vote :)
15:06:07 <edwarnicke> edwarnicke: does not wish to be PTL
15:06:08 <regXboi> edwarnicke: I *do* get a vote
15:06:42 <regXboi> I will be hanging around as a committer, just not nearly as active as the past
15:07:25 <regXboi> while the shock and awe continue, we can finish the next topic in the agenda :)
15:07:31 <regXboi> #topic Action Items from last meeting
15:07:35 * flaviof sad to hear regXboi will no longer be PTL
15:07:39 <regXboi> #info there were none, so .... done
15:07:48 * flaviof does not wish to be PTL
15:09:21 <edwarnicke> yamahata for PTL!
15:09:25 * yamahata is fine with PTL,  but he lacks the experience of even commiter...
15:09:37 <yamahata> Wow...
15:09:42 <regXboi> yamahata: PTL is actually more about facing the community
15:09:57 <regXboi> and handling the SR process milestones
15:10:02 <regXboi> beyond that - not so much
15:10:09 <yamahata> I'm quite fine to fill the role. But I need help.
15:10:15 <flaviof> yamahata: would you be willing? I will do my very best to support you in that role
15:10:40 <edwarnicke> yamahata: Help we can give you :)
15:10:45 <regXboi> ack
15:10:52 * regXboi channels bill the cat
15:11:11 <yamahata> Yeah I'm willing. It's a surprise to be PTL right after the day when I became a committer.
15:11:23 <regXboi> yamahata: that's how it works sometimes :)
15:11:31 <regXboi> but trust me, you'll do fine
15:11:44 <regXboi> #agreed yamahata as PTL
15:11:53 <regXboi> #action regXboi to announce to necessary places
15:11:54 <yamahata> Anyway I'll do my best
15:11:58 <flaviof> regXboi: as you transition, any chance you can help yamahata in this role?
15:12:37 <regXboi> flaviof, yamahata: I should be around
15:12:44 <flaviof> as in the details, etc. maybe listing the many things you do as ptl and we never get to know about.
15:12:50 <regXboi> and yes I can help out with advice etc
15:13:08 <regXboi> flaviof: um - update the wiki, set the agenda, do the SR make-work
15:13:13 <regXboi> it's pretty boring
15:13:40 <regXboi> oh yes - and go on the warpath when upstream breaks the silo ....
15:13:44 <regXboi> can't forget that one
15:13:53 <flaviof> heh, its boring but crucial to avoid the ODL police chasing after the project.
15:14:04 <regXboi> anyway... let's move on :)
15:14:07 <flaviof> k
15:14:14 * yamahata is scared :-)
15:14:22 <regXboi> #topic open patch sets
15:14:31 <regXboi> we've got a bunch of patch sets to review and merge
15:14:37 <regXboi> now that the silo is stable again
15:14:39 <regXboi> so...
15:14:54 <edwarnicke> Yay stable silo!
15:14:59 <flaviof> edwarnicke: +1
15:15:00 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/24042/ yang model re-version
15:15:22 <regXboi> flavio, you +2'd that, but it still needs an submit
15:15:24 <flaviof> yeah, I think the sooner we do this the better for Be
15:15:38 <flaviof> just wanted to wait for the other on that...
15:15:46 <flaviof> all agree on merging this now?
15:15:52 <regXboi> I mean, I can submit it, but that would *really* look funny ...
15:16:14 <regXboi> so yamahata, this is one of those things that a PL does
15:16:15 <flaviof> no worries, I can do it; just wanted a final word from this meeting on this
15:16:42 <regXboi> after this merges, I will be sending email to release list to announce that we've done this and downstream projects are now broken and need to update
15:17:08 <regXboi> and yes flaviof, pull the trigger ;)
15:17:15 <flaviof> ack...
15:17:34 <odp-gerritbot> A change was merged to neutron: Reversion yang model  https://git.opendaylight.org/gerrit/24042
15:17:40 <flaviof> :)
15:17:42 <yamahata> It looks like my right on gerrit is still non-committer. it would take a while, though.
15:17:57 <regXboi> let's get that taken care of now
15:18:25 <regXboi> zxiiro: ping - yamahata was approved as a committer at yesterday's TSC ... can you do the needful?
15:18:55 <regXboi> in the meantime
15:19:02 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/28064/ preparation for MOXy 2.6.x
15:19:23 <zxiiro> regXboi: should ping Andy, I'm on Vacation and am not supposed to be working ;)
15:19:28 <regXboi> this patch fixes items that I found while the silo was broken
15:19:35 <regXboi> zxiiro: ack, sorry
15:19:53 <regXboi> we'll really want it before 2.6.x tries to merge in the future
15:20:06 <regXboi> #action regXboi to heckle tykeal about yamahata's promotion
15:20:42 <regXboi> edwarnicke, flaviof: can we get this one merged?
15:21:08 <flaviof> edwarnicke: can I leave that to you. /me still too green on moxy
15:21:43 <regXboi> well, that one can wait - it's not in the critical path :)
15:21:46 <edwarnicke> regXboi: Looking
15:21:51 <flaviof> +javax validation .:)
15:21:59 <regXboi> in the meantime
15:22:04 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/27726/ Make Neutron*Request implement INeutronRequest Interface
15:22:15 <regXboi> I'm ok with this one
15:22:20 <edwarnicke> regXboi: Not going to hold this up over this
15:22:25 <regXboi> so... now that we've reversioned
15:22:30 <odp-gerritbot> A change was merged to neutron: northgound: Make Neutron*Request implements INeutronRequest interface  https://git.opendaylight.org/gerrit/27726
15:22:32 <edwarnicke> regXboi: But could we get that 3rd party dependency into dependency management in odlparent?
15:22:43 <regXboi> edwarnicke: no, as I understand it
15:22:47 <regXboi> that won't do what we need
15:22:50 <odp-gerritbot> A change was merged to neutron: Changes to prepare for MOXy 2.6.x  https://git.opendaylight.org/gerrit/28064
15:22:54 <regXboi> it doesn't actually do the import
15:22:57 <edwarnicke> regXboi: Why not?
15:23:10 <regXboi> edwarnicke: bring it up with skitt
15:23:16 <edwarnicke> ack
15:23:26 <regXboi> I wanted it there and was told it wouldn't work
15:23:42 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/27728/ Consolodate CRUD logic in Northbound
15:23:43 <edwarnicke> OK... I'll follow up there
15:23:50 <regXboi> again, I'm ok with that patch so :)
15:24:18 <regXboi> well ... it depends on
15:24:21 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/27727/ add initDefaults() method to NeutronObject
15:24:31 <odp-gerritbot> A change was merged to neutron: NeutronObject: add initDefaults() method to NeutronObject  https://git.opendaylight.org/gerrit/27727
15:24:32 <odp-gerritbot> A change was merged to neutron: Neutron*Northbound: consolidate crud logic  https://git.opendaylight.org/gerrit/27728
15:24:37 <regXboi> so there we go :)
15:24:58 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/26711/ BGPVPN
15:26:10 <regXboi> now, Thomas Morin had comments on this because the openstack project is changing its API
15:26:15 <flaviof> that one lgtm, but I saw a bunch of geed feedback from yamahata and regXboi
15:26:27 <regXboi> so... my question is - merge this and then update later or wait?
15:26:31 <flaviof> s/geed/good
15:26:34 <regXboi> I lean towards merge and update
15:26:43 <yamahata> It looks good to me. I suspect they need to rebase it, though.
15:26:52 <regXboi> yamahata: actually no
15:27:05 <regXboi> it's not in merge conflict
15:27:14 <regXboi> and the models are properly versioned
15:27:20 <regXboi> you know
15:27:26 <regXboi> a recheck would probably be useful :)
15:27:31 <regXboi> just to verify that
15:27:59 * regXboi starts recheck
15:28:30 <regXboi> lastly
15:28:41 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/24598/ L2Gateway
15:28:47 <regXboi> I think this needs help
15:28:59 <regXboi> because it conflicts with the bgpvpn work
15:29:25 <regXboi> and there are outstanding -1's against it
15:29:26 <flaviof> yeah, it needs to apply yamahata's feedback too
15:29:47 <regXboi> let me run a recheck on it as well
15:30:36 <regXboi> we'll let those cook for a bit
15:30:41 <regXboi> and come back to them later
15:31:10 <regXboi> #topic ML2 ODL driver rewrite
15:31:29 <regXboi> I didn't put the details of this into the agenda - who did?
15:31:38 <yamahata> I did.
15:31:48 <regXboi> ok yamahata: then you lead :)
15:31:52 <yamahata> I'd like to share the direction on it.
15:32:19 <yamahata> Now the branch of networking-odl for Liberty has been cut. So it's now open for Mitaka cycle.
15:32:40 <yamahata> I think we can start pushing patches for ODL driver rewrite.
15:33:05 <yamahata> We have choices to make the driver rewrite progress.
15:33:14 * regXboi notes - the BGPVPN patch passes with the new yang model
15:33:29 * regXboi asked for any objections to merging it in?
15:33:33 <flaviof> yamahata: any chance we can have a get together on this at the Summit (Tokyo)?
15:33:38 <yamahata> One way is to introduce new one and merge patches. After stabilizing it, deprecat old one.
15:33:41 * regXboi asks for any objections to merging it in
15:33:52 <flaviof> regXboi: no objections from me
15:33:59 <yamahata> flaviof: Definitively. I'd like to share it in advance.
15:34:11 <flaviof> yamahata: awesome
15:34:18 <regXboi> edwarnicke, yamahata: you ok if 26711 merges?
15:34:21 <yamahata> another choice is to create a new branch, after stabilizing it merge it back.
15:34:40 <mlemay> yamahata: depends on the amount of chances IMHO
15:34:43 <yamahata> Fine with merging 26711
15:34:43 <mlemay> *changeS*
15:34:56 <flaviof> yamahata: do you think the changes are going to take us past Beryllium?
15:35:20 <yamahata> It would be past Beryllium, I expect.
15:35:21 <odp-gerritbot> A change was merged to neutron: BGPVPN: Added yang, api and transcriber for BGPVPN  https://git.opendaylight.org/gerrit/26711
15:35:23 <flaviof> it is a bit tricky dealing with Mitaka and Beryllium/Boron...
15:35:35 <flaviof> but that is not biggie.
15:35:36 <mlemay> yamahata: how about simply having the changes in a folder?
15:36:01 <mlemay> to make it incremental
15:36:13 <yamahata> mlemay: What's the difference from introduce new one in addition to the existing one?
15:37:08 <yamahata> My personal preference is to introduce new one than branch.
15:37:55 <mlemay> me too
15:38:10 <flaviof> yamahata: i think we can go with that model too
15:38:46 <mlemay> @yamahata: no difference but I'm just saying a the file level might be a good idea to rework it on the same branch and keep some of the current files too.. sorry if I wasn't clear.
15:38:49 <yamahata> mestery: ping? what's your opinion?
15:39:17 <rcurran> mlemay, note that the refactor does not overwrite existing modules
15:39:19 <flaviof> yamahata: new one meaning: a repo in stackforge called networking-odl2 ?
15:39:39 <yamahata> with having both new/exising ones, user can still continue to use the existing one and developer can easily test new one.
15:40:00 <flaviof> yamahata: ack, I like that
15:40:02 <yamahata> flaviof: no. networking-odl will include both ones.
15:40:16 <flaviof> yamahata: cool. make sense
15:40:16 <asomya> we just label the entry point opendaylight_v2 to point to the new driver, the old one can stay in the tree till v2 is proven
15:40:54 <mlemay> yes
15:41:07 <flaviof> yamahata: ack, I like that too
15:41:28 <mlemay> that is what I was hoping for (keeping both in parrallel)
15:41:33 <mlemay> the old one is still useful
15:42:40 <yamahata> It seems like we reached consensus.
15:43:23 <mlemay> +1
15:43:36 <regXboi> somebody do a #agree ;)
15:43:40 <regXboi> with the consensus
15:44:08 <yamahata> #agreed for ODL driver rewrite, keep both drivers in parallel during development
15:44:24 <regXboi> thanks :)
15:44:28 * yamahata uses the chair power first time. :-)
15:44:42 <regXboi> #info for discussion leading to that agree, see log transcript
15:44:55 <yamahata> That's it for ODL ML2 driver rewrite.
15:44:55 <regXboi> ok... last but not least
15:45:00 <regXboi> #topic open mike
15:45:09 <regXboi> anybody have any items they want to bring up?
15:46:31 <yamahata> none from me
15:46:59 <flaviof> none from me
15:47:08 <regXboi> anybody?  bueller?
15:47:54 * flaviof smells cookies.....
15:47:56 <regXboi> going once
15:48:37 <regXboi> going twice
15:50:29 <regXboi> #topic cookies
15:50:34 <regXboi> #endmeeting