15:04:25 <yamahata> #startmeeting neutron_northbound
15:04:25 <odl_meetbot> Meeting started Fri Oct 23 15:04:25 2015 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:04:25 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:25 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:04:40 <yamahata> #info yamahata
15:05:35 <yamahata> It seems like we don't hve quorum, but I'll go anyway..
15:05:45 <yamahata> #chair flaviof
15:05:45 <odl_meetbot> Current chairs: flaviof yamahata
15:05:51 <flaviof> #info flaviof
15:05:56 <yamahata> #topic agenda bashing and roll call
15:06:11 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings
15:07:04 <yamahata> do we have anyother agenda items to cover?
15:07:24 <flaviof> yamahata: want to go over the networking-odl gerrits too?
15:07:52 <yamahata> flaviof: sure if we have time.
15:07:56 <flaviof> #link https://review.openstack.org/#/q/status:open+project:openstack/networking-odl,n,z networking-odl
15:08:03 <flaviof> yamahata: sounds good.
15:08:23 <yamahata> #topic Announcements
15:08:48 <yamahata> openstack summit tokyo will be held next place
15:09:06 <yamahata> I believe many of ODL community will attend.
15:09:28 * flaviof looking forward to meeting neutron folks
15:09:32 <yamahata> #link http://mitakadesignsummit.sched.org/overview/type/neutron#.VimUjnUVikp neutron design summit session
15:10:00 <yamahata> #link https://etherpad.openstack.org/p/mitaka-neutron-unplugged-track unplugged session planning on Friday Oct 30
15:10:16 <yamahata> Officially unplugged session is planned on Friday Oct 30
15:10:59 <yamahata> But due to the past experience, people may leave on Friday etc. so it might be too late to try to discuss topics on Friday
15:11:14 <yamahata> we should plan discussion earlier than Friday.
15:11:47 <yamahata> This IRC meeting will be canceled on Oct 30.
15:11:53 <flaviof> yamahata: yeah, agree.
15:11:57 <flaviof> on both
15:12:42 <yamahata> Probably on Nov 6 too unless someone chair it. I'l be on vacation for a week
15:12:58 <yamahata> anything else to announce?
15:13:36 <yamahata> okay move on
15:13:40 <flaviof> yamahata: I should be around on Nov/6.
15:14:02 <yamahata> flaviof: cool. then please take care of it.
15:14:12 <flaviof> ack
15:14:33 <flaviof> #action flaviof to host nn meeting on Nov/6, if there are enough folks participating
15:14:45 <flaviof> #info no nn meeting on Oct/30/15
15:15:13 <yamahata> #topic action items from last meeting
15:15:38 <yamahata> review https://git.opendaylight.org/gerrit/#/c/24598/ l2 gate way patch
15:15:54 <yamahata> I haven't a chance to review it yet.
15:16:08 <yamahata> I'll try it after packing
15:16:28 <yamahata> #topic OpenStack Summit logistics
15:16:41 <flaviof> yamahata: I see comments from you on that already
15:17:17 <yamahata> lol. oops
15:17:30 * yamahata even didn't remember which review I did or not...
15:17:56 <flaviof> all good.
15:18:02 <yamahata> ODL meeting in tokyo timeslot.
15:18:41 <yamahata> sometime somewhere on Tuesday or keynot session on wednesday would work
15:19:05 <flaviof> yamahata: Tuesday is good for me.
15:19:29 <flaviof> anybody else available? anybody in this meeting coming to openstack summit?
15:19:53 * flaviof is pretty sure armax will be there. ;)
15:21:22 <yamahata> people seems shy.
15:21:32 <flaviof> indded!
15:21:34 <asomya> I'll be there, tuesday is fine with me as well
15:22:07 <yamahata> Okay then let's try to get together on Tuesday morning.
15:22:22 <yamahata> Probably around registration counter.
15:22:41 <yamahata> I don't know how the venue looks like, though.
15:22:55 <flaviof> is 9am too early? I signed up for a hands on lad at 10:15am
15:23:08 <yamahata> 9am works for me.
15:23:36 <asomya> +1
15:24:10 <yamahata> #info ODL discussion meeting 9am on Tuesday around registration counter
15:24:13 <flaviof> #link cool
15:24:16 <flaviof> #undo
15:24:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2523d90>
15:24:25 <flaviof> #link https://www.evernote.com/l/AoGUdT_Le11E_Z68EUVgNiX4a_T6NH9ijZU Campus map
15:24:55 <yamahata> I'll get data sim and can be reached with @ymhtq
15:24:58 <flaviof> I'm sure there is an official link; this one is from my notes
15:25:21 <flaviof> yamahata: what is @ymhtq ?
15:25:32 <yamahata> twitter
15:25:36 <asomya> #link https://www.openstack.org/summit/tokyo-2015/campus-maps/
15:25:40 <flaviof> ack. cool
15:25:44 <flaviof> asomya: ty!
15:27:04 <flaviof> #info planning to meet at 9am (Japan time) at ...
15:27:09 <flaviof> Grand Prince International Convention Center ok?
15:28:37 <yamahata> seems okay
15:30:10 <yamahata> let's move on...
15:30:11 <flaviof> #info planning to meet at 9am (Japan time) at Grand Prince International Convention Center (#3 on campus map, where the coffee symbol is shown)
15:30:19 <flaviof> #undo
15:30:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x238f610>
15:30:39 <flaviof> #info planning to meet at 9am (Japan time) at Grand Prince International Convention Center (#3 on campus map, where the coffee symbol is shown) On tuesday, Oct/27/15
15:31:50 <yamahata> #topic open patches
15:32:16 <yamahata> several patches has been floating for a while
15:32:42 <yamahata> they need review, but I suppose it would be after openstack summit because people are busy for it
15:32:57 <yamahata> any comments/discussion with the patches?
15:33:07 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/28232/ northbound: Split out AD-SAL logic from AbstractNeturonNorthbound
15:33:14 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/28233/ bgpvpn: simplify bgpvpn related code
15:33:25 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/28234/ use INeutronObject instead of NeutronObject where possible
15:33:33 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/24598/ L2Gateway depends on openstack patch above
15:33:54 <flaviof> yamahata: they all lgtm.
15:34:04 <yamahata> regarding to l2gw patch, neutron side patch will be merged first.
15:34:24 <yamahata> or can we merge ODL side first?
15:34:43 <flaviof> yamahata: i can merge these today. will give it another pass and test a few
15:35:02 <yamahata> flaviof: please go ahead
15:35:36 <yamahata> #topic bug
15:35:42 <yamahata> https://bugs.launchpad.net/networking-odl/+bug/1504671 subnet not associated with network on creation
15:35:53 <yamahata> we discussed it last week.
15:35:53 <flaviof> #action to review gerrit 28232, 28233, 28234, 24598
15:36:00 <flaviof> #undo
15:36:00 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2386210>
15:36:09 <flaviof> #action flaviof to review gerrit 28232, 28233, 28234, 24598
15:36:39 <yamahata> But I'm not sure the situation. So I'd like to discuss it at the summit.
15:37:07 <flaviof> yamahata: yes, in regards to that bug, do you think it is a big deal for networking odl to send a network update when subnets are added/removed
15:37:07 <flaviof> ?
15:37:42 <yamahata> flaviof: It's not a big deal to change ML2 driver side.
15:37:58 <flaviof> that is basically the open question. if networking-odl can update odl on the subnets that the network belongs to, then this will be inline with the existing nn implementation
15:38:12 <yamahata> But I'm suspecting it would cause race condition. So it would still remain an issue.
15:38:48 <flaviof> yamahata: race, huh?
15:39:14 <yamahata> ODL ML2 driver can send subnet creation then network update. There is a (small) window between two requests.
15:39:19 <flaviof> wouldn't that be taken care by the versioning changes?
15:39:53 <yamahata> Within the windows, the subnet exists, but the network:subnet doesn't include it.
15:40:56 <flaviof> as long as a subnet change is followed by a network update I'd think it is okay for network obj to be sent with stale list of subnets, folloed by the 'correct' list of subnets
15:41:55 <flaviof> vthapar: agree ^^
15:42:31 <yamahata> I see.
15:43:04 <flaviof> yamahata: having said that, it is possible we can talk more on that at the summit.
15:43:25 <yamahata> flaviof: +1 for talking at the summit
15:43:39 <flaviof> but first step to me is agreeing where to make the 'fix'. my vote is on networking-odl
15:43:47 <flaviof> cool. next topic?
15:43:56 <yamahata> #topic ML2 ODL driver rewrite
15:44:19 <yamahata> Yesterday I uploaded a slide to show my thoughts
15:44:55 <yamahata> #link https://docs.google.com/presentation/d/1h764vorS9vrj0uW1h8bVS7MuGvstvbQy2Q3xDw0yIOs/edit?usp=sharing
15:45:19 <yamahata> The current proposed code doesn't address dependency fully and fullsync
15:45:36 <yamahata> The slide above tries to address those issues.
15:46:23 <yamahata> It's a bit complex. needs to be reviewed and to be simplified.
15:46:32 <yamahata> so please go review them.
15:47:03 <flaviof> #action everybody to review https://docs.google.com/presentation/d/1h764vorS9vrj0uW1h8bVS7MuGvstvbQy2Q3xDw0yIOs/edit?usp=sharing
15:47:33 <flaviof> #action everybody to also review https://wiki.opendaylight.org/view/NeutronNorthbound:NeutronDriverOverhaul
15:48:16 <yamahata> That's it from me. then patch review?
15:48:19 <flaviof> yamahata: hihg level question on slide: does it account for non-ml2 itemas as well? L3 lbass, sg ?
15:49:01 <yamahata> It describes only ML2, but the logic can apply to L3, LbaaS, SG.
15:49:25 <yamahata> Regarding to SG, we need ML2 SG API effort which right now Midokura guys are working on it.
15:49:41 <yamahata> If Midokura is busy with other issue, I'm willing to work on SG API.
15:49:48 <yamahata> Actually Yalei of my team will.
15:49:54 <flaviof> ack
15:50:12 <asomya> yamahata: So this introduces a new thread that keeps checking the state of the ODL DB which is the sequence number?
15:50:39 <flaviof> as long as the proposed solution does not overlook all nn objects (in and outside ml2 scope) I think that is a good solution
15:50:58 <yamahata> asomya: Yes when seqnum is introduced in ODL side.
15:51:15 <yamahata> The described logic can be done without sending seqnum.
15:51:30 <yamahata> in that case, the monitoring thread just checks connection between neutron and ODL.
15:51:48 <asomya> yamahata: I still have a few questions and reservations, will save them for the physical meeting at the summit :)
15:51:49 <yamahata> checks if the connection is alive or not.
15:52:11 <yamahata> asomya: sure
15:52:34 <john_a_joyce> yamahata: i have not reviewed the slide - but just checking connection state can't detect all conditions
15:52:37 <yamahata> Let me point out that anyone can comment on the slide
15:53:06 <yamahata> john_a_joyce: correct. failure detection needs another consideration.
15:53:18 <yamahata> the slide doesn't address it.
15:53:34 <john_a_joyce> ok - let me review and we can discuss in the summit
15:53:46 <asomya> yamahata: Can i add the workflow in a separate slide for a slightly different solution?
15:53:51 <flaviof> yamahata: will spend some time on this. connection is very relevant, when we factor in lb or clustering.
15:54:04 <yamahata> I think we should define failure model more cldearly and develop failure detection method
15:54:19 <john_a_joyce> yes - i agree with that
15:54:24 <yamahata> asomya: please send a request for edit rights.
15:54:34 <asomya> yamahata: will do
15:54:35 <john_a_joyce> the current changes only try to prevent a failure case
15:55:04 <yamahata> also those who want edit right, don't hesitate to send a request for edit right on the slide
15:55:06 <john_a_joyce> but there are always going to be boundary conditions and corner cases
15:55:51 <yamahata> john_a_joyce: exactly.
15:56:41 <yamahata> based on failure model, we can develop test scenario and then testsets
15:58:20 <yamahata> Please note that the slide is only a starting point for discussion.
15:58:31 <yamahata> and further development
15:58:41 <flaviof> yamahata: understood. thanks for doing that.
15:59:32 * flaviof has another meeting to attend...
15:59:41 <yamahata> time is running out
15:59:46 <yamahata> anything else urgent?
15:59:52 <yamahata> #topic open mike
16:00:13 <yamahata> going once...
16:00:23 <yamahata> going twice...
16:00:43 <yamahata> thanks
16:00:45 <yamahata> #topic cookies
16:00:49 <yamahata> #endmeeting