16:03:38 <yamahata> #startmeeting neutron_northbound
16:03:38 <odl_meetbot> Meeting started Fri Dec  4 16:03:38 2015 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:38 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:38 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:03:47 <yamahata> #chair flaviof
16:03:47 <odl_meetbot> Current chairs: flaviof yamahata
16:03:55 <yamahata> #info yamahata
16:04:14 <yamahata> #topic agenda bashing and roll call
16:04:29 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda
16:04:38 <yamahata> I didn't update the agenda page, though.
16:05:26 <yamahata> today the agenda is patch review, bug, and ml2 odl driver rewrite and other open issues
16:05:39 <flaviof> sounds good
16:05:46 <yamahata> do we have any open items?
16:05:51 <flaviof> #info flaviof  but leaving in 10 mins
16:06:14 <yamahata> #topic Announcements
16:06:27 <yamahata> M4 was cut. and now it's M5 cycle.
16:06:42 <yamahata> basically API is freezed officially.
16:07:01 <yamahata> I'm not sure how strict it is, though.
16:07:07 <yamahata> any other announcement?
16:08:02 <yamahata> let's move on
16:08:03 <flaviof> nothing on news from my neck of the woods
16:08:15 <yamahata> #topic action items from last meeting
16:08:32 <yamahata> nothing left except patch review I'm aware of.
16:09:05 <yamahata> #topic patch review
16:09:18 <yamahata> in ODL side, there is only one patch left
16:09:20 <flaviof> right, I just merged gerrit
16:09:36 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/24598/ l2gw
16:09:43 <yamahata> the patch is merged.
16:09:50 <flaviof> ack
16:10:06 <yamahata> #action yamahata update release wiki page
16:10:12 <flaviof> any pending on networking-odl side?
16:10:23 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Beryllium_Release_Plan
16:10:45 <yamahata> #link https://review.openstack.org/#/q/status:open+project:openstack/networking-odl,n,z  networking-odl patches
16:11:02 <yamahata> we have bunch of remaining patches.
16:11:07 <flaviof> yeah, thanks for the links
16:11:34 <yamahata> Is there special patches to discuss right now?
16:11:58 <yamahata> I think we can merge as preparation https://review.openstack.org/#/c/226437/
16:12:06 <yamahata> db migration patch
16:12:13 <flaviof> i have https://review.openstack.org/#/c/252030/
16:12:25 <flaviof> it is actually a cherry pick to stable/liberty
16:12:36 <flaviof> I'm not sure who/how to get that done
16:13:03 <yamahata> #link https://review.openstack.org/#/c/252030/ Use ODL stable/lithium (aka SR3) by default
16:13:28 <flaviof> there is an issue with gate-networking-odl-python27 which I do not quite understand yet
16:13:32 <yamahata> Do you mean ci failure?
16:13:40 <flaviof> yeah, right
16:13:41 <yamahata> I'll look into it.
16:14:00 <flaviof> thanks yamahata
16:14:02 <yamahata> #action Isaku/everyone look into CI failure of https://review.openstack.org/#/c/252030/
16:14:27 <yamahata> any other patches to discuss?
16:14:32 <flaviof> the odl folks (like Jamo) need this so they can use SR3 in their test
16:14:47 <flaviof> that is all from me
16:15:30 * flaviof needs to step out... nice talking to y'all!
16:15:32 <yamahata> Oh so the 252030 is a sort of argent
16:15:43 <yamahata> flaviof: bye for now
16:15:51 <flaviof> yamahata ack, it would be nice to have that.
16:16:17 <yamahata> any other patch discuss?
16:16:22 * yamahata is waiting a bit
16:16:39 <yamahata> move on.
16:16:55 <yamahata> #topic ML2 ODL driver rewrite
16:17:03 <yamahata> any update?
16:17:17 <yamahata> We're aware several patches are update and needs review.
16:17:19 <asomya> yamahata: I just posted a new patch addressing the review comments
16:17:34 <asomya> And apologies to everyone for my extended absence
16:17:36 <yamahata> asomya: Very cool! I'll give it reviews
16:18:00 <yamahata> asomya: I hope you had a good refresh and come back with full energy. :-)
16:18:00 <john_a_joyce> yamahata - we think they are complete enough to merge if no code issues
16:18:04 <rcurran> yamahata, note that UT patchset will be pushed up soom
16:18:23 <john_a_joyce> enhancements and additions can be deferred to future patches
16:18:37 <asomya> Yamahata: Any idea when this will be merged: https://review.openstack.org/#/c/226437/
16:19:19 <yamahata> any objections for that. I just wanted to have someone else like flavio to review it.
16:19:28 <yamahata> If no objections, I'll merge it now.
16:19:51 * yamahata going once
16:19:57 <john_a_joyce> no objections from me - I would love to see that happen
16:20:10 * yamahata going twice
16:20:44 <yamahata> I approved the patch to trigger the merge.
16:21:06 <yamahata> It will be merged soon unless merge conflict or any issues are found.
16:21:07 <john_a_joyce> thank you ymahata - and thank you even more Arvind for the heavy lifting
16:21:50 <yamahata> any other issues?
16:22:24 <yamahata> move on
16:22:32 <yamahata> #topic open mike
16:22:49 <yamahata> anything else to discuss? or can we close the meeting today?
16:23:06 <asomya> yamahata: We still haven't solved the full sync story for the driver rewrite
16:23:55 <yamahata> asomya: Right, I'm right now working on it. I hope I can upload the first(WIP) patch soon.
16:24:22 <asomya> yamahata: cool, can you share the architecture details? maybe over email
16:24:55 <yamahata> The basic idea is the one which is described in the design slide
16:25:01 * yamahata looking for the link
16:25:35 <yamahata> https://docs.google.com/presentation/d/1h764vorS9vrj0uW1h8bVS7MuGvstvbQy2Q3xDw0yIOs/edit?usp=sharing
16:25:46 <yamahata> #link https://docs.google.com/presentation/d/1h764vorS9vrj0uW1h8bVS7MuGvstvbQy2Q3xDw0yIOs/edit?usp=sharing ML2 ODL rewrite
16:26:01 <yamahata> there is no change from it. (except coding details)
16:26:13 <asomya> thanks
16:27:02 <yamahata> anything else?
16:27:34 <john_a_joyce> not from me and need to sign off anyway
16:27:55 <yamahata> seems nothing else, let's close the meeting
16:28:01 <yamahata> thank you everyone
16:28:14 <yamahata> #topic cookies
16:28:22 <yamahata> #endmeeting