16:04:18 <yamahata> #startmeeting neutron_northbound
16:04:18 <odl_meetbot> Meeting started Fri Dec 11 16:04:18 2015 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:04:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:18 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:04:38 <yamahata> #topic agenda bashing and roll call
16:04:40 <yamahata> #info yamahata
16:04:52 <flaviof> #info flaviof
16:05:01 <yamahata> #chair flaviof
16:05:01 <odl_meetbot> Current chairs: flaviof yamahata
16:05:09 <flaviof> hi all
16:05:13 <rcurran> hi
16:05:20 <asomya> hello
16:05:47 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.2812.2F11.29 agenda
16:06:03 <john_a_joyce> hello
16:06:12 <yamahata> Is there anything else to discuss today?
16:07:07 <flaviof> nothing else from me.
16:07:19 <yamahata> okay move on
16:07:27 <yamahata> #topic Announcements
16:08:09 <yamahata> Be release is approaching fast. Some needs to be done for release
16:08:18 <yamahata> e.g. documentation and so on.
16:08:48 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Beryllium_Release_Plan
16:09:35 <yamahata> TBH I don't fully understand what should be done yet. Anyway I need your help for it.
16:09:46 <flaviof> yamahata is there any to doc, other than the ... heh you just answered me
16:10:13 <yamahata> Yes, there is a wiki page for it.
16:10:27 <yamahata> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan
16:10:28 <flaviof> maybe we can ask regXboi for pointers? I too know nothing about this
16:11:08 <flaviof> heh, i got that, just not what these fields need on that link
16:11:24 * flaviof looking
16:11:42 <yamahata> I'm trying to figure it out recently. It's a bit long.
16:12:05 <flaviof> ineed!
16:12:29 <yamahata> and also Boron planning will happen soon. So we should prepare it.
16:12:47 <yamahata> I suppose there is a design summit or something for Boron.
16:12:56 <flaviof> k. feels like we need a lawer to plow through these mounds of text. ;)
16:13:10 <yamahata> Then we can flesh out what we want to achieve for Boron cycle.
16:14:01 <yamahata> That's all from me for announce.
16:14:17 <yamahata> I'd like people to be aware of release stuff.
16:15:10 <yamahata> anything for announce?
16:15:32 <yamahata> next topic is schedule
16:15:32 <flaviof> on that subject --- -and hopefully not deviating too much from agenda -- i recall some talks from Wojciech on desire to have a way to tie southbound info in neutron port. Is that a networking-odl topic?
16:16:12 <yamahata> anyone know?
16:16:28 <yamahata> https://git.opendaylight.org/gerrit/#/c/23594/  is it related to this patch?
16:16:37 * flaviof looking
16:16:54 <john_a_joyce> flaviof - can you explain more
16:16:55 <flaviof> yeah, that is right
16:17:52 <flaviof> john_a_joyce basically, there is a desire in netvirt to have a common place in odl to map neutron port to different southbounds
16:18:32 <yamahata> Per my understanding, he'd like to support neutron provider network. So the related info needs to be pushed down to ODL.
16:18:41 <flaviof> today, the link between neutron port and ovs is via external_id attr in ovs. it would be nice the the bread crumb lived in the neutron port obj instead
16:18:49 <yamahata> The patch is an attempt to define the data model.
16:18:54 <flaviof> right
16:18:59 <john_a_joyce> Ok - but that model may need some work
16:19:07 <john_a_joyce> there are two vectors
16:19:12 <flaviof> definitely.
16:19:28 <john_a_joyce> one for how the VM connects to the switch vhost vs. virtio
16:19:39 <flaviof> ok, we can tble this for now; possibly a Boron planning topic.
16:19:55 * flaviof did not mean to interrupt john_a_joyce
16:20:01 <john_a_joyce> I talk to woj a lot - I will bring it up with him next week
16:20:10 <flaviof> john_a_joyce sounds good!
16:20:14 <john_a_joyce> sure flavio
16:20:38 <yamahata> Great!
16:21:25 <yamahata> #action john_a_joyce bring device mapper model up with wojciech
16:21:51 <john_a_joyce> will do yamahata
16:21:54 <yamahata> move on
16:21:57 <yamahata> #schedule
16:22:02 <yamahata> #topic schedule
16:22:36 <yamahata> Christmas is coming and people tend to take vacation.
16:22:57 <yamahata> So it's desirable to make our schedule clear
16:23:17 <yamahata> I expect people won't show up Dec 25 and Dec 1.
16:23:31 <yamahata> Or do we want to have this meeting even on those days?
16:23:36 <flaviof> eh, Jan/1/16
16:23:48 <yamahata> How about next week? Dec 18 and Jan 8.
16:23:52 <yamahata> oops, yes Jan 1
16:24:39 <yamahata> My idea is to cancel Dec 25 and Jan 1.
16:24:51 <yamahata> and We can hold a meeting on Dec 18 and Jan 8.
16:24:53 <john_a_joyce> next week should be good
16:24:56 <yamahata> Is it reasonable?
16:25:00 <john_a_joyce> 1/8 don't know jury duty
16:25:03 <rcurran> yamahata, yes
16:25:15 <yamahata> Okay
16:25:16 <john_a_joyce> yes - agree
16:25:31 <flaviof> yamahata agree. flaviof will be away between these dates too (except for Jan/8)
16:25:31 <yamahata> #action yamahata update the schedule on wiki and announce it
16:26:25 <yamahata> #topic action items from last meeting
16:26:40 <yamahata> So far I'm not aware of any except patch review
16:27:02 <yamahata> #topic patch review
16:27:31 <yamahata> Is there any specific patch which you want to draw attention for?
16:27:44 * yamahata sorry for delaying the patch
16:28:13 * yamahata will review at least https://review.openstack.org/#/c/222409/
16:28:30 <yamahata> The following patch needs attention in my view
16:28:34 <yamahata> #link https://review.openstack.org/#/c/222409/
16:28:56 <flaviof> #action flaviof to also add review comments on https://review.openstack.org/#/c/222409/
16:29:10 <rcurran> yes, please review
16:29:35 <yamahata> In ODL side, I have https://git.opendaylight.org/gerrit/#/c/31042/
16:29:53 <john_a_joyce> yes - we thank that one is ready to go
16:29:55 <yamahata> But it changes rest API. So I'm trying to find a way to define optional argument
16:30:06 <john_a_joyce> would really like to get it merged before the holiday
16:30:34 <john_a_joyce> are there any macro concerns people have about it?
16:30:50 <yamahata> I suppose in boron cycle the way to allow optional argument needs to be established to support neutron extension reasonably
16:30:53 <flaviof> #link https://git.opendaylight.org/gerrit/#/c/31189/ another gerrit (less complexity) that needs merging
16:31:07 <john_a_joyce> I will look at https://git.opendaylight.org/gerrit/#/c/31042/
16:32:12 <yamahata> Any other patches?
16:32:35 <flaviof> there is an issue, but no patch yet....
16:32:50 <flaviof> has to do with when neutron is used with L3_HA
16:32:50 <yamahata> move on
16:33:02 <flaviof> it creates a network for vrrp that has no tenant id
16:33:24 <flaviof> as Isaky may remember, ODL crashes when it tries to extrace the tenant i from empty string:
16:33:51 <yamahata> flaviof: did we file a bug for it?
16:34:02 <flaviof> https://github.com/openstack/networking-odl/blob/stable/liberty/networking_odl/ml2/mech_driver.py#L126
16:34:15 <flaviof> yamahata not yet... kinda fresh one
16:34:55 <flaviof> the work around is to not use l3_ha
16:35:12 <yamahata> Ah yes, I remember it.
16:35:24 <flaviof> but that sould be handled in either networking_odl or nn
16:35:45 <flaviof> it was news to me that l3_ha created this 'special' network...
16:35:45 <yamahata> Agreed.
16:36:14 <flaviof> #action flaviof to create a bug on issue when odl is used with l3_ha enabled
16:36:54 <flaviof> yamahata I will open the bug, but will need help (from y'all) on what you think the best 'fix' is on this one
16:37:24 <yamahata> For boron planning, we can create a list of (new) feature that are not supported.
16:37:40 <flaviof> sounds good
16:37:52 <yamahata> Openstack neutron constantly is introducing new features.
16:38:17 <yamahata> #topic bugs
16:38:29 <yamahata> Any other bugs which needs attention?
16:38:55 * flaviof sorry misspelling your name yamahata !
16:39:04 * yamahata no problem
16:39:32 <yamahata> seems we don't have special bugs.
16:40:05 <yamahata> For Be cycle, it might be an idea to have bug squashing.
16:41:02 <yamahata> next topic is
16:41:05 <yamahata> #topic ML2 ODL driver rewrite
16:41:18 <yamahata> Do we have anything.
16:41:19 <yamahata> ?
16:41:49 <asomya> Updates pushed to the review, now includes unit tests rolled into the main review and Db migrations
16:41:55 <john_a_joyce> just the patch from a above
16:42:06 <yamahata> asomya: cool. Surely will review it
16:42:38 <john_a_joyce> https://review.openstack.org/#/c/222409/
16:42:53 <yamahata> #link https://review.openstack.org/#/c/222409/
16:42:54 <flaviof> do any of you folks have doc on testing it w/out having a full o/s + odl deployment?
16:42:59 <john_a_joyce> as said above would really like to get this merged before the holidays
16:43:24 <rcurran> please note that this is (for now) introducing an opendaylightv2 driver so as not to impact current development and deployments of ml2 odl
16:43:30 * flaviof looking for a light weight of trying out the changes for review w/out a full setup
16:43:47 <john_a_joyce> we don't flavio, but we are in the process of getting that together via a rally suite
16:43:51 <yamahata> At this point, rui is working on lightweight testing.
16:44:06 <john_a_joyce> and we can also use Rui's test framework
16:44:07 <flaviof> cool, I highly anticipate something like that
16:44:34 <flaviof> bare in mind I know nothing about rui/rally, so go ez on me :)
16:45:29 <john_a_joyce> rui is a person - rally is a test module
16:45:36 <john_a_joyce> :-)
16:45:39 <flaviof> i see this intrumental for closing the bridge and getting more fresh blood in the group
16:45:52 <flaviof> john_a_joyce hah ack on Rui + rally
16:46:11 <yamahata> lol
16:46:27 <flaviof> sorry rui!
16:47:07 <yamahata> #topic https://review.openstack.org/#/c/252755/
16:47:10 <yamahata> oops
16:47:12 <yamahata> #undo
16:47:12 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1eda210>
16:47:21 <yamahata> #topic Beryllium release preparation and Boron planning
16:47:33 <yamahata> I already discussed at announce
16:47:46 <yamahata> #topic open mike
16:47:58 <yamahata> anything else to discuss?
16:49:17 <yamahata> seems nothing else.
16:49:29 <yamahata> Return back people 10min
16:49:40 <flaviof> #topic cookies
16:50:04 <yamahata> #endmeeting