16:04:52 <yamahata> #startmeeting neutron_northbound
16:04:52 <odl_meetbot> Meeting started Fri Dec 18 16:04:52 2015 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:04:52 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:52 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:05:08 <yamahata> #topic agenda bashing and roll call
16:05:11 <yamahata> #info yamahata
16:05:56 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.2812.2F18.29 agenda
16:06:17 <yamahata> anything else for agenda today?
16:07:10 <yamahata> flaviof: hi
16:07:19 <flaviof> yamahata hi
16:07:24 <yamahata> #chair flaviof
16:07:24 <odl_meetbot> Current chairs: flaviof yamahata
16:07:28 <flaviof> sorry my irc client disconnected
16:07:59 <yamahata> seems no new agenda
16:08:02 <yamahata> #topic Announcements
16:08:11 <yamahata> #info M5 status due is yesterday
16:08:24 <yamahata> #action yamahata report M5 status
16:08:39 <yamahata> So it's code freeze.
16:09:03 <yamahata> Boron design summit is in planning
16:09:56 <yamahata> #link https://lists.opendaylight.org/pipermail/tsc/2015-December/004393.html Boron design forum
16:10:12 <odp-gerritbot> Aswin Suryanarayanan proposed a change to neutron: Fixes Bug 4814  https://git.opendaylight.org/gerrit/31609
16:10:35 <yamahata> According to discussion it would be held in SanMateo SFO on Feb 29 - Mar 1
16:10:54 <yamahata> I'm planning to attend it because I'm local.
16:11:15 <yamahata> any other announcement?
16:11:18 <flaviof> it is unlikely I will be there... sorry.
16:12:32 <yamahata> anyway we should have a list of topics for planning.
16:13:02 <yamahata> #topic action items from last meeting
16:13:31 <yamahata> john_a_joyce: any update on wojciech? It's not urgent, though.
16:13:53 <john_a_joyce> I did let woj know we need to talk through that
16:14:00 <john_a_joyce> but we did not find a common time
16:14:05 <yamahata> It seems other action items are already addressed
16:14:07 <john_a_joyce> I have a slot with him on Monday
16:14:32 <yamahata> john_a_joyce: It's fine. Anyway it will be for Boron or later.
16:14:34 <john_a_joyce> I will make it the first item
16:14:43 <john_a_joyce> sure
16:15:03 <yamahata> #topic Open Patch sets needing review/merging
16:15:23 <yamahata> Now suddenly we have a set of patches in the queue
16:15:33 <yamahata> for bug fixes
16:15:55 <flaviof> yeah! that is a good problem to have :)
16:16:01 <yamahata> Do we have any patches that requires special care?
16:16:32 <yamahata> To me they are basically okay to merge. (Except tests)
16:16:45 <flaviof> yamahata looks like some of the gerrits are failing due to aaa
16:16:45 <yamahata> (except tests are missing)
16:17:21 <flaviof> ack, I think they are all k for merge
16:17:35 <vthapar> fixes for 4807, 4805 and 4818 all go in NeutronSubnet, if you can merge 4807 and 4807 I'll add test cases as part of 4818 instead of adding the mon two places.
16:17:47 <vthapar> ^in.
16:17:59 <yamahata> vthapar: great!
16:18:26 <yamahata> Looking at sonar stats, tests coverage is steadly dropping down.
16:19:21 <yamahata> I'm a bit concerned about it. I'm wondering about test coverage because those model bugs aren't caught so far.
16:19:50 <yamahata> Even with tempest.
16:20:29 <flaviof> it is a very valid point.
16:20:53 <yamahata> At some point (probably after making tempest passes), it would be worthwhile to address test coverage.
16:21:06 <flaviof> for bug 4775 let me add a small test as well.
16:21:25 <flaviof> #action flaviof to add ut to exercise fix for bug 4775
16:21:27 <yamahata> I also have to add tests for my patches.
16:22:14 <yamahata> #topic bug
16:22:30 <yamahata> Do we have any bugs that we have to pay attention to?
16:22:33 <flaviof> just like vthapar mentioned, they need not to be in same gerrit, as long as we get it done, agree?
16:22:52 <flaviof> nothing new from me on that.
16:23:00 <yamahata> agreed
16:23:15 <yamahata> We have a complain from lispmapper on initialization
16:23:34 <yamahata> At this point, I don't have any idea where to look at, though.
16:23:53 <yamahata> #action yamahata file a bug for lispmapper complain
16:23:59 <flaviof> yamahata got more details on the complaint?
16:24:33 <yamahata> Only mails on the mailing list.
16:24:43 <flaviof> ack
16:24:47 <yamahata> It's quite easy to reproduce. But hard to dig into it.
16:25:17 <yamahata> hard for me.
16:25:38 <yamahata> without the knowledge of karaf/osgi.
16:26:18 <yamahata> any other bugs?
16:26:36 <vthapar> a minor one, was wondering about status of https://bugs.opendaylight.org/show_bug.cgi?id=3824
16:26:54 <vthapar> I'd be willing to take this to closure.
16:27:17 <yamahata> vthapar: please go ahead. feel free to take it over.
16:28:12 <vthapar> yamahata, will do.
16:28:20 <yamahata> #topic ML2 ODL driver rewrite
16:28:33 <yamahata> Now Arvind is actively respining the patch
16:29:03 <yamahata> #link https://review.openstack.org/#/c/222409/
16:29:03 <yamahata> Opendaylight driver refactor to handle out of sync issues
16:29:17 <yamahata> I suppose we can merge soon.
16:29:23 <yamahata> asomya: any comments?
16:29:35 <asomya> yamahata: The review comments have been addressed, just a couple of test failing that we hope to have fixed soon (possible today)
16:29:56 <yamahata> #action everyone review the patch https://review.openstack.org/#/c/222409/
16:30:31 <john_a_joyce> sure yamahata - i am just about finished my review
16:31:06 <flaviof> yamahata ack. I think that -- sort of the issues you mentioned -- that is a lgtm
16:31:26 <yamahata> We can continue the discussion as review
16:31:46 <yamahata> is there any discussion that should be done in IRC now?
16:32:45 <yamahata> okay move on
16:32:53 <yamahata> #topic OpenStack release support
16:33:36 <yamahata> #link https://lists.opendaylight.org/pipermail/neutron-dev/2015-December/000512.html ODL neutron northbound Beryllium release dependencies on Openstack release
16:34:03 <yamahata> Ariel questioned about supported combination of release openstack vs ODL.
16:34:40 <yamahata> He wants to support Kilo:{Li, Be} and willing to help it out.
16:35:00 <flaviof> that is a valid question from Ariel, especially because ODL and O/S are in a out of sync release sched.
16:35:44 <yamahata> So far we haven't (written) policy for it. So for Boron, we should define it.
16:36:19 <yamahata> For Beryllium, what should we do?
16:36:40 <flaviof> my thinking is that the Be should support Liberty and Mitaka.
16:36:50 <vthapar> question: what does support mean here? does it refer to set of features, like security groups etc?
16:37:19 <vthapar> or is it more from a "we'll fix bugs" perspective?
16:38:19 <yamahata> vthapar: Good question.
16:39:16 <yamahata> Given Kilo is "security-support", ODL support for Kilo would be a kind of "bug fix"
16:39:58 <yamahata> With our resource, Liberty and Mitaka seems practical.
16:40:37 <yamahata> But I'd also like to help him as long as He's driving it. i.e. I don't want to actively prohibit it.
16:41:12 <yamahata> That's all my current personal opinion.  I'd like to hear others opinion.
16:41:21 <yamahata> flavio already given it. :-)
16:41:37 <flaviof> another dimension of complexity is in regards to 'users' of nn within odl. I think it may be worth mentioning that while we 'support' a certain o/s release, there is no guarantee that the feature implemented
16:41:53 <vthapar> yamahata: what about newer features that were added in Be, like BGPVPN and L2GW? does Kilo+Li mean even those should be supported on Li?
16:41:54 <flaviof> example ipv6 in ovsdb netvirt
16:43:18 <yamahata> No new feature for Kilo+Li.
16:43:20 <vthapar> flaviof: +1 for me this is a more important question. what does support mean? coz am sure the basic stuff would even work with icehouse with a few tweaks in ML2 driver code [basic auth]
16:43:40 <yamahata> Hmm we need to create a support matrix to define what support is.
16:43:42 <flaviof> yamahata +1
16:43:49 <vthapar> yamahata +1
16:44:05 <yamahata> do we have ariel?
16:44:54 <yamahata> seems not.
16:45:56 <yamahata> the support Kilo+Li, Kilo+Be, Liberty+Li, Liberty+Be will have different characteristic.
16:46:11 <yamahata> (and future Mitaka)
16:46:56 <yamahata> For resource reason, we'd like to minimize the effort for Kilo+{Li, Be}
16:47:07 <flaviof> yamahata +1
16:47:09 <yamahata> only bug fix for Liberty+Li
16:47:32 <yamahata> Is that the base line for direction?
16:48:20 <flaviof> sounds reasonable to me.
16:49:17 <flaviof> yamahata in essence what this means is that we will make no plans for backporting big changes such as mdsal neutron to stable Lithium.
16:49:52 <yamahata> flaviof: good point
16:50:10 <vthapar> flaviof: +1.
16:50:17 <flaviof> i think that we are all in agrement on this
16:50:30 <yamahata> +1
16:50:44 <flaviof> #info we'd like to minimize the effort for Kilo+{Li, Be}. only bug fix for Liberty+Li
16:50:46 <yamahata> Let's continue the discusion on the mailing list to include Ariel
16:51:34 <yamahata> move on
16:51:42 <yamahata> #topic Beryllium release preparation and Boron planning
16:52:20 <yamahata> any otherissues on this topic? I already mentioned about M5 report and design forum.
16:53:12 <yamahata> #topic open mike
16:53:27 <yamahata> anything?
16:53:29 <vthapar> yamahata, about the model changes bug...
16:53:34 <flaviof> in the past we talked about rally (test) and rui :)
16:53:58 <flaviof> i would like to hear a little more on that, but after model changes bug
16:54:03 <vthapar> https://bugs.opendaylight.org/show_bug.cgi?id=4810
16:54:22 <vthapar> think woudl be good to share with others what you said in reply to my comment on gerrit.
16:54:37 <yamahata> vthapar: Good idea
16:55:13 <yamahata> During fixing a model bug with vthapar, I found several bugs there in neutorn models.
16:55:33 <yamahata> For example string is used instead of ip-address or ip-prefix
16:56:14 <yamahata> If it's a bug to cause non-working, we have to fix it for Beryllium. We have no choice here.
16:56:41 <yamahata> But in some places string type is used instead of ip-address or ip-prefix.
16:57:04 <yamahata> It's a kind of working. So I don't want to risk breakage for Beryllium.
16:57:34 <flaviof> yamahata +1
16:57:43 <yamahata> So IMHB it would be worthwhile to revise neutron models as a while in early Boron cycle.
16:57:58 <yamahata> I filed a bug to track it.
16:58:27 <yamahata> vthapar: any supplement?
16:58:57 <flaviof> another good candidate for that time frame is #link https://git.opendaylight.org/gerrit/#/c/27291/ dummy provider req
16:59:26 <yamahata> flaviof: +1
16:59:49 <flaviof> ideally in Boron all apps should be required to use mdsal to access all neutron data. do iaware can be removed
16:59:58 <vthapar> yamahata: one more issue uncovered is insufficient test cases in UT/IT/tempest
17:00:05 <yamahata> Rui is working on testing framework and rally.
17:00:18 <yamahata> The progress is a bit slow. But we're surely working on it.
17:00:53 <flaviof> yamahata is the work Rui is working on something that is publicly visible?
17:00:57 <yamahata> On tempest test, I can run tempest.api.network to see issues based on race condition
17:01:07 <yamahata> flaviof: Not yet except patches on networking-odl
17:01:10 <flaviof> he should not feel he is doing it alone -- unless he wants that
17:01:26 <flaviof> ack.
17:01:30 <yamahata> flaviof: We should help him definitively.
17:01:53 <yamahata> As tempest api test is conversing, I can join him after that.
17:02:34 <flaviof> yamahata these race issues you see -- will they be gone once #linke https://review.openstack.org/#/c/222409 is in?
17:02:35 <yamahata> Off course, anyone can join.
17:03:02 <yamahata> No. I should have been clear.
17:03:29 <flaviof> ack, no prob.
17:03:38 <yamahata> I'm seeing MD-SAL transaction: optimistic lock failure in ODL and read timeout on networking-odl
17:03:53 <yamahata> It causes random failures on tempest api test.
17:04:24 <yamahata> for lock issue, https://git.opendaylight.org/gerrit/#/c/31577/
17:04:36 <yamahata> For read time out, I'm now looking into it.
17:04:39 <flaviof> on both "race" issue and "Rally" the more wiki/doc we manage to make avail the better are the chances of getting folks involved. For one it would educate a non-rally person -- like me -- how this works
17:05:19 <flaviof> yamahata ack on "lock failure". thanks for looking into it!
17:05:50 <yamahata> We are 5 mins over.
17:05:53 <yamahata> Anything urgent?
17:06:12 <flaviof> happy holidays everyone!
17:06:27 <yamahata> have nice holidays.
17:06:45 <yamahata> #topic cookies
17:06:50 <yamahata> #endmeeting