15:04:04 <regXboi> #startmeeting neutron_northbound_03_20_2015
15:04:04 <odl_meetbot> Meeting started Fri Mar 20 15:04:04 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:04:04 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:04 <odl_meetbot> The meeting name has been set to 'neutron_northbound_03_20_2015'
15:04:15 <regXboi> #chair edwarnicke fflaviof
15:04:15 <odl_meetbot> Warning: Nick not in channel: fflaviof
15:04:15 <odl_meetbot> Current chairs: edwarnicke fflaviof regXboi
15:04:23 <regXboi> #chair flaviof
15:04:23 <odl_meetbot> Current chairs: edwarnicke fflaviof flaviof regXboi
15:04:27 * regXboi can't type
15:04:37 * edwarnicke wonders about musical chairs... threatens to sing
15:04:37 <regXboi> #unchair fflaviof
15:04:37 <odl_meetbot> Current chairs: edwarnicke flaviof regXboi
15:04:37 <alagalah_> regXboi: ^^^ that was pretty good
15:04:39 <alagalah_> :)
15:05:00 <regXboi> #topic agend bashing and roll call
15:05:12 <edwarnicke> #info edwarnicke
15:05:18 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings <- agenda
15:05:22 <regXboi> #info regXboi
15:05:44 <regXboi> we need to start talking about M4 status items (sigh)
15:05:55 <regXboi> anybody see any other changes ?
15:06:19 <edwarnicke> regXboi: It feels like the M* status items never end
15:06:29 <regXboi> alagalah_: even if lurking, your input is welcomed :)
15:06:33 <regXboi> edwarnicke: ++
15:06:55 * dfarrell07 didn't know #unchair was an action *learns*
15:07:05 <alagalah_> :thumbsup:
15:07:36 <regXboi> ok, so ... let's talk action items...
15:07:52 <regXboi> flaviof: did you add in the link to the lithium project page?
15:07:58 <flaviof> regXboi: yup
15:08:31 <regXboi> Ed, I know I saw the poll email
15:08:46 <regXboi> #info flaviof added link to lithium project page
15:09:03 <regXboi> edwarnicke, I know I saw the poll email - I saw the replies
15:09:15 <regXboi> #info edwarnicke has polled users about VPNaaS
15:09:19 <edwarnicke> #info nobody is reporting needing neutron VPNServices for LI
15:09:20 <regXboi> what did we get as a response?
15:09:24 <regXboi> cool
15:09:28 <regXboi> ok, then let's do that yang only
15:09:44 <regXboi> #agreed therefore VPNaaS will be added as yang only in Li
15:09:49 <edwarnicke> #info lest there be confusion, we *do* have the ODL VPN Services guys doing good work, just not using that neutron API this round
15:10:07 <regXboi> #action regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
15:10:10 <edwarnicke> regXboi: Do we need to add it to yang in Li?
15:10:15 <regXboi> I unfortunately, have not made progress
15:10:21 <regXboi> edwarncike: we *should*
15:10:27 <regXboi> er edwarnicke: we *should*
15:10:33 <edwarnicke> regXboi: Why?
15:10:40 <edwarnicke> regXboi: I don't think anyone is using it
15:10:41 <regXboi> because it will be part of Kilo
15:10:50 <regXboi> so that folks who want to use it during Be development can
15:11:20 * regXboi would like to get ahead of the curve where possible
15:11:37 <edwarnicke> regXboi: Ack
15:11:44 <flaviof> regXboi: on the topic of migrating to new neutron, we still have a pending gerrit: https://git.opendaylight.org/gerrit/#/c/16161/
15:11:55 <regXboi> and if something has to go to meet deadline - that would be #1
15:12:00 * regXboi goes and looks
15:12:00 <edwarnicke> regXboi: I think though from what I've been told, current VPNaaS isn't really usable, and thats why nobody is using it.  The hope is perhaps to make it usable in Liberty
15:12:40 <regXboi> edwarnicke: I believe I have a counter example for that, though not ODL based
15:12:47 <edwarnicke> regXboi: OK :)
15:12:54 <regXboi> flaviof: can you work with the plugin2oc folks?
15:12:59 <flaviof> anybody knows folks on contrail who can move https://git.opendaylight.org/gerrit/#/c/16161/  fwd?
15:13:06 <regXboi> and possibly escalate to zxiiro?
15:13:16 <flaviof> regXboi: i don't know who the contrail folks are
15:13:25 <edwarnicke> regXboi: flaviof we should go look at the neutron model patch: https://git.opendaylight.org/gerrit/#/c/15989/
15:13:37 <edwarnicke> regXboi: flaviof We either need to provide further feedback or merge it
15:13:42 <regXboi> whoa folks we are getting ahead of ourselves
15:13:50 * edwarnicke is so confused
15:13:59 <regXboi> we have one more action item we haven't covered
15:14:09 <regXboi> did either of you look at the doc patch?
15:14:12 <zxiiro> i think you guys got the right people cc'd
15:14:33 <flaviof> #action flaviof to try to find contrail folks to work on https://git.opendaylight.org/gerrit/#/c/16161/ or escalate it to zxiiro
15:15:00 <flaviof> zxiiro: thanks.
15:15:27 <regXboi> #action edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides
15:15:36 <edwarnicke> regXboi: link ?
15:15:40 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/16340/ initial document patch
15:15:42 <zxiiro> flaviof: might be worth emailing the folks listed on their wiki page too https://wiki.opendaylight.org/view/Southbound_plugin_to_the_OpenContrail_platform:Main
15:16:08 <flaviof> zxiiro: I know the email to Ankur (sp?) is bouncing...
15:16:10 <regXboi> ok... now
15:16:16 <regXboi> #topic review yang model
15:16:27 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/15989/ <- yang model patch
15:16:42 <regXboi> I've been commenting on this
15:16:45 <edwarnicke> #info reviewed doc patch
15:17:07 <regXboi> I'm behind on the last three patch sets
15:17:09 <kkoushik_> to summarize - i've fixed all the review comments and submitted updates. i've also uploaded security-groups and metering models
15:17:21 <regXboi> yes - those are the two I still have to look t
15:17:22 <regXboi> er at
15:17:26 <kkoushik_> only thing pending is lbaasv2
15:17:43 <regXboi> #action regXboi to review security-groups and metering models on yang model patch
15:18:00 <regXboi> I'll try to get to it this weekend - I've been swamped playing "techno janitor"
15:18:09 * edwarnicke goes to give the patch a quick review
15:19:04 <edwarnicke> kkoushik_: You are still defining uuid locally ratther than using yang:uuid
15:19:29 <kkoushik_> i did send out the comment that i tried with the ovsdb type uuid import and got compile errors
15:19:45 <kkoushik_> (i sent it to this group and also replied via review comments)
15:19:49 <edwarnicke> kkoushik_: Did you use the correct dependencies (because we are not getting compile errors from it in ovsdb)
15:20:14 <kkoushik_> not sure how to fix those? is it in the yang model or on the pom files?
15:20:29 <edwarnicke> regXboi: Do all entities carry a name and tenant-id in neutron ?
15:21:31 <regXboi> not *all*
15:21:41 <regXboi> A lot do, but not *all*
15:22:00 * regXboi notes that he's not sure how to contain rules in groups in the current security model
15:23:05 <edwarnicke> kkoushik_: Why are the network related identities still in neutron-attr rather than neutron-network ?
15:23:21 <edwarnicke> kkoushik_: One second, downloading your patch to see build errors
15:24:47 <edwarnicke> regXboi: So then wouldn't tenant-id and name belong as attributes of the thing, not as 'base' attributes that are presumed to be on all things?
15:25:15 <kkoushik_> edwarnicke: I guess you are referring to the network identities - will fix them now and move them over to neutron-network
15:25:32 <regXboi> edwarnicke: yes
15:25:44 <edwarnicke> kkoushik_: Cool :)
15:25:48 <regXboi> and I've made comments on the security and metering models
15:25:58 <regXboi> so I'm ready to move on to the next topic when others are
15:25:59 <edwarnicke> kkoushik_: I am going to poke quickly to find out why yang:uuid is vexing you :)
15:26:35 <regXboi> can we move on to testing?
15:26:54 <regXboi> #topic review testing
15:27:17 <regXboi> #info regXboi still owes patch, but wants folks to review the proposed junit strategy
15:27:26 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:JUnitTestStrategy <- proposed strategy
15:28:15 <regXboi> #link http://java.dzone.com/articles/how-test-rest-api-junit possible junit approach for rest testing
15:28:38 <regXboi> #info regXboi exploring above link about testing dummy provider via junit and resteasy in jjb
15:28:43 <regXboi> thoughts on all that?
15:29:13 <edwarnicke> regXboi: Question... are we verifying both that the correct value is transcribed *and* that the correct *Aware is passed the correct value?
15:30:55 <regXboi> edwarnicke: my plan was to pass in a JSON object to each I*aware interface and make sure the correct object comes out on the other end of the I*Aware interface
15:31:09 * regXboi mumbles wait I said that wrong
15:31:38 <regXboi> edwarnicke: my plan was to go through each set of CRUD calls and make sense that the correct objectcomes out the other end of the I*Aware interface
15:31:46 <regXboi> because that covers both cases
15:31:53 <edwarnicke> ack
15:32:50 <regXboi> any other questions on test?  (I really have to find time to work on this)
15:34:10 <Gaurav_> Hi all, this is Gaurav
15:34:16 <Gaurav_> i am from TCS
15:34:35 <Gaurav_> we would like to contribute to neutron northbound...
15:34:49 <Gaurav_> please guide us, from where should we start.. :)
15:35:08 <regXboi> Gaurav_: welcome!
15:35:49 <regXboi> if you go look at https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings
15:35:53 <regXboi> that's where we are right now
15:36:38 <regXboi> we are currently talking about JUnit test strategy, which is proposed in https://wiki.opendaylight.org/view/NeutronNorthbound:JUnitTestStrategy
15:37:02 <regXboi> as well as the possibility of use junit for rest testing as discussed in http://java.dzone.com/articles/how-test-rest-api-junit
15:37:09 <regXboi> does any of that look feasible?
15:37:28 <regXboi> in addition... (changing topics)
15:37:35 <regXboi> #topic review documentation
15:37:46 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/16340/ <- documentation patch
15:38:10 <regXboi> #info we need to start fleshing out the body of that documentation patch as M4 will look for word counts
15:38:21 * regXboi looks for volunteers
15:38:46 <regXboi> #info looking for volunteers - don't have to today, but will need somebody as we get closer to M4
15:38:57 <regXboi> #topic M4 status items
15:39:31 <regXboi> #info M4 deadline for us is 4/2 - two weeks
15:39:31 <odp-gerritbot> Ed Warnicke proposed a change to neutron: Example of how to use yang:uuid  https://git.opendaylight.org/gerrit/16922
15:39:46 <regXboi> here's what we will need to do:
15:39:46 <edwarnicke> kkoushik_: https://git.opendaylight.org/gerrit/16922 <- example of how to get yang:uuid working
15:39:57 <regXboi> 1) API freeze -> I'm not too worried about that
15:40:07 <regXboi> once we have the yang model done, we are pretty much there
15:40:21 <regXboi> 2) Documentation: Project readouts MUST include a word count of each relevant .adoc file with a goal of draft documentation done.
15:40:36 <regXboi> that's why I'm looking for volunteers
15:40:46 <regXboi> Projects are encouraged to meet the requirements to be included in maven central      Project readout MUST include whether or not this was accomplished
15:40:50 <regXboi> er oops
15:40:52 <regXboi> 3) Projects are encouraged to meet the requirements to be included in maven central      Project readout MUST include whether or not this was accomplished
15:41:07 <regXboi> edwarnicke: do you see a problem with this one?  I don't but I'm wondering if I'm missing something
15:41:20 <regXboi> and lastly:
15:41:24 <regXboi> 4) ntegration & System Test      Participating projects must run a simple system test on a karaf distribution with the project's recommended features installed on Code Merge (e.g. merge job), any upstream project Code Merge (e.g. integration job), as well as Release Creation events, e.g., weekly, RC and formal releases.4.
15:41:37 <regXboi> so we *really* need to be focusing on test and documentation now
15:41:56 <edwarnicke> regXboi: and model :)
15:42:13 <regXboi> so I'm proposing to redo the agenda for next week so we can start checking the M4 items off
15:42:34 <regXboi> edwarnicke: right now I'm looking at nits and missing the lbaasv2 and vpnaas and it's good
15:42:45 <kkoushik_> edwarnicke: thx - i see the pom.xml changes made the difference
15:42:46 <regXboi> and ready for unit testing
15:43:05 <regXboi> but we are in much better shape with code then the other items :(
15:43:41 <edwarnicke> kkoushik_: it was a little more than that, you were also using yang-types without a revision
15:44:10 <edwarnicke> kkoushik_: I also moved you to using binding-parent, because it uses yangtools-artifacts and thus you don't have to worry about sorting out things like versions as you inherit those from it :)
15:44:12 <regXboi> ok folks, anything else?
15:44:35 <flaviof> regXboi: ml2 to handle clustering...
15:44:46 <flaviof> regXboi: heard of anything like that?
15:45:00 <flaviof> I'm pretty sure edwarnicke will, if not already
15:45:36 <regXboi> no I've not
15:45:46 <flaviof> regXboi: this may not cause changes on neutron project, but there is a desire to have openstack HA using ODL HA.
15:45:46 <regXboi> clustering of what?
15:45:59 <regXboi> um
15:46:04 * regXboi laughs
15:46:10 * regXboi giggles
15:46:20 <regXboi> mestery: do you know anything about this?
15:46:47 <regXboi> sorry folks, but I don't see how one can actually do that without back channels
15:47:17 <regXboi> unless we are defining openstack HA in a different way than I am thinking
15:47:30 <regXboi> so .... enlighten me :)
15:47:38 <flaviof> regXboi: ok. sounds like the thought of HA has not made it to neutron northbound.
15:48:03 <flaviof> we have ODL HA; or at least say we do, right?
15:48:23 <regXboi> actually, I don't think we do *yet*
15:48:30 <regXboi> but I'll be happy to be corrected
15:48:32 <flaviof> there is also openstack HA, but the open question is what that means to ml2
15:48:52 <edwarnicke> flaviof: Tell me about how OS HA works
15:49:19 <flaviof> edwarnicke: I defer it to Jan. He recorded the meeint yesterday
15:50:17 <regXboi> no, I have no idea what this is about
15:50:25 <regXboi> but I still fail to see how it will happen
15:50:41 <regXboi> openstack HA implies (to me at least) some HA in the neutron/nova DB
15:50:58 <flaviof> regXboi: i think that is what folks are trying to figure out.
15:51:00 <regXboi> so ODL HA wouldn't help that, unless you are proposing to store all of OS data in ODL
15:51:13 <regXboi> and I think that would be a horrible idea
15:51:43 <flaviof> regXboi: you can shoot the messenger all day long. I got thick skin... ;)
15:52:08 <regXboi> flaviof: I'm not shooting you, I'm just saying we've got enough to finish without haring off
15:52:30 <flaviof> regXboi: ack.
15:52:55 <regXboi> I'll see about pinging some folks about it when I have time
15:53:01 <regXboi> anything else?
15:53:23 * edwarnicke still needs to know how OS does HA
15:53:50 <regXboi> ok but do we need to know that in the context of this meeting or can we close up for this week?
15:54:47 <edwarnicke> regXboi: Lets get an AI on it
15:55:02 <edwarnicke> flaviof: Would you take an AI to find out how OS does HA, so we can make sure we do stuff taht works with it?
15:55:34 <flaviof> edwarnicke: no. I would think you want to talk to Jan M.
15:55:39 <regXboi> I guess that's fair
15:55:54 <edwarnicke> flaviof: Why would Jan M know about OpenStack HA?
15:56:11 <flaviof> edwarnicke: because he setup a meeting on that yesterday.
15:56:23 <edwarnicke> On Openstack HA, or ODL HA?
15:56:39 <regXboi> I hope ODL HA
15:56:52 <flaviof> edwarnicke: on how to use OS HA with  ODL HA
15:56:56 <regXboi> because having an OS HA meeting without NN is .... well .... not a good idea
15:57:06 <flaviof> regXboi: +1
15:58:43 <regXboi> #link http://docs.openstack.org/high-availability-guide/content/ch-intro.html <- a starting point on OS HA
15:58:44 <edwarnicke> flaviof: Can you point me to the mail to the lists about an OpenStack HA meeting? (I ask because there may be some confusion, because I know Jan is chasing ODL HA stuff... but would be surprised if OpenStack HA is on his radar)
15:59:14 <flaviof> edwarnicke: yes. but... you can go directly to him, no?
15:59:27 <edwarnicke> flaviof: Already underway :)
15:59:38 <edwarnicke> flaviof: first thing I did :)
15:59:48 <regXboi> ok, so we'll figure this out on the ML?
15:59:54 <edwarnicke> regXboi: Sure :0
15:59:55 <edwarnicke> :0
15:59:56 <edwarnicke> :)
16:00:05 <regXboi> #topic muffins
16:00:08 <regXboi> #endmeeting