14:59:44 <regXboi> #startmeeting neutron_northbound_03_27_2015
14:59:44 <odl_meetbot> Meeting started Fri Mar 27 14:59:44 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:59:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:44 <odl_meetbot> The meeting name has been set to 'neutron_northbound_03_27_2015'
14:59:52 <regXboi> #chair flaviof edwarnicke
14:59:52 <odl_meetbot> Current chairs: edwarnicke flaviof regXboi
15:00:04 <regXboi> #topci roll call, agenda bashing
15:00:13 <regXboi> #topic roll call and agenda bashing
15:00:22 <regXboi> #info regXboi
15:00:46 <regXboi> all who are here feel free to #info in
15:00:49 <edwarnicke> #info edwarnicke
15:00:57 <regXboi> that way I know who can get action items :)
15:01:08 <edwarnicke> #undo
15:01:08 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x189f810>
15:01:15 <edwarnicke> ;)
15:01:23 <regXboi> [hint: the ones who are in the channel and aren't #info in get first dibs]
15:01:48 <regXboi> so edwarnicke, you might want to undo that undo
15:01:51 <regXboi> :)
15:01:53 <edwarnicke> #info edwarnicke
15:02:03 <Bhavesh> #info Bhavesh
15:02:38 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.283.2F27.29 Today's agenda
15:02:53 <regXboi> anybody want to add items to that beast?
15:03:42 <flaviof> regXboi: I'll need to leave in 30 mins
15:03:53 <regXboi> well, then we better get cracking
15:04:02 <shreshtha> hi
15:04:08 <regXboi> #topic action items from last meeting
15:04:28 <regXboi> I'm still working on test patches, so I can't claim #1 is done (sigh)
15:04:35 <flaviof> regXboi: I am having a lot of issues in running tempest consistently. will need help later in pm, if possible
15:04:51 <regXboi> flaviof: I'm not sure I *care* about tempest between now and 4/2
15:05:03 <regXboi> #action regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
15:05:04 <flaviof> on #2 I escalated the contrail merge issue to Thanh and Phil
15:05:24 <regXboi> #info flaviof escalated the contrail merge issue to Thanh and Phil
15:05:33 <regXboi> thanks - we'll talk about that patch later on
15:05:45 <regXboi> have you two looked at the documentation patch?
15:05:58 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/16340/ documentation patch in question
15:06:04 <flaviof> regXboi: no, not yet.
15:06:15 <regXboi> #action edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides
15:06:30 <flaviof> regXboi: ack
15:06:32 <regXboi> I've finished #4 (as that patch has been merged)
15:06:44 <regXboi> #info regXboi reviewed security-groups and metering models on yang model patch
15:06:53 <regXboi> and that's the action items from last time
15:06:56 <regXboi> #topic M4
15:07:09 * regXboi hears drum beat
15:07:18 <Shreshtha_> hi ... we would like to contribute to junit testing .. can we pick up apis for load balancering
15:07:24 <regXboi> Folks, M4 for us is 4/2 (i.e. less than a week)
15:07:45 <regXboi> Shreshtha_: hi - we'll get to that as part of the agenda
15:07:45 <Shreshtha_> i believe code freez is april 30
15:07:54 <regXboi> #info M4 deadline is 4/2
15:08:06 <edwarnicke> regXboi: Would now be a good time to talk about putting the neutron model stuff under /neutron/ or /openstack/neutron so its not all hanging off the top level of the model tree?
15:08:16 <regXboi> edwarnicke: wait one
15:08:28 <edwarnicke> regXboi: ack :)
15:08:30 <regXboi> we've got lots of subtopics we have to meet for M4
15:08:33 <edwarnicke> (M4 related due to API freeze)
15:08:38 <regXboi> Sub topic 1: API Freeze
15:08:46 <regXboi> #topic M4/API Freeze
15:09:01 <regXboi> so... the yang model patch got merged
15:09:17 <regXboi> *but* edwarnicke has a related topic on tree structure he wants to bring up
15:09:24 <regXboi> #info yang model patch is merged
15:09:35 <regXboi> #info edwarnicke has tree structure topic to discuss
15:09:43 <regXboi> ok, edwarnicke, that's your queue
15:09:47 <regXboi> er cue :)
15:10:05 * regXboi passes "duck" to edwarnicke
15:10:17 <edwarnicke> regXboi: Sure
15:10:22 <edwarnicke> So, the issues is this
15:10:54 <edwarnicke> Right now we are putting in the top level of the model tree each individual object (network, router, floatingips, port, etc)
15:10:57 <kkoushik__> #info kkoushik
15:11:07 <edwarnicke> But logically they are *not* global things, logically they are all scoped under neutron
15:11:23 <edwarnicke> So I was thinking we should actually scope them in the model tree under a neutron container
15:11:38 <edwarnicke> So they become /neutron/networks /neutron/ports etc
15:11:54 <regXboi> #info edwarnicke points out that each neutron object is being put at the top level of the model tree
15:12:13 <regXboi> #info while logically ther aren't global, they are scoped under neutron
15:12:32 <edwarnicke> Curious other peoples thoughts
15:12:34 <regXboi> #info so edwarnicke is proposing that we should actually scope them in the model tree under a neutron container
15:12:58 <regXboi> #info regXboi asks about the implication of splitting models that include augmentations :)
15:13:52 <odp-gerritbot> Ed Warnicke proposed a change to neutron: DO NOT MERGE - First go at putting neutron model under /neutron  https://git.opendaylight.org/gerrit/17243
15:14:01 <regXboi> I think it's a reasonable proposal to keep the tree clean, but I believe that it means we have to restructure some of the extention models so that we don't get circular dependencies
15:14:10 <flaviof> edwarnicke: if the implications of this change are not high risk, scoping is a good idea. We shall never mix ovs's port with neutron port, so the better job we do in scoping 'port' (for instance) the better we are.
15:14:12 <edwarnicke> regXboi: flaviof kkoushik__ here's a start at what I mean: https://git.opendaylight.org/gerrit/17243
15:14:13 <regXboi> #link https://git.opendaylight.org/gerrit/17243 first go at this patch
15:14:27 <edwarnicke> flaviof: That's kind of my thinking ;)
15:14:50 <regXboi> #action everybody to review https://git.opendaylight.org/gerrit/17243 and provide comments
15:15:01 <regXboi> I've given out an action :)
15:15:03 <kkoushik__> edwarnicke: I'll think about the implications and review
15:15:17 <edwarnicke> kkoushik__: Please note,its *not* complete yet
15:15:37 <kkoushik__> edwarnicke: i understand - will review the concept
15:15:40 <edwarnicke> kkoushik__: There is a cycle between neutron.yang and neutron-l3.yang that still needs to be broken
15:15:41 <regXboi> in addition, the yang code also requires the *aaS models - kkoushik__ can we look to you for that?
15:16:22 <kkoushik__> i started working on LBaaS -
15:16:30 <edwarnicke> kkoushik__: :)
15:16:31 <kkoushik__> will put more effort into it
15:16:42 <regXboi> #info yang also requires *aaS models
15:16:50 <regXboi> #info kkoushik__ has started LBaaS
15:17:23 <regXboi> ok, the spi tree is now actually behind the yang model in some ways - it is missing VPNaaS and metering (and possibly others) - do we have a volunteer for that?
15:18:07 <regXboi> the key thing is that the NB code will need methods for anything new in the spi tree, and that we need to get in enough by 4/2 so that we can freeze the APIs
15:18:43 <regXboi> and lastly, the transcriber code needs to actually write to the yang model
15:18:50 <regXboi> so...
15:19:01 <regXboi> #info the spi tree needs to catch up with the yang model
15:19:15 <regXboi> #info the nb tree needs methods for any new objects added to the spi tree
15:19:26 <regXboi> #info the transcriber tree needs to write into the yang model
15:19:36 <regXboi> #info and looking for volunteers for all of these
15:20:40 <regXboi> sigh
15:21:05 <regXboi> well, I'll hit the mailing list after the meeting and see what a message there shakes out...
15:21:42 <regXboi> #info thanks for flaviof for rebasing the IPv6 patch from controller over to neutron - its merged in and that should help with the tempest testing
15:21:53 <edwarnicke> flaviof: :)
15:22:07 <regXboi> #link https://git.opendaylight.org/gerrit/#/q/project:neutron+status:open current open patches
15:22:10 <flaviof> np!
15:22:19 <regXboi> I want to go through these at the end of the meeting and see what we can merge
15:22:27 <regXboi> flaviof: thanks for the reviews
15:22:38 <regXboi> #topic M4/documentation
15:22:44 <odp-gerritbot> A change was merged to neutron: Add JAXB JUnit testing for Neutron Floating IPs  https://git.opendaylight.org/gerrit/17067
15:22:45 <odp-gerritbot> A change was merged to neutron: Add Junit testing of JAXB for Neutron FWaaS objects  https://git.opendaylight.org/gerrit/17056
15:23:00 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/16340/ updated documentation
15:23:17 <regXboi> #info We really need a volunteer for the YANG model piece of this
15:23:31 <regXboi> #action regXboi to address colindixon review comments on the documenation patch
15:23:47 <regXboi> but I'm on the hook for the colin's comments
15:23:57 <regXboi> anything else on documentation?
15:24:07 <regXboi> if not ...
15:24:19 <regXboi> #topic M4/Maven Central
15:24:32 <regXboi> #link http://central.sonatype.org/pages/requirements.html requirements for maven central
15:24:45 <regXboi> edwarnicke: we pretty much cover all of this already, don't we?
15:25:02 <regXboi> I couldn't find the pieces I showed in the agenda when I looked
15:25:11 <edwarnicke> regXboi: Looking
15:25:20 <regXboi> but can I look to you to fill in what is missing?
15:25:30 <regXboi> as your maven/pom fu is strong?
15:25:34 <edwarnicke> Javadoc and source should be handled by jenkins
15:25:40 <edwarnicke> Code signing is being handled by jenkins
15:25:57 <regXboi> it's the pom file requirements that I wasn't 100% sure about
15:26:04 <edwarnicke> I suspect we are not good on this: http://central.sonatype.org/pages/requirements.html#sufficient-metadata
15:26:13 <edwarnicke> But would have to check
15:26:23 <regXboi> yep - that's where I was most nervous
15:26:32 <regXboi> can I action you to fix that?
15:26:52 <regXboi> #action edwarnicke to align pom with requriements from http://central.sonatype.org/pages/requirements.html#sufficient-metadata
15:26:58 <regXboi> (silence is assent :) )
15:27:29 <regXboi> #topic M4/integration and system test
15:28:06 <regXboi> flaviof: as testing contact, I'm sort of looking to you to make sure we have the simple system test running on merge/integration and rc events
15:28:31 <Shreshtha_> hi,, can we pick up junit testing for some apis for this week target
15:28:32 <flaviof> regXboi: yes, and I do the same with dfarrell07 :)
15:28:41 <edwarnicke> Shreshtha_: Many thanks :)
15:28:49 <regXboi> Shreshtha_: it's all yours
15:29:11 <Shreshtha_> pleasure :)
15:29:18 <regXboi> #action flaviof to work karaf system test for merge, integration, and RC events
15:29:36 <Shreshtha_> we will be submiting in patches coming week...
15:29:40 <flaviof> regXboi: is that jjb?
15:29:49 <regXboi> #action Shreshtha_ to put together junit testing for some apis this week
15:29:51 <regXboi> flaviof: yes
15:30:25 <regXboi> #info the junit strategy documented on https://wiki.opendaylight.org/view/NeutronNorthbound:JUnitTestStrategy has been implemented
15:30:28 <regXboi> yea!
15:30:48 <regXboi> ok... flaviof, we are going to talk the nastiness of the open junit patch
15:31:03 <regXboi> if you have to run away, we've covered pretty much everything else
15:31:27 <flaviof> regXboi: yeah. I will get back to meeting notes.
15:31:30 <flaviof> thanks
15:31:37 <regXboi> Topic namespace ugliness in network junit/jaxb test
15:31:46 <regXboi> #topic namespace ugliness in network junit/jaxb test
15:31:52 <regXboi> sigh fingers faster than hand
15:32:14 <regXboi> so folks, this patch needs a rebase, but to make it work I had to do something potentially ugly
15:32:46 <regXboi> specifically, if you look at NeutronNetwork.java, I had to hard code the name directly into the object, rather than use namespaces
15:33:08 <regXboi> because I haven't been able to get namespace registration to work with jersey's stock jaxb unmarshaller
15:33:19 <regXboi> so the options are either to go with this and strip out MOXy
15:33:28 <regXboi> or pull MOXy into the JAXB/Junit testing
15:34:03 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/17078/ patch in question
15:34:27 <regXboi> #info regXboi points out that this patch makes a change to how namespaces are handled in jaxb
15:34:49 <regXboi> #info because he has been unable to get namespace registration to work with jersey's stock jsonjaxb unmarshaller
15:35:13 <edwarnicke> flaviof: Do you know anything about this, I think you guys are using jackson for this, right?
15:35:14 <regXboi> #info so he only sees two options at this point: (1) pull out moxy and hardcode full attributes names (with namespace embedded)
15:35:24 <regXboi> #info or (2) pull moxy into the junit testing
15:35:33 <regXboi> I'm interested in people's thoughts
15:35:47 <regXboi> as this is going to come up again when we get to ports
15:36:40 * flaviof stepping out... be back in a couple of hours.
15:36:46 <edwarnicke> regXboi: My preference would be that we get away from moxy entirely... but that's work, and so I defer to who is doing the work here
15:37:03 <regXboi> edwarnicke: that is actually my preference as well
15:37:11 <regXboi> so I'm leaning towards #1
15:37:50 <regXboi> anybody else have an opinion?
15:38:29 <regXboi> ok ...
15:38:51 <regXboi> #action regXboi to rebase  https://git.opendaylight.org/gerrit/#/c/17078/ and look at pulling MOXy out
15:39:19 <regXboi> #topic marking FWaaS classes and interfaces as deprecated patch
15:39:30 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/16150/
15:39:44 <regXboi> edwarnicke: flaviof has +2'd this
15:39:53 <regXboi> any reason not to merge this in?
15:39:54 <odp-gerritbot> A change was merged to neutron: Marking of FWaaS classes and interfaces with as deprecated.  https://git.opendaylight.org/gerrit/16150
15:40:03 <regXboi> ok :)
15:40:12 * edwarnicke is a man of action, not words
15:40:18 <regXboi> alrighty folks, that's all the topics I have for today
15:40:28 <regXboi> #topic open discussion
15:41:12 <regXboi> #info regXboi wonders if we need to schedule mini-hackathon IRC meetings and hangouts more frequently to increase velocity
15:41:27 <regXboi> that info is something that I'm putting on the table for folks to think about
15:41:57 <regXboi> we're going to have a lot of things we have to finish by M5, and i'm wondering if we need to gather up more often that once per week...
15:42:15 <regXboi> I'll put the question to the mailing list and see what folk's reaction is
15:42:37 <regXboi> #action regXboi to float mini-hackathon trial ballong to mailing list
15:42:55 <regXboi> any other topics on people's mind?
15:43:06 <regXboi> I know that flaviof sent email about tempest test problems
15:43:19 <regXboi> but I'm not sure how/when to factor that into our plans
15:44:05 <regXboi> other topics .... going once
15:44:30 * edwarnicke waiting for the gavel
15:44:35 <regXboi> going twice
15:44:55 <regXboi> ok folks can have 15 minutes back... see you on the mailing list
15:44:58 <regXboi> #topic muffins
15:45:03 <regXboi> #endmeeting