15:00:22 <regXboi> #startmeeting neutron_northbound_2015_03_13
15:00:22 <odl_meetbot> Meeting started Fri Mar 13 15:00:22 2015 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:00:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:22 <odl_meetbot> The meeting name has been set to 'neutron_northbound_2015_03_13'
15:00:34 <regXboi> #chair flaviof, edwarnicke
15:00:34 <odl_meetbot> Current chairs: edwarnicke flaviof regXboi
15:00:42 <regXboi> #topic agenda bashing
15:00:51 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda
15:01:21 <regXboi> folks, take a look at the agenda - is there anything else we need to cover?
15:01:56 * dfarrell07|sick is here
15:02:23 <regXboi> dfarrell07|sick thanks
15:02:33 <mestery> regXboi: LGTM
15:02:35 <flaviof> #info flaviof
15:02:52 <regXboi> mestery: thanks - will give others a few minutes
15:03:16 <kkoushik_> yes, i'm here
15:03:45 <regXboi> if there are no changes, we will move to action items from previous meeting...
15:04:01 <regXboi> #topic cover action items
15:04:19 <regXboi> flaviof: do you have the links for the emails on how to migrate?
15:04:33 * regXboi knows you sent them, but was wondering if we can point to links
15:04:35 <flaviof> #info flaviof checked all uses of neutron and sent email
15:05:28 <flaviof> regXboi: I made all the changes needed instead of showing how to do it. So I have gerrits, listed in dev-neutron
15:05:56 <regXboi> ok, we'll see about linking that on the project page
15:06:02 <regXboi> can I ask you to do that?
15:06:26 <flaviof> regXboi: link to the email I sent?
15:06:40 <regXboi> yes - add that to the Lithium project page (somewhere)
15:06:48 <edwarnicke> dfarrell07|sick: weren't you instructed to get well
15:06:49 <flaviof> regXboi: np
15:06:55 <regXboi> flaviof: thanks
15:07:20 <flaviof> #action flaviof to add link in Lithium project page on the info for migrating projects to the new neutron repo
15:07:24 <dfarrell07|sick> edwarnicke: lol, working on it ;)
15:07:26 <regXboi> you beat me to it
15:07:30 <regXboi> ok next item
15:07:40 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Lithium_Release_Plan#User_Facing_Karaf_Features_List <- list of karaf features
15:07:47 <regXboi> that look correct edwarnicke?
15:08:01 <edwarnicke> regXboi: yep :)
15:08:20 <regXboi> ok... next
15:08:31 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/16340/ <- initial document commit
15:08:44 <regXboi> IIRC I listed that on the project page
15:09:10 <regXboi> and
15:09:33 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/16155/ <- dummy provider code
15:09:40 <regXboi> I think we can try writing test cases to that
15:10:31 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/15989/ <- yang model
15:10:37 <regXboi> we'll talk about this more later
15:10:38 <edwarnicke> regXboi: Looks good to me :) Mind if I merge
15:10:53 <regXboi> edwarnicke, we should change the comment first?
15:11:23 <edwarnicke> regXboi: I was referencing the test dummy
15:11:32 <regXboi> edwarnicke: I know
15:11:41 <regXboi> the comment on that patch is "DO NOT MERGE"
15:11:57 <odp-gerritbot> Ryan Moats proposed a change to neutron: Dummy provider for neutron testing  https://git.opendaylight.org/gerrit/16155
15:12:05 <regXboi> and that change should do the trick
15:12:36 <regXboi> so once that verifies - sure we can +2 and merge it
15:13:02 <regXboi> back to the yang model (action item #5) I consider that closed
15:13:08 <regXboi> as we are now breaking the model apart
15:13:12 <edwarnicke> regXboi: ?
15:13:20 <edwarnicke> regXboi: The yang model still needs a bit of workj
15:13:30 <regXboi> yes, and we have a topic for it
15:13:40 <edwarnicke> Doh
15:13:43 <regXboi> the action item was "to add all the extensions into a single model"
15:13:43 <edwarnicke> read to fast
15:13:55 <regXboi> I consider that action item closed because we are breaking it apart :)
15:14:06 <edwarnicke> Is kkoushik_ around ?
15:14:09 <kkoushik_> yes, i'm here
15:14:23 <edwarnicke> kkoushik_: Cool, do you see the two comments to your updates?
15:14:36 <regXboi> before we get to that - we have one more action item :)
15:14:39 <kkoushik_> i've addressed most of the comments from patch6 in patch7
15:14:46 <kkoushik_> ok, i'll wait
15:14:47 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings <- meeting wiki page
15:14:53 <regXboi> #topic Yang Model
15:15:05 <regXboi> kkoushik_ -> ok *now* :)
15:15:19 <edwarnicke> kkoushik_: There are two new ones to patch 7 :)
15:15:38 <edwarnicke> kkoushik_: I commented asking why we don't just use the standard yang uuid (example of its use here:  https://git.opendaylight.org/gerrit/gitweb?p=ovsdb.git;a=blob;f=southbound/southbound-api/src/main/yang/ovsdb.yang;h=ac27f72709aec7bbb15c4e75f90f5807c2415f8a;hb=HEAD )
15:15:41 <kkoushik_> ok - all the comments except breaking up the model into more pieces + new comments on patch7 have been addressed
15:15:56 <kkoushik_> I tried that - but it won't compile in the neutron ws
15:16:19 <kkoushik_> not sure where/how to bring the latest model in which has the uuid: definition
15:16:36 <regXboi> edwarnicke: can you help out after we are done?
15:16:37 <edwarnicke> kkoushik_: And Wojiech commented about binding host_id not being a uuid
15:16:47 <edwarnicke> kkoushik_: That's why I pointed you to the example :)
15:16:48 <regXboi> well
15:16:51 <edwarnicke> kkoushik_: https://git.opendaylight.org/gerrit/gitweb?p=ovsdb.git;a=blob;f=southbound/southbound-api/src/main/yang/ovsdb.yang;h=ac27f72709aec7bbb15c4e75f90f5807c2415f8a;hb=HEAD does it
15:16:52 <kkoushik_> i'll address that
15:16:57 <regXboi> well
15:17:05 <regXboi> the binding items all need to go into an extension
15:17:21 <regXboi> as does the router:external in networks (second extension)
15:17:22 <kkoushik_> ed: i'll fix that - thx
15:17:38 <kkoushik_> regXboi: agreed on the new extension models
15:17:45 <regXboi> kkoushik_: thanks
15:17:53 <kkoushik_> regXboi: will get to them by monday
15:18:02 <regXboi> note: the router:external extension also adds the router and floatingip models
15:18:10 <regXboi> because that is all part of the L3 extension
15:18:26 <regXboi> so I'd suggest calling that one neutron-L3.yang
15:18:38 <kkoushik_> regXboi: ok - that makes sense
15:18:38 <regXboi> or something like that
15:19:11 <kkoushik_> i'm having trouble replying to comments on gerrit webpage(they get marked as "Draft")
15:19:29 <kkoushik_> not sure how to publish them for public visibility
15:19:31 <regXboi> IIRC, that's the case until you "post" a review
15:19:31 <edwarnicke> kkoushik_: You have to submit your 'Reply' for them to go in
15:19:47 <regXboi> so on the yang model, here's what I see that we still need:
15:20:05 <regXboi> neutron-security-groups (security groups and rules)
15:20:26 <regXboi> neutron-metering (metering labels and rules)
15:20:40 <regXboi> neutron-lbaas (LBaaS v2.0)
15:20:51 <regXboi> mestery: am I missing anything?
15:21:25 * regXboi wondering about vpnaas
15:23:03 <mestery> vpn
15:23:05 <mestery> lets do that too
15:23:10 <regXboi> pointer?
15:23:17 <mestery> to what? The API doc?
15:23:33 <regXboi> will that be part of Kilo?
15:23:36 <edwarnicke> mestery: Think we could get Prem to do VPN ;)
15:23:47 <regXboi> if so, then pointers to the API and the datamodel
15:23:48 <mestery> It's been a part of Havana, Icehouse and Juno, non-experimental, so yes.
15:24:08 <regXboi> interesting - it's not documented on the Networking API page
15:24:35 * edwarnicke would gets how hard documentation is
15:24:52 <edwarnicke> s/would//
15:24:56 <regXboi> ok, so we will need links to the API and the data model
15:25:08 <regXboi> but yes, we need to add neutorn-vpnaas (VPNaaS) as well
15:25:35 <edwarnicke> regXboi: Should we loop in the VPN Services guys to work on that?
15:25:37 * regXboi admits that he still needs to do attribute level checking
15:25:43 <edwarnicke> regXboi: I bet Prem would be all over it :)
15:26:25 <regXboi> edwarnicke: if they are willing to commit both yang model and data model/Aware interface/Dummy Provider code, sure
15:26:42 <edwarnicke> regXboi: Question on that point
15:26:51 <regXboi> but they don't get to cherry pick the yang model
15:26:57 <regXboi> edwarnicke: ask away
15:27:02 <edwarnicke> regXboi: Since we do not currently have the Aware for VPN Services, do we necessarily need it added?
15:27:14 <regXboi> for consistency's sake - yes
15:27:23 <edwarnicke> regXboi: My understanding is we were maintaining the Aware stuff to ease migration
15:27:30 <edwarnicke> which I wholeheartedly support
15:27:36 <edwarnicke> But in this case, there is no migration
15:27:56 <edwarnicke> It feels strange to introduce an API we already intend to deprecate in Be
15:27:59 <regXboi> as we are not requiring folks to switch to yang in this release, I can't ask a project to support both I*Aware and Yang
15:28:10 <edwarnicke> regXboi: Fair
15:28:13 <regXboi> so, for example
15:28:31 <regXboi> I'm thinking of folks like OVSDB and VTN here
15:28:43 <regXboi> if they want VPNaaS, we'd leave them a bit out in the cold
15:28:58 <regXboi> but yes, it *does* look odd providing a new interface that we are going to deprecate in Be
15:29:13 <edwarnicke> regXboi: Might it be worth asking if they intend to do anything with that in Li ?
15:29:26 <edwarnicke> regXboi: I think the only folks looking to do stuff in Li with VPN are VPN Services (though could be mistaken)
15:29:32 <regXboi> edwarnicke: you've got the action item :)
15:29:44 * edwarnicke should learn to keep his mouth shut ;)
15:30:03 <regXboi> #action edwarnicke to poll users of neutron to see if any (other than VPN services) are looking to use Neutron VPNaaS in the Li timeframe
15:30:16 <regXboi> hey, if you get a no answer, then we just go Yang on that one
15:30:33 <edwarnicke> regXboi: Fair :)
15:30:50 <regXboi> edwarnicke: can I also ask you to approach Prem about providing the initial neutron-vpnaas yang model?
15:30:56 <edwarnicke> regXboi: Shall I send email to neutron-dev, vpn-dev, and disucss ?
15:30:56 <regXboi> you know him better than I
15:31:03 <edwarnicke> regXboi: Happy to
15:31:10 <edwarnicke> regXboi: And my guess is he will be excited to do so :0
15:31:11 <edwarnicke> :0
15:31:13 <edwarnicke> :)
15:31:16 * edwarnicke can't type today
15:31:32 <regXboi> I'd be fair - I'd send the email to the projects that flaviof submitted patches to :)
15:32:16 <regXboi> #link https://lists.opendaylight.org/pipermail/neutron-dev/2015-March/000048.html list of neutron dependencies
15:32:24 <regXboi> so more than just neutron, vpn and discuss
15:32:30 <edwarnicke> regXboi: Yep
15:32:48 <regXboi> anything else on Yang for now or can we move on to testing?
15:33:02 <regXboi> obviously, yang stays on the agenda for next week :)
15:33:11 <regXboi> doh
15:33:30 <edwarnicke> regXboi: Sounds good... next topic :)
15:33:36 <regXboi> wait - need infos :)
15:33:51 <regXboi> #info we still need neutron-security-groups (security groups and rules)
15:34:02 <regXboi> #info we still need neutron-metering (metering labels and rules)
15:34:10 <regXboi> #info we still need neutron-lbaas (LBaaS v2.0)
15:34:14 <regXboi> ok
15:34:18 <regXboi> #topic testing
15:34:38 <regXboi> first item here - we need to finish the M3 testing item, which is ETA today
15:34:51 <regXboi> "Simple system test on a karaf distribution with the project's recommended features installed " is what it literally says
15:34:57 <regXboi> do we have a patch on intergration for that?
15:35:11 <regXboi> or a patch anywhere?
15:35:37 <edwarnicke> regXboi: I don't think so yet
15:35:52 <regXboi> do we think we can get one by COB today?
15:35:57 <regXboi> or do we slip this to red :/
15:36:05 <edwarnicke> regXboi: I think for us that would consist of something which loads the dummy provider and simply checks to see if we are unmarshalling all the REST correct, right?
15:36:08 <flaviof> regXboi: by "project's recommended features installed" do you mean feature:install odl-ovsdb-openstack
15:36:10 <flaviof> ?
15:36:14 <edwarnicke> regXboi: I don't think it can be done today
15:36:22 <regXboi> flaviof: no
15:36:40 <flaviof> regXboi: you mean dummy test?
15:36:51 <regXboi> I would think it is odl-neutron-service
15:37:01 <flaviof> regXboi: make sense.
15:37:04 <regXboi> and then the dummy provider
15:37:11 <regXboi> and edwarnicke is correct
15:37:20 <regXboi> it is a simple unmarshalling of all the REST at this point
15:37:29 <edwarnicke> flaviof: neutron has to be tested standalone
15:37:33 <flaviof> understood.
15:37:50 <regXboi> #link https://wiki.opendaylight.org/view/NeutronNorthbound:JUnitTestStrategy <- wiki page on JUnit testing strategy for more complex cases
15:37:52 <edwarnicke> flaviof: neutron is provider agnostic :)
15:38:18 <regXboi> we are bleeding into the second sub-topic here, which is the JUnit stuff
15:38:19 <flaviof> edwarnicke: indeed.
15:38:26 <edwarnicke> regXboi: I tend to prefer system tests for REST stuff to unit tests
15:38:48 <regXboi> edwarnicke: if you look at that page - I leave the marshall/unmarshall to system test
15:38:54 <edwarnicke> regXboi: We literally hit two issues this week on the RESTCONF migration where the underlying classes had 100% unit test code coverage, and we still had bugs because of jersey interactions
15:39:02 <edwarnicke> regXboi: Cool, read to fast ;)
15:39:03 <regXboi> those methods I call out are actual logic that we can test in JUnit
15:40:00 <regXboi> edwarnicke: refresh - I clarified
15:40:25 <regXboi> by stating that the majority can be tested via system test, so this page concentrates on the other (bold)
15:40:36 <flaviof> edwarnicke: the chatty issues on jetty.... is that something that will get fixed soon?
15:40:53 <edwarnicke> flaviof: chatty issues on jetty ?
15:41:03 * flaviof not sure if that is what edwarnicke meant by REST issues
15:41:43 <flaviof> edwarnicke: project's recommended features installed
15:41:54 <flaviof> undo that.... :)
15:42:00 <flaviof> edwarnicke:  java.lang.IllegalStateException: No LoginService for org.eclipse.jetty.security.authentication.BasicAuthenticator@678309d4 in org.eclipse.jetty.security.ConstraintSecurityHandler@4bfa7263 java.lang.IllegalStateException: No LoginService for org.eclipse.je
15:42:28 <regXboi> can we take that up after we are done?
15:42:45 * regXboi doesn't want to go off and troubleshoot jetty problems here
15:42:51 <flaviof> regXboi: np. thought that is what we were talking about. sorry
15:43:56 <regXboi> not precisely, I'm talking about have a patch to integration that does a simple unmarshalling test with the dummy providers against odl-neutron-service
15:44:06 <regXboi> so that we can claim we are done with M3
15:44:52 <regXboi> edwarnicke: although now that I've typed the above, I'm thinking that we may need a separate dummy provider feature for integration to be happy :/
15:45:43 <regXboi> so, who can I #action for that item :)
15:45:53 * regXboi waits for the crickets .....
15:46:07 <regXboi> that item == the integration patch
15:47:24 * regXboi listens to the crickets
15:48:44 <regXboi> flaviof: as test contact, can I look to you to do set that up?
15:50:07 <regXboi> did everybody just run away?
15:50:18 * dfarrell07|sick is still here
15:50:55 * regXboi watches the time for documentation run away
15:51:09 <dfarrell07|sick> ping flaviof
15:52:17 <flaviof> regXboi: sorry, here
15:52:17 <dfarrell07|sick> well...lol
15:52:25 <dfarrell07|sick> ah cool :)
15:52:38 <flaviof> regXboi: dfarrell07|sick: I'm busy with mdsal work on ovsdb; would prefer to defer that action to dfarrell07|sick if possible
15:53:07 <regXboi> dfarrell07|sick are you up to doing that ?
15:53:48 <dfarrell07|sick> I think it's pretty out of scope for my current TODOs, would be very non-trivial for me to get spun on that much NNB project detail
15:54:06 <regXboi> dfarrell07|sick - that is why I asked
15:54:30 <regXboi> dfarrell07|sick - do you know how integration sets up the robot framework for testing?
15:54:59 <regXboi> i.e. are you willing to help someone else (who has the NNB project expertiese) get the intergration patch in?
15:55:02 <dfarrell07|sick> regXboi: to be honest, I know the basics but most of my Integration work hasn't been in that domain (integration with outside projects/tools)
15:55:16 <dfarrell07|sick> regXboi: yes, I can help muster Integration team help
15:55:25 <regXboi> dfarrell07|sick: ok that's fair
15:56:39 <regXboi> #action regXboi to put together integration patch (with resource help from dfarrell07|sick) for REST unmarshalling testing of odl-neutron-service with dummy provider.
15:56:51 * regXboi sighs
15:57:00 <regXboi> ok, next topic
15:57:15 <regXboi> #topic documentation
15:57:51 <regXboi> #link https://git.opendaylight.org/gerrit/#/c/16340/ <- intiial documentation link
15:58:05 <regXboi> edwarnicke, flaviof: I'm going to action you both to review
15:58:24 <regXboi> and add comments about fleshing out the two parts
15:58:53 <regXboi> #action edwarnicke, flaviof to review initial documentation patch and provide comments/structure for fleshing out the two sides
15:59:06 <regXboi> anything else?
15:59:15 <regXboi> otherwise...
15:59:24 * dfarrell07|sick has nothing else
15:59:27 <regXboi> going once?
15:59:28 <dfarrell07|sick> cookies?
15:59:44 <regXboi> edwarnicke, flaviof: going twice?
16:00:06 <regXboi> sold...
16:00:09 <regXboi> #topic cookies
16:00:12 <regXboi> #endmeeting