16:01:44 <yamahata> #startmeeting neutron_northbound
16:01:44 <odl_meetbot> Meeting started Fri Jan  8 16:01:44 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:44 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:02:02 <yamahata> #topic agenda bashing and roll call
16:02:12 <yamahata> #info yamahata
16:03:23 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings
16:03:56 <flaviof> #info flaviof
16:04:06 <yamahata> I'd like to add one more on discussion on Be release
16:04:18 <yamahata> #chair flaviof
16:04:18 <odl_meetbot> Current chairs: flaviof yamahata
16:04:41 <yamahata> any other agenda?
16:05:39 <yamahata> okay let's move on
16:05:45 <flaviof> nothing else from /me at the moment
16:05:54 <yamahata> #topic Announcements
16:05:59 <yamahata> a happy new year
16:06:27 <flaviof> happy new year folks!
16:06:31 <yamahata> and I hope everyone spent good time and now returning back to the work
16:07:07 <yamahata> call for speaker for openstack summit ausutine is opened
16:07:59 <yamahata> #info https://www.openstack.org/summit-login/login?BackURL=%2Fsummit%2Faustin-2016%2Fcall-for-speakers%2F call for speaker openstack summit ausutin 2016
16:08:08 <yamahata> the deadline is Feb 1
16:08:17 <yamahata> I'd like to discuss it today
16:08:50 <flaviof> it is unlikely /me will make it to this one; but I was wondering if folks have something to speak as well. if so I could help prepare
16:08:58 <yamahata> and also call-for-participation for ONS is also open
16:09:39 <flaviof> yamahata have a link for that (ONS)?
16:09:41 <yamahata> flaviof: oh that's a pity.
16:10:22 <yamahata> #link http://opennetsummit.org/program/ Submit a Proposal to Speak at Open Networking Summit 2016
16:10:42 <yamahata> Last year ODL mini summit was collocated with ONS 2015
16:10:52 <yamahata> But it doesn't seem on 2016
16:11:15 <flaviof> thanks for the link. and indeed too bad about Austin
16:11:21 <yamahata> any other announcement?
16:12:39 <yamahata> #topic action items from last meeting
16:13:21 <yamahata> Isaku wrote (a first draft of) documentation for neutron northbound
16:13:48 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/32109/ beryllium document for neutron northbound
16:14:04 <yamahata> I missed the required date, but it's better than nothing
16:14:36 <yamahata> So far it didn't get review. Is there any procedure for Be documentation?
16:15:12 <yamahata> I updated the project release plan wiki page to reflect the current situation
16:15:35 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Beryllium_Release_Plan Neutron northbound Beryllium release plan
16:16:24 <yamahata> before moving onto other planned agend, I'd like to discuss call-for-speakers for openstack summit
16:16:28 <flaviof> cool. thanks for doing that!
16:16:42 <yamahata> #topic  call-for-speakers for openstack summit austin 2016
16:17:16 <yamahata> I think we'd like to apply for it jointly.
16:17:43 <yamahata> who is interested in it? Especially our networking-odl effort is worthwhile to speak.
16:18:05 <john_a_joyce> what were you thinking in terms of content
16:18:21 <yamahata> IIRC, flaviof, armand and others gave presentation in the past
16:18:25 <john_a_joyce> were you thinking we should cover the rewrite?
16:18:34 <yamahata> something like status update on the project
16:19:10 <yamahata> john_a_joyce: Yeah! What's new, (demo?), future direction and so on
16:19:36 <john_a_joyce> if you think there would be interest in the V2 driver that we (or at least I) could sign on for that portion
16:19:38 <yamahata> depending on time, easy introduction on how-to-use
16:19:59 <vthapar> at thsi point I am not sure of my travel plans but support for BGPVPN and [hopefully] L2GW added in Be+Mitaka could interesting for OpenStack community.
16:20:32 <yamahata> vthapar: definitively BGPVPN and L2GW should be discussed.
16:21:25 <flaviof> yamahata i think a preso on rally may be interesting too, but it could we are too early on that for the summit
16:21:30 <vthapar> is it normally just a presentation or a demo too?
16:23:00 <yamahata> flaviof: that=demo?
16:23:24 <yamahata> vthapar: It's up to speakers. We can go for presentation only or with demo.
16:23:40 <yamahata> IIRC flaviof gave short demo in the past, right?
16:25:21 <yamahata> Anyway we have many interest for speaking at the summit. Let's try to summit it.
16:25:28 <flaviof> yamahata that is right. demo is nice but not required
16:26:36 <yamahata> The next step is, write down the abstraction (and internal coordination to get grant for presentation)
16:27:27 <yamahata> If possible, it would be better to pull Armand in
16:27:39 <flaviof> armax ^^
16:28:28 <yamahata> #action everyone interested internal arrangement and prepare abstract
16:29:26 <yamahata> any questions or comments?
16:29:53 <flaviof> yamahata it is possible armax got too busy the the ptl duties and would not be able to get involved in networking-odl
16:30:23 <yamahata> flaviof: sounds plausible
16:31:05 <yamahata> #topic patch review/bug fix
16:31:28 <yamahata> Is there any patch/bug that needs attention?
16:32:20 <yamahata> Now one issue for beryllium release is test coverage for norhtbound-api
16:32:27 <yamahata> So Ritu has started to address it
16:32:32 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/32239/
16:32:43 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/31981/
16:33:07 <yamahata> 75%+ coverage is required for stable api. But now it's around 50%-
16:34:14 <yamahata> anything else?
16:35:00 <yamahata> #topic ML2 ODL driver rewrite
16:35:06 <yamahata> okay now, the main topic
16:35:13 <flaviof> yamahata about the empty tenantid issue
16:35:18 <yamahata> #undo
16:35:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1ffbb50>
16:35:45 <flaviof> i saw some emails from Keith and you on this. Are we all settled? any further work needed?
16:35:53 <yamahata> Oh, it should be addressed.
16:36:01 <flaviof> okay, cool!
16:36:13 <yamahata> So far BGP seems to have fixed the issue.
16:36:23 <yamahata> The issue was in unit test.
16:36:27 <flaviof> excellent
16:36:30 <yamahata> s/BGP/GBP/
16:36:45 <flaviof> understood
16:36:49 <yamahata> GBP has very extensible unit tests to catch such modification.
16:37:03 <yamahata> so the fix was simple. done by Keith.
16:37:47 <yamahata> On our side, we should be more careful and communicate well with dependent projects.
16:37:55 * flaviof ready for main topic; sorry for interrupt
16:38:29 <yamahata> https://git.opendaylight.org/gerrit/#/c/31945/
16:38:47 <yamahata> gongosh has related patch. He seems on vacation?
16:39:04 <yamahata> I'd like to merge it somehow before release.
16:39:16 <yamahata> #topic ML2 ODL driver rewrite
16:39:39 <asomya> #link https://review.openstack.org/#/c/222409/
16:39:41 <yamahata> okay, at the last minutes we found tempest doesn't run
16:40:34 <rcurran> yeah, ODL CI hasn't run successfully for months, but this patch was breaking in a different way. something armax commented on.
16:40:34 <yamahata> Is anyone looking into it? any insights?
16:40:49 <rcurran> i posted the finding in the review
16:40:58 <yamahata> I though test failure is acceptable.
16:41:15 <yamahata> But unable to run test itself isn't acceptable.
16:41:56 <rcurran> i don't think it can be fixed until l3 is ported over to use the new design
16:42:33 <yamahata> rcurran: agreed. Do you plan to post it soon?
16:42:51 <rcurran> yes, right after l2 gets in
16:43:26 <yamahata> Do you already have it internally?
16:43:32 <rcurran> yes
16:43:47 <rcurran> verifying w/ a real ODL controller now
16:43:58 <rcurran> i.e. not UT
16:44:01 <yamahata> If so, can you post it now. So that we can see if devstack works
16:44:25 <yamahata> without UT is okay. We can mark the patch work-in-progress
16:44:33 <rcurran> yeah, thinking the same thing. sure let me post a WIP patch set
16:45:03 <yamahata> The point is that to show it will be surely fixed/addressed.
16:45:29 <asomya> yamahata: Should we merge the L2 patch or wait to check if Rich's l3 patch passes tempest?
16:46:36 <yamahata> If rcurran can post the patch shortly, I'd like to wait.
16:46:54 <yamahata> because I'd like to honer armax call.
16:47:16 <rcurran> asomya, that's what i was hoping for since my work env. w/ the l3 code,  obviously has a dep on l2, is a bit fudged
16:47:32 <rcurran> but i'll post a WIP
16:47:43 <asomya> yamahata: fair enough
16:47:58 <yamahata> #action rcurran post WIP l3 patch
16:48:03 <rcurran> btw, is anyone working on the non-v2 related CI issue?
16:48:10 <yamahata> #action everyone look into devstack issue with l3 patch
16:48:34 <yamahata> I've started to look into it.
16:49:13 <yamahata> The scenario tests fails to wait timeout. So many timeouts results in tempest abort due to total timeout
16:49:15 <rcurran> note, for this initial push of L3 work, I wouldn't spend a ton of time on the code itself (although i don't think it will change), goal is to make sure stach.sh passes
16:50:13 <yamahata> I tried CI with Beryllium snapshot. The result is same. i.e. tempest abort with timeout
16:51:39 <yamahata> #link https://review.openstack.org/#/c/264981/ trigger CI with Be snapshot
16:52:30 <flaviof> yamahata when you say l3 issue...
16:52:56 <flaviof> are you using l3agent with odl, or are you referring to using OLD_L3=True ?
16:53:10 <yamahata> ODL_L3=True
16:53:45 <flaviof> i know that when using ODL_L3, there is a know limitation that we are currently implementing in that ODL does not reply to pings
16:54:26 <flaviof> #link https://bugs.opendaylight.org/show_bug.cgi?id=4132  ping issue
16:54:41 <yamahata> If it's known to fail, related tests of tempest can be disabled.
16:55:32 <flaviof> ok. ircc all l3 tests do an initial ping to test router interface, so it may affect most of them
16:55:33 <yamahata> Or fix the bug
16:55:46 <flaviof> good news is that the fix is in the way
16:55:55 <yamahata> Oh cool!
16:55:58 <flaviof> https://git.opendaylight.org/gerrit/#/c/32135/
16:56:28 <flaviof> it will still take a little while longer, but we know what to do to address that.
16:56:40 <yamahata> BTW I noticed openstack CI is run against lithium-snapshot-0.3.1
16:56:51 <flaviof> it requires ovs 2.5, because older ovs do not allow icmp type to be set in action
16:56:52 <yamahata> should it be 0.3.3?
16:57:13 <flaviof> yamahata yes, definitely on 0.3.3
16:57:41 <yamahata> I'm also wondering to add CI test against beryllium-snapshot-0.4.0. Does it make sense?
16:57:54 <yamahata> or too early?
16:58:19 <flaviof> yamahata it does, but its a little tricky because its not release; thus a bit too unstable.
16:59:13 <yamahata> #action yamahata make CI run against 0.3.3 and look into beryllium CI
16:59:45 <yamahata> anything else to discuss?
16:59:57 * yamahata one minutes left...
17:00:26 <yamahata> anything urgent this week?
17:01:06 <yamahata> #topic open mike
17:01:29 <yamahata> going one
17:01:31 <yamahata> once
17:01:49 <yamahata> going twice
17:02:12 <yamahata> thank you every one
17:02:24 <yamahata> a happy new year again and welcome back to happy hacking
17:02:29 <yamahata> #topic cookies
17:02:35 <yamahata> #endmeeting