16:02:32 <yamahata> #startmeeting neutron_northbound
16:02:32 <odl_meetbot> Meeting started Fri Jan 15 16:02:32 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:32 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:32 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:02:39 <yamahata> #topic agenda bashing and roll call
16:02:43 <yamahata> #info yamahata
16:02:59 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings#Agenda_for_Next_Meeting_.281.2F15.2C_2016.29
16:03:20 <yamahata> any topic for agenda?
16:03:32 <yamahata> in addition to the above link
16:04:15 <flaviof> #info flaviof
16:04:20 <yamahata> flaviof: hi
16:04:37 <flaviof> yamahata hello!
16:04:51 <yamahata> #chair flaviof
16:04:51 <odl_meetbot> Current chairs: flaviof yamahata
16:05:03 <yamahata> #topic Announcements
16:05:25 <yamahata> the details for opendaylight design forum has been announced
16:05:30 * yamahata looking for the link
16:06:12 <yamahata> #link https://lists.opendaylight.org/pipermail/tsc/2016-January/004543.html design forum announce ment
16:06:35 <yamahata> It's Feb 29 and Mar 1 at San Mateo CA
16:07:17 <yamahata> Finally the first patch for rewriting of odl mechanism driver was merged!
16:07:29 <yamahata> Kudos to asomya rcurran
16:07:43 <flaviof> yamahata +1 asomya rcurran !
16:07:53 <yamahata> I really thank you for your patiance. It was a long process.
16:08:03 <rcurran> thanks ... on to L3 + SG ... then lots of testing :-)
16:08:23 <asomya> yamahata flaviof: thanks for the reviews
16:08:24 <yamahata> Yeah many things to do are on our road ahead
16:09:14 <yamahata> call for speaker for ONS 2016 is today
16:09:29 <yamahata> and call for speaker for openstack summit 2016 austin is Feb 1
16:09:35 <yamahata> announce again.
16:09:50 <flaviof> asomya my pleasure. fyi there are some smart folks joining in on that effort too I'll send email to ml to introduce you guys to each other
16:10:07 <yamahata> I suppose we would like to apply for it jointly to promote our effort.
16:10:21 <yamahata> I uploaded the draft as a base.
16:10:21 <flaviof> #action flaviof to send email to ml to introdude Oded, Joshua to nn
16:10:30 <yamahata> #link https://lists.opendaylight.org/pipermail/tsc/2016-January/004543.html
16:11:16 <yamahata> the setting is everyone-can-review. If you send a request, I'll add editable-right.
16:11:44 <yamahata> flaviof: very cool!
16:12:03 <yamahata> anything else to announce?
16:13:18 <yamahata> moving on
16:13:21 <yamahata> #topic action items from last meeting
16:13:42 <yamahata> rcurran: posted patches for ODL plugin
16:14:04 <yamahata> yamahata: posted a patch related to CI
16:14:30 <yamahata> #topic patches reviews
16:14:47 <yamahata> Do we have patches that needs special care or urgent?
16:15:19 <asomya> yamahata: The patch i posted for the SG fix to the V2 driver is kinda urgent
16:15:26 <asomya> #link https://review.openstack.org/#/c/267120/
16:15:49 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/32109/
16:15:53 <asomya> a very short fix, should be a quick review
16:16:00 <yamahata> asomya: sure
16:16:09 <yamahata> #action everyone to review  https://review.openstack.org/#/c/267120/
16:16:24 <asomya> yamahata: thanks
16:16:25 <yamahata> https://git.opendaylight.org/gerrit/#/c/32109/ is a patch for documentation of neutron northbound
16:16:44 <yamahata> It needs to be merged before Beryllium release. Please review.
16:17:04 <yamahata> It's urgent because Beryllium release is counting down.
16:17:12 <yamahata> thanks vithar for review it.
16:17:24 <yamahata> any other patches? or bug?
16:18:20 <yamahata> #topic bugs
16:18:37 <yamahata> Right now I'm starting to look at CI timeout.
16:18:59 <yamahata> Actually it has starting before Dec.
16:19:46 <yamahata> most of scenario tests fails due to ssh connection failure. timeout ~= 5min *N => jenkins abort
16:20:08 <flaviof> yamahata do you have a bug or any other info on this issue? I was not aware of it, other than the transaction retry changes
16:20:09 <yamahata> That's what I've found for now.
16:21:09 <yamahata> #action yamahata file a bug for openstack CI jenkins abort
16:21:22 <flaviof> cool, thanks.
16:21:34 <yamahata> For now I have only jenkins logs. I haven't dug into OF table details yet.
16:21:58 <yamahata> Oh there is a filed bug
16:22:10 <yamahata> #link https://bugs.opendaylight.org/show_bug.cgi?id=3913 Neutron Tempest Test Failure: tempest.scenario.test_network_basic_ops
16:23:13 <yamahata> any other bugs to discuss?
16:23:14 <flaviof> yamahata that is the timeout issue or a different one?
16:23:26 <yamahata> flaviof: timeout issue.
16:23:37 <flaviof> i wanted to mention another bug
16:24:07 <flaviof> #link https://bugs.opendaylight.org/show_bug.cgi?id=4924 fixed_ips
16:24:53 <flaviof> Oded is changing the filter to allow fixed_ips to be provided on port update. This was noticed when testing SGs
16:25:27 <flaviof> #link https://review.openstack.org/#/c/266991/  networking-odl side of change for bug 4924
16:25:56 <flaviof> just wanted to mention it here, in case anybody thinks that would be a problem
16:26:43 <flaviof> i think not...
16:27:42 <yamahata> any other bugs?
16:27:45 <flaviof> that is it from me
16:28:19 <yamahata> #topic ML2 ODL driver rewrite
16:28:41 <yamahata> Now we are moving forward to have new patches.
16:28:57 <yamahata> asomya: rcurran anything to share for those patches?
16:29:31 <yamahata> #link https://review.openstack.org/#/c/266583/
16:29:31 <yamahata> Opendaylight L3 service plugin refactor to handle out of sync issues
16:29:47 <rcurran> L3 is in the review queue. Next up would be SG. Goal is to reach parity with existing L3/SG v1 (original) code
16:29:54 <yamahata> #link https://review.openstack.org/#/c/267120/  Instance creation fails with the new V2 driver
16:31:02 <yamahata> a patch for SG precommit event seems near to merge. So it can be utilized
16:31:14 <yamahata> #link https://review.openstack.org/#/c/252755/  Add precommit_XXX event for security group and rules
16:31:23 <yamahata> rcurran: cool!
16:31:57 <flaviof> rcurran +1
16:32:31 <rcurran> there will be some juggling of code as folks make updates to original driver that may need to be factored in w/ v2 driver
16:34:38 <yamahata> anything else or move on...
16:34:56 <yamahata> #topic OpenStack release support
16:35:20 <yamahata> So far he hasn't responded. So there is no progress.
16:35:50 <yamahata> Regarding to release support, is there any opinion?
16:36:10 <yamahata> If no, we'll just focus on Kilo/Mitaka vs Lithium/Beryllium
16:36:25 <yamahata> Oh Liberty/Mitaka, not Kilo
16:37:16 <flaviof> yamahata ack +1 on Liberty/Mitaka
16:38:18 <yamahata> I hope the patch for openstack project so that openstack CI will be run against both lithium and beryllium
16:38:35 <yamahata> #link https://review.openstack.org/#/c/265437/ networking-odl: enable test with ODL release of beryllium-snapshot
16:39:05 <yamahata> seems there is no specific requirement for now.
16:39:11 <yamahata> #topic open mike
16:39:26 <yamahata> anything else to discuss?
16:39:32 <flaviof> i got a couple... bear with me
16:39:37 <flaviof> :)
16:39:42 <vthapar> I had couple questions too.
16:39:46 <flaviof> Using MD-SAL, and removing iAware API
16:39:57 <flaviof> ovsdb is now 100% md-sal based in regards to neutron northbound. Any other projects still using iAware in Boron?
16:40:07 <flaviof> the push for this is that iAware api is not useable if ODL is used with clustering
16:40:13 <flaviof> #link https://git.opendaylight.org/gerrit/#/c/27291/  removing iAware req
16:40:23 <yamahata> At least Group Based Policy is still using IAware API
16:41:13 <flaviof> yamahata ack. i think that for Boron, we will have green light for removing iaware, but that is definitely something that needs to be coord.
16:41:14 <yamahata> and I don't see any patches for it in GBP patch queue
16:41:46 <yamahata> My plan is to raise it at design forum and/or talk with Keith
16:41:46 <flaviof> second "topic": Clustering — any of you ever deployed O/S HA with ODL clustering (Beryllium)?
16:42:01 <flaviof> yamahata +1 thanks!
16:42:32 <vthapar> flaviof: not yet but in the works. can't give a time as all the folks working on it are done for the day
16:42:34 <yamahata> #action yamahata raise iaware issue at design forum  and/or talk with Keith.
16:42:48 <vthapar> flaviof: ^clustering.
16:43:07 <flaviof> vthapar cool. thanks!
16:44:07 <flaviof> we are planning on using HAProxy on northbound of ODL, but I have never really played with that in O/S
16:44:17 <yamahata> I forgot to mention that stable/beryllium branch was cut.
16:44:28 <yamahata> #info stable/beryllium branch was cut.
16:45:01 <flaviof> yamahata ack. with that, I think we can use stable/be for the CI tests.
16:45:44 <flaviof> next question: Rally testing… any updates from Rui?
16:46:14 <yamahata> flaviof: unfortunately no updates except patch respining
16:46:24 <flaviof> yamahata ack, np!
16:46:56 <flaviof> last one from me: in the near future I’ll be less involved with opendaylight project
16:47:07 <flaviof> if any of you who have had some history with the project and would like to become
16:47:09 <flaviof> a comitter, please let me or Isaku know.
16:48:15 <flaviof> vthapar you had questions?
16:48:46 <vthapar> yes.
16:49:12 <vthapar> 1. Regarding the v2 driver... I'd like it done fore BGPVPN as well as L2GW plugin [which isn't started yet].
16:49:40 <vthapar> BGPVPN is currently sitting in networking-bgpvpn, but I think this would be a good reason and moment to bring it into networking-odl.
16:50:00 <vthapar> the one in n-bgpvpn can be considered v1_0 and this one v2_0.
16:50:11 <vthapar> wanted to know how easy or difficult would be to do this?
16:50:19 <vthapar> and if anyone has any objections to it?
16:50:58 <flaviof> vthapar no objections on my part but, isn't networking-bgpvpn used outside ODL?
16:51:02 <yamahata> IIRC, dirver for bgpvpn was commited to n-bgpvpn for release management ant api stability.
16:51:22 <yamahata> Now it's okay with them.
16:51:35 <vthapar> flaviof: yep, but am talking about bgpvpn odl driver specifically.
16:51:39 <yamahata> For me, it's okay to include driver for bgpvpn.
16:51:41 <vthapar> yamahata: yep
16:51:52 <yamahata> Is it okay with them?
16:51:57 <vthapar> with liberty release at least they have a stable enough API.
16:52:29 <vthapar> I expect them to be. I am not sure how easy o difficult it would be to have the out-of-sync fixes if it is not in n-odl.
16:52:37 <flaviof> vthapar ack. make sense to ne in networking-odl then.
16:52:37 <vthapar> ^easy or difficult.
16:53:14 <vthapar> for Mitaka at least I will continue to support driver in n-bgpvpn too.
16:53:17 <asomya> vthapar: will have to scope the bgpvpn driver in it's current for to answer the easy/difficult question
16:53:42 <vthapar> asomya: fair enough.
16:53:51 <yamahata> which timeframe do you have in mind? Mitaka or N?
16:54:14 <vthapar> I would prefer Mitaka and willing to put in effort to get it done
16:54:46 <vthapar> L2GW may not be ready by Mitaka coz still needs some work on plugin side.
16:54:49 <flaviof> vthapar a potential trouble there is that v2 may not be ready for Mitaka.
16:55:25 <vthapar> flaviof, np. that is why I would continue supporting existing one in n-bgpvpn, this one can be considered experiantial.
16:55:52 <vthapar> if we can't make it, we'll go in N. but would prefer to get started sooner than later.
16:56:09 <yamahata> So you plan to continue to have old(v1) in n-bgpvon and new(v2) in n-odl?
16:56:29 <vthapar> yamahata: at least till Mitaka release.
16:56:31 <flaviof> vthapar k. as long we do not overload v2 before we get parity with v1
16:57:09 <vthapar> flaviof: agree on that. this comes after L3 and SG and when all say ready to bring bgpvpn in.
16:57:48 <flaviof> cool beans
16:57:56 <vthapar> my second question was regarding how we're handling updates in NN today.
16:58:22 <vthapar> basically the updateDelta method in all Neutron*Northbound methods
16:58:59 <vthapar> I believe proper fix for it requires mech driver to send the complete object for update rather than just delta, right?
16:59:24 <vthapar> then we can just dump the object into MDSAL without having to add back some crucial fields.
16:59:39 <vthapar> right?
17:00:11 <flaviof> vthapar i thought that the updateMD methods did that for us, but this may be a case by case question
17:00:59 <vthapar> flaviof, I still some comments to that in code. at least in Network, Subnet and Port they're there.
17:01:57 <yamahata> vthapar: What's concern? do you have specific issues with bgpvpn or l2gw?
17:02:32 <yamahata> or general code quality/consistency?
17:02:37 <vthapar> yamahata: not really, for those two we don't use any updateDelta at all and in driver code I already send the complete object.
17:03:00 <vthapar> yep. I think it might be required for making NN fully transparent.
17:03:07 <vthapar> for reference: https://github.com/opendaylight/neutron/blob/master/northbound-api/src/main/java/org/opendaylight/neutron/northbound/api/NeutronPortsNorthbound.java#L251
17:03:51 <vthapar> the comment in there suggests that it is a patch code that should be addressed.
17:04:07 <yamahata> In that direction, the direction is to switch to RESTConf from custom neutron northbound.
17:04:32 <vthapar> I haven't looked deeper, but suspect it could also lead to data loss.
17:04:45 <yamahata> NN will maintain only yang mode with full transparency.
17:05:00 <vthapar> yamahata: so the driver will directly use restconf?
17:05:05 <yamahata> That would be a bit long term.
17:05:12 <yamahata> vthapar: yes.
17:05:40 <yamahata> It exposes yang model version directly. there maybe compatibility issue.
17:06:14 <vthapar> okay, good enough.
17:06:23 <yamahata> Does it make sense? At this point, just an idea. need to reach consensus before decision.
17:06:33 <flaviof> yes. the compatibility is the more dangerous issue by going straight restconf. but the automation would eliminate a lot of manual code.
17:07:18 <vthapar> I am in favor of this. I think you'd asked me to work on bgpvpn driver so it can sue restconf directly. plan to do that, haven't had time yet.
17:07:55 <vthapar> if out-of-sync is not ready by mitaka for bgpvpn driver, I'll see if I can write it to use restconf.
17:07:55 <flaviof> yamahata i think it is a valid idea. it would be awesome to have yangtools spitting out some python that would be used by networking-odl
17:08:14 <vthapar> flaviof: +1
17:08:28 <yamahata> we should understand the implication for compatibility. given openstack rolling upgrade is requirement.
17:08:37 <flaviof> ack
17:09:32 * yamahata 10minutes over...
17:10:03 <vthapar> am done. thanks for your patience :)
17:10:06 <yamahata> vthapar: more questions?
17:10:08 <yamahata> oh.
17:10:16 <yamahata> any other question or let's close the meeting
17:10:47 <yamahata> okay thanks everyone
17:10:49 <yamahata> #topic cookies
17:10:55 <yamahata> #endmeeting