16:02:35 <yamahata> #startmeeting neutron_northbound
16:02:35 <odl_meetbot> Meeting started Fri Jan 22 16:02:35 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:35 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:02:44 <yamahata> #topic agenda bashing and roll call
16:02:47 <yamahata> #info yamahata
16:02:58 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting page
16:03:05 <yamahata> I missed to update the agenda, though
16:03:58 <yamahata> are there special topic?
16:04:25 <yamahata> I'd like to discuss https://review.openstack.org/#/c/215612/ vhost user patch
16:04:55 <yamahata> in addition to routine topics
16:05:56 <yamahata> #topic Announcements
16:06:34 <yamahata> The deu date for call-for-speakers for openstack summit is approaching. Feb 1.
16:06:55 <yamahata> If you're interested in it, please contact me and review the abstract
16:07:52 <yamahata> #link https://docs.google.com/document/d/15BLN2hAXep5_6KhVFeiVu4M2wDiwzkT30Rhv88XX2_I/edit?usp=sharing draft of abstrct for openstack summit
16:08:27 <yamahata> ODL design summit is also planned on Feb 29 and Mar 1.
16:08:40 <yamahata> We should prepair our toics
16:08:54 <yamahata> #action yamahata prepare wiki page for design forum.
16:09:28 <yamahata> lastly openstack CI had an issue yesterday. But I suppose it's already okay.
16:10:26 <yamahata> The new job gate-tempest-dsvm-networking-odl-lithium-snapshot and gate-tempest-dsvm-networking-odl-beryllium-snapshot is run instead of gate-tempest-dsvm-networking-odl
16:10:41 <yamahata> rcurran: Are you seeing still the issue?
16:10:54 <rcurran> no, CI working again
16:11:05 <rcurran> working as in it's running :-)
16:11:33 <yamahata> Cool. If any issues, don't hesitate to raise it.
16:11:39 <yamahata> any other announcement?
16:13:46 <yamahata> #topic action items from last meeting
16:14:03 <yamahata> flavio sent out the mail
16:14:42 <yamahata> Isaku hasn't the bug yet, but looking into it. there are a finding. If you're curious, I'll share it later.
16:15:18 <yamahata> #topics patch review
16:15:40 <yamahata> Is there any patch that needs special attention?
16:15:58 <yamahata> I'd like to discuss https://review.openstack.org/#/c/215612/ vhost user patch
16:16:32 <yamahata> Wojciech Dec has raised an issue on the patch.
16:16:55 <yamahata> Is wojciech here?
16:17:42 <yamahata> If he has real concern, I'd like to address it.
16:17:52 <john_a_joyce> I guess he isn't but I work with Woj on some of our vhost implementations
16:18:06 <john_a_joyce> do you know his concern or I can check with him
16:18:21 <john_a_joyce> I need to review that change closely myself
16:18:28 <yamahata> He left review comment on the gerrit review.
16:18:55 <yamahata> If no, I'd like to make progress with the patch.
16:19:17 <yamahata> To be honest, I'm not very satisfied with the patch state for reasons.
16:19:30 <john_a_joyce> I agree with his comments
16:20:24 <john_a_joyce> a host does not need to be dedicated and we have to ensure the change is generic as there are other implementations using vhostuser
16:21:04 <john_a_joyce> let me review before Monday and provide specific comments on how to make it more general
16:21:14 <yamahata> john_a_joyce: thanks.
16:21:27 <yamahata> #action john_a_joyce  review before Monday and provide specific comments on how to make it more general
16:22:00 <yamahata> At this point ODL lacks functionalities to provide networking-odl backend capability
16:22:31 <yamahata> and the conversion neutron host-id to ODL node-id
16:22:41 <john_a_joyce> you mean for vhostuser connections?
16:22:45 <yamahata> At least we should address it in Boron cycle.
16:23:17 <yamahata> I mean backend like ovsdb/netvirt, vtn, gbp can supports dpdk or not
16:23:50 <yamahata> Ah openflow feature.
16:24:00 <john_a_joyce> ok
16:24:03 <yamahata> ovs-dpdk isn't fully compatible with plan ovs
16:24:18 <yamahata> the backend needs to be aware of it.
16:24:38 <yamahata> so that only supported flows(match/action) are used
16:25:24 <yamahata> we can discuss on details offline. Is it okay?
16:26:17 <yamahata> any other patches to discuss?
16:26:32 <john_a_joyce> sure ok for me
16:27:40 <yamahata> move on...
16:27:43 <yamahata> #topic bugs
16:27:59 <yamahata> any bugs that needs attention?
16:28:42 <yamahata> I beg for scrubbing/attacking filed bugs.
16:29:20 <yamahata> #topic ML2 ODL driver rewrite
16:29:39 <yamahata> any update or discussion?
16:29:54 <yamahata> there are several patches floating around. should be reviewed.
16:29:59 <rcurran> not from me, just looking for reviwers
16:30:14 <rcurran> serveral patches? for ODL v2 driver?
16:30:33 <yamahata> yes
16:30:37 <yamahata> https://review.openstack.org/#/c/266583/
16:30:42 <rcurran> there's just - https://review.openstack.org/#/c/266583
16:30:58 <yamahata> Oh only one.
16:31:22 <rcurran> yes, there is the *DO NOT REVIEW/MERGE* patch that I use to test v2 against the CI
16:32:02 <yamahata> can you add 'DO NOT REVIEW/MERGE' at the subject line? so that we don't have to open the page.
16:32:17 <rcurran> sure
16:33:01 <yamahata> #topic OpenStack release support
16:33:17 <yamahata> there is no update.
16:33:37 <yamahata> #topic Beryllium release preparation and Boron planning
16:34:03 <yamahata> The boron release is fast approaching. Let's squash bugs.
16:34:16 <yamahata> #topic open mike
16:34:26 <yamahata> any opens?
16:34:45 <vthapar> one topic that came up during bgpvpn discussion earlier today
16:35:19 <vthapar> there is a use case where driver may need to get some information from backend. applies to all bgpvpn drivers...
16:35:35 <vthapar> are there any plans for some framework which allows this?
16:36:03 <yamahata> What kind of information?
16:36:05 <vthapar> or we'll always be 'push to odl' driver?
16:36:30 <yamahata> At least for port-binding, we need ODL to provide its capability.
16:36:47 <vthapar> in this particular case about some ip prefixes learnt by ODL/BGP/vpnservice
16:37:26 <vthapar> not allow a subnet to be associated with a VPN if it has been learned already [might not be wording it 100% correctly]
16:37:57 <yamahata> driver retrieving info from ODL wouldn't be difficult
16:38:06 <yamahata> I'd like to discuss it for Boron.
16:38:08 <vthapar> and sometime back a similar request came for an L2GW use case too.
16:38:34 <yamahata> ODL callback to networking-odl would require more work.
16:38:40 <vthapar> +1 for discussing in Boron.
16:39:05 <vthapar> I think this should be good enough for starters.
16:41:04 <yamahata> #action vthapar, yamahata file a discussion topic for boron planning
16:41:26 <yamahata> any other topic?
16:41:43 <yamahata> I'd like to discuss about logistics.
16:42:13 <yamahata> So far we've just discussed on IRC meeting. and didn't use other tools to track tasks.
16:42:37 <yamahata> In the past, there was an attempt to use trello board
16:43:22 <yamahata> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound trello board neutron northbound
16:43:36 <yamahata> Do we want to use it? or the current style is okay?
16:44:10 <yamahata> Personally either is okay as long as we're productive.
16:44:51 <vthapar> I am also okay either ways. you're the one doing tracking so your vote matters the most :)
16:45:59 <yamahata> okay. Anyway if we adapt new way, it will be after Beryllium release.
16:46:06 <yamahata> any other topics?
16:47:17 <yamahata> Then I'd like to share finding during digging into CI timeout
16:47:44 <yamahata> Some assumption by tempest isn't satisfied. So it should be properly setup.
16:48:07 <yamahata> scenario tests requires public network access, but it isn't for now.
16:48:23 <yamahata> That's first thing to fix.
16:48:32 <yamahata> that's all from me.
16:48:52 <yamahata> if no more topics, we can close meeting early today.
16:48:54 <yamahata> going once...
16:49:08 <yamahata> going twice...
16:49:20 <yamahata> thanks every one
16:49:23 <ankurgupta> thanks
16:49:25 <yamahata> #topic cookies
16:49:29 <yamahata> #endmeeting