16:02:48 <yamahata> #startmeeting neutron_northbound
16:02:48 <odl_meetbot> Meeting started Fri Feb 12 16:02:48 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:48 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:48 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:02:56 <yamahata> #topic agenda bashing and roll call
16:02:58 <yamahata> #info yamahata
16:03:18 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting info
16:03:24 <yamahata> Today I missed to update the agenda
16:03:57 <yamahata> Is there any topics other than ones in the page?
16:04:47 * yamahata going once
16:05:01 * yamahata going twice
16:05:29 <yamahata> seems nohting. If you have any, please raise it at open mike
16:05:33 <yamahata> #topic Announcements
16:05:41 <yamahata> It's beryllium RC2
16:05:55 <yamahata> Actually RC2.2 was build yesterday
16:06:11 <yamahata> It should be almost release
16:06:24 <yamahata> For neutron northbound, we have three critical bugs
16:06:42 <yamahata> #link https://bugs.opendaylight.org/show_bug.cgi?id=3423
16:06:50 <yamahata> #link https://bugs.opendaylight.org/show_bug.cgi?id=4527
16:06:57 <yamahata> #link https://bugs.opendaylight.org/show_bug.cgi?id=4550
16:07:19 <yamahata> 3423 seems invalid? I'm asking it for the bug reporter
16:07:34 <yamahata> 4527 and 4550 are real bug. But we didn't made fixes.
16:07:47 <yamahata> The fix will be in Beryllium-SR1 which is planned on March
16:08:07 <yamahata> #link https://bugs.opendaylight.org/buglist.cgi?bug_status=__open__&list_id=48464&order=Importance&product=neutron&query_format=specific bug of ODL neutron northbound
16:08:33 <yamahata> Other bugs are not classified as critical so far.
16:08:57 <yamahata> So please test beryllium release
16:09:36 <yamahata> #link https://review.openstack.org/#/c/278839/  networking-odl test with beryllium RC2.2
16:09:46 <yamahata> any other announcement?
16:10:48 <yamahata> #topic action items from last meeting
16:11:02 <yamahata> I suppose there is none remaining
16:11:29 <yamahata> #topic Open Patch sets needing review/merging
16:11:54 <yamahata> on odl side there are two patches need attention
16:12:29 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/33932/ Bug 4527 - Security Group Rule doesn't allow all protocols
16:12:43 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/33957/
16:12:44 <yamahata> Bug 4550 - always rebuild security group rule in security group
16:12:56 <yamahata> The plan is to merge them for Beryllium-SR1
16:13:09 <yamahata> Without those patches, security group might not work.
16:13:34 <yamahata> any other patches?
16:14:34 <yamahata> next topic
16:14:38 <yamahata> #topic bugs
16:14:50 <yamahata> I already discussed two bugs.
16:14:58 <yamahata> any other specific bugs?
16:16:01 <yamahata> move on
16:16:13 <yamahata> #topic ML2 ODL driver rewrite
16:16:17 <yamahata> any update?
16:16:37 <asomya> have two important patches pending in review
16:16:46 <yamahata> I was busy with ODL release. So I didn't have enough time to review...
16:16:50 <asomya> https://review.openstack.org/#/c/275339/
16:16:50 <asomya> https://review.openstack.org/#/c/276381/
16:17:22 <asomya> The V1 unit tests are failing due to a recent neutron change though: https://review.openstack.org/#/c/215467/
16:17:32 <rcurran> plus v2 L3 support - has 3 +1's - https://review.openstack.org/#/c/266583/
16:17:37 <asomya> I'm looking into fixing the V1 tests
16:17:44 <yamahata> Cool.
16:18:21 <yamahata> So we have four patches under review.
16:18:38 <yamahata> #action yamahata and others review patches.
16:18:54 <yamahata> any other patches?
16:19:00 <rcurran> yes, 4 v2 patches in queue
16:19:43 <yamahata> BTW several bug fixes were merged for v1 driver.  I think similar patches are needed for v2 driver.
16:20:50 <asomya> yamahata: I will update V2 with those fixes
16:21:05 <john_a_joyce> yamahata - going forward it would be nice that any v1 bug fixes aren't approved unless also applied to the v2 driver
16:21:31 <john_a_joyce> for the ones already done we can handle applying them
16:21:37 <yamahata> john_a_joyce: sounds reasonable. So far I approved those fixes for beryllium release.
16:21:59 <john_a_joyce> sure makes sense for getting the release done
16:22:38 <yamahata> #action asomya update V2 with those fixes
16:22:44 <yamahata> any other issues?
16:23:33 <yamahata> okay move on
16:23:36 <yamahata> #topic OpenStack release support
16:23:40 <yamahata> there is no update
16:23:53 <yamahata> I suppose we can discuss at deisgn forum.
16:24:04 <yamahata> #topic Beryllium release preparation and Boron planning
16:24:17 <yamahata> The topic submission due for opendaylight design forum is today.
16:24:37 <yamahata> anyone attend it? At least I will.
16:25:11 <yamahata> I'm prepairing document for discussion there
16:25:20 <yamahata> #link https://docs.google.com/presentation/d/1kq0elysCDEmIWs3omTi5RoXTSBbrewn11Je2d26cI4M/edit?usp=sharing ODL neutron discussion
16:25:27 <yamahata> It's still draft yet.
16:26:03 <yamahata> I suppose Wojciech Dec wants to add provider network support
16:26:15 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/23594/
16:26:41 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:FutureReleaseWishList#Boron feature request or discuttion topics
16:28:10 <yamahata> #topic open mike
16:28:17 <yamahata> any topics?
16:29:32 <yamahata> nothing?
16:29:35 <yamahata> going once
16:30:00 <yamahata> going twice
16:30:10 <yamahata> okay I'll give you 30min back
16:30:16 <yamahata> thanks everyone
16:30:24 <yamahata> #topic cookies
16:30:30 <yamahata> #endmeeting