16:04:35 <yamahata> #startmeeting neutron_northbound
16:04:35 <odl_meetbot> Meeting started Fri Feb 26 16:04:35 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:04:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:35 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:04:43 <yamahata> #topic agenda bashing and roll call
16:04:50 <yamahata> #info yamahata
16:05:12 <yamahata> any agenda items?
16:05:22 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda page
16:06:40 <yamahata> seems nothing, let's move on
16:06:46 <yamahata> #topic Announcements
16:07:01 <yamahata> #info ODL beryllium was official released
16:07:26 <yamahata> #info ODL developer design forum will be held next week. Feb 29, Mar 1
16:07:37 <yamahata> any other announcements?
16:07:56 <yamahata> the schedule was announced
16:08:11 <yamahata> #link http://events.linuxfoundation.org/events/opendaylight-developer-design-forum/program/schedule DDF schedule
16:08:30 <Pramod> Hi Isaku
16:08:33 <yamahata> I'll give two presentation related to neutron
16:08:37 <yamahata> Pramod: hi
16:09:51 <yamahata> rcurran: I'll introduce networking-odl activity there. If possible, I'd like you guys to review the presentation.
16:10:28 <rcurran> this is for the summit?
16:10:44 <yamahata> for opendaylight developer design forum
16:11:09 <rcurran> ok, sure forward to mail alias or directly to john, arvind and myself
16:11:11 <yamahata> #link http://odpddf2016.sched.org/event/6Gjv/networking-odl-syncing-opendaylight-with-openstack-neutron-isaku-yamahata-intel?iframe=no&w=i:100;&sidebar=yes&bg=no
16:12:03 <yamahata> #action yamahata send link to the presentation to rcurran john an arvind
16:12:26 <yamahata> any other announcement?
16:13:18 <yamahata> #topic action items from last meeting
16:13:45 <yamahata> I reviewed the patch to unblock the bug.
16:14:09 <yamahata> Per my understanding, networking-odl is not blocked by the bug.
16:14:27 <yamahata> I also converted wishlist to trello board
16:14:52 <yamahata> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound trello board for neutron northbound
16:15:23 <yamahata> If you have any tasks/requests/wishlist etc.. , please create trello card
16:15:52 <yamahata> If you are not the member of the board, please let me know. I'll add you to the member
16:16:37 <yamahata> #topic patch review
16:17:45 <yamahata> Any patches for special attention?
16:18:10 <yamahata> I suppose v2 driver patches are near to merge.
16:18:15 <yamahata> Sorry for slow review
16:18:54 <rcurran> yes, the backup is causing some minor issues because of the dependency issues
16:19:45 <rcurran> friendly reminder that these patches don't impact any existing ODL functionality
16:21:00 <yamahata> anything else?
16:21:29 <yamahata> #topic Bug
16:22:13 <yamahata> #link https://bugs.opendaylight.org/show_bug.cgi?id=4527 bug ecurity Groups : For "Other Protocol" rule
16:22:36 <yamahata> On ODL side, security group has issue. We'll discuss on how to solve it.
16:22:49 <yamahata> at ODL design forum.
16:23:11 <yamahata> After the forum, the patch would be addressed.
16:23:35 <yamahata> #link https://bugs.opendaylight.org/show_bug.cgi?id=5369 Router Interfaces of Routers remain unfilled
16:23:59 <yamahata> This bug affect L3 functionality.
16:24:09 <yamahata> For L3 to function, it needs to be fixed.
16:24:23 <vthapar> yamahata: fix didn't work, interfaces are available to I*Aware providers but still didn't show up in MDSAL.
16:24:54 <yamahata> vthapar: okay.
16:25:11 <vthapar> no one else is using it and for vpnservice we're moving to use NeutronPort.
16:25:27 <vthapar> so we can reduce urgency of this one, esp if plan is to remove them altogether in Boron.
16:25:27 <yamahata> vthapar: Agree that it's the way.
16:25:51 <vthapar> I am working on vpnservice fix for stable/beryllium and once ready we won't need this fix.
16:26:39 <yamahata> vthapar: cool. I'm a bit nervous about beryllium compatibility not to break downstream project.
16:27:21 <yamahata> any other bugs to discuss?
16:27:42 <vthapar> yamahata: doesn't look like anyone else is using it else would've raised this bug long time back
16:28:18 <yamahata> vthapar: agree.
16:29:27 <yamahata> #topic ML2 ODL driver rewrite
16:29:35 <yamahata> rcurran: any update?
16:30:28 <rcurran> nothing specific, obviously would like to see these patches get merged so it makes life easier for others to look at and work on v2 updates
16:30:58 <yamahata> sure.
16:31:24 <yamahata> #topic OpenStack release support
16:31:26 <yamahata> no update
16:31:37 <yamahata> I'll raise this issue at design forum.
16:32:23 <yamahata> Anyway if we'd like to support more releases than currently being tested, we need someone who takes care of it.
16:32:35 <yamahata> We don't have engineering resource currently.
16:32:47 <yamahata> #topic Beryllium release preparation and Boron planning
16:33:16 <yamahata> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound trello board for boron cycle
16:33:44 <yamahata> This trello board captures tasks/issues for Boron cycle
16:34:05 <yamahata> Please update it if you have any
16:35:20 <yamahata> Per my understanding, the requirement from neutron/networking-odl to ODL is to introduce hash calculation(or any mechanism) to detect random data breakage.
16:35:45 <yamahata> Any other requirement to ODL?
16:37:03 <yamahata> seems nothing at this moment.
16:37:09 <yamahata> #topic Open Mike
16:37:17 <yamahata> anything to discuss?
16:38:46 <yamahata> we're done. give 20min back to you
16:38:51 <yamahata> thanks everyone.
16:38:55 <rcurran> thanks, bye
16:39:00 <yamahata> #topic cookies
16:39:05 <yamahata> #endmeeting