16:02:23 <yamahata> #startmeeting neutron_northbound
16:02:23 <odl_meetbot> Meeting started Fri Mar  4 16:02:23 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:23 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:02:31 <yamahata> #topic agenda bashing and roll call
16:02:40 <yamahata> #info yamahata
16:02:49 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting agenda
16:03:16 <yamahata> any agenda in addition to usual topics?
16:03:58 <yamahata> I'd like to share my take away from ODL developer deisgn forum today. openmike?
16:05:13 <yamahata> seems nothing else, move on
16:05:15 <yamahata> #topic action items from last meeting
16:05:44 <yamahata> there was only one item. yamahata send link to the presentation for design forum.
16:06:00 <yamahata> I gave talk there.
16:06:51 <yamahata> #link https://docs.google.com/presentation/d/1zCtXJHW20JomaX6oVw-PybdGluTqw-i5koObWlsKv8g/edit?usp=sharing networking-odl talk
16:07:36 <yamahata> #link https://docs.google.com/presentation/d/1kq0elysCDEmIWs3omTi5RoXTSBbrewn11Je2d26cI4M/edit?usp=sharing neutron northbound boron planning
16:07:59 <yamahata> #topic patch review/bug
16:08:16 <yamahata> any patches/bugs which needs special attention?
16:08:50 <yamahata> I caught up with the patch review.
16:09:31 <rcurran> yes, thanks for that
16:09:49 <yamahata> I need two arbitoration needed.
16:10:08 <yamahata> FOr unit test breakage, https://review.openstack.org/#/c/280374/ and https://review.openstack.org/#/c/283018/
16:10:42 <yamahata> for v2 driver https://review.openstack.org/#/c/276381/
16:10:53 <yamahata> This patch interfares with l3 patch.
16:12:16 <yamahata> For unit test breakage, how do you want to proceed? I suppose we can consolidate into single patch.
16:13:10 <yamahata> asomya: do you want to driver 280374 or let Federico to drive his own?
16:13:19 <asomya> yamahata: Federico can drive it
16:13:49 <yamahata> asomya: okay, so can you please leave your comment to his patch and abondan yours?
16:14:04 <asomya> yamahata: will do it today
16:14:32 <yamahata> #action asomya take action on unit test breakage
16:14:43 <yamahata> Cool. then v2 patch
16:15:40 <yamahata> rcurran:   Regarding to 276381 the issue is that it interferes with your patches, right?
16:16:30 <rcurran> yes, asomya commented that introducing the table may not be worth it ... i agree
16:16:35 <rcurran> at least for now
16:17:00 <yamahata> Okay, so then let's abandon table approach and merge 276381 first.
16:17:15 <rcurran> i have another patch that i'll be pushing up, once 276381 goes in (orignal style), which adds a lot more l3 validation code
16:17:50 <yamahata> Great.
16:18:10 <rcurran> asomya, you good with this
16:18:23 <asomya> rcurran: yeah, i will roll back the patch
16:18:29 <asomya> to a previous version
16:18:33 <rcurran> right
16:18:43 <yamahata> #action asomya update https://review.openstack.org/#/c/276381/ removing table approach
16:19:08 <yamahata> #info rcurran has another patch once 276381 goes in
16:19:46 <yamahata> per my undertanding, after merging those patches and securitygroup patch, we can actually start testing v2 driver.
16:20:00 <yamahata> Are we on the same page?
16:20:23 <rcurran> yes, no reason for ODL CI for fail (other than why it's failing today)
16:20:37 <rcurran> s/for/to/
16:21:00 <yamahata> Cool, given the current openstack schedule, we are going to switch to v2 driver in Mitaka cycle.
16:21:38 <yamahata> any other patches/bugs?
16:22:43 <yamahata> #topic ML2 ODL driver rewrite
16:22:57 <yamahata> actually we covered most topic rigth now
16:24:06 <yamahata> I'd like to point out that yalei started on fullsync. It's far away from merge though.
16:24:32 <yamahata> lightweight testing patch was also merged. So we can start on testset and etc.
16:24:35 <yamahata> anyother?
16:25:53 <yamahata> okay next topic is openmike, but I'd like to share my take away at design forum
16:26:03 <yamahata> #topic odl developer design forum
16:26:12 <yamahata> I gave two talks there
16:26:19 <yamahata> my take away is
16:26:36 <yamahata> regarding to opnestack, odl support, there was no feedback and no help offered
16:26:56 <yamahata> So the support will be minimum due to engineering resource.
16:27:57 <yamahata> Regarding to feature gap for openstack, the biggest issues is (centralized) SNAT.
16:28:22 <yamahata> It requires modification on both openstack and ODL. I'm willing to drive it.
16:28:36 <yamahata> Several parties complained about it.
16:29:20 <yamahata> Another gap is portbinding. People didn't complain about it explicitly, but I understand people try to workaround the issue due to lack of good portbinding.
16:29:44 <yamahata> So IMHB clean support of portbinding is needed.
16:30:10 <yamahata> So I'd like to driver it also.
16:30:20 <john_a_joyce> Isaku sorry to go back - regarding full sync is there  a patch or RFE to review?
16:30:37 <john_a_joyce> We would like to see the details as it is a tricky problem
16:31:21 <yamahata> john_a_joyce: it's a patch. But it's not ready for review unfortunately
16:31:31 <rcurran> john_a_joyce, https://review.openstack.org/#/c/275142/
16:31:42 <rcurran> very much a WIP
16:31:53 <yamahata> https://review.openstack.org/#/c/275142/
16:31:59 <john_a_joyce> ok thanks
16:32:25 <yamahata> I think the patch needs total reorganization.
16:33:35 <yamahata> IPv6 is also major feature gap. But people are aware of it and willing to drive it as the community.
16:34:36 <yamahata> Another topic is testing. Right now ODL CI tests doesn't address clustering. So we should test it.
16:34:55 <yamahata> CI/test team will address it in Boron cycle.
16:35:12 <yamahata> I suppose networking-odl team should give them feedback.
16:35:35 <yamahata> Those are my take away.
16:36:13 <yamahata> questions/comments?
16:36:50 <yamahata> I introduced networking-odl v2 activities. It triggered hot technical discussion.
16:37:21 <yamahata> Unfortunately I couldn't recruit any resources.
16:37:27 <yamahata> they are basically ODL engineers.
16:37:55 <yamahata> #topic open mike
16:37:57 <asomya> yamahata: What were the key concerns/reservations around the V2 discussion?
16:38:05 <yamahata> #undo
16:38:05 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2c246d0>
16:38:35 <yamahata> clustering support and how intergrity is guarrentted.
16:38:42 <yamahata> Some raised sequence number etc..
16:39:32 <yamahata> no new tech issues. We had discussed them in the past. some are still open, though.
16:39:55 <asomya> yamahata: Regarding clustering, I sent you a reply to the email.. do we have a reverse proxy layer between neutron and ODL or is the plugin to manage multiple ODL endpoints
16:40:35 <yamahata> At this point my personal preference is to use loadbalancer like haproxy between networking-odl and ODL.
16:41:36 <asomya> yamahata: that's good, the driver already supports a single endpoint.. is there anything else we need to do to support clustering or is it just testing it?
16:45:09 <rcurran> opps? meeting over :-)
16:47:19 <yamahata> I lost the network. Do I loose messages?
16:47:25 <rcurran> no
16:47:45 <rcurran> ahh ... did you see asomya's last message? 11:41
16:47:55 <yamahata> no I didn't.
16:47:57 <asomya> yamahata: that's good, the driver already supports a single endpoint.. is there anything else we need to do to support clustering or is it just testing it?
16:48:25 <yamahata> nothing right now. Maybe documentation for CI team.
16:48:45 <yamahata> jamo and others had asked how to set it up.
16:48:52 <yamahata> So documentation will help them.
16:49:15 <yamahata> Right now it's only README.rst in git repo of networking-odl and it's black magic.
16:49:35 <asomya> ok thanks
16:50:33 <yamahata> anything else? any other topics?
16:51:17 <yamahata> okay thanks every one.
16:51:24 <rcurran> thanks
16:51:24 <yamahata> #topic cookies
16:51:29 <asomya> thanks
16:51:31 <yamahata> #endmeeting