15:04:27 <yamahata> #startmeeting neutron_northbound
15:04:27 <odl_meetbot> Meeting started Fri Mar 18 15:04:27 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:04:27 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:27 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:04:34 <yamahata> #topic agenda bashing and roll call
15:04:55 <yamahata> #info yamahata
15:05:22 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda page
15:05:36 <yamahata> bug I haven't update the page. the agenda I have is usual one
15:05:53 <yamahata> any other agenda items?
15:07:31 <yamahata> seems nothing else. move on.
15:07:37 <yamahata> #topic Announcements
15:08:12 <yamahata> ODL boron M1 cycle ended. our project applyed for Boron simultenious release
15:08:27 <yamahata> The release plan is at https://wiki.opendaylight.org/view/NeutronNorthbound:Boron_Release_Plan
15:08:36 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Boron_Release_Plan boron release plan(draft)
15:09:11 <yamahata> I put the main theme and priority as draft
15:09:53 <yamahata> code clean up(removing legacy I*Aware interfaces)
15:10:11 <yamahata> revise yang model. We found several bugs in its definitions
15:10:15 <yamahata> neutron HA support
15:10:22 <yamahata> improve port binding
15:10:36 <yamahata> providernet
15:10:43 <yamahata> lastly centralized SNAT support
15:11:16 <yamahata> The priority is mostly driven by the community.
15:11:38 <yamahata> i.e. if someone steps up for some feature, it will get priority. Otherwise low priority.
15:12:12 <yamahata> any comments/thoughts?
15:13:22 <yamahata> the next topic
15:13:28 <yamahata> #topic action items from last meeting
15:13:40 <yamahata> there is no action items from last week.
15:13:52 <yamahata> #topic bugs and patch review
15:14:08 <yamahata> bugs
15:14:24 <yamahata> #link https://bugs.opendaylight.org/show_bug.cgi?id=5478 Null values received on neutron security-group-rule-delete and security-group-delete
15:14:57 <yamahata> He reports two issues. One bug is addressed by already proposed patch.
15:15:08 <yamahata> another issue will be addressed soon.
15:15:25 <yamahata> On openstack side, We have one bug
15:15:47 <yamahata> #link https://bugs.launchpad.net/networking-odl/+bug/1557976 sg events callback: sg group deleted but the related rules are left
15:16:10 <yamahata> The issue is default sg rules aren't created on ODL side
15:16:24 <yamahata> and also on deletion of sg, the related rules aren't deleted.
15:16:31 <yamahata> Yalei is proposing patches.
15:16:44 <yamahata> #link https://review.openstack.org/#/c/294451/
15:16:45 <yamahata> Cascading delete rules related to SG
15:17:07 <yamahata> #link https://review.openstack.org/#/c/294423/ Security group call back need cascading delete the related rules
15:17:43 <yamahata> any other bugs that need attention?
15:17:50 <yamahata> or patches?
15:19:14 <yamahata> I have also another patch review
15:19:16 <yamahata> https://review.openstack.org/#/c/281693/
15:19:28 <yamahata> Pass the complete info in sg/rules db into PRECOMMIT_XXX callback
15:19:33 <yamahata> It's also needed for security group support
15:19:51 <yamahata> move on
15:20:01 <yamahata> #topic ML2 ODL driver rewrite
15:20:14 <yamahata> So far I have merged related patches.
15:20:23 <yamahata> The next thing is to test it.
15:21:07 <yamahata> And also full sync patch is WIP. https://review.openstack.org/#/c/275142/
15:21:27 <yamahata> It would take a while. But we need it for Mitaka for feature parity with v1 driver
15:22:20 <yamahata> Given the Mitaka schedule, probably we should implemented limited version of full sync instead of whole functionality of fullsyn
15:22:32 <yamahata> any other update?
15:22:54 <yamahata> asomya: rcurran ?
15:23:20 <rcurran> sorry, on another window, no updates from me
15:23:28 <asomya> yamahata: no updates from me
15:23:52 <yamahata> okay next topic
15:23:54 <john_a_joyce> isaku on the full sync - it looks like you detect a full sync is needed by polling ODL to get the complete set of resources
15:24:09 <john_a_joyce> and then compare against what neturon has?
15:24:41 <john_a_joyce> is that the correct understanding of the spec?
15:25:07 <yamahata> Hmm no. It's not efficient and impractical if the number of resource (e..g ports) are large
15:25:22 <yamahata> For cold boot detection, dummy network will be used.
15:25:45 <yamahata> To detect random data breakage in ODL, I suppose hash or something would be needed as we discussed.
15:25:55 <john_a_joyce> yes - I was worried about that
15:26:05 <john_a_joyce> also the database is constantly changing
15:26:30 <john_a_joyce> so you can sync everything but detection is limited to a cold boot case
15:26:38 <yamahata> Yes for Mitaka.
15:27:05 <john_a_joyce> Ok - I need to study that more been busy on other things
15:27:06 <yamahata> healing random data breakage will be attacked for Newtorn and Boron
15:27:16 <john_a_joyce> I do agree this is an important peice
15:27:41 <john_a_joyce> ok thanks
15:28:50 <yamahata> I'll drop the item of release support from the agenda
15:29:01 <yamahata> for planning
15:29:22 <yamahata> #topic Beryllium release preparation and Boron planning
15:29:44 <yamahata> ODL boron planning is being done. and it was discussed at ODL developer design forum.
15:29:53 <yamahata> The outcome is the planning page
15:30:07 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Boron_Release_Plan boron planning
15:31:05 <yamahata> For Newton planning, do we want some page? or etherpad?
15:31:24 <yamahata> openstack summit is the end of April, so we have a while.
15:32:14 <yamahata> There are several requrement from ODL side.
15:32:32 <yamahata> Basically it's for port binding and SNAT support.
15:33:16 <yamahata> Also we'd like to continue v2 driver effort.
15:33:26 <yamahata> any other requests/wishlist?
15:35:12 <yamahata> okay seems nothing. anyway I should prepair page for newton planning
15:35:21 <yamahata> #action yamahata prepare a page for newton planning
15:35:28 <yamahata> #topic open mike
15:35:38 <yamahata> anything to discuss?
15:36:57 <yamahata> seems nothing.
15:37:09 <yamahata> I'll give 20mins to you
15:37:14 <yamahata> thank you everyone
15:37:20 <rcurran> bye
15:37:20 <yamahata> #topic cookies
15:37:25 <yamahata> #endmeeting