15:02:43 <yamahata> #startmeeting neutron_northbound
15:02:43 <odl_meetbot> Meeting started Fri Apr  8 15:02:43 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:43 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:02:54 <yamahata> #chair rcurran asomya
15:02:54 <odl_meetbot> Current chairs: asomya rcurran yamahata
15:03:00 <yamahata> #topic agenda bashing and roll call
15:03:04 <yamahata> #info yamahata\
15:03:08 <yamahata> #info yamahata
15:04:00 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting adgenda
15:04:33 <yamahata> Although it's not listed, I'd like to discuss about timeslot change.
15:04:55 <yamahata> After action items before patch/bug discussion
15:05:14 <yamahata> any other topics today?
15:07:08 <yamahata> #topic Announcements
15:07:17 <yamahata> openstack Mitaka was released
15:07:21 <yamahata> on April 7.
15:07:28 <yamahata> #link http://releases.openstack.org/mitaka/index.html
15:08:11 <yamahata> So networking-odl will need to release mitaka at some point. It's up to us.
15:09:05 <yamahata> any other announcement?
15:10:13 <yamahata> seems nothing. next topic
15:10:20 <yamahata> #topic action items from last meeting
15:11:02 <yamahata> We have only one item to start a discussion on journaldb issue. It's already done and reached consensus
15:11:26 <yamahata> #topic timeslot change
15:12:54 <yamahata> Recently Odded, Mike has joined networking-odl and requested timeslot change of this irc meeting
15:13:26 <yamahata> They proposed wednesday or thursday 8:00am(pst/pdt)
15:13:40 <yamahata> Does this work for you? asomya rcurran ?
15:14:01 <yamahata> For me, vishal, wednesday works, but thursday doesn't.
15:14:12 <asomya> yamahata: Both times work for me
15:14:38 <john_a_joyce> Wednesday would not work for me
15:14:45 <rcurran> either day is fine for me
15:14:47 <john_a_joyce> but Thursday would
15:14:58 <yamahata> Cool. Is it okay to change the timeslot from April 13?
15:15:28 <asomya> +1
15:15:40 <john_a_joyce> Well - I would not be able to participate most weeks on Wednesday
15:15:53 <john_a_joyce> but if Rich and Arvind are there it is probably ok
15:16:16 <yamahata> thanks. If necessary, we can have adhoc meeting.
15:17:19 <yamahata> #action yamahata update timeslot on wiki and announce the timeslot change
15:17:42 <yamahata> next one is patches/bugs
15:17:44 <yamahata> #topic patches/bugs
15:18:08 <yamahata> the biggest issues is lost pending entries in journaldb
15:18:35 <yamahata> #link https://bugs.launchpad.net/networking-odl/+bug/1563297
15:18:59 <yamahata> There was a discussion thread on mailing list and I suppose asomya is working on patch.
15:19:28 <yamahata> asomya: any update?
15:19:43 <asomya> yamahata:I have the cleanup thread working
15:19:55 <asomya> will be posting a WIP review today, just wrapping up unit tests
15:19:58 <yamahata> Wow great.
15:20:24 <yamahata> I think it should be included in Mitaka release of networing-odl.
15:21:13 <yamahata> Mike and Oded has been proposing clean up patches too.
15:21:17 <yamahata> What do you think?
15:21:46 <yamahata> Can we merge them? or do they cause patch conflict?
15:21:50 <asomya> i think it should be included in mitaka, maybe a backport if the stable branch is already cut
15:22:06 <yamahata> #link https://review.openstack.org/#/c/302053/
15:22:15 <yamahata> #link https://review.openstack.org/#/c/301784/
15:22:16 <yamahata> ODL v2: Fix multiple updates race
15:22:35 <yamahata> #link https://review.openstack.org/#/c/301606/
15:22:35 <yamahata> Reduce dependency validations code duplication
15:22:51 <asomya> it should be fine
15:23:05 <asomya> don't think there should be too many collisions
15:23:40 <yamahata> I see. then can you please review them. If it's okay, I'll merge them.
15:23:49 <asomya> ok i'll do that today
15:24:42 <yamahata> thanks
15:25:01 <yamahata> #action asomy will review 301606, 301784 and 302053
15:25:12 <yamahata> #action yamahata if they are okay, merge them
15:25:23 <yamahata> another topic is sfc
15:25:36 <yamahata> #link https://review.openstack.org/#/c/300898/
15:25:36 <yamahata> Service Function Chaining Driver for OpenDaylight
15:25:58 <yamahata> Anil and Tom are proposing to support networking-odl API by ODL
15:26:12 <yamahata> If you're interested, please jump in the discussion
15:26:41 <yamahata> any other patches/bugs which needs attention?
15:27:39 <yamahata> seems nothing.
15:27:42 <yamahata> #topic ML2 ODL driver rewrite
15:27:56 <yamahata> I suppose we covered it
15:28:34 <yamahata> #topic boron planning
15:28:49 <yamahata> M2 is April 21. I have no special update on it.
15:29:09 <yamahata> The ODL patch that break dependent ODL project is planned.
15:29:25 <yamahata> #topic preparing openstack summit austin presentation
15:29:31 <yamahata> #link https://etherpad.openstack.org/p/newton-neutron-summit-ideas
15:29:40 <yamahata> #link https://etherpad.openstack.org/p/newton-neutron-networking-odl-summit
15:30:40 <yamahata> For presentation, we should have a meeting there for preparing. Hopefully on Monday.
15:30:50 <yamahata> I'll communicate offline
15:31:23 <yamahata> For discussion, Friday is allocated as official schedule.
15:32:02 <yamahata> Usually friday is not good time as people may lease on friday. Probably we should have another one before Friday.
15:32:21 <yamahata> One possibility is on wednesday after our presentation.
15:32:27 <yamahata> any ideas/thoughts/
15:32:29 <yamahata> ?
15:33:18 <asomya> might be too late on wednesday
15:34:05 <yamahata> I see. Maybe monday or tuesday during keynote session?
15:34:05 <asomya> thursday morning?
15:34:17 <asomya> yeah during keynotes works
15:35:09 <yamahata> #link https://www.openstack.org/summit/austin-2016/summit-schedule/ schedule
15:35:54 <yamahata> #action yamahata and others check openstack summit schedule. find out good timeslot
15:36:50 <yamahata> #topic open mike
15:36:57 <yamahata> any topics to discuss?
15:37:45 * yamahata waiting
15:37:51 * yamahata going once
15:38:05 * yamahata going twice
15:38:10 <yamahata> okay thank you everyone
15:38:16 <yamahata> #topic cookies
15:38:21 <yamahata> #endmeeting