15:01:08 <yamahata> #startmeeting neutron_northbound
15:01:08 <odl_meetbot> Meeting started Wed May  4 15:01:08 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:08 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:08 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:01:13 <yamahata> #chair oshvartz asomya rcurran
15:01:13 <odl_meetbot> Current chairs: asomya oshvartz rcurran yamahata
15:01:26 <yamahata> #topic agenda bashing and roll call
15:01:41 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting agenda
15:01:47 <yamahata> #info yamahata
15:02:00 <yamahata> Today we'll follow up the openstack summit discussion.
15:02:13 <yamahata> Other than that, do we have any topics?
15:03:11 <yamahata> seems nothing.
15:03:15 <yamahata> #topic Announcements
15:03:32 <yamahata> we had f2f meeting at the openstack summit
15:03:56 <yamahata> the minutes can be found at https://etherpad.openstack.org/p/newton-neutron-networking-odl-summit
15:04:13 <yamahata> #link https://etherpad.openstack.org/p/newton-neutron-networking-odl-summit openstack summit networking-odl team meating
15:04:18 <mkolesni> hi, sorry my lan gave me problems
15:04:44 <yamahata> CFP for opendaylight summit will be closed on May 6
15:04:57 <mkolesni> when is ODL summit?
15:05:01 <yamahata> #link http://events.linuxfoundation.org/events/opendaylight-summit/program/cfp ODL summit CFP
15:05:16 <yamahata> Sep 27-29
15:05:29 <yamahata> #link http://events.linuxfoundation.org/events/opendaylight-summit opendaylight summit page
15:05:43 <yamahata> Is anyone planning to attend?
15:06:09 <yamahata> I'm applying for CFP. My case depends on the result.
15:06:14 <asomya> Yamahata: Not sure yet, will try to make it
15:06:33 <yamahata> If necessary, we can jointly apply for CFP.
15:06:39 <vthapar> same here, will try to make it but not confirme.
15:06:40 <mkolesni> i probably can't make it but will have to see
15:06:50 <oshvartz> same for me
15:07:00 <asomya> October is the barcelona summit, a bit close to that
15:07:11 <yamahata> Yeah. that's the issue.
15:07:37 <yamahata> any other announcement?
15:07:37 <mkolesni> will you be attending the OpenStack one?
15:08:00 <asomya> mkolesni: me?
15:08:14 <mkolesni> just generally asking
15:08:26 <asomya> yeah i'll be attending that
15:08:26 <mkolesni> as it would be nice to meet face to face
15:09:01 <yamahata> At least I'll try to get travel budget. But I'm not sure at this point.
15:09:04 <gvrangan> yamahata: I have reported this  bug for L3 with devstack https://bugs.launchpad.net/networking-odl/+bug/1573317
15:09:22 <gvrangan> yamahata: Please let me know if this is valid?
15:09:45 <yamahata> gvrangan: sure. can we discuss at patch/bug review ?
15:09:53 <gvrangan> yamahata: sure
15:10:00 <yamahata> #action yamahata review https://bugs.launchpad.net/networking-odl/+bug/1573317
15:10:35 <yamahata> Also videos for openstack summit austin is now available.
15:10:42 <yamahata> #link https://bugs.launchpad.net/networking-odl/+bug/1573317 openstack summit austin videos
15:10:48 <yamahata> any other announcement?
15:11:13 <yamahata> As notice, after this irc meeting, we'll have bluejeans meeting.
15:11:32 <yamahata> mkolesni: do you have link for bluejeans?
15:11:33 <asomya> yamahata: videos link is the bug link
15:11:40 <mkolesni> yes, 1 sec
15:11:55 <yamahata> #link https://www.openstack.org/videos/summits/show/6 openstack summit videos
15:12:07 <mkolesni> https://bluejeans.com/790073977/
15:12:09 <yamahata> oops
15:12:13 <mkolesni> yamahata: ^
15:12:25 <yamahata> okay any other announcement?
15:12:58 <yamahata> #topic Follow up of openstack summit
15:13:23 <yamahata> In details, we'll discuss by bluejeans. Any other specific topic? otherwise let's move on.
15:14:13 <asomya> We'll be discussing the partial/full out of sync scenarios as well as a couple of solutions we cooked up at the summit in the bluejeans meeting
15:14:39 <yamahata> asomya: yes.
15:14:51 <yamahata> #topic action items from last meeting
15:15:27 <yamahata> yamahata updated launchpad and gerrit.
15:15:42 <yamahata> So now asomya and mkolesni are coredev.
15:15:55 <yamahata> Congrats and welcome to patch review.
15:16:07 <oshvartz> congrats :-)
15:16:08 <yamahata> #action yamahata update pypi networking-odl owner
15:16:09 <mkolesni_> sorry dropped out for a few seconds
15:16:10 <asomya> yamahata: thanks
15:16:20 <vthapar> congrats!
15:16:27 <mkolesni_> thanks
15:16:31 <yamahata> Regarding to release mitaka networking-odl, it's on-going.
15:17:07 <yamahata> Regarding to patch review, I personally think that we don't have to follow strictly 2 +2 policy.
15:17:43 <mkolesni_> seeing as now we will be ~3 cores that would be almost impossible
15:17:44 <yamahata> Anyway when there are tech discussions going on, we shouldn't merge the patch without consensus.
15:18:24 <yamahata> On the other hand, we can merge trivial patches without 2 +2 like updating odl release definitions.
15:18:55 <mkolesni_> seems logical to me
15:19:05 <yamahata> Is it okay for now to see how it will end up.
15:19:41 <yamahata> If any issues, we can discuss here and adjust it.
15:20:24 <yamahata> okay move on.
15:20:26 <yamahata> #topic patches/bugs
15:20:41 <yamahata> any patches/bugs need attention?
15:20:57 <mkolesni_> I'd like to get https://review.openstack.org/305132 merged
15:21:06 <mkolesni_> #link https://review.openstack.org/305132 Add journal maintenance thread
15:21:28 <asomya> yamahata: There are a number of patches out for review that don't have associated bugs or blueprints.
15:21:46 <mkolesni_> i don't see any critical issues there so i'd like to continue with the review and if nothing is wrong we can merge
15:22:07 <yamahata> asomya: Oh.  Then, we are managing patchs badly. Okay let's try to fix through patch review.
15:22:37 <asomya> yamahata: i'll add comments to these reviews
15:22:39 <yamahata> Now networking-odl blueprint is available. Do we want to use it for big feature?
15:22:50 <mkolesni_> asomya, yamahata: what would be the guidelines for this?
15:23:01 <yamahata> #action everyone add review comments to associate bug report.
15:23:12 <asomya> mkolesni_: similar to neutron, follow the template as much as possible and file a bug for each patch
15:23:37 <mkolesni_> lets say if the patch is a refactor to simplify code, do we want to mandate a bug/rfe?
15:23:40 <asomya> #link http://docs.openstack.org/developer/neutron/policies/bugs.html#bug-report-template
15:24:17 <mkolesni_> i thinki think if it's just refactor we can skip any bug refs in the comment
15:24:39 <mkolesni_> but if its actually some bug or feature then of course require it
15:25:00 <asomya> mkolesni_: yes, the bug would just be a simple explanation of why it's being done. down the line it would be helpful to have a paper trail to see why that particular patch was pushed
15:25:26 <mkolesni_> asomya: i think you should explain "why" in the commit message
15:25:54 <mkolesni_> for refactoring, doing this in a bug weould be kind of abusing the bug concept..
15:26:20 <asomya> well neutron mandates bugs for refactors as well
15:26:35 <mkolesni_> i dont think we have to be that strict
15:26:54 <asomya> if everyone feels it's excessive then we don't have to mandate that
15:27:09 <rcurran> good thing we have three cores now :-)
15:27:09 <mkolesni_> i think we need to use our common sense
15:27:19 <yamahata> asomya: do we want to be so strict? Personally we don't have to be so strict given that the team size.
15:27:25 <mkolesni_> and not just enforce blindly
15:27:35 <asomya> yamahata: ok, sound fair
15:27:41 <mkolesni_> can we take https://review.openstack.org/312034 as example?
15:27:56 <mkolesni_> i refactored the filters code for V2 to be simpler
15:28:06 <mkolesni_> so how would i classify it?
15:28:25 <mkolesni_> obviously i'm not solving any bug here, nor am i adding any new functionality
15:28:41 <mkolesni_> so in this case it would seem extranous to have a bug
15:29:47 <yamahata> asomya: what do you think?
15:30:00 <asomya> yamahata, mkolesni_: I can live with that :)
15:30:47 <mkolesni_> asomya, yamahata: ok so lets say that if you're changing behavior externally then you need to associate with a bug/rfe?
15:31:06 <mkolesni_> i.e behavior that has external visibility, not internal stuff
15:31:22 <asomya> like api changes?
15:31:25 <yamahata> Yes. This is not permanent. We can revise it when we found any problems.
15:31:32 <mkolesni_> so that if i renamed a parameter of a function then i don't need a bug :)
15:31:56 <mkolesni_> even if you add a column to the db i'd consider it having external implications
15:32:35 <mkolesni_> generally use common sense and not be super strict
15:32:52 <mkolesni_> of course we can see if this becomes a problem we can adjust the process
15:32:53 <asomya> as yamahata said, we can go with this for now and review is starts creating problems
15:33:00 <mkolesni_> exactly
15:33:02 <asomya> *if
15:33:52 <mkolesni_> ok so regarding my patch id really like it to move along since i dont see there are any major issues there
15:34:08 <mkolesni_> and it has other patches depending on it
15:34:45 <yamahata> #agree go with this for now and review if any issues.
15:34:53 <yamahata> Okay can we back to patch?
15:35:05 <mkolesni_> yes
15:35:20 <yamahata> Regarding to 305132, asomya rcurran , are you okay with the patch now?
15:35:28 <yamahata> If yes, I'll review and merge it.
15:35:39 <yamahata> I'm catching up the patch now...
15:36:21 <asomya> yamahata: I think this one needs an associated bug report :)
15:36:31 <yamahata> #action yamahata review https://review.openstack.org/#/c/305132/
15:36:41 <asomya> fairly large change introducing new features
15:36:58 <mkolesni_> i dont mind filing a bug there
15:36:59 <yamahata> asomya: agreed ;-). except it, is there any issue left?
15:37:15 <asomya> codewise, no issues
15:37:59 <yamahata> seems settled down.
15:38:05 <yamahata> any other patches/bugs?
15:38:24 <asomya> I'll rebase my review once the maintenance one goes in
15:38:26 <asomya> #link https://review.openstack.org/#/c/304168/
15:38:36 <yamahata> #action everyone review https://review.openstack.org/#/c/304168/
15:39:10 <yamahata> no more patches/bugs?
15:39:32 <mkolesni_> https://review.openstack.org/307218
15:39:38 <yamahata> otherwise we can skip ML2 ODL driver rewrite/boron planning and go for bluejeans.
15:39:48 <mkolesni_> #link https://review.openstack.org/307218 ODL v2: Full sync resources
15:40:01 <mkolesni_> this one i had addressed the comments
15:40:25 <mkolesni_> #link https://review.openstack.org/312033 Enrich port details in journal
15:40:36 <mkolesni_> his friend following rcurran's comments
15:41:05 <mkolesni_> the second one is necessary to have the port sent to ODL correctly when full sync runs
15:41:22 <mkolesni_> it's problematic to run through the mech driver since it expects a call context
15:41:46 <mkolesni_> i think this approach is cleaner since it also would work for future cases such as partial sync
15:41:49 <yamahata> any other?
15:42:09 <yamahata> can we go to bluejeans?
15:42:29 <mkolesni_> no more from me
15:43:03 <yamahata> okay let's see at bluejeans.
15:43:15 <yamahata> #topic cookies
15:43:19 <yamahata> #endmeeting