15:01:55 <yamahata> #startmeeting neutron_northbound
15:01:55 <odl_meetbot> Meeting started Wed May 11 15:01:55 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:55 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:02:02 <yamahata> #chair vthapar asomya
15:02:02 <odl_meetbot> Current chairs: asomya vthapar yamahata
15:02:08 <yamahata> #topic agenda bashing and roll call
15:02:14 <yamahata> #info yamahata
15:02:27 <yamahata> today mike and odded won't attend due to the national holiday
15:02:41 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting adenda
15:02:58 <yamahata> is there any other topics today in addition?
15:04:56 <yamahata> seems nothing else.
15:05:10 <yamahata> #topic Announcements
15:05:47 <yamahata> networking-odl for mitaka has been released
15:05:56 <yamahata> and the stable/mitaka branch has been also cut
15:06:07 <yamahata> #link https://review.openstack.org/#/c/312331/
15:06:07 <yamahata> Release networking-odl 2.0.0 (mitaka) release
15:06:42 <yamahata> launchpad/networking-odl allows blueprint
15:07:08 <yamahata> #link https://blueprints.launchpad.net/networking-odl blueprint
15:07:15 <yamahata> any other announcement?
15:07:46 <vthapar> yamahata: any submissions for ODL Summit from Neutron?
15:08:15 <yamahata> vthapar: Yes. I submit CFP on networking-odl integration
15:08:39 <yamahata> I'm reusing same topic... Maybe I have to find new topic, though.
15:08:44 <vthapar> cool
15:09:11 <yamahata> anything else?
15:09:39 <yamahata> #topic action items from last meeting
15:10:02 <yamahata> yamahata updated pypi ownership
15:10:15 <yamahata> patch/bug reviews were done
15:10:33 <yamahata> next topic is management related
15:10:42 <yamahata> #topic blueprint management
15:11:05 <yamahata> This week we don't have mike and oded. So we would like to continue discussion next week.
15:11:23 <yamahata> #action yamahata send summary mail for odl neutron mailing list
15:11:37 <yamahata> now we have launchpad blueprint available.
15:11:51 <yamahata> Do we want to use blueprint/spec process for networking-odl?
15:12:00 <yamahata> For now we have several blueprints registered.
15:12:10 <yamahata> #link https://blueprints.launchpad.net/networking-odl blueprints
15:12:35 <asomya> For major feature i think it's a good idea
15:12:41 <yamahata> Given that the team size is small, we don't have to use heavy process like core neutron.
15:12:47 <asomya> not for all features
15:13:12 <vthapar> asomya: +1
15:13:16 <yamahata> I think we should track/coordinate major features.
15:13:20 <yamahata> Okay.
15:13:41 <yamahata> Do we want to have spec? at least major feature. like sfc, qos support.
15:14:17 <asomya> yamahata: From my experience in neutron, the spec review process doesn't seem to help much
15:14:18 <yamahata> IMHO, light spec will help. But full neutron spec would be too heavy, though. It would be case-by-case, though.
15:14:50 <asomya> yamahata: +1 for light spec
15:15:04 <vthapar> yamahata: +1
15:15:35 <yamahata> we have consensus. anyway I'll sent a mail to get feedback.
15:15:50 <yamahata> Next week, let's decide it.
15:16:01 <yamahata> any other thoughts/comments?
15:17:21 <yamahata> okay move on
15:17:23 <yamahata> #topic patches/bugs
15:17:35 <yamahata> any patches/bugs that need attention?
15:17:50 * yamahata is a bit behind review. today will catch them up
15:18:02 <asomya> https://review.openstack.org/#/c/305132/ is ready for merge i think
15:18:51 <yamahata> Cool. I'll check it to merge it
15:18:59 <yamahata> #action yamahata review/merge https://review.openstack.org/#/c/305132/
15:19:55 <yamahata> how about https://review.openstack.org/#/c/307171/  ?
15:20:05 <yamahata> I'll review it today.
15:21:40 <yamahata> okay. any other bugs/patches?
15:22:49 <yamahata> seems nothing else.
15:22:59 <yamahata> #topic ML2 ODL driver rewrite
15:23:17 <yamahata> I suppose we can cover this topic as normal patch/bug session.
15:23:33 <yamahata> So I'm wondering dropping this from agenda.
15:24:09 <yamahata> #topic Boron planning
15:24:10 <asomya> yamahata: +1, most of the bug discussions center around it anyways
15:24:22 <yamahata> #undo
15:24:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x29a7890>
15:25:01 <yamahata> oaky, next topic
15:25:04 <yamahata> #topic Boron planning
15:25:22 <yamahata> in M2, we had several dependency notification from ODL project
15:25:34 <yamahata> netvirt, GBP, vtn, vpnservice
15:25:59 <yamahata> I suppose there are more projects which haven't notify dependency officially
15:26:06 <yamahata> that's all this week
15:26:14 <yamahata> #topic open mike
15:26:22 <yamahata> any thing else to discuss?
15:26:46 <asomya> yamahata: Bluejeans sessiion postponed to next week?
15:26:56 <asomya> since mike and oded aren't available
15:27:01 <yamahata> asomya: yes as mike and oded are off today
15:27:42 <yamahata> anything else or the remaining time will be given back.
15:28:24 <vthapar> Neutron northbound bugs and patches?
15:28:35 <yamahata> Ah yes.
15:28:44 <vthapar> the yang model changes in NN
15:28:46 <yamahata> Right now I'm working on patches to update yang models.
15:29:14 <yamahata> I hit a bug of yangtools or mdsal.
15:29:33 <yamahata> So it would take a while to upload new patches.
15:29:50 <vthapar> similar to issue I mailed ovsdb-dev half an hour ago?
15:30:05 <yamahata> I haven't the mail yet.
15:30:14 <vthapar> https://git.opendaylight.org/gerrit/#/c/38664/
15:30:21 <yamahata> The issue is that yang union under indentityref
15:30:58 <vthapar> okay, this one was about yang choice.
15:31:27 <vthapar> also wanted to close out decision on https://bugs.opendaylight.org/show_bug.cgi?id=5735
15:32:10 <yamahata> vthapar:  yes. We have to decide how to fix it.
15:32:47 <vthapar> I was thinking more on lines of making ip-address field a list of ip-addresses and retaining subnet as they only key
15:32:51 <yamahata> #action yamahata look into https://bugs.opendaylight.org/show_bug.cgi?id=5735
15:33:47 <yamahata> I see.
15:34:51 <yamahata> On the other hand, in neutron the pair (subnetid, ip-address) is stored.
15:35:16 <yamahata> I'm wondering if we should follow openstack neutron way or do it in different way.
15:35:18 <vthapar> what about multiple IPs for given subnet?
15:35:30 <vthapar> when we get fixed IPs we get them as a list.
15:36:32 <yamahata> The primary key for the table is (network-id, subnet-id, ip-address)
15:36:50 <yamahata> neutron port has a relationship to it.
15:36:53 <yamahata> as list
15:37:22 <yamahata> I assumes the list of fixed ip addresses is short.
15:37:30 <yamahata> e.g. 3 or 4 at most.
15:37:53 <yamahata> So I suppose looping over the list won't be an issue.
15:38:06 <yamahata> vthapar: do you have any concern?
15:38:32 <yamahata> I also understand {}
15:38:37 <yamahata> oops
15:38:44 <vthapar> yamahata: I would prefer model that corresponds to what we get in JSON, if it is subnetId - Ip, am okay with that.
15:39:20 <vthapar> I'll probably have to check what json we get. I thought it was list of IPs per subnetid so was going with that.
15:39:27 <yamahata> I also understand {'subnet-id': [ip-address0, ...], 'subnet-id-1', ...} is easy to handle by vpnservice or netvirt
15:39:54 <yamahata> vthapar: I greed that we should check the resulted JSON.
15:40:18 <vthapar> yes, it comes in handy from netvirt perspective, don't need to know the IP to fetch it for a given subnet, which tends to be use case for extra routes etc.
15:40:28 <yamahata> #link http://developer.openstack.org/api-ref-networking-v2.html neutron api doc
15:40:56 <yamahata> #link http://developer.openstack.org/api-ref-networking-v2.html#listPorts list port
15:41:11 <yamahata> Here we can see the example of json
15:42:18 <vthapar> but it only covers single fixed Ip. I should have it in my q-svc.log somewhere. will update the bug with it and then we can decide on how to fix it.
15:42:38 <vthapar> I'll also look at different ways how it is used in vpnservice/netvirt.
15:42:52 <yamahata> Please notice "[{}, ]". It's a list of dict.
15:43:33 <vthapar> yeah, it suggests subnet-ipaddress will be better.
15:44:02 <vthapar> we do want NN to be as transparent as possible so should come up with model that aligns with what we get.
15:44:09 <yamahata> Cool.
15:44:24 <yamahata> Can you please give the patch the explicit comment for record?
15:44:28 <yamahata> Then, I'll update the patch.
15:45:07 <vthapar> we don't have patch for this yet, only the bug.
15:45:17 <yamahata> Ah, then on the bug report
15:45:28 <vthapar> I held off to patch as was wondering if we want to take it up as part of the bigger patch where we're modifying all yangs.
15:45:44 <vthapar> would make sense, else we will end up causing disruption twice.
15:46:00 <vthapar> yeah, will add to bug report.
15:46:01 <yamahata> Agree. I don't want two disruptions.
15:46:11 <yamahata> (or even one disrutpion if possible)
15:46:49 <vthapar> one disruption can be avoided by using revision and new yangfile with revision in file name.
15:47:15 <vthapar> onus would be on others to modify code to use new yangs, but nothing would break.
15:49:04 <yamahata> I see.
15:49:49 <yamahata> anything else to discuss?
15:50:15 <vthapar> nothing from me.
15:50:34 <yamahata> okay I'll give you 10min back
15:50:42 <yamahata> thank you, everybody
15:50:44 <yamahata> #topic cookies
15:50:53 <yamahata> #endmeeting