15:04:01 <yamahata> #startmeeting neutron_northbound
15:04:01 <odl_meetbot> Meeting started Wed Jun  1 15:04:01 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:04:01 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:01 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:04:23 <yamahata> #chair mkolesni oshvartz asomya
15:04:23 <odl_meetbot> Current chairs: asomya mkolesni oshvartz yamahata
15:04:32 <yamahata> #topic agenda bashing and roll call
15:04:35 <yamahata> #info yamahata
15:04:50 <yamahata> sorry for my absence the past two weeks.
15:05:05 <mkolesni> no problem
15:05:17 <yamahata> Do we have any adgenda in addition to usual patch/bug review?
15:05:28 <yamahata> I have two announcement today.
15:05:34 <mkolesni> we can talk about the spec process
15:05:45 <mkolesni> and perhaps about journal recovery if we have time
15:05:53 <yamahata> #info agenda spec process
15:06:15 <yamahata> #info agenda journal recovery if we have time
15:06:26 <yamahata> any other topics?
15:07:14 <yamahata> seems nothing else.
15:07:18 <yamahata> #topic Announcements
15:07:26 <mkolesni> https://review.openstack.org/#/c/312199/12/specs/newton/neutron-stadium.rst
15:07:31 <mkolesni> we have so AIs there
15:07:37 <mkolesni> but we can keep it to other meeting
15:07:41 <yamahata> Yes, that's exactly I'd like to share it.
15:07:56 <mkolesni> ok :)
15:08:33 <yamahata> In order to stay under neutron stadium, networking-odl has to fulfill some issues.
15:09:35 <yamahata> The line 303
15:09:39 <yamahata> We have to
15:09:51 <yamahata> * adopt neutron-api, and neutron-lib;
15:09:59 <yamahata> * complete docs, end-to-end testing, and demonstrate ability to upgrade;
15:10:30 <yamahata> Per code wise, I suppose we can address it.
15:10:45 <yamahata> For documentation, we don't have anyone assigned to it explicitly.
15:10:56 <yamahata> right now
15:11:09 <mkolesni> we should probably turn these into bugs or rfes
15:11:23 <mkolesni> concrete tasks
15:11:39 <yamahata> #action yamahata everyone need to break down stadium items into concrete tasks and have it assigned
15:11:55 <yamahata> bugs/rfes sounds good idea!
15:12:24 <mkolesni> so that we have a good way to track it
15:12:53 <mkolesni> i can document the journal & maintenance infra for example so i'll add a bug for that
15:13:22 <yamahata> cool
15:13:48 <yamahata> #action mkolesni file a bug for document the journal & maintenance infra for example
15:14:46 <yamahata> If we have any questions/issues on neutron-stadium.rst, we have to raise it right now.
15:14:51 <yamahata> it would be merged soon.
15:15:31 <yamahata> I have another issue to share
15:15:51 <yamahata> In ODL side, big code change/re-architect is planned/happening.
15:16:20 <yamahata> i.e. In ODL netvirt project, the code base would be changed from the existing one to VPNService
15:16:37 <mkolesni> how does that affect us?
15:16:55 <yamahata> devstack may need update.
15:17:19 <yamahata> I'm asking Erricson guys to update it. But I'm not sure they do in timely manner.
15:17:38 <yamahata> We'd like to start to test it proactively.
15:17:53 <mkolesni> do they have someone working on ODL's neutron or networking-odl project?
15:17:55 <yamahata> It would also causes regression/QA issues
15:18:14 <yamahata> Vithal and vivek are familiar with networking-odl.
15:18:32 <yamahata> They are also working on ODL side. I don't know their priorities.
15:18:56 <mkolesni> if they dont have anyone dedicated then it probably not in their priority list
15:19:02 <yamahata> ODL behaviour would be changed radically.
15:19:15 <oshvartz> Can we create a list of tasks for it >
15:19:16 <oshvartz> ?
15:19:21 <yamahata> Sure.
15:19:44 <yamahata> #action yamahata/everyone to create tasks to track vpnservice code base issue
15:20:29 <yamahata> In ODL netvirt project, they are having code walkthrought etc recently.
15:20:50 <yamahata> They've recorded the session. So you man be interested in it.
15:21:12 <oshvartz> sure, can you send the link for it
15:21:39 <yamahata> https://lists.opendaylight.org/pipermail/ovsdb-dev/2016-May/thread.html
15:21:52 <yamahata> The details are announce at the mailing list
15:22:30 <yamahata> That's all from me.
15:22:35 <yamahata> any other announcement?
15:22:44 <mkolesni> nothing from my side
15:23:15 <yamahata> #topic action items from last meeting
15:23:39 <yamahata> The spec for journal recovery was already filed.
15:23:59 <yamahata> The next topic is spec process
15:24:06 <mkolesni> im working on a detailed spec
15:24:08 <yamahata> #topic spec process
15:24:18 <mkolesni> so its going along with the next topic
15:24:39 <yamahata> #link https://blueprints.launchpad.net/networking-odl
15:25:06 <yamahata> For now we have several blueprints and I had assigned priority based on my personal opinion
15:25:32 <yamahata> For now the goal is to track our activity in lightweight way.
15:25:48 <mkolesni> so i see a spec for qos driver
15:26:07 <mkolesni> #link https://review.openstack.org/314221	Add Spec for QoS driver
15:27:08 <yamahata> Yea
15:27:42 <yamahata> As the management process, do we have any issues? or any request to change the process?
15:28:11 <yamahata> When we have new blueprint, we can discuss it in this meeting and approve it/assign priority.
15:28:55 <yamahata> any thoughts/comments?
15:28:56 <mkolesni> i think some things need more than blueprint
15:29:10 <mkolesni> but otoh a big spec like neutron is too much
15:29:49 <mkolesni> for example for journal recovery the bp is shallow
15:29:54 <mkolesni> no design details
15:30:23 <mkolesni> so im also writing a spec for review
15:30:57 <yamahata> Got it. Do we want formal process? or just discuss case-by-case basis?
15:31:06 <mkolesni> i think what we probably need is a spec template, perhaps the one from neutron could do but we should probably simplify it
15:31:16 <mkolesni> i also see in tree spec for sfc
15:32:12 <mkolesni> if we use specs for review we should also put them somewhere
15:32:50 <mkolesni> btw, if we continue in the stadium the stadium doc specifies that specs should be in neutron-specs if im not mistaken
15:32:57 <mkolesni> or use rfe process
15:33:47 <yamahata> for the stadium, the basic principle is to resemble neutron process, but in lighter way.
15:34:57 <yamahata> Do we want spec repo? or is it okay to store them in doc directory?
15:35:07 <yamahata> For now we are using doc/ dir.
15:35:19 <mkolesni> i think for now doc/source/specs
15:35:31 <mkolesni> since its not quite user facing documentation
15:35:39 <mkolesni> so probably no reason to mix them
15:35:47 <yamahata> mkolesni: sounds reasonable
15:36:49 <yamahata> if it's okay, I'll send a patch to create the dir and move the existing under it.
15:37:06 <yamahata> #action yamahata upload a patch for doc/source/specs dir
15:37:22 <yamahata> any other thoughts/comments?
15:37:39 <mkolesni> sure
15:37:57 <mkolesni> i will send a patch for a template?
15:38:16 <mkolesni> and we can decide per blueprint if we want a spec reviewed or not
15:38:23 <yamahata> cool
15:38:31 <yamahata> #action mkolesni  send a patch for a template
15:39:59 <yamahata> anything else?
15:40:17 <mkolesni> nothing about this
15:40:37 <yamahata> move on
15:40:53 <yamahata> #topic patches/bugs
15:41:28 <yamahata> any patches/bugs to raise?
15:41:35 <yamahata> mkolesni: do you have some?
15:41:42 <mkolesni> yes
15:42:00 <mkolesni> #link https://review.openstack.org/312033 	Complete port details by journal instead of mech driver
15:42:14 <mkolesni> this can probably be merged
15:42:36 <yamahata> asomya: rcurran do you have any issues with the patch?
15:43:20 <rcurran> yikes blinking icon :-) ... sorry busy w/ other projects
15:43:31 <rcurran> just reviewed full sync - looks good
15:43:45 <rcurran> and this requires the port detail change ... i'll +1
15:43:58 <yamahata> Can you please take a look at 312033? After your's review, we would merge it.
15:44:03 <asomya> no issues from my end
15:44:34 <yamahata> asomya: rcurran thanks
15:44:51 <mkolesni> i saw rcurran's comments on the full sync patch, will try to address them asap
15:45:01 <yamahata> Now I merged 321594	Updated from global requirements
15:45:01 <mkolesni> #link https://review.openstack.org/321504 Refactor SG callbacks
15:45:43 <yamahata> #action mkolesni respin 307218	ODL v2: Full sync resources
15:46:02 <yamahata> #action everyone review https://review.openstack.org/321504 Refactor SG callbacks
15:47:02 <yamahata> #link https://review.openstack.org/#/c/308031/
15:47:03 <yamahata> pseudo-agentdb-binding
15:47:24 <yamahata> I suppose maintenance thread issue needs to be resolved.
15:47:49 <yamahata> mohammed will address it.
15:48:14 <yamahata> any other patches/bugs?
15:48:16 <mkolesni> i think it doesnt make sense to introduce those changes
15:48:28 <mkolesni> i dont know if you guys are in agreement or not
15:48:40 <mkolesni> perhaps we should discuss here and come to a conclusion?
15:49:08 <yamahata> Do we have mohammed?
15:49:30 <yamahata> personally I'm okay with either way.
15:50:07 <mkolesni> the change makes the simple logic more complicated thus making it more bug prone IMHO
15:50:09 <yamahata> So you mkolesni has opinion, we can go for your call.
15:50:19 <mkolesni> ok :)
15:50:47 <mkolesni> just trying to voice my thoughts on that
15:51:10 <mkolesni> essentially we should strive for as much simplicity as possible
15:51:25 <mkolesni> since complexity makes it harder to spot bugs
15:51:57 <mkolesni> thats why i do some refactors here and there to reduce the complexity
15:53:56 <yamahata> agreed that's KISS principle
15:54:40 <mkolesni> cool
15:54:53 <yamahata> we covered most patches.
15:54:58 <yamahata> next topic
15:55:10 <yamahata> #topic ODL neutorn northbound
15:55:22 <yamahata> #link https://lists.opendaylight.org/pipermail/neutron-dev/2016-May/000782.html networking-odl driver for sfc yang models
15:55:39 <yamahata> Anil has raised an issue on ODL northbound API.
15:55:56 <yamahata> So far ODL neutron northbound REST API is hand written for networking-odl.
15:56:09 <yamahata> He wants to use restconf with yangmodel directly.
15:56:27 <yamahata> To be honest, I haven't understand its implication.
15:56:40 <mkolesni> this means we need to adapt the client code in networking-odl?
15:56:53 <yamahata> Maybe, maybe not.
15:57:08 <mkolesni> thats what i understood from the email
15:57:26 <yamahata> we need to understand those issues before deciding.
15:58:32 <yamahata> Or postpone the dicusion to the next cycle and stay in the current way.
15:58:43 <yamahata> for this cycle.
15:59:00 <mkolesni> is the networking-odl-sfc going to use the journal mechanic?
15:59:23 <yamahata> Yes. Our principle is to require v2 driver, isn't it?
15:59:33 <mkolesni> yeah just making sure
15:59:54 <mkolesni> so from what i understood it's about the client we use
16:00:06 <mkolesni> would it call "neutron" like APIs or direct ODL ones
16:00:28 <yamahata> Yes.
16:00:31 <mkolesni> i dont know whats the pros and cons of each approach
16:00:45 <mkolesni> so perhaps Anil can elaborate on that?
16:01:17 <yamahata> Rigth, Anil should discuss about it because he wants to drive it.
16:01:40 <yamahata> Otherwise, I'd like to postpone it to the next cycle.
16:01:50 <mkolesni> im fine with that
16:02:12 <yamahata> Eventually we should evaluate those issue. But I don't think we have another engineering resource for this cycle.
16:02:54 <yamahata> okay, we're over running.
16:03:03 <yamahata> so please voice on the mailing list.
16:03:19 <yamahata> next topic
16:03:22 <yamahata> #topic boron planning
16:03:30 <yamahata> I reported M3 status.
16:03:43 <yamahata> #topic open mike
16:03:52 <yamahata> anything else to discuss today?
16:04:06 <mkolesni> nothing from my side
16:04:15 <mkolesni> i think we will skip bluejeans?
16:04:23 <mkolesni> personally i have to go
16:04:30 <yamahata> Do we have urgent/complex issue?
16:04:40 <yamahata> asomya: rcurran ?
16:04:51 <rcurran> nothing from me
16:04:54 <asomya> none from me, we discussed partial sync in bluejeans last week
16:04:57 <yamahata> Oh, then let's skip it today.
16:05:07 <yamahata> Thank you everyone
16:05:17 <mkolesni> thanks Isaku & everyone
16:05:18 <yamahata> #topic cookies
16:05:23 <yamahata> #endmeeting