15:04:47 <yamahata> #startmeeting neutron_northbound
15:04:47 <odl_meetbot> Meeting started Wed Jun 22 15:04:47 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:04:47 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:47 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:04:54 <yamahata> #chair mkolesni
15:04:54 <odl_meetbot> Current chairs: mkolesni yamahata
15:05:02 <yamahata> #topic agenda bashing and roll call
15:05:08 <yamahata> #info yamahata
15:05:18 <yamahata> I don't have any specific one today
15:05:23 <yamahata> any other?
15:05:35 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Main
15:05:42 <yamahata> #undo
15:05:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x29b8210>
15:05:50 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings
15:06:07 <yamahata> #topic Announcements
15:06:30 <yamahata> On last monday I have merged a patch series for ODL neutron northbound.
15:06:39 <yamahata> It may affects integration.
15:06:53 <yamahata> On ODL side, netvirt and group based policy was fixed.
15:07:18 <yamahata> But nic and vpnservice haven't been fixed yet. I have provided patches for them, though.
15:07:27 <yamahata> any other announcement?
15:07:32 <vthapar> yamahata: vpnservice might not need the patch.
15:07:57 <vthapar> yamahata: vpnservice code has been moved to netvirt, will get back on what is the plan on disabling those modules in vpnservice pom files.
15:08:15 <vthapar> but if you have we can get them in to unblock build issues.
15:08:38 <yamahata> vthapar: really? When I tried to build it, it failed. https://git.opendaylight.org/gerrit/#/c/40258/
15:08:54 <yamahata> anyway vpnservice project is aware of it, it's up to the project.
15:09:00 <vthapar> vpnservie? yes, it will fail. but it is not part of distribution anymore.
15:09:09 <vthapar> no more code is going into vpnservice in boron.
15:09:26 <yamahata> vthapar: Oh I see. got it.
15:09:59 <vthapar> keep the patch though, once decision is made on what to do with it, we may merge it in.
15:10:32 <yamahata> It's quite up to vpnservice project. I've fullfilled the responsibility.
15:10:54 <vthapar> yamahata: thanks for that :) I would've brought it up earlier but was off past couple weeks.
15:11:39 <yamahata> any other announcement?
15:12:36 <yamahata> move on
15:12:39 <yamahata> #topic action items from last meeting
15:12:47 <yamahata> I updated trello board
15:13:02 <yamahata> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound trello board for ODL neutron northbound
15:13:13 <yamahata> I've created new list
15:13:35 <yamahata> Especially v2driver next steps and VPNService migration
15:14:11 <yamahata> For v2 driver, I suppose the next thing is to finish migration.
15:14:34 <yamahata> so add tests set and find any gaps compared to v1 driver.
15:15:01 <yamahata> featurewise, journal recovery and hash calculation
15:15:30 <mkolesni> re journal recovery ive replied in the patch
15:15:49 <yamahata> mkolesni: thanks. Will check it.
15:17:06 <mkolesni> iyamahat: also the L3 full sync
15:17:12 <mkolesni> i see you +1 it
15:17:15 <yamahata> The goal of trello board it to collect task items ad sort out things
15:17:23 <mkolesni> how long do you want to wait there?
15:17:25 <yamahata> #topic patches/bugs
15:18:03 <yamahata> mkolesni: https://review.openstack.org/#/c/330395/ this one?
15:18:19 <mkolesni> iyamahat: yes
15:18:22 <yamahata> asomya: can you please take a look at 330395 ?
15:18:49 <asomya> yamahata: will do
15:19:03 <yamahata> After that, let's merge it. (or respin)
15:19:27 <yamahata> any other patches to discuss?
15:19:37 <yamahata> #link https://review.openstack.org/#/q/project:openstack/networking-odl pseudo port binding
15:20:08 <yamahata> Given the patch has started to grow, I'd like to merge it somehow and start new patches to continue this effort
15:20:16 <yamahata> What do you think?
15:20:29 <mkolesni> i have to take a second look on iy
15:20:31 <mkolesni> it
15:20:39 <mkolesni> btw the link you gave is not to that patch
15:20:48 <yamahata> #undo
15:20:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2aabd90>
15:21:01 <yamahata> #link https://review.openstack.org/#/c/308031/ pseudo port binding driver
15:21:02 <mkolesni> #action mkolesni re-review pseudo port binding
15:21:20 <yamahata> I'd like to make it progress somehow.
15:21:41 <mkolesni> of course
15:22:05 <yamahata> As I filed trelloboard, I've identified other two tasks for it. Those will be addressed by other patches
15:22:18 <yamahata> devstack support, openstack CI
15:22:38 <mkolesni> asomya: are you on that patch also?
15:22:58 <asomya> mkolesni: which patch?
15:23:06 <mkolesni> asomya: 308031
15:23:07 <yamahata> The patch is also needed for VPP
15:23:28 <mkolesni> asomya: your input would be valuable there since its a deep change
15:23:29 <asomya> i'll review it as well
15:24:17 <mkolesni> cool
15:24:22 <yamahata> Great
15:24:31 <yamahata> next patch
15:24:43 <yamahata> #link https://review.openstack.org/#/c/324052/ create dir, doc/specs, for spec
15:25:15 <yamahata> creating per cycle directory is too much. so it will be fine to have only general directory.
15:25:31 <yamahata> mkolesni: If it's okay, I'll update the patch
15:25:48 <mkolesni> yamahata: i think so since we dont expect to have that much volume like neutron has
15:25:58 <yamahata> mkolesni: agreed
15:26:09 <asomya> mkolesni: +1
15:26:47 <yamahata> #action yamahata update 324052 to use general directory
15:26:54 <yamahata> the next patch is https://review.openstack.org/#/c/331382/
15:27:06 <yamahata> #link https://review.openstack.org/#/c/331382/ improve error handling of request to opendaylight
15:27:19 <yamahata> The patch is to show my idea. Not ready for merge.
15:27:42 <yamahata> Is the direction correct? or should we pursue other direction?
15:28:04 <mkolesni> yamahata: i gave it a preliminary review, overall i think the direction makes sense but there are some comments
15:28:36 <yamahata> mkolesni: thanks. the patch is still at early phase. I wanted early feedback
15:29:05 <yamahata> we can continue detailed discussion at gerrit
15:29:08 <mkolesni> yamahata: you got it :)
15:29:19 <yamahata> That's all from me
15:29:25 <yamahata> any other patches to discuss?
15:29:47 <mkolesni> none on my side
15:30:39 <yamahata> okay next agenda
15:31:01 <yamahata> #topic Boron planning
15:31:14 <yamahata> The next milestone, M5, is code freeze.
15:31:28 <yamahata> So we need to rush for code for ODL neutron northbound.
15:31:39 <yamahata> Especially QoS code is under heavy respin
15:32:14 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/37165/
15:32:28 <yamahata> next topic
15:32:33 <yamahata> #topic open mike
15:32:44 <yamahata> anything else to discuss?
15:33:01 <mkolesni> do you want the bluejeans or can we pass it today?
15:33:23 <mkolesni> asomya, yamahata ^
15:33:36 <yamahata> Do we have any complex topics? otherwise we can skip bluejeans
15:33:44 <mkolesni> none on my side
15:33:58 <asomya> nohthing from me
15:34:08 <yamahata> okay, let's skip it
15:34:21 <mkolesni> ok
15:34:32 <yamahata> seems nothing else.
15:34:36 <yamahata> Thank you everyone
15:34:44 <mkolesni> thanks Isaku
15:34:51 <asomya> thanks
15:34:51 <mkolesni> see you guys
15:34:55 <yamahata> #topic cookies
15:34:59 <mkolesni> have a nice day :)
15:35:00 <yamahata> #endmeeting