15:02:20 <yamahata> #startmeeting neutron_northbound
15:02:20 <odl_meetbot> Meeting started Wed Jul  6 15:02:20 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:20 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:02:31 <yamahata> #topic agenda bashing and roll call
15:02:37 <yamahata> #info yamahata
15:02:58 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting adgenda
15:03:10 <yamahata> are they any other topics to discuss?
15:03:42 <oshvartz> not from my side
15:04:17 <yamahata> additionally I have topic on openstack CI to support vpnservice, broken tests.
15:04:30 <yamahata> #topic Announcements
15:04:45 <yamahata> CFP for openstack summit is approaching. July 13.
15:05:08 <yamahata> I think ODL team should apply for it jointly.
15:05:16 <yamahata> I'm contacking related people privately.
15:05:29 <yamahata> next, there was ODL hackfest last week.
15:05:37 <yamahata> So I skipped this meeting last week.
15:05:50 <yamahata> The outcome is, some progress on SFC.
15:05:59 <yamahata> both on ODL neutorn northbound and networking-odl.
15:06:07 <yamahata> the patches on ODL neutron northbound is merged.
15:06:23 <yamahata> And now Anil uploaded the patch to networking-odl
15:06:59 <yamahata> #link https://review.openstack.org/#/c/337948/
15:07:00 <yamahata> OpenStack Networking-SFC driver for OpenDaylight
15:07:14 <yamahata> that's all from me.
15:07:28 <yamahata> #topic action items from last meeting
15:08:09 <yamahata> Item: yamahata update 324052 to use general directory
15:08:20 <yamahata> the patch for spec directory was merged
15:08:45 <yamahata> #topic patches and bugs
15:08:58 <yamahata> any specific patches?
15:09:13 <oshvartz> I don't have pending patches
15:09:27 <yamahata> For now the big ones are, log recovery, pseudo port binding and sfc driver
15:10:17 <yamahata> as bug or not, now I'm seeing several tests are failing
15:10:52 <yamahata> https://review.openstack.org/#/c/337948/ e.g. gate-networking-odl-python27
15:10:55 <yamahata> we need to fix them
15:11:33 <oshvartz> do we know when it started to fail ?
15:11:37 <yamahata> #action yamahata everyone fix tests failure e.g. http://logs.openstack.org/48/337948/2/check/gate-networking-odl-python34/36bef46/
15:11:57 <yamahata> Ah No. I just noticed it because of the review of SFC driver
15:12:20 <yamahata> I haven't looked into it. I suspect that new tests were added.
15:13:14 <oshvartz> will try to take a look on it
15:13:19 <yamahata> Cool.
15:13:31 <yamahata> #action oshvartz look into tests failure
15:14:08 <yamahata> From me, that's it for bugs, patches
15:14:16 <yamahata> Do you have any others?
15:14:46 <oshvartz> no
15:15:00 <yamahata> okay, then move on
15:15:13 <yamahata> #topic boron planning
15:15:31 <yamahata> no specific update
15:15:38 <yamahata> #topic Open Mike
15:15:59 <yamahata> I'd like to raise adding openstack CI test for vpnservice.
15:16:22 <yamahata> Now ODL CI has been working on vpnservice.
15:16:32 <yamahata> I think openstack ci should also add such tests
15:17:15 <yamahata> Alon Kochba uploaded a patch which was merged.
15:17:49 <yamahata> But we need more to enhance devstack and add something like gate-tempest-dsvm-networking-odl-boron-snapshot-vpnservice
15:18:19 <yamahata> Is someone working on it already?
15:18:48 <oshvartz> I don't think
15:19:12 <yamahata> Okay then I need to look into it.
15:19:15 <oshvartz> the tempest test that we have today are working ?
15:19:23 <yamahata> #action yamahata look into devstack, openstack CI for vpnservice
15:19:37 <yamahata> with VPNservice?
15:19:45 <yamahata> or the existing one?
15:19:49 <oshvartz> no with old netvirt
15:19:58 <yamahata> I see
15:20:06 <oshvartz> because as far as I remember they are failing
15:20:09 <yamahata> The tests runs. but some tests are known to fail.
15:20:42 <oshvartz> so we need to make sure is will be "green"
15:21:28 <yamahata> Agreed.
15:21:47 <yamahata> They should be fixed somehow
15:22:10 <oshvartz> otherwise they are not effective
15:22:33 <yamahata> Ideally those tests should vote.
15:22:43 <yamahata> otherwise people will ignore the results.
15:23:24 <oshvartz> agree
15:24:48 <yamahata> API tests pass, some of scenario tests for network operation fail.
15:25:27 <oshvartz> we should make a "ignore" list because IPV6 and SG are not fully supported yet
15:25:37 <yamahata> For old netvirt case, we can disable those tests because it will be deprecated.
15:26:35 <yamahata> For future the focus is vpnservice.
15:28:36 <yamahata> any other topic to discuss?
15:28:59 <oshvartz> I don't think
15:29:55 <yamahata> thanks, let's give you back 30min
15:30:06 <oshvartz> :-)
15:30:09 <yamahata> thank you every one
15:30:13 <yamahata> #topic cookies
15:30:18 <yamahata> #endmeeting