15:03:39 <yamahata> #startmeeting neutron_northbound
15:03:39 <odl_meetbot> Meeting started Wed Jul 20 15:03:39 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:03:39 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:39 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:03:43 <mkolesni> sure
15:03:46 <yamahata> #chair mkolesni asomya
15:03:46 <odl_meetbot> Current chairs: asomya mkolesni yamahata
15:03:54 <yamahata> #topic agenda bashing and roll call
15:03:59 <yamahata> #info yamahata
15:04:14 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings agenda
15:04:30 <yamahata> Today I have special topic except usual agenda
15:04:39 <yamahata> any other topics?
15:04:55 <yamahata> I have _no_ special topic except usual topic
15:05:10 <mkolesni> none from me
15:05:20 <mkolesni> 216837
15:05:33 <yamahata> #topic Announcements
15:05:55 <yamahata> M5 is tomorrow. It's code freeze
15:06:00 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Boron_Release_Plan
15:06:17 <yamahata> #action yamahata M5 status report
15:06:25 <yamahata> any other announcement?
15:07:19 <yamahata> seems nothing. move on
15:07:22 <yamahata> #topic action items from last meeting
15:07:39 <yamahata> I had three items.
15:07:49 <yamahata> openstack CI. now it seems working correctly. done
15:08:05 <yamahata> openstack CI for vpnservice and v2 driver
15:08:15 <yamahata> Now I've started to work on it.
15:08:23 <yamahata> I'd like to make it happend soon.
15:08:44 <yamahata> My goal is to achieve v2 driver migration in newton cycle.
15:08:56 <yamahata> Recently it's getting pepople's interest.
15:09:03 <yamahata> e.g. HPE seems testing it
15:09:10 <mkolesni> you mean to run tempest on v2 + odl master with the new netvirt?
15:09:17 <yamahata> Yes.
15:09:28 <mkolesni> sounds good
15:09:54 <yamahata> People seems starting testing such combination. so networking-odl community should catch it up
15:10:08 <yamahata> idealy we should be ahead of it with openstack CI.
15:10:38 <yamahata> one ovn guy posted a mail to openstack-dev on journaing stuff
15:11:08 <yamahata> the last item is to catch up review. done.
15:11:31 <yamahata> #topic patches/bugs
15:11:53 <yamahata> any patches/bugs which needs attention?
15:12:10 <yamahata> hpe reported some bugs related to v2 driver
15:12:11 <mkolesni> none from me
15:12:51 <yamahata> Anyway at first we need to reproduce it before digging it.
15:13:58 <yamahata> seems that's all.
15:14:17 <yamahata> #topic open mike
15:14:20 <yamahata> anything else?
15:14:30 <yamahata> #action yamahata update meeting page. it's too stale.
15:14:53 <yamahata> Regarding ODL side, code freeze is soon.
15:15:01 <vthapar> is Ariel around for vlan-aware-vm patch?
15:15:05 <yamahata> So it's time to start carbon planning.
15:15:19 <yamahata> Oh vlan-aware-vm.
15:15:21 <mkolesni> do we need the bluejeans today? i dont have anything to discuss
15:15:37 <vthapar> looks like he is not around.
15:15:45 <yamahata> I don't neither. So we can skip bluejeans.
15:16:19 <yamahata> regarding to vlan-aware-vm, I'm fine to include the patch for Boron. But it should be experimental or beta
15:16:29 <mkolesni> sounds goood
15:16:41 <yamahata> because neutron API seems still non-fixed.
15:17:01 <yamahata> But I'd like to know his plan.
15:17:24 <yamahata> volunteer on its driver of networking-odl?
15:17:25 <vthapar> yamahata, agree. wanted his word before we got that in, even if experimental.
15:18:23 <vthapar> though as per Bence's comment API is still not frozen.
15:18:40 <vthapar> so either we merge as is on experimental basis and fix it as a bug later,
15:18:47 <yamahata> #link https://review.openstack.org/#/c/342459/
15:18:47 <yamahata> WIP: driver for trunk plugin
15:18:50 <vthapar> or we get a waiver to get this in assuming API is finalized.
15:20:37 <yamahata> vthapar: yeah. If we'd like to include it for boron, we need his commit.
15:20:50 <yamahata> Otherwise it will slip into carbon
15:21:28 <yamahata> On the otherhand QoS yang model patch will be merged.
15:22:12 <vthapar> yamahata, exactly. outside of uncertainity about API, does patch look okay to you?
15:22:29 <yamahata> yang model itself looks okay.
15:22:34 <vthapar> as in, subport as subnode of trunk.
15:23:03 <yamahata> I checked trunk plugin in neutron.
15:23:12 <yamahata> subport as subnode of trunk is better.
15:23:41 <yamahata> We don't want to track subports addition/deletion.
15:23:42 <vthapar> yeah, I also went through it before reviewing this and felt it worked better.
15:24:24 <vthapar> will you send out a mail to Ariel on this plan then? get this in as experimental and revisit later to make sure this makes to Boron.
15:24:36 <yamahata> Yes. I'll do
15:24:44 <vthapar> once yang is in we can get started on impl code in netvirt.
15:24:47 <yamahata> #action yamahata check Ariel for vlan-aware-vm plan
15:24:58 <vthapar> yamahata: thanks.
15:25:18 <vthapar> I'll probably pick up n-odl driver once API gets finalized.
15:25:40 <yamahata> Regarding neutron plugin side, I suppose it would be good
15:26:04 <yamahata> #link https://review.openstack.org/#/c/341212/ dd trunk create/delete notifications and augment subport notifications
15:26:25 <yamahata> I asked to include PRECOMMIT event. and it's in the patch.
15:26:55 <yamahata> So it would be v2 driver ready.
15:27:28 <vthapar> ok
15:27:56 <yamahata> any other topic?
15:28:42 <yamahata> seems nothing.
15:29:04 <yamahata> just FYI. so far I've focused on ODL side for a while.
15:29:24 <yamahata> But now I'll focus on networking-odl as it's code freeze tomorrow.
15:29:41 <yamahata> if nothing else, I'll give you back 30min
15:29:42 <mkolesni> cool
15:30:13 <yamahata> thank you everyone
15:30:21 <yamahata> #topic cookies
15:30:23 <mkolesni> thanks Isaku
15:30:26 <yamahata> #endmeeting