15:04:31 <yamahata> #startmeeting neutron_northbound
15:04:31 <odl_meetbot> Meeting started Wed Jul 27 15:04:31 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:04:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:31 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:04:43 <yamahata> #chair vthapar mkolesni asomya
15:04:43 <odl_meetbot> Current chairs: asomya mkolesni vthapar yamahata
15:04:50 <yamahata> #topic agenda bashing and roll call
15:04:56 <yamahata> #info yamahata
15:05:02 <mkolesni> #info mkolesni
15:05:07 <asomya> #info asomya
15:05:13 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting adgenda
15:05:19 <vthapar> #info vthapar
15:05:24 <yamahata> I updated the page.
15:05:57 <yamahata> In addition to usual topics, I newly added "migrating to new features"
15:06:22 <yamahata> I mean, what needs to be done to switch to new features like v2 driver for Newton cycle.
15:06:30 <yamahata> any other agenda items?
15:07:08 <mkolesni> what was decided about vlan aware vms?
15:07:17 <mkolesni> its pushed back to carbon?
15:07:28 <yamahata> it's for carbon.
15:07:31 <vthapar> yes
15:07:34 <mkolesni> ok
15:07:49 <yamahata> #topic Announcements
15:08:09 <yamahata> Boron M5 was past. Now it's code freeze.
15:08:24 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Boron_Release_Plan
15:08:52 <yamahata> Soon the branch will be cut and master branch will be open for Carbon.
15:09:08 <yamahata> Personally I'll focus on networking-odl.
15:09:23 <yamahata> voting for openstack summit is open
15:09:32 <yamahata> #link https://www.openstack.org/summit/barcelona-2016/vote-for-speakers/
15:09:48 <yamahata> So please vote for our and ODL proposals
15:09:57 <mkolesni> +1
15:09:59 <yamahata> any other announcement?
15:10:53 <yamahata> seems nothing, next.
15:10:55 <yamahata> #topic action items from last meeting
15:11:20 <yamahata> yamahata report M5 report, updated meeting page and decidec vlan-aware-vm plan. done
15:12:02 <yamahata> The next planned topic is "migrating to new features". before that I'd like to finish other items before.
15:12:13 <yamahata> #topic patches/bugs
15:12:31 <yamahata> I've uploaded a bunch of patches to enabled new features with devstack
15:12:53 <yamahata> My goal is to enable new features with openstack CI
15:13:31 <yamahata> Any patches/bugs which we need special attention for?
15:14:35 <yamahata> So far I hard from some complaining about logging of networking-odl is too verbose.
15:14:46 <yamahata> Anyway we will see by CI.
15:14:56 <mkolesni> there was some report by a guy from hpe
15:15:15 <mkolesni> but i think its low priority since he's talking about debug logs
15:15:51 <yamahata> #link https://bugs.launchpad.net/networking-odl/+bug/1605112 q-svc.log if filled with [networking_odl.journal.journal] printouts
15:16:27 <yamahata> #link https://bugs.launchpad.net/networking-odl/+bug/1604678 networking ODL-V1 VS. networking ODL-V2 - PortsAdminExtendedAttrsTestJSON test cases fail
15:16:43 <yamahata> I made 1605112 low priority
15:17:20 <yamahata> any volunteer for 1604678
15:17:38 <asomya> 1605112 might be invalid, i'll triage it
15:17:41 <yamahata> anyway after enabling CI, I expect more will pop up.
15:17:55 <yamahata> asomya: cool thanks.
15:18:49 <yamahata> any other bugs/patches?
15:19:38 <yamahata> okay we can move on to migration to new features.
15:19:42 <yamahata> #topic migrating to new features
15:20:30 <yamahata> Although there are many things to be added for new features, we should also think about how to switch to them.
15:20:39 <yamahata> I put some
15:20:46 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings
15:20:57 <yamahata> I'll create a wiki page for it
15:21:06 <yamahata> #action yamahata create a wiki page for feature migration
15:21:40 <yamahata> at least we should enable openstack CI and stabilize/harden them.
15:21:42 <mkolesni> we need to do it gradually
15:21:54 <mkolesni> i.e. first switch to v2 driver
15:22:07 <mkolesni> once its stable switch to vpnservice netvirt
15:22:20 <mkolesni> if we do all at once we wont know where the problems come from
15:22:53 <yamahata> mkolesni: fully agree. one thing at a time
15:23:24 <yamahata> vpnservice isn't feature parity for Boron. It will take for Carbon. So for newton cycle it will be experimental.
15:23:38 <yamahata> I suppose vpnservice switch will be the last.
15:23:51 <mkolesni> makes sense
15:24:38 <yamahata> For v2 driver, in addition to CI, what else should be done?
15:25:04 <mkolesni> once  ci is stable we should make it default
15:25:21 <yamahata> mkolesni: +1
15:26:09 <yamahata> benchmark with many resources is necessary. e.g. 10k ports
15:26:30 <mkolesni> do we have h/w for that?
15:26:34 <yamahata> Probably Rally can be used. and we'd like to know latency increase and CPU usage.
15:26:59 <yamahata> we don't have any in public.
15:27:12 <mkolesni> i thought rally is for the api load i.e. running many requests
15:27:30 <mkolesni> but not necessarily with many resources
15:27:58 <yamahata> mkolesni: right.
15:28:18 <yamahata> We may have to create simple script for benchmark if rally isn't suitable.
15:28:24 <mkolesni> we need to see if its possible upstream
15:28:50 <yamahata> yeah.
15:28:50 <mkolesni> should be but well see..
15:29:15 <mkolesni> probably we need tests for full sync
15:29:23 <mkolesni> and journal recovery
15:29:38 <mkolesni> and other maintenance features we have
15:29:56 <yamahata> new tests would be needed for those.
15:30:18 <mkolesni> i dont think its on tempest level
15:30:35 <mkolesni> probably we need some system test layer in the project
15:33:04 <yamahata> For pseudo agent port binding, it needs to be tested at first
15:33:04 <mkolesni> ill try to work on it but cant guarantee
15:33:12 <yamahata> mkolesni: cool.
15:33:33 <yamahata> I'm also trying to plan benchmark internally first. But right now no guarantee.
15:34:14 <yamahata> mohammed will work on port binding related staff.
15:34:33 <mkolesni> ok
15:35:30 <yamahata> The behaviour of v2 driver would be interesting. If it can be a topic at opendaylight/openstack summit, design summit/forum.
15:36:13 <yamahata> anything else?
15:36:26 <yamahata> I'll create a page, so please add your ideas.
15:36:30 <mkolesni> ok
15:36:55 <yamahata> #topic open mike
15:37:01 <yamahata> anything else to discuss?
15:37:11 <mkolesni> nothing from my side this week
15:37:22 <yamahata> Cool. so we can skip bluejeans
15:37:29 <mkolesni> +1
15:37:31 <vthapar> nothing from me either.
15:37:44 <vthapar> one suggestion, would be good to send openstack voting link to mail list
15:38:00 <yamahata> vthapar: can you take it?
15:38:10 <vthapar> yamahata: sure.
15:38:18 <yamahata> #action vthapar  send openstack voting link to mail list
15:38:19 <mkolesni> the list is rather small, perhaps ask people to spread it around
15:38:24 <yamahata> yay ;-)
15:38:39 <vthapar> will send it to neutron, netvirt and ovsdb.
15:38:40 <yamahata> #action everyone ask people to spread openstack voting around
15:38:42 <vthapar> ovsdb is lot bigger :)
15:38:49 <mkolesni> good idea
15:39:19 <vthapar> need to specify which particular topics? the way it is done couldn't extract links to individual submissions.
15:39:31 <vthapar> had to search "Opendaylight" and then find ours.
15:40:33 <yamahata> It seems like that the specific topic can't be linked intentionally.
15:41:07 <vthapar> yeah :)
15:41:28 <mkolesni> perhaps yamahata can send you the names to vote for?
15:41:31 <vthapar> want me to give instructions on how to find, just mention use "opendaylight" in search
15:41:41 <yamahata> mkolesni: sure
15:42:07 <yamahata> The evolution of OpenDaylight with OpenStack: big changes for production environment in future
15:42:16 <yamahata> OpenStack Networking SFC and L2GW service through OpenDaylight
15:42:22 <yamahata> the second is for vthapar
15:42:53 <vthapar> yeah, will add those too.
15:43:26 <vthapar> thsoe are the only two from us, right?
15:43:27 <mkolesni> you can search for "Isaku" ;P
15:43:49 <mkolesni> Have a bite of 1K+ nodes with a handful of servers
15:44:02 <mkolesni> found that one when searching for Isaku :)
15:44:15 <yamahata> there are many odl proposal. SFC seems hot topic
15:44:55 <yamahata> okay anyother topics?
15:45:02 <yamahata> otherwise I'll give you back 15mins.
15:45:06 <mkolesni> +1
15:45:27 <yamahata> thank you everyone!
15:45:33 <mkolesni> thanks Isaku
15:45:35 <yamahata> #topic cookies
15:45:41 <mkolesni> have a nice day everyone
15:45:43 <yamahata> #endmeeting