15:06:10 <yamahata> #startmeeting neutron_northbound
15:06:10 <odl_meetbot> Meeting started Wed Aug 17 15:06:10 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:06:10 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:06:10 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:06:15 <yamahata> #chair mkolesni
15:06:15 <odl_meetbot> Current chairs: mkolesni yamahata
15:06:22 <yamahata> #topic agenda bashing and roll call
15:06:26 <yamahata> #info yamahata
15:06:28 <mkolesni> #info mkolesni
15:07:01 <yamahata> Except usual items, any topics?
15:07:15 <mkolesni> the email?
15:07:20 <yamahata> As mkolesni suggested, how to make progress for newton release.
15:07:44 <yamahata> mkolesni: yes.
15:07:48 <mkolesni> ok
15:08:12 <yamahata> #topic Announcements
15:08:36 <yamahata> Now ODL boron is RC1. there are weekly boron review meeting.
15:08:57 <yamahata> any other announcement?
15:09:54 <mkolesni> nothing from me
15:09:54 <yamahata> seems nothing else. move on
15:10:01 <yamahata> #topic action items from last meeting
15:10:16 <yamahata> mkolesni: thanks for covering last week.
15:10:24 <mkolesni> iyamahat: sure no prob
15:10:32 <yamahata> I filed a bug report
15:10:48 <mkolesni> yes i saw thats good
15:10:57 <yamahata> Regarding to documentation for ODL, the patch was merged
15:11:22 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/32109/
15:11:22 <yamahata> Documentation for Neutron Northbound project
15:12:00 <yamahata> okay, now actual discussion
15:12:02 <yamahata> #topic patches/bugs
15:12:31 <yamahata> #link https://review.openstack.org/#/q/status:open+project:openstack/networking-odl+branch:master+topic:journal-pickup
15:12:43 <yamahata> I have several patches to make v2driver work
15:13:17 <mkolesni> i will take a look at those
15:13:26 <yamahata> #link https://lists.opendaylight.org/pipermail/neutron-dev/2016-August/000971.html
15:13:40 <yamahata> and there is a thread in mailing list on how to make progress
15:14:10 <mkolesni> did you see sort by created date is necessary?
15:14:37 <mkolesni> i replied on the bug but didnt see a response from you
15:14:56 <yamahata> Oh which one? I may have missed it.
15:15:07 <mkolesni> #link https://bugs.launchpad.net/networking-odl/+bug/1609609
15:18:25 <yamahata> Probably I wasn't clear enought.
15:18:56 <yamahata> The problem is datetime or timestamp is too coarse which is second precision.
15:19:38 <mkolesni> the problem with the dependency calculations?
15:19:49 <mkolesni> or generally?
15:19:51 <yamahata> So we have many journal entries which have same timestamp, so that dependency validator thinks false-positive invalid dependency.
15:20:09 <mkolesni> for that i think what i suggested in the email makes more sense
15:20:14 <yamahata> dependency calculations.
15:20:18 <mkolesni> calculate the deps on insert time
15:20:45 <mkolesni> but this bug is about the ordering of entries in the journal
15:21:14 <mkolesni> essentially the journal is a queue which is currently built around "last updated" concept
15:21:27 <mkolesni> if we switch it it would reuire many changes
15:22:58 <mkolesni> since we already spent most of the cycle around this concept i dont think it would be good to change this late unless you have a concrete reason which isnt specified in the bug
15:23:26 <mkolesni> iyamahat: what do you think?
15:23:37 <yamahata> mkolesni: that sounds fair.
15:23:48 <yamahata> Let me rethink on it.
15:24:26 <yamahata> So far have you tested v2driver with tempest?
15:24:29 <mkolesni> ok
15:24:50 <mkolesni> not personally but i think there was an email from an HPE guy covering failures there
15:25:05 <yamahata> At least fixes are necessary to make tempest.api.network pass decently.
15:25:23 <yamahata> That's for sure.
15:25:59 <yamahata> huge backlog after test isn't good.
15:26:34 <mkolesni> of course question is did you see failures that relate directly to the ordering by "last updated"
15:26:36 <mkolesni> ?
15:27:22 <yamahata> Sure. let me check it.
15:27:36 <barak> Hi guys. as for tempest and v2, the ticket opened is https://bugs.launchpad.net/networking-odl/+bug/1604678/ . I have tried to look at this and added a comment to the ticket few minutes ago
15:28:08 <yamahata> So far I tried to make it work somehow. should start to revise those patches for good fix.
15:29:23 <mkolesni> seems that the problem there is related to the _enrich_port
15:29:35 <yamahata> https://review.openstack.org/#/c/350244/ would fix.
15:31:08 <mkolesni> ill make sure to re-review that one tomorrow
15:31:49 <yamahata> #action mkolesni yamahata review bug report https://bugs.launchpad.net/networking-odl/+bug/1604678/
15:32:20 <mkolesni> #action mkolesni re-review https://review.openstack.org/#/c/350244/
15:32:55 <mkolesni> also regarding the dependency checks
15:33:19 <mkolesni> in the email you agree with me that its better to move them to creation time?
15:34:23 <yamahata> mkolesni: I'm not sure at the moment. we need to give it consideration.
15:34:32 <yamahata> I'm open.
15:34:46 <mkolesni> i think if you calculate during create time you solve the db problem with dates
15:35:17 <mkolesni> otherwise the change to also introduce an autoicrementing column is complicating the code
15:35:26 <mkolesni> and im not sure yet its a good idea
15:36:23 <mkolesni> ie if youre adding an auto increment column why not have it be the primary key and drop the id
15:36:43 <yamahata> Although I'm open for long term direction, I'd really like to deliver v2driver for Newton.
15:36:57 <yamahata> I'm afraid of big change.
15:37:08 <yamahata> Yes, my patches are also big change.... :-(
15:37:15 <mkolesni> of course, what i suggest is that we prioritize moving the dependency calculations for Ocata
15:37:36 <mkolesni> and for now not merge your big changes unless theyre absolutely necessary..
15:37:59 <mkolesni> ie see if they actually fix tempest or they dont change anything there
15:38:36 <mkolesni> we should focus more on stabilizing the existing code and perhaps some missing features such as the journal recovery
15:38:55 <mkolesni> i already started working on journal recovery
15:39:05 <yamahata> mkolesni: very great!
15:39:43 <mkolesni> there are some aspects there that are harder to crack than i initially thought, so may be they wont make it in time
15:40:00 <mkolesni> but ill make it iteratively so at least we have some of it in by Newton
15:41:43 <mkolesni> i agree the timestamp is not a very good granularity, but question is if its a big problem or not.. i think not so much
15:42:00 <mkolesni> especially if we move the dependency checks to the create part
15:45:08 <yamahata> Yeah. It would be a time to revise dependency-validation scheme.
15:45:29 <yamahata> Now we're having experience with it.
15:47:50 <yamahata> It seems we come up to some point.
15:47:57 <yamahata> any further discussion?
15:48:19 <yamahata> #topic open mike
15:49:03 <yamahata> ODL summit is approaching in september.
15:49:31 <yamahata> we need to prepare for design forum and presentation.
15:49:41 <mkolesni> what do we need to prepare?
15:49:53 <mkolesni> except the talk we have together
15:50:27 <yamahata> design forum.
15:50:54 <mkolesni> what is expected there? is there a formal schedule or just discussion gorups?
15:50:57 <yamahata> we should provide community input in the context of neutron.
15:51:30 <yamahata> There is a wiki page to gather topics.
15:51:34 <yamahata> let me find it...
15:53:02 <yamahata> #link https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum
15:53:48 <yamahata> I'd like to discuss on new neutron features and get feedback on its priority.
15:54:08 <yamahata> For example pluggable IPAM is interesting given that new netvirt has its own dhcp server service.
15:54:31 <mkolesni> ok
15:55:20 <yamahata> any other topics to discuss? or can we close the meeting?
15:55:35 <mkolesni> none from me
15:55:47 <yamahata> thank you everyone.
15:56:02 <yamahata> #topic cookies
15:56:10 <yamahata> #endmeeting