15:05:35 <yamahata> #startmeeting neutron_northbound
15:05:35 <odl_meetbot> Meeting started Wed Sep 21 15:05:35 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:05:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:35 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:05:39 <yamahata> #chair mkolesni
15:05:39 <odl_meetbot> Current chairs: mkolesni yamahata
15:05:45 <yamahata> #topic agenda bashing and roll call
15:05:47 <yamahata> #info yamahata
15:05:49 <mkolesni> #info mkolesni
15:06:13 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting agenda
15:06:29 <yamahata> We have usual item.
15:06:36 <yamahata> and also ODL summit planning
15:06:41 <yamahata> any other agenda items?
15:08:22 <mkolesni> none from me
15:08:23 <yamahata> seems nothing else. move on.
15:08:30 <yamahata> #topic Announcements
15:08:39 <yamahata> next week opendaylight summit will be held
15:09:04 <yamahata> So the irc meeting on Sep 28 will be skipped as we will meet there in f2f
15:10:04 <yamahata> any other announcement?
15:11:10 <yamahata> okay next
15:11:12 <yamahata> #topic action items from last meeting
15:11:21 <yamahata> there is none from the last week
15:11:41 <yamahata> #topic ODL summit planning
15:12:21 <yamahata> #link https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum#Neutron_Northbound:_Carbon_and_openstack_Ocata_Planning
15:12:41 <yamahata> The schedule for developer design forum is not announce yet?
15:13:03 <yamahata> anyway we will have a session there to discuss on neutron northbound and networking-odl
15:13:17 <yamahata> #link https://docs.google.com/presentation/d/1606VOorn9pk90ICw99IeT9tIwB_itoGS2jIErp7pGwg/edit
15:13:23 <yamahata> #link https://trello.com/b/LhIIQ8Z0/odl-neutronnorthbound
15:13:51 <yamahata> Please feel free to update trello board for wishlist and slide.
15:14:52 <yamahata> at high level, I'd like to cover restspect the last cycle, networking-odl plan for newton release, prioritize features of neutron northbound
15:15:50 <mkolesni> networking-odl will need more stabilization work
15:16:11 <yamahata> mkolesni: I can't agree with you more!
15:17:27 <mkolesni> seems like a lot of slides
15:17:30 <yamahata> any other thoughts/ideas on topics of developer design forum?
15:17:35 <mkolesni> how much time do we have for this?
15:17:39 <yamahata> Yeah, too much.
15:17:49 <yamahata> Maybe around 30min-50min I guess.
15:17:59 <mkolesni> not enough..
15:18:08 <yamahata> I need to slim it down.
15:18:19 <yamahata> Probably continue with unconference session.
15:18:38 <mkolesni> makes sense
15:19:15 <mkolesni> whats the plan for monday?
15:19:26 <yamahata> Regarding to prioritization, netvirt session would also help.
15:19:29 <mkolesni> besides some tutorial sessions?
15:19:48 <yamahata> there is fd.io mini summit.
15:19:49 <mkolesni> maybe we should meet a bit on monday to start discussing these?
15:20:11 <yamahata> #link http://events.linuxfoundation.org/events/opendaylight-summit/program/schedule
15:20:18 <yamahata> mkolesni: Yes it makes sense.
15:20:37 <mkolesni> i plan on sight seeing manday but i can come to couple of hours since we have a lot to talk about
15:21:05 <mkolesni> whats your take on this?
15:21:46 <yamahata> what time is convenient for you?
15:22:06 <yamahata> I'll be available after lunch.
15:22:30 <yamahata> Given you'll go for sightseeing, late evening is better for you?
15:22:56 <yamahata> e.g. 4pm, 5pm
15:22:57 <mkolesni> i can do 4PM
15:23:10 <mkolesni> lets try to get more people though
15:23:23 <mkolesni> perhaps send an email?
15:23:59 <yamahata> do you mean monday?
15:24:10 <yamahata> anyway I'll make announce for it
15:24:13 <mkolesni> now with the perliminary details
15:24:27 <mkolesni> and monday with exact details of where we meet and so
15:24:29 <yamahata> #action yamahata make announce for odl summit developer design forum.
15:24:57 <mkolesni> because i dont know if they'll let us in to the conf center on monday if were not registered for tutorials/fdio
15:25:30 <yamahata> At worst we can meet lobby at the venue, marriott hotel.
15:25:41 <mkolesni> yeah ok
15:26:07 <mkolesni> what i meant perhaps send email today to start some traction so people won't be surprised next week
15:26:17 <mkolesni> that was my idea
15:27:38 <yamahata> anything else?
15:29:09 <yamahata> okay move onto next
15:29:13 <yamahata> #topic #topic patches/bugs
15:30:14 <yamahata> any urgent patches to discuss?
15:30:23 <yamahata> https://review.openstack.org/#/c/359501/
15:30:34 <yamahata> This is the one I'd like to make progress somehow.
15:31:01 <yamahata> My patches for v2 driver can be discussed at ODL Developer design forum
15:31:25 <mkolesni> i loked at it but im not enough knowledgable in that area yet
15:31:36 <mkolesni> i can perhaps give +1
15:31:49 <yamahata> okay.
15:31:56 <yamahata> any other patchtes/bugs?
15:33:16 <mkolesni> no as you said we can discuss others at the smmit
15:33:33 <yamahata> #topic open mike
15:33:47 <yamahata> anything else to discuss?
15:34:13 <yamahata> do we want to have bluejeans? I suppose no.
15:34:13 <mkolesni> i wanted to discuss something from journal recovery
15:34:18 <yamahata> Sure.
15:34:23 <mkolesni> no bluejeans necessary
15:34:49 <mkolesni> so i came across a little problem in the journal recovery
15:35:06 <mkolesni> for most L2/L3 resources were ok
15:35:29 <mkolesni> but for router interface, we don't have a way to know whats on the ODL side
15:35:44 <yamahata> Do you mean add/remove interface operation?
15:36:02 <mkolesni> yeah
15:36:09 <mkolesni> theres only the add/remove operations
15:36:23 <mkolesni> but no way to actually know what interfaces are "present"
15:36:52 <mkolesni> now, in the new netvirt its not a problem since they ignore this and just go by the port info
15:36:54 <yamahata> do you mean "present" on router? attached or not to the router?
15:37:22 <mkolesni> yeah
15:37:46 <mkolesni> i.e. if add_router_interface was called, there is no apparent change in any ODL resource
15:38:05 <yamahata> I see.
15:38:24 <yamahata> We need to see it the device owner of the port is router or not.
15:38:36 <yamahata> It's updated by update_port.
15:38:36 <mkolesni> yeah but thats on the ports anyway
15:38:51 <mkolesni> regardless if you call add_router_interface for that port or not
15:38:52 <yamahata> Actually add/remove interface operation is nop in ODL neutron northbound
15:39:25 <mkolesni> i thought old netvirt did support that?
15:39:53 <yamahata> old netvirt doesn't use add/remove interface operation.
15:40:08 <yamahata> But it looks into the owner of port
15:40:16 <mkolesni> ok so i suggest then that we remove those from the ODL REST API
15:40:28 <mkolesni> and in the driver just ignore these
15:40:54 <yamahata> Yeah. Recently I'm wondering if router interface operation can be removed.
15:41:29 <yamahata> #action yamahata add the topic to remove add/remove interface for ODL summit discussion.
15:41:31 <mkolesni> ok so for now im ignoring it in the journal recovery code
15:41:39 <mkolesni> and we can discuss removal in the summit
15:42:30 <mkolesni> ok nothing else from me then
15:42:37 <yamahata> https://git.opendaylight.org/gerrit/gitweb?p=neutron.git;a=blob;f=northbound-api/src/main/java/org/opendaylight/neutron/northbound/api/NeutronRoutersNorthbound.java;h=2eee4be8e396cde856a0617bdd02ac4fc5bd6a20;hb=refs/heads/master#l189
15:42:54 <yamahata> The add/remove router interface is implemented as nop
15:43:17 <yamahata> anything else.
15:43:22 <yamahata> or close the meeting
15:43:35 <mkolesni> nothing from me
15:46:09 <yamahata> #topic cookies
15:46:13 <yamahata> #endmeeting