15:01:50 <yamahata> #startmeeting neutron_northbound
15:01:50 <odl_meetbot> Meeting started Wed Nov  2 15:01:50 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:50 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:50 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:01:54 <yamahata> #chair mkolesni
15:01:54 <odl_meetbot> Current chairs: mkolesni yamahata
15:02:01 <yamahata> #topic agenda bashing and roll call
15:02:06 <yamahata> #info yamahata
15:02:19 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting page
15:02:27 <mkolesni> #info mkolesni
15:02:48 <yamahata> Today I'd like to discuss about neutron stadium mainly and meeting timeslot
15:03:00 <yamahata> as follow up of openstack summit
15:03:07 <yamahata> do we have any other topics?
15:03:19 <mkolesni> what about the stable branch & release tag
15:03:36 <yamahata> Yeah.
15:03:37 <mkolesni> newton is already out we need to release as well
15:03:45 <yamahata> right.
15:04:44 <yamahata> so first release, stable branch and then timeslot, finally neutron stadium. Does it make sense?
15:05:03 <mkolesni> sure
15:05:16 <yamahata> #topic Announcements
15:05:26 <yamahata> last week there was openstack summit.
15:05:35 <yamahata> The biggest issue for networking-odl is neutron stadium
15:05:51 <mkolesni> as i see it stable branch is actually required by stadium
15:05:56 <yamahata> #link https://review.openstack.org/#/c/383910/ Ocata: Assessment for networking-odl
15:06:22 <yamahata> ODL community gathered and discussed on what we can do to remain in neutron stadium
15:06:36 <yamahata> by Ocata-1, Nov 14.
15:06:52 <yamahata> that's all from me. any other announcement?
15:06:58 <mkolesni> ok
15:07:17 <yamahata> #topic stable release/tag
15:07:45 <yamahata> Given the current situation, I'm thinking to cut/tag stable/release at Ocata-1.
15:08:14 <yamahata> because we're heavily working on newton backlong to fullfill neutron stadium requirement.
15:08:21 <mkolesni> actually stadium work doesnt relate to the release were suposed to make
15:08:26 <yamahata> Does it make sense?
15:08:36 <mkolesni> i think we need to release asap
15:08:55 <yamahata> I see. We have already release notes. So any other patches to include?
15:09:13 <mkolesni> maybe just the journal would be nice but we can always backport it
15:09:22 <mkolesni> as far as im concerned
15:09:34 <mkolesni> we can backport anything we see fit later on
15:09:38 <yamahata> Do you have list of patches?
15:10:02 <mkolesni> https://review.openstack.org/#/c/374613/
15:10:09 <yamahata> Okay, so I'd like to include rally fix and grenade patches.
15:10:16 <mkolesni> #link https://review.openstack.org/#/c/374613/ Journal recovery for syncing with ODL
15:10:38 <mkolesni> ok so lets make an effort to push the last bits and get the release out
15:10:43 <yamahata> #link https://review.openstack.org/#/c/353050/
15:10:44 <yamahata> Add grenade plugin
15:10:48 <mkolesni> im guessing version would be 3.0.0?
15:10:55 <yamahata> #link https://review.openstack.org/#/c/392005/ rally fix
15:11:02 <yamahata> Yes.
15:11:26 <mkolesni> ok
15:11:49 <yamahata> So after merging those three patches, let's ask to cut stable/newton
15:11:59 <yamahata> I'll upload the patch for that
15:12:36 <yamahata> #action yamahata after merging three patches, upload a patch to cut stable/newton
15:13:01 <mkolesni> cool
15:13:07 <yamahata> stable/branch is done.
15:13:10 <yamahata> next topic
15:13:15 <yamahata> #topic meeting timeslot
15:13:39 <yamahata> At openstack summit John asked me to consider the timeslot of irc meeting.
15:13:44 <yamahata> So I sent out a mail on it.
15:13:46 <mkolesni> seems that jjoyce is fine with Wed
15:14:10 <yamahata> #link https://lists.opendaylight.org/pipermail/neutron-dev/2016-November/001044.html
15:14:45 <mkolesni> however if not then Mon at the same time is fine for him
15:15:14 <yamahata> Oh Now I read the reply.
15:15:41 <yamahata> oh, either timeslot works for me too.
15:15:55 <yamahata> Monday or wednesday.
15:16:35 <yamahata> I'd prefer not to churn unnecessarily. If possible, I'd like to stay same time slot.
15:16:47 <yamahata> thoughts?
15:16:47 <mkolesni> sure if jjoyce is fine with it
15:17:38 <yamahata> I see. first option is wednesday, the second choice is monday.
15:17:53 <mkolesni> the only thing making monday better is that we have more time for AIs
15:17:54 <yamahata> #action yamahata reply john's mail.
15:18:09 <mkolesni> but i dont mind to keep it on Wed
15:18:18 <yamahata> Oh I see. Can you please reply to his mail for Monday?
15:18:33 <yamahata> Usually Monday is good for week planning.
15:18:40 <mkolesni> ok
15:19:16 <yamahata> My plan is to keep this time slot next week. and then switch timeslot if we'll do.
15:19:29 <mkolesni> sure
15:19:49 <yamahata> next topic
15:19:53 <yamahata> #topic neutron stadium
15:20:21 <mkolesni> ive been focusing on docs there
15:20:29 <yamahata> #link https://review.openstack.org/#/c/383910/ ocata assesment
15:20:36 <mkolesni> we also saw neutron-lib has CI and also it is being used
15:20:49 <mkolesni> do you know what else is needed on that front?
15:21:12 <yamahata> For now, nothing to do until Nov 14.
15:21:31 <yamahata> In middle/long term, we need to get involved to help neutorn-lib effort.
15:22:01 <mkolesni> do you know more details?
15:22:14 <mkolesni> i.e. are we supposed to not import anything from neutron?
15:22:22 <yamahata> Right.
15:22:37 <yamahata> So neutron-lib needs to be enhanced to cover more.
15:23:02 <yamahata> subprojects are expected to contribute to neutron-lib to make it happen.
15:23:03 <mkolesni> im not sure 100% is ever possible
15:23:21 <mkolesni> but we can try
15:23:45 <yamahata> neutron-lib is still at early phase. there are many thing to do.
15:24:24 <yamahata> any other questions?
15:24:33 <mkolesni> i think there maybe the decision could be changed since we do use it to some degree
15:24:56 <yamahata> Agreed. I expect so.
15:25:10 <yamahata> #link https://etherpad.openstack.org/p/Keeping_ODL_in_OpenStack_Stadium meeting minutes at openstack summit
15:25:24 <yamahata> #link https://bugs.launchpad.net/networking-odl/+bugs?field.tag=neutron-stadium-evolution task list for neutron stadium
15:25:40 <yamahata> #link https://docs.google.com/spreadsheets/d/1j9edHIQpLUA7NS9L8GugIQ8X38-LoZ5cvqsAEHdsz_0/edit#gid=0 details task/owner tracker
15:25:59 <mkolesni> ill keep working on the docs front
15:26:15 <mkolesni> still need to document full sync
15:26:24 <yamahata> Cool.
15:26:29 <mkolesni> and also have so deployer docs
15:26:37 <mkolesni> some*
15:26:51 <mkolesni> or admin docs
15:27:14 <yamahata> I suppose admin/user docs has higher priority than developer doc
15:27:32 <mkolesni> sure
15:28:17 <yamahata> for scenario tests, networking-odl has tested only v1 driver + old netvirt.
15:28:21 <mkolesni> ill get on top but my knowledge might be lacking in some areas so people should feel free to join
15:29:05 <mkolesni> re the docs
15:29:58 <yamahata> regarding to stable branch maintenance, there are three patches.
15:30:38 <yamahata> #link https://review.openstack.org/#/c/392286/
15:30:38 <yamahata> tools: catch up neutron-lbaas change
15:30:50 <yamahata> #link https://review.openstack.org/#/c/389856/ stop doing any magic cloning of neutron during CI
15:31:01 <yamahata> #link https://review.openstack.org/#/c/389859/ stop doing any magic cloning of neutron during CI
15:31:27 <mkolesni> ill take a look though im not farmiliar with OS CI so much
15:31:30 <yamahata> are you interested in it? Ihar has complained about the current situation of networking-odl.
15:31:58 <yamahata> I see. Then, I'll continue to take care of those three.
15:32:13 <mkolesni> ok
15:32:24 <yamahata> I just wondered about role of Ihar and you.
15:32:45 <mkolesni> Ihar is focused on Neutron
15:33:01 <mkolesni> and is a stable maintainer
15:33:12 <mkolesni> so probably thats his interest
15:33:26 <yamahata> I see.
15:34:27 <yamahata> regarding to other tasks, the first priority is to make (all) scenario tests pass.
15:34:42 <yamahata> the second is to run multi-node tests (and hopefully make them pass)
15:34:52 <yamahata> the thirdone is to run functional tests.
15:35:01 <mkolesni> is there some ci infra problem there?
15:35:07 <yamahata> this one would be easy because it has only one test at the moment.
15:35:37 <yamahata> I don't see big issue. the task is to write a patch to project-config to define jenkins job.
15:35:40 * sridharg has a question regarding ovsdb_interface and would like to bring it up during the appropriate slot.
15:35:59 <mkolesni> hi sridharg :)
15:36:05 <yamahata> sridharg: ok. After this topic, we'll have open mike slot
15:36:14 <sridharg> sure thanks yamahata mkolesni
15:36:44 <yamahata> the last task is fullstack tests. I guess this would be difficult because we need to write test scheme from the scratch with defining what to test.
15:36:48 <mkolesni> so on Ocata M1 armax will redo his assesment?
15:37:20 <mkolesni> not sure what fullstack since were agentless
15:37:23 <yamahata> I suppose at Ocata-1, the patch, https://review.openstack.org/#/c/383910/ will be merged.
15:37:38 <yamahata> Until that we can keep give comment to update the situation.
15:37:59 <mkolesni> so what exactly full stack means for us?
15:38:49 <yamahata> #link http://docs.openstack.org/developer/neutron/devref/development.environment.html#testing-neutron
15:39:15 <yamahata> #link http://docs.openstack.org/developer/neutron/devref/development.environment.html#fullstack-tests full stack stests
15:39:59 <yamahata> In my understanding, in ODL case, deploy ODL and node with OVS. create netns to emulate vm.
15:40:15 <yamahata> send request to ODL neutron northbound etc. check if VM connectivity etc.
15:40:19 <yamahata> That's my understanding.
15:40:39 <mkolesni> ok this has little chance of happening in 2 weeks
15:40:41 <yamahata> It would be arguable that it's neutron test or ODL test though.
15:41:12 <yamahata> For functional test, we have only db migration sync validation tests at the moment.
15:41:34 <yamahata> In future, deploy neutorn server with networking-odl and deploy ODL with only neutron northbound.
15:41:40 <mkolesni> yea need more
15:42:03 <yamahata> send request to neutron server and check if ODL md-sal has expected data.
15:42:13 <yamahata> But it's after ocata-1.
15:42:21 <mkolesni> sure
15:42:44 <yamahata> any other issue to discuss?
15:43:17 <mkolesni> please review docs patches i sent
15:43:24 <yamahata> sure, off course!
15:43:29 <mkolesni> i think theyre good 2 go
15:43:51 <yamahata> let's move on
15:43:57 <yamahata> #topic open mike
15:44:03 <yamahata> sridharg: you're on stage
15:44:30 <sridharg> yamahata, ack
15:44:48 <sridharg> yamahata, I wanted to bring up an issue that I have seem with OpenStack Newton and master
15:45:10 <sridharg> basically in Newton release ovsdb_interface is defaulted to "native" (from "vsctl")
15:45:17 <yamahata> Yes.
15:45:23 <sridharg> mitaka - https://github.com/openstack/neutron/blob/stable/mitaka/neutron/agent/ovsdb/api.py#L33
15:45:28 <sridharg> newton - https://github.com/openstack/neutron/blob/stable/newton/neutron/agent/ovsdb/api.py#L33
15:45:50 <sridharg> My ODL setup is something like this - I have an external ODL Controller and an all-in-one devstack setup
15:46:25 <sridharg> when I'm creating some networks, dhcp agent is overriding the manager of ovs to local ip (i.e, ovsdb_connection)
15:46:42 <yamahata> Yeah, that causes issue.
15:46:44 <sridharg> this is causing issues in ODL
15:46:59 <yamahata> Have you looked at those patches, bug report?
15:47:11 <yamahata> #link https://bugs.launchpad.net/neutron/+bug/1614766 ovsdb managers shouldn't be erased/overwritten
15:47:22 <sridharg> I just noticed that you have a related patch - https://review.openstack.org/#/c/357528/2
15:47:25 <yamahata> #link https://review.openstack.org/#/c/357528/ ovsdb: don't erase existing ovsdb managers
15:47:40 <yamahata> #link https://review.openstack.org/#/c/382629/ bug/1614766 work around
15:47:56 <yamahata> For networking-odl, the work around is to use vsctl instead of native
15:47:58 <sridharg> yamahata, If I understand correctly the patch is trying to add a new manager instead of overriding the existing manager. Is this understanding correct?
15:48:09 <yamahata> That's right.
15:48:29 <yamahata> But in all-in-one node case, 6644 port is conflicting. So we need to change its port.
15:48:44 <sridharg> I agree with you that using "vsctl" would be a solution.
15:49:25 <sridharg> does having multiple managers configured on OVS work?
15:49:33 <sridharg> even when ODL Controller is an external controller?
15:50:02 <yamahata> Yes and no.
15:50:21 <yamahata> with external ODL case, we don't have port conflict.
15:51:18 <sridharg> ok. Say we have external ODL and dhcp-agent instead of overriding the manager adds a new manager (i.e., ptcp:127.0.0.1:6640)
15:51:45 <sridharg> how will it be able to create dhcp ports since ovsdb-server may not be listening on tcp?
15:51:56 <mkolesni> sorry guys gtg
15:52:10 <mkolesni> have a good day/evening
15:52:14 <sridharg> I've seen that in my setup, ovsdb-server is listening on unix socket and not tcp.
15:52:23 <yamahata> mkolesni: bye
15:52:27 <sridharg> i.e., --remote=punix:/var/run/openvswitch/db.sock
15:52:28 <mkolesni> bye
15:52:36 <yamahata> dhcp-agent will actively connect to 6640 port.
15:52:55 <yamahata> and directly talks ovsdb protocol.
15:53:03 <sridharg> I agree, but we should also have ovsdb-server listening on 6640 right?
15:53:12 <yamahata> Right.
15:53:28 <sridharg> By default (atleast in my setup) this is not the case. My ovsdb server is only listening on unix domain socket.
15:53:38 <yamahata> usually devstack sets it up. or other deployment tool like fuel should do.
15:54:14 <yamahata> With the current code, dhcp(or other) agent sets it up if ovsdb server doesn't.
15:54:23 <yamahata> and overwrites the existing setting.
15:55:56 <yamahata> #link https://github.com/openstack/neutron/blob/stable/newton/neutron/agent/ovsdb/native/connection.py#L80
15:56:39 <yamahata> #link https://github.com/openstack/neutron/blob/stable/newton/neutron/agent/ovsdb/native/helpers.py#L29
15:57:03 <sridharg> If i understood correctly, enable_connection_uri is only setting the manager. Does it also restart ovsdb-server to listen on tcp:6640?
15:57:22 <yamahata> we don't have to restart ovsdb-server.
15:57:36 <yamahata> Once manager is set, ovsdb will do it without restarting.
15:58:45 <sridharg> ooh ok. So your patch is going to help when we have an external ODL controller (for local ODL Controller we will have port-conflict). Is this correct?
15:59:04 <yamahata> that's right.
15:59:19 <yamahata> the patch is not high priority for me because we have work around.
15:59:29 <yamahata> If you like, please go take it over.
16:00:00 <sridharg> cool. thanks yamahata for patiently answering the queries.
16:00:12 <yamahata> any other issues?
16:00:18 <yamahata> or can we close the meeting?
16:00:29 <sridharg> yamahata, I will take a look at the review comments in your patch and will update it if required. thank you.
16:00:40 <sridharg> yamahata, ack from my side.
16:00:46 <yamahata> thanks
16:00:51 <yamahata> let's close the meeting.
16:00:58 <yamahata> #topic cookies
16:01:02 <yamahata> #endmeeting