16:02:24 <yamahata> #startmeeting neutron_northbound
16:02:24 <odl_meetbot> Meeting started Mon Nov 21 16:02:24 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:24 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:24 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:02:30 <yamahata> #chair mkolesni
16:02:30 <odl_meetbot> Current chairs: mkolesni yamahata
16:02:36 <yamahata> #topic agenda bashing and roll call
16:02:49 <mkolesni> #info mkolesni
16:02:55 <yamahata> #info yamahata
16:03:12 <yamahata> from me, I'd like to summarise neutron stadium effort and Ocata plan
16:03:21 <yamahata> In addition to usual topics
16:03:28 <mkolesni> sure
16:03:32 <yamahata> hello john_a_joyce
16:04:28 <john_a_joyce> hello
16:04:41 <mkolesni> hi john_a_joyce
16:04:53 <yamahata> we've just started. Now agenda bashing call.
16:05:02 <yamahata> do you have any topic today?
16:05:14 <john_a_joyce> hi mkolesni
16:05:24 <john_a_joyce> nothing specific for me to bring up
16:06:19 <yamahata> okay usual topics, neutron stadium, and ocata planning.
16:06:26 <yamahata> move on
16:06:32 <yamahata> #topic Announcements
16:06:47 <yamahata> Ocata 1 was Nov 14 and ocata-1 assessment for networking-odl was done.
16:06:57 <yamahata> The final summary is beind reviewed.
16:07:11 <yamahata> #link https://review.openstack.org/#/c/389397/ Ocata: Assessment summary
16:07:20 <yamahata> It's not finalised yet.
16:07:37 <mkolesni> i think in terms of docs were half way there
16:07:52 <mkolesni> better than nothing, but its very bare bones at the moment
16:08:14 <yamahata> mkolesni: agreed.
16:08:47 <yamahata> the assessment of networking-odl is merged
16:08:56 <yamahata> #link https://review.openstack.org/#/c/383910/ Ocata: Assessment for networking-odl
16:09:13 <yamahata> The sentense of "networking-odl will be removed from neutron stadium" was removed
16:09:41 <yamahata> So I suppose we're out of "emergency" status.
16:09:57 <mkolesni> seems so
16:09:59 <yamahata> anyway we need to continue to fill those gaps.
16:10:16 <mkolesni> agreed
16:10:28 <mkolesni> im currently working on functional tests as you know
16:10:38 <yamahata> So far I have intentionally merged patches very aggressively to make progress without other's reviews.
16:11:11 <yamahata> #topic neutorn stadium
16:11:29 <yamahata> But the pace could be slowed down to wait for reviews.
16:11:52 <mkolesni> i think so
16:12:05 <mkolesni> im doing very basic functional tests
16:12:18 <mkolesni> do you know if anyone would like to add some more complex ones?
16:12:30 <yamahata> So far I'm not aware of anyone.
16:13:18 <mkolesni> also in that regard
16:13:26 <yamahata> We have 4 or 5 items to fill gaps.
16:13:28 <mkolesni> do you know whats happening with this patch?
16:13:30 <mkolesni> https://review.openstack.org/#/c/394476/
16:13:43 <mkolesni> to add functional job to the CI
16:14:01 <mkolesni> #link https://review.openstack.org/#/c/394476/ add non-voting functional tests job for networking-odl
16:14:10 <yamahata> He seems like not so active now.
16:14:20 <yamahata> we should take it over.
16:14:25 <yamahata> mkolesni: do you want to take it?
16:14:31 <mkolesni> hes from Intel, i thought maybe you know
16:14:49 <mkolesni> i dont mind to push it forward, we need the tests to start running
16:15:09 <yamahata> thanks.
16:15:38 <yamahata> he's not dedicatedly assigned to networking-odl. but generally on CI.
16:16:21 <mkolesni> ok dont want him to get offended if i take over that patch
16:17:50 <yamahata> Okay. the followings are items for neutron stadium.
16:18:09 <yamahata> 1. documentation: not critical now. but we need more
16:18:33 <yamahata> 2. stable/branch maintenance. there are several patches under review. those need to get merged
16:18:49 <yamahata> 3. functioal tests: to have CI (and more tests)
16:19:08 <yamahata> 4. fullstack tests: to have CI (and more tests)
16:19:16 <yamahata> 5. mutlinode tests: to have CI
16:19:25 <yamahata> 6. gerenade test: to have CI.
16:19:29 <mkolesni> im not sure what we need fullstack for
16:19:36 <mkolesni> do you have an idea?
16:20:05 <mkolesni> i think functional should be enough
16:20:34 <yamahata> Ideally, we can have test cases that check network connectivity with only neutron, ODL without creating readl VM, but with netns.
16:21:15 <yamahata> Given that ODL netvirt team has its own CSIT, its priority is not so high.
16:21:26 <yamahata> Oh I forgot
16:21:40 <yamahata> 7. make tempest test(scenario tests) run and pass
16:21:57 <mkolesni> i dont know since ODL already has CSIT what value do we get from fullstack
16:22:08 <mkolesni> i think its more trouble than its worth, for now
16:22:16 <yamahata> Right now we have test with old netvirt, but we should migrate to new netvirt(vpnservice)
16:22:18 <mkolesni> but we can always decide we need some in the future
16:22:35 <yamahata> mkolesni: yeah.
16:22:59 <mkolesni> also what does multi node mean?
16:23:39 <mkolesni> i.e. we have Neutron on one node and ODL on another?
16:23:53 <mkolesni> 911651
16:24:03 <yamahata> we would have control node and compute only node
16:24:18 <yamahata> Ooops, all-in-one node and compute node.
16:24:29 <yamahata> #link https://review.openstack.org/#/c/397093/ add odl-server service in devstack for networking-odl multinode job
16:25:06 <yamahata> It can test e.g. live migration.
16:26:14 <yamahata> any other questions?
16:26:24 <mkolesni> so basically its tempest tests for aio + compute node?
16:27:17 <yamahata> aio?
16:27:33 <mkolesni> all in one
16:27:37 <yamahata> Yes.
16:27:43 <mkolesni> ok makes sense
16:27:50 <yamahata> Some scenario tests requires multiple nodes.
16:28:43 <yamahata> As we have added more scenario tests, I noticed that tempest CI hits timeout(120min)
16:29:14 <yamahata> gate-tempest-dsvm-* takes about 1h30-50min
16:29:35 <yamahata> So we need to consider a way to run tempest in pararell mode.
16:29:52 <mkolesni> how is it done in other projects?
16:30:12 <yamahata> Normally it's run in parellel mode.
16:30:18 <yamahata> e.g. neutron, ovn, midonet
16:30:34 <yamahata> I tested it for networking-odl with https://review.openstack.org/#/c/399986/
16:30:39 <yamahata> It seems unstable.
16:30:51 <yamahata> Probably we should attack it after migrating to new netvirt.
16:31:09 <yamahata> execution time reduces to around 40mins
16:31:31 <mkolesni> seems reasonable
16:32:23 <yamahata> any items regarding to neutron stadium?
16:33:28 <mkolesni> none from me
16:33:31 <yamahata> next topic
16:33:36 <yamahata> #topic ocata planning
16:33:49 <yamahata> at first, let me summarise the status of newton
16:34:00 <yamahata> The 3.0.0 was released, but stable/newton branch isn't cut yet.
16:34:12 <yamahata> #link https://review.openstack.org/#/c/398624/
16:34:12 <yamahata> networking-odl: Release networking-odl newton/3.1.0
16:34:23 <yamahata> I'm asking infra team to cut it.
16:34:35 <yamahata> Hmm, it get -1. I'll respin it.
16:34:40 <mkolesni> i think that a bit problematic some code already is there that is for ocata only
16:34:45 <yamahata> #action respin https://review.openstack.org/#/c/398624/
16:35:21 <yamahata> so do you have any specific git changeset/hash we should use?
16:35:41 <mkolesni> so they either should cut branch at earlier hash or we will need to revert some changes
16:36:22 <yamahata> For me either way is okay. mkolesni  you have an opinion. Can you please drive it?
16:37:19 <mkolesni> will release team accept it?
16:37:49 <yamahata> For the patch of 398624, I'll respin it based on hash you'll give.
16:38:10 <yamahata> After that, we would need adjustment patches to stable/newton.
16:38:30 <mkolesni> i dont mind which has you use for 3.1
16:38:41 <yamahata> Okay, then I'll update the patch.
16:38:43 <mkolesni> just pointing out the fact that some reverts will be necessary
16:40:22 <yamahata> Gotcha.
16:41:11 <yamahata> For Ocata planning, I have the following items in mind.
16:41:27 <yamahata> 1. neutron stadium effort continued
16:41:56 <yamahata> 2. CI migration to new features(new netvirt, v2 driver, pseudo agent port binding)
16:42:09 <yamahata> 3. more on v2 driver
16:42:17 <yamahata> any other items?
16:42:42 <yamahata> Ocata cycle is short than usual.
16:42:44 <mkolesni> specifically id like to try move the dependency calculations
16:42:55 <yamahata> #link https://releases.openstack.org/ocata/schedule.html Ocata Release Schedule
16:43:01 <yamahata> mkolesni: Great.
16:43:54 <mkolesni> so basically it gives us 2 months till feature freeze?
16:44:00 <yamahata> Yes.
16:44:07 <yamahata> So far release type of networking-odl is independnet.
16:44:15 <mkolesni> we should try to keep up with Neutron schedule this release
16:44:44 <mkolesni> its a bit poroblematic that we miss the openstack deadlines each time
16:44:45 <yamahata> it means networking-odl team has flexibility. (with effort to follow neutorn schedule)
16:45:14 <mkolesni> sure just that i think if we follow the schedule more tightly it will help with ODL adoption
16:45:17 <yamahata> Another choice is to follow openstack schdule.
16:45:46 <yamahata> It means networking-odl team needs to follow neutron release more strictly.
16:45:47 <mkolesni> right now its causing uncertainty since we dont have a release schedule
16:46:17 <yamahata> Do we want to change networking-odl release type from independent to neutron release?
16:46:44 <mkolesni> i think we should strive to keep up with the Neutron schedule as much as possible
16:47:03 <mkolesni> perhaps a 1-2 week slip is OK but we should aim to be as close as possible
16:47:11 <mkolesni> that's my opinion
16:48:28 <yamahata> I meant more formal one.
16:48:39 <yamahata> Now networking-odl is released at the page of https://releases.openstack.org/independent.html
16:49:01 <yamahata> If we follow openstack schedule, we can move to https://releases.openstack.org/newton/index.html
16:49:09 <mkolesni> lets keep it independent this cycle and see if a formal change is needed at the beginning of next one?
16:49:24 <yamahata> It mean networking-odl team really has to follow its release schedule.
16:49:37 <yamahata> mkolesni: sounds good idea.
16:49:40 <mkolesni> were all grown ups here i think we can manage :)
16:50:36 <yamahata> Yeah, we should experiment if we can manage or not.
16:50:53 <yamahata> any other topic to discuss regarding to ocata cycle?
16:51:18 <mkolesni> nothing from me
16:51:45 <yamahata> #topic action items from last meeting.
16:51:49 <yamahata> we don't have any
16:51:53 <yamahata> #topic patches/bugs
16:52:04 <yamahata> do we have any specific one to discuss?
16:52:16 <yamahata> Recently patch proposal/review is quite active.
16:52:22 <mkolesni> none from me
16:52:27 <mkolesni> seems velocity is good now
16:52:39 <yamahata> #topic open mike
16:52:53 <yamahata> this time slot seems working.
16:53:06 <mkolesni> works for me :)
16:53:22 <john_a_joyce> this slot works fine for me - although I am not that active in the project at the moment
16:53:37 <yamahata> cool
16:53:55 <mkolesni> john_a_joyce: feel free to jump in if you have time
16:54:04 <yamahata> thanksgiving, december and new year is approaching. We would like to make our schedule clear.
16:54:14 <yamahata> when to have or skip.
16:54:47 <yamahata> at least I can attend Nov 28, dec 5.
16:55:06 <mkolesni> we dont have anything special here so i dont mind
16:55:08 <yamahata> Dec 26 would be skipped.
16:55:20 <yamahata> so would Jan 2.
16:55:40 <john_a_joyce> yeah Dec 26 and Jan 2 I would not be able to attend
16:55:48 <mkolesni> Dec 12/19?
16:56:13 <yamahata> I can attend Dec 12. Not sure Dec 19 at this point.
16:56:55 <mkolesni> OK so lets raise this again on Dec 5 and well know more clearly?
16:57:04 <yamahata> mkolesni: sounds reasonable.
16:57:12 <mkolesni> cool
16:57:20 <yamahata> any other issue?
16:57:25 <mkolesni> none from me
16:57:29 <yamahata> or can we close this meeting?
16:57:35 <mkolesni> +1
16:57:42 <yamahata> thanks everyone
16:57:50 <mkolesni> thank you Isaku
16:57:56 <mkolesni> see you around
16:58:03 <yamahata> #topic cookies
16:58:07 <john_a_joyce> thanks everyone
16:58:09 <yamahata> #endmeeting