16:02:31 <yamahata> #startmeeting neutron_northbound
16:02:31 <odl_meetbot> Meeting started Mon Nov 28 16:02:31 2016 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:31 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:02:35 <mkolesni> could be a good idea
16:02:39 <yamahata> #chair mkolesni
16:02:39 <odl_meetbot> Current chairs: mkolesni yamahata
16:02:46 <yamahata> #topic agenda bashing and roll call
16:02:48 <yamahata> #info yamahata
16:02:50 <mkolesni> #info mkolesni
16:03:05 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting agenda
16:03:44 <yamahata> Do we have any topics in addition to usual topics?
16:03:55 <mkolesni> nothing from me
16:04:07 <yamahata> I have none
16:04:10 <yamahata> okay
16:04:28 <yamahata> #topic Announcements
16:04:35 <john_a_joyce> Hello - Mike and Isaku
16:04:41 <yamahata> john_a_joyce: hello
16:04:47 <john_a_joyce> I don't have any specific agenda items
16:04:58 <mkolesni> hi John
16:05:16 <yamahata> now we've just started now.
16:05:43 <yamahata> #info we've released newton release of 3.1.0
16:05:58 <yamahata> the stable/newton branch is finally cut and released.
16:06:15 <yamahata> #info stable/liberty is about to be end-of-life.
16:07:06 <yamahata> Ocata-1 was nov 14. and Ocata-2 is Dec-12
16:07:28 <yamahata> any other announcement?
16:07:39 <mkolesni> no
16:08:04 <mkolesni> tell me, how to sign up/in to ODL bugzilla?
16:08:04 <john_a_joyce> no
16:08:26 <yamahata> #topic action items from last meeting
16:08:40 <yamahata> respin https://review.openstack.org/#/c/398624/
16:08:54 <yamahata> It's done as the patch was merged.
16:09:00 <alonko> hey guys, just wanted to bring up some missing stable/mitaka backporting
16:09:11 <yamahata> alonko: yes
16:09:18 <yamahata> #topic patches/bugs
16:09:24 <alonko> commented on https://review.openstack.org/#/c/384075 and a few other stable/mitaka related patches that were pending, hope you can get to it now that neurton stadium issues have calmed down
16:09:30 <yamahata> alonko: which patch do you have in mind?
16:09:50 <alonko> these were related according to you for the actual gate runs
16:09:54 <alonko> https://review.openstack.org/#/c/396024/
16:09:54 <alonko> https://review.openstack.org/#/c/396025/2
16:10:36 <yamahata> for stable/mitaka branch?
16:10:52 <alonko> yeah. we should probably get a better fix in place for odl-releases so we don't have to update all branches all the time
16:11:57 <yamahata> #action review backport patches for stable/mitaka 384075 396024 and 396025 that make ci work
16:12:41 <yamahata> It seems once those patches are merged, it would make sense to release stable/newton branch?
16:12:53 <yamahata> 2.0.1 or 2.1.0
16:13:16 <mkolesni> stable newton?
16:13:21 <yamahata> yes.
16:13:25 <mkolesni> you mean release stable mitaka?
16:14:05 <yamahata> Oops, stable/mitaka.
16:14:07 <yamahata> Right
16:15:10 <yamahata> any other patches/bugs that need attention?
16:15:45 <mkolesni> yes
16:15:59 <yamahata> mkolesni: which patch/bug?
16:16:08 <mkolesni> https://review.openstack.org/#/c/401124/7
16:16:17 <mkolesni> its functional CI fix
16:16:26 <mkolesni> I finally got the gate to run the CI
16:16:35 <yamahata> #link https://review.openstack.org/#/c/401124
16:16:36 <yamahata> Fix functional CI
16:16:37 <mkolesni> specifically it fails one test due to ODL bug
16:16:48 <mkolesni> ill file a bug and disable that test for now
16:17:42 <mkolesni> but the patch for CI infra should be good to go regardless
16:17:51 <yamahata> Okay, I'll review
16:18:09 <yamahata> #action review https://review.openstack.org/#/c/401124
16:19:00 <yamahata> any other?
16:19:35 <yamahata> Recently we need recheck much more than before as more test cases added. especially scenario tests
16:20:08 <yamahata> I noticed one neutron bug
16:20:16 <yamahata> #link https://bugs.launchpad.net/networking-odl/+bug/1550278 tempest.api.network.test_dhcp_ipv6.NetworksTestDHCPv6.* tempest tests are failing repeatedly in the gate for networking-ovn
16:20:36 <yamahata> Which was originally filed for ovn, but we're recently hitting it too.
16:20:50 <mkolesni> ok
16:21:00 <mkolesni> can we increase the timeout in the gate?
16:21:05 <mkolesni> or is it something else?
16:21:16 <yamahata> I've already increased timeout from default 120mins to 180mins
16:21:29 <mkolesni> not helping?
16:21:37 <yamahata> It helped.
16:22:05 <yamahata> We can observe it by grafana failure graph
16:22:12 <yamahata> #link http://grafana.openstack.org/dashboard/db/networking-odl-failure-rate
16:23:00 <yamahata> In long term, we should pursue parallel execution of test cases to shorten execution time
16:23:15 <yamahata> it's temporal fix to lengthen timeout.
16:24:18 <yamahata> #link https://review.openstack.org/#/c/399986/ DO NOT MERGE: test tempest parallel execution
16:24:43 <yamahata> with parallel execution, test execution time reduces to about 40mins.
16:24:54 <mkolesni> sorry dropped
16:25:22 <yamahata> Now we're discussing timeout.
16:25:53 <yamahata> I tested parallel execution. it should be enabled in long term. hopefully Ocata
16:25:59 <yamahata> #link https://review.openstack.org/#/c/399986/
16:26:53 <yamahata> For now the focus to enable CI
16:27:12 <yamahata> make grenade plugin and multinode test run/pass
16:27:40 <yamahata> #link https://review.openstack.org/#/c/393979/ Move grenade-networking-odl job to check queue
16:27:53 <yamahata> The patch is blocked because grenade doesn't pass yet
16:28:21 <yamahata> and multinode tempest CI runs, but results in failure.
16:29:00 <yamahata> mkolesni is addressing functional test CI
16:29:27 <mkolesni> indeed
16:29:45 <yamahata> any other bugs/patches to discuss?
16:30:44 <yamahata> seems none. move ont
16:30:46 <yamahata> #topic open mike
16:30:53 <yamahata> any thing else to discuss today?
16:31:34 <mkolesni> https://bugs.opendaylight.org/show_bug.cgi?id=7256
16:31:34 <yamahata> Once openstack CI is stabilized, the next step is to enable new new features with openstack CI.
16:31:41 <mkolesni> submitted this right now
16:31:58 <mkolesni> Driver V2 fails to sync SecGroup update
16:32:02 <yamahata> #link https://bugs.opendaylight.org/show_bug.cgi?id=7256 Updating security groups fails with HTTP 500
16:32:13 <mkolesni> should be fixed on ODL side
16:32:38 <yamahata> what operation to neutron was issued?
16:32:47 <yamahata> update-security-group?
16:33:06 <mkolesni> yes
16:33:32 <mkolesni> as i said earlier the functional tst fails on this
16:33:41 <yamahata> I'll look into it.
16:33:44 <mkolesni> V1 driver works but V2 fails
16:33:58 <yamahata> #action yamahata, dig into https://bugs.opendaylight.org/show_bug.cgi?id=7256
16:34:05 <mkolesni> cool
16:34:09 <yamahata> that's important info.
16:35:03 <yamahata> anything else?
16:35:19 <mkolesni> nope
16:35:24 <john_a_joyce> nothing from me
16:35:31 <yamahata> okay give 25min to you
16:35:38 <john_a_joyce> thanks
16:35:40 <yamahata> thanks every one
16:35:47 <yamahata> #topic cookies
16:35:52 <yamahata> #endmeeting