16:02:57 <yamahata> #startmeeting neutron_northbound
16:02:57 <odl_meetbot> Meeting started Mon Jan 16 16:02:57 2017 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:57 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:57 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:03:01 <yamahata> #chair mkolesni
16:03:01 <odl_meetbot> Current chairs: mkolesni yamahata
16:03:06 <yamahata> #chair vthapar
16:03:06 <odl_meetbot> Current chairs: mkolesni vthapar yamahata
16:03:12 <yamahata> #topic agenda bashing and roll call
16:03:14 <yamahata> #info yamahata
16:03:30 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting agenda
16:03:33 <mkolesni> #info mkolesni
16:03:38 <vthapar> #info vthapar
16:03:48 <yamahata> Do you have any additional topic?
16:04:03 <mkolesni> v2 driver as default?
16:04:54 <yamahata> mkolesni: good topic. and also new netvirt as default
16:05:28 <yamahata> #topic Announcements
16:06:14 <yamahata> openstack ocata release is feb 13. so if you'd like to push something, please hurry up
16:06:21 <yamahata> #link https://releases.openstack.org/ocata/schedule.html
16:06:53 <yamahata> opendaylight carbon M3(feature freaaze) offset 1 is Jan 19.
16:07:08 <mkolesni> when is feature freeze for ocata
16:07:11 <yamahata> So you'd like to push new feature, please voice it.
16:07:21 <yamahata> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan
16:07:50 <yamahata> Ocata feature freeze is Ocata-3 Jan 23-27
16:08:12 <yamahata> It's also soft string freeze.
16:08:32 <yamahata> Jan 30-Feb03: hard string freeze
16:08:34 <vthapar> yamahata: we got VLan Aware VMs coming up. am working on driver code. we're also working on L2gw and BGPVPN v2 drivers. these 3 we're targetting for Ocata.
16:09:03 <mkolesni> ok so we plan to adhere to the feature freeze?
16:09:10 <yamahata> vthapar: Do you have created RFE for them? If not yet, please create them and assign them to you.
16:09:23 <yamahata> mkolesni: For now yes.
16:09:35 <mkolesni> if so any feature needs to be pushed prior to the feature freeze and we need to cut the branch around that time
16:09:46 <vthapar> yamahata: will do.
16:10:06 <yamahata> As discussed, we'd like to follow Ocata release cycle as much as possible.
16:10:26 <mkolesni> also why are we still writing v1 style drivers?
16:10:29 <yamahata> and release networking-odl ocata.
16:10:52 <yamahata> mkolesni: we don't need to. which driver?
16:11:16 <mkolesni> i think i saw one on the review
16:12:09 <yamahata> v1 style isn't necessary, but not prohibited. Sometimes v1 style is convenient for debug.
16:12:17 <yamahata> It's up to driver writer.
16:12:26 <mkolesni> yamahata: https://review.openstack.org/#/c/415334/
16:12:26 <yamahata> any other announcement?
16:12:44 <yamahata> #topic v2 driver as default
16:13:30 <mkolesni> #link https://review.openstack.org/420417
16:13:42 <mkolesni> #link https://review.openstack.org/420424
16:13:52 <mkolesni> #link https://review.openstack.org/420425
16:14:00 <mkolesni> please review these patches
16:14:08 <mkolesni> also if im missing something let me know
16:14:33 <yamahata> Cool. I'll review it tomorrow as I'm on PTO today.
16:14:59 <mkolesni> ok enjoy the PTO
16:15:14 <mkolesni> so basically its setting devstack to v2 by default
16:15:20 <yamahata> So there are patches for v2 driver as default. and Also I've uploaded patches for new netvirt as default.
16:15:22 <mkolesni> and changing the CI to bv2
16:15:46 <yamahata> Let's merge them and iron them out.
16:15:58 <mkolesni> can you add me as reviewer to those patches?
16:16:06 <yamahata> mkolesni: sure.
16:16:11 <mkolesni> great
16:16:33 <yamahata> #action yamahata add mkolesni as review of patches that make new netvirt as default
16:17:01 <mkolesni> so besides devstack and ci what else is there to do?
16:18:05 <yamahata> nothing else except stabilize/bug fix.
16:18:14 <mkolesni> ok sounds good
16:18:27 <mkolesni> i think v2 + new netvirt might be more stable
16:18:49 <yamahata> I put my review on 420417
16:18:56 <yamahata> can you please add release notes?
16:19:13 <mkolesni> 3
16:19:25 <mkolesni> sure ill hanlde it tomorrow
16:20:02 <yamahata> mkolesni: anything else?
16:20:18 <mkolesni> the other 2 patches in the ci
16:20:27 <mkolesni> i put you reviewer on them
16:20:39 <yamahata> mkolesni: okay.
16:21:02 <yamahata> back to normal agenda.
16:21:10 <mkolesni> oh one more thing
16:21:23 <yamahata> mkolesni: go ahead
16:21:27 <mkolesni> some backports were made to stable newton branch
16:22:10 <mkolesni> perhaps we should tag it as release 3.2.0? or are we waiting for neutron point release?
16:22:18 <yamahata> #topic patches/bugs
16:23:11 <yamahata> so you think 417682 is worthwhile for new release?
16:23:52 <yamahata> I'd like to backport 420174 to stable branch too.
16:24:16 <yamahata> With the patch, we don't have to maintain ODL stable release.
16:24:26 <yamahata> #link https://review.openstack.org/#/c/420174/
16:24:54 <yamahata> oops. wrong patch/link
16:25:11 <mkolesni> ?
16:25:12 <yamahata> #link https://review.openstack.org/#/c/419313/
16:25:13 <yamahata> devstack: check latest revision of ODL snapshot
16:25:37 <mkolesni> ok sure
16:25:47 <mkolesni> so go ahead and backport it
16:25:57 <mkolesni> and then we can make a release
16:26:01 <yamahata> Sure.
16:26:20 <mkolesni> its not only 417682 btw there was also the circular dependencies fix
16:26:40 <yamahata> #action yamahata backport 419313 and release 3.2.0
16:26:50 <mkolesni> +1
16:27:28 <yamahata> If there are candidates for backport, please propose them for 3.2.0 as soon as possible
16:28:22 <mkolesni> nothing that i know of currently
16:28:36 <yamahata> any other patches/bugs to discuss?
16:28:46 <mkolesni> none from me
16:29:49 <yamahata> okay. move on
16:30:04 <yamahata> #topic open mike
16:30:24 <yamahata> anything else to discuss?
16:30:30 <yamahata> vthapar: do you have any?
16:30:43 <vthapar> yamahata: had some questions about the v2 driver, mainly validations.
16:31:03 <yamahata> go ahead. you're on stage
16:31:26 <vthapar> my understanding is that validations are to make sure that if an object CRUD depends on another one's CRUD, we add it in there.
16:31:37 <vthapar> e.g. Subnet requires NEtwork to be done. correct?
16:31:49 <yamahata> yes. right.
16:32:00 <vthapar> anything else for which we add validations?
16:32:08 <yamahata> for trunk api?
16:32:30 <vthapar> yeah, for trunk bgpvpn and l2gw... just wanted to understand what validations are used for.
16:32:40 <vthapar> so other than such crud dependencies, what else we use it for?
16:32:57 <yamahata> for example, there are dependencies between trunk and ports(main, sub)
16:33:11 <yamahata> ports before trunk needs to be done.
16:33:25 <yamahata> trunk needs to be done before ports.
16:33:41 <vthapar> right, what about delete? should port delete check for trunk/subport deletion too?
16:33:46 <yamahata> We can deduce it from API and it's semantics.
16:34:10 <yamahata> Yes. we don't want to delete trunk before deletion of main/sub ports.
16:34:50 <yamahata> For now there are some corner cases that is difficult to detect.
16:35:07 <yamahata> I believe mkolesni  is working (will?) on it.
16:35:30 <mkolesni> i will but mostly to move it to the insertion phase
16:35:44 <mkolesni> not planning on adding new validations just improve the general mechanism
16:35:59 <vthapar> okay, in case of ports, there is no reference from port to subport/trunk... so do we loop through all pending trunk/subports to see if any of those are still using port?
16:36:01 <yamahata> mkolesni: do you plan it for Ocata? or Pike?
16:36:18 <mkolesni> ocata is ending soon, pike makes more sense
16:36:28 <yamahata> vthapar: yes for now.
16:36:56 <vthapar> ok.
16:37:12 <yamahata> If it's too difficult or too much calculation, we can discuss.
16:37:21 <yamahata> Hoping mkolesni
16:37:31 <vthapar> sure, will put up what understand and rest can be taken up as part of review.
16:37:31 <yamahata> hoping mkolesni's new code would help it.
16:38:30 <vthapar> second, when using V2, do we filter out any fields? e.g. some fields in an openstack object may not be persisted in ODL side.
16:38:43 <vthapar> do we filter any such fields before adding to journal?
16:39:04 <yamahata> basically we don't have to filter any fields.
16:39:12 <yamahata> In the current code, it's historical reason.
16:39:50 <vthapar> aha, got it. was confused by those :)
16:40:00 <vthapar> makes my life easier then.
16:40:07 <yamahata> In your case, you can ignore filtering.
16:40:24 <vthapar> other was https://git.opendaylight.org/gerrit/#/c/41699/
16:40:50 <vthapar> I'm going by yang as in this patch when working on driver...
16:41:06 <vthapar> basically same as you last reviewed, only addition of admin-attrs also.
16:41:39 <vthapar> if we can get the yang merged, I can get started on rest of NN changes as well as netvirt.
16:41:40 <yamahata> #link https://git.opendaylight.org/gerrit/#/c/41699/
16:41:40 <yamahata> Yang Model for Openstack Neutron Trunkport API's
16:42:10 <yamahata> cool.
16:42:47 <vthapar> I'll be bringing in v1 driver also for vlan aware vms, mainly coz, as you said, I used it for debugging etc.
16:43:02 <vthapar> hope that is acceptable.
16:43:18 <vthapar> v2 I got basic code ready, validations and units pending.
16:43:27 <mkolesni> i think generally we should focus on v2 driver architecture
16:43:31 <vthapar> tempest can't be done till we got ODL NN code ready.
16:43:51 <mkolesni> carrying v1 code is legacy and not being to be fixed
16:44:19 <vthapar> mkolesni: v1 was just easier to write and test what data is going across. I've named it dummydriver.py in fact.
16:44:21 <mkolesni> the more drivers we have in V2 we can fix any potential issues better
16:45:02 <mkolesni> i know but basically v1 driver is not production ready
16:45:06 <vthapar> agree.
16:45:23 <mkolesni> and i think spending effort on it instead of v2 is a bit wasted cycles
16:45:43 <mkolesni> while we could improve any potential flaws in v2 if more drivers were on it
16:46:01 <vthapar> mkolesni: v1 was just easier for me to write and test data coming in from plugin, providing inputs for v2.
16:46:18 <mkolesni> yes i know just stating my opinion
16:46:30 <mkolesni> yamahata can either agree or not
16:46:40 <vthapar> I do agree :)
16:46:52 <yamahata> mkolesni: I gree with you basically.
16:47:06 <yamahata> The mix of v1 and v2 would be worse.
16:47:53 <yamahata> anything else to discuss?
16:47:57 <yamahata> vthapar: any other questions?
16:48:53 <vthapar> yamahata, nothing right now. thanks a ton :)
16:49:21 <mkolesni> i think we can wrap this meeting then
16:49:26 <yamahata> thanks every one
16:49:30 <mkolesni> and let yamahata go on his PTO :)
16:49:30 <yamahata> have a nice day!
16:49:38 <mkolesni> thanks Isaku!
16:49:41 <yamahata> #topic cookies
16:49:42 <mkolesni> enjoy your day off
16:49:45 <yamahata> #endmeeting