16:02:05 <yamahata> #startmeeting neutron_northbound
16:02:05 <odl_meetbot> Meeting started Mon Feb  6 16:02:05 2017 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:05 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:05 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:02:09 <yamahata> #chair mkolesni_
16:02:09 <odl_meetbot> Current chairs: mkolesni_ yamahata
16:02:13 <yamahata> #chair vthapar
16:02:13 <odl_meetbot> Current chairs: mkolesni_ vthapar yamahata
16:02:21 <yamahata> #topic agenda bashing and roll call
16:02:24 <yamahata> #info yamahata
16:02:30 <vthapar> #info vthapar
16:02:32 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings
16:03:11 <mkolesni> #info mkolesni
16:03:35 <yamahata> I have some additional topics. openstack summit CFP, stable/ocata branch and openstack CI unstability
16:03:49 <mkolesni> i wanted to talk about dep validation simplification
16:03:53 <yamahata> Do you have any other agenda items today?
16:04:15 <vthapar> yamahata: v2 driver patches for trunk. l2gw and bgpvpn
16:04:47 <mkolesni> vthapar: trunk is quite in a good condition, i sent some minor comments just now
16:04:53 <yamahata> we have plenty agenda items today.
16:05:01 <mkolesni> from my perspective that is :)
16:05:07 <yamahata> #topic Announcements
16:05:36 <yamahata> openstack summit boston Call for presentation is very near.
16:06:03 <mkolesni> did u see the email?
16:06:06 <yamahata> #link Feb6 (PST) Feb 7, UST
16:06:13 <yamahata> Yeah, let's discuss offline
16:06:49 <yamahata> I'd like to submit it today. Even after submission, we can edit it until the deadline.
16:07:33 <yamahata> Oh, mkolesni left...
16:07:38 <mkolesni> im back
16:07:59 <vthapar> mkolesni, I replied to yours. +1 to continue offline.
16:08:01 <mkolesni> ok so i didnt understand if its abstract for one talk or two?
16:08:08 <mkolesni> ah ok
16:08:31 <yamahata> #link https://releases.openstack.org/ocata/schedule.html
16:08:40 <yamahata> ocata release is soon.
16:08:54 <yamahata> networking-odl need to cut stable/ocata soon.
16:09:08 <yamahata> I'm thinking around Feb 9 or 10.
16:09:27 <mkolesni> ok that is very close
16:09:38 <yamahata> The deadline provided by the release team is Feb 16.
16:09:47 <yamahata> At worst Feb 13 or 14.
16:09:49 <mkolesni> of course we can still backport afterwards but need stable maint team approval
16:10:10 <yamahata> I'd like to send a request to cut the branch Feb 13 or 14 at worst.
16:10:37 <yamahata> Yeah, but for new feature, e.g. v2 driver for trunk etc needs to be merged before cutting the branch.
16:10:56 <mkolesni> ok
16:10:58 <vthapar> yamahata: I Can get code ready as long as I get review comments :)
16:11:21 <yamahata> #action everyone review the patches before cutting ocata branch.
16:11:22 <vthapar> yamahata: I'll work on addressing mike's but if you can also review would save another patchset cycle.
16:11:34 <mkolesni> as i said from my perspective trunk is almost ready
16:11:38 <yamahata> I'll review them today.
16:12:12 <yamahata> any other announcement?
16:13:08 <yamahata> ok, move on
16:13:10 <yamahata> #topic action items from last meeting
16:13:33 <yamahata> I guess we don't have no action items.
16:13:50 <yamahata> #topic carbon/ocata planning
16:13:51 <vthapar> yamahata: would be good to list out ones we're targetting for Ocata, will make it easier to prioritize.
16:14:09 <yamahata> vthapar: good idea.
16:14:19 <yamahata> For ocata, I have those items.
16:14:58 <yamahata> v2 drivers(qos, trunk, l2gw, bgpvpn), newnetvirt migration,
16:15:24 <mkolesni> new netvirt is more related to CI not quite to the branch cut off though isnt it?
16:15:25 <yamahata> websocket is on the border. it can be slipped to Pike because we have only framework code.
16:15:56 <yamahata> mkolesni: right.
16:16:21 <mkolesni> websocket seems low priority since for now ODL doesn't report port status correctly anyway
16:16:34 <mkolesni> so i dont think we need to psend cycles on it
16:16:38 <mkolesni> spend*
16:17:01 <yamahata> fair enough regarding to websocket.
16:17:04 <vthapar> I'll work with Vivek to get bgpvpn and l2gw ready once trunk is good to go.
16:17:05 <vthapar> mkolesni, waht about your patches for dependency validations refactoring?
16:17:07 <vthapar> if needed, would be good to get them sooner than later.
16:17:20 <mkolesni> ok so patch is https://review.openstack.org/#/c/427576/
16:17:33 <mkolesni> i just noticed there a recurring pattern to all the validations
16:17:53 <mkolesni> so this simplifies them a lot making it easier to write new dependencies
16:18:57 * vthapar is having some connection issues.
16:19:02 <mkolesni> so if you guys agree we can merge this and adjust the drivers patches since this will reduce them quite a bit
16:19:23 <yamahata> The patch looks good refactoring at a first glance.
16:19:25 <vthapar> mkolesni: +1
16:19:39 <yamahata> I'd like to review it more closely.
16:19:50 <mkolesni> sure of course
16:19:55 <yamahata> Just a matter of  my review bandwidth.
16:20:01 <vthapar> playing devil's avocate though, would be good to wait and have more code come in.
16:20:21 <vthapar> in case other driver code bring in some different pattern.
16:20:39 <mkolesni> vthapar: currently i didnt see such a case
16:21:01 <mkolesni> perhaps need to go over the pending drivers and see..
16:21:25 <yamahata> patches for v2 driver under review needs to be updated.
16:21:31 <vthapar> mkolesni: me neither, but like yamahata yet to look at them as a review. and haven't seen the QoS or SFC driver ones yet.
16:22:03 <yamahata> I'll talk with manjeet to update QoS patches update.
16:22:16 <yamahata> But I'm not sure if SFC will be worked.
16:23:05 <vthapar> vishnoianil mentioned he had changes ready and got the reviewed in barcelona offline.
16:23:39 <yamahata> Yeah, Isaku and Anil sat down to review it.
16:23:46 <mkolesni> https://review.openstack.org/#/c/424064/22/networking_odl/journal/dependency_validations.py seems much consistent with the refactor only thing i see is that update is not checked for network/router association but probably because theyre link objects
16:26:09 <yamahata> Regarding to dep-validator, we don't have to be perfect in Ocata cycle. Thosecan be fixed in Pike.
16:26:43 <yamahata> anything else on carbon/ocata planning?
16:27:27 <mkolesni> yamahata: whatever you decide is fine with me the refactor is a simplification which makes the code easier to write and maintain
16:28:06 <yamahata> mkolesni: I'm in favor with the patch. Simply I'd like to look it more closely once more.
16:28:53 <mkolesni> sure just saying if we want it in makes more sense for it to be first to merge so that the drivers patches can be simplified leading in turn to less review hassle there
16:29:06 <yamahata> we can skip Neutron stadium effort. Probably it's okay to drop from agenda item
16:29:15 <yamahata> #topic migrating to new features
16:29:28 <yamahata> Now I'm looking into new netvirt migration. ssh failure.
16:29:56 <yamahata> Once I fix it, I'll upload a patch to make those CI gate from experimental.
16:30:23 <yamahata> #topic patches/bugs
16:30:40 <mkolesni> you mean move them to non voting?
16:30:42 <yamahata> We have already discussed dep-validator simplification and v2driver.
16:30:48 <yamahata> Yes, non-voting.
16:31:10 <mkolesni> ok cool
16:31:39 <yamahata> any other patches/bugs to discuss?
16:32:04 <mkolesni> im working on some stop gap for the port status
16:32:29 <mkolesni> thing is now port status is immediately set to ACTIVE when its bound
16:32:42 <mkolesni> now if ODL is working fine usually this shouldnt be a problem
16:33:22 <mkolesni> but if say ODL is down or unreachable for a while, Neutron incorrectly reports this as ACTIVE even though the request didnt even get sent to ODL
16:33:40 <mkolesni> so for now I want to move the marking of ACTIVE to after the port update is synced to ODL
16:34:10 <mkolesni> and a longer term solution were working on is have the controller update the status so that we can deduce it via the websockets mechanism
16:34:11 <yamahata> Do you mean https://review.openstack.org/#/c/428115/ and https://review.openstack.org/#/c/428115/
16:34:16 <mkolesni> right now its WIP
16:34:40 <mkolesni> yes https://review.openstack.org/#/c/428114 and https://review.openstack.org/#/c/428115
16:34:53 <yamahata> ODL reporting to neutron with websocket is long standing item.
16:34:59 <mkolesni> it will probably be ready for Pike
16:35:10 <mkolesni> maybe we could backport it once its ready though
16:35:13 <yamahata> Okay they are for Pike.
16:35:24 <mkolesni> yea so this is a temp solution im working on
16:35:41 <mkolesni> better to at least update the status once we know ODL got the bind request..
16:35:42 <yamahata> I'm very glad that others are also aware of ODL reporting status.
16:36:09 <mkolesni> yes its one of the issues were focusing on at Red Hat
16:36:24 <yamahata> At least networking-odl and ODL neutron northbound would be in pike/carbon.
16:36:58 <mkolesni> hopefully :)
16:38:03 <yamahata> any other bugs/patches?
16:38:23 <mkolesni> none from me
16:38:36 <yamahata> Okay then, openstack CI unstability.
16:38:48 <yamahata> For now, we're issuing many recheck.
16:39:32 <yamahata> I had hoped that the situation isn't very bad. But now it's quite difficult for patches to land.
16:39:34 <mkolesni> yea as i reported old netvirt is buggy so its causing some random failures when FIP is used
16:40:02 <yamahata> tempest with v1 driver passes.
16:40:10 <mkolesni> we can either disable the V2 from voting or better just migrate to new netvirt which doesnt seem to have the bugs
16:40:11 <yamahata> Hmm,
16:40:38 <mkolesni> i prefer the second options :)
16:41:07 <mkolesni> shague_ is already planning on switching CSIT to V2 tests seeing theyre quite stable there
16:41:08 <vthapar> I too prefer 2n but if it can take time, I'd suggest make v2 non voting and manually check if failures are valid or not before giving +1.
16:41:33 <vthapar> will require bit extra effort from reviewers but will save time on rechecks.
16:42:05 <mkolesni> usually youll see failure due to FIP not being provisioned on ODL
16:42:17 <mkolesni> so itll fail to ping 172.24.*.*
16:42:27 <mkolesni> or some such ip
16:42:56 <yamahata> I see.
16:43:02 <mkolesni> i think even more time is wasted on the multi node job
16:43:05 <yamahata> mkolesni: can you take care of making them non-voting?
16:43:13 <mkolesni> perhaps we should move that to experimental queue for now?
16:43:31 <mkolesni> ok sure
16:44:11 <yamahata> We need to be quick as branch cutting is near.
16:44:45 <vthapar> yamahata, mkolesni, is there a way to look at build history of a job? like we have in ODL?
16:45:03 <yamahata> zuul health monitor
16:45:22 <mkolesni> there is grafana right?
16:45:45 <yamahata> #link http://status.openstack.org/openstack-health/#/
16:45:46 <mkolesni> so what about multi node job?
16:45:51 <yamahata> #link http://status.openstack.org/openstack-health/#/g/project/openstack~2Fnetworking-odl
16:45:59 <mkolesni> it takes 2+ hours and its non voting
16:46:30 <yamahata> I don't know when/how often health monitor is updated
16:46:42 <yamahata> #link http://grafana.openstack.org/dashboard/db/networking-odl-failure-rate
16:48:26 <yamahata> http://status.openstack.org/ is the portal for openstack CI.
16:49:04 <yamahata> any other topics?
16:49:11 <yamahata> #topic open mike
16:49:12 <mkolesni> yamahata: so what about multi node job?
16:49:33 <mkolesni> i think we can move it to experimental its really clogging the proccess
16:49:37 <yamahata> Right now it's unstable. We're planning to look into it once new netvirt is enabled.
16:50:07 <mkolesni> ok
16:50:59 <mkolesni> so are you submitting the talk today?
16:51:11 <yamahata> mkolesni: that's the plan.
16:51:22 <mkolesni> ok and its 1 talk or 2?
16:51:29 <yamahata> May plan 1 talk.
16:51:35 <yamahata> Should we split it into 2?
16:52:03 <mkolesni> i dunno i thought maybe one is too much to go both into details and give a high level
16:52:15 <mkolesni> perhaps one high level more for admin/deployer
16:52:43 <mkolesni> and one more detailed for devs or deployers who want to know more about the behind the scenes of how the V2 driver works
16:53:13 <mkolesni> this one proposal seems to concentrate both concepts if im not mistaken
16:53:51 <mkolesni> so i though it might be good to split such that people can come to the high level and then if they want to hear more they can go to the detailed one
16:54:03 <yamahata> Maybe I tried to put too much into single talk.
16:54:16 <mkolesni> or maybe detailed one wont be interesting in new summit format but high level would be
16:54:36 <mkolesni> so committee will prefer the high level one
16:54:41 <mkolesni> i dunno just my thought
16:54:48 <yamahata> Yeah, In the last summit it seems like each SDN has two slot at most and high level or operator stories were chosen.
16:54:50 <mkolesni> vthapar: have a thought on the matter?
16:55:34 <vthapar> mkolesni: am okay with either but not sure how many at summit would be interested in details.
16:55:53 <mkolesni> ok thats first for the committe to decide isnt it?
16:56:07 <vthapar> based off responses and questions at end of previous ones, not many interested in deep dive.
16:56:20 <mkolesni> i think two separate talks have a higher chance committee will like at least one of them
16:56:32 <mkolesni> probably the higher level one
16:57:04 <vthapar> mkolesni: good point.
16:57:30 <mkolesni> but i think both should be sent and let the summit gods decide maybe theyll think both are interesting :)
16:57:54 <mkolesni> so im up for co speaking at whatever you need be it one or two proposals
16:58:10 <yamahata> I see. Let's file both
16:58:15 <vthapar> mkolesni: I don't think we ever had more than one selected as presentation.
16:58:34 <mkolesni> well you never know right? :)
16:58:57 <vthapar> me too, okay with either. we can always consider brown bags etc. for deep dive if not selected.
16:59:15 <vthapar> am up for either/both.
16:59:20 <yamahata> At worst vbrownbag and lightening talk is available.
16:59:27 <mkolesni> sure thats a good idea :)
16:59:45 <yamahata> For abstract, let's discuss it offline. and feel free to edit submission directly.
16:59:55 <mkolesni> hmm lightning talk about deep dive? i rather get hit by a lightning i reckon :D
16:59:55 <yamahata> I think submission is editable until deadline.
17:00:14 <mkolesni> isnt deadline today?
17:00:17 <vthapar> we just need to hype v2 as second coming of, well, ODL :)
17:00:24 <mkolesni> hehe
17:00:31 <yamahata> 11:59PM PST ON FEBRUARY 6, 2017 (7:59 ON FEBRUARY 7, 2017 UTC)!
17:00:40 <yamahata> https://www.openstack.org/summit/boston-2017/call-for-presentations/
17:00:50 <mkolesni> in the year of our lord 2017 will come a great driver..
17:01:20 <mkolesni> i might have some time to read emails later but not much if not i might see it tomorrow morning
17:01:24 <mkolesni> its 7PM here
17:01:42 <vthapar> and it is 10:30pm here, I'll probably see it in morning.
17:01:54 <yamahata> I don't want to play with clocks. So I'd like to submit it today.
17:01:59 <mkolesni> vthapar: oh quite late :)
17:02:35 <vthapar> mkolesni, yeah, so most likely will not be able to check it till much later.
17:02:57 <mkolesni> yamahata: ok so if you decide 2 presentations just split and submit both and if i have any fixes ill notify u asap via email
17:03:07 <yamahata> sure.
17:03:11 <mkolesni> cool
17:03:11 <yamahata> anything else?
17:03:17 <mkolesni> nothing from me
17:03:30 <vthapar> mkolesni, quick word
17:03:37 <mkolesni> vthapar: sure
17:03:39 <vthapar> replied to your comments on review, take alook and reply before going off
17:03:47 <mkolesni> ok
17:03:52 <vthapar> so can work on them and be ready before you come online tomorrow.
17:04:18 <vthapar> yamahata: would be good if you can reviw and comment too, so next patch addresses everything.
17:04:24 <yamahata> vthapar: sure.
17:04:39 <yamahata> okay thank you everyone.
17:04:42 <vthapar> yamahata, mkolesni: thanks!
17:04:44 <yamahata> good night vthapar.
17:04:49 <yamahata> #topic cookies
17:04:55 <yamahata> #endmeeting