16:02:24 <yamahata> #startmeeting neutron_northbound
16:02:24 <odl_meetbot> Meeting started Mon Feb 13 16:02:24 2017 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:24 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:24 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:02:36 <yamahata> #chair mkolesni
16:02:36 <odl_meetbot> Current chairs: mkolesni yamahata
16:02:38 <yamahata> #chair vthapar
16:02:38 <odl_meetbot> Current chairs: mkolesni vthapar yamahata
16:02:46 <yamahata> #topic agenda bashing and roll call
16:02:53 <vthapar> #info vthapar
16:02:58 <yamahata> #info yamahata
16:03:06 <yamahata> any topics today?
16:03:14 <yamahata> as usual, patch/bug review
16:03:33 <yamahata> this week stable/ocata branch will be cut and final patch review for ocata.
16:04:06 <yamahata> and ptg topics and requirement from daya if possible
16:04:10 <yamahata> any other topics?
16:04:28 <vthapar> none from me.
16:04:48 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting agenda
16:04:59 <yamahata> #topic Announcements
16:05:08 <yamahata> openstack PTG is next week
16:05:20 <yamahata> stable/ocata branch will be cut this week.
16:05:42 <yamahata> From Pike cycle, we'd like to graduate from independent release cycle.
16:05:52 <yamahata> any other announcement?
16:06:31 <vthapar> none from me.
16:06:36 <yamahata> #topic action items from last meeting
16:06:54 <yamahata> only patch review
16:06:59 <yamahata> move on
16:07:41 <yamahata> #topic Carbon planning
16:07:58 <yamahata> This week there is a request from Daya.
16:08:15 <yamahata> The tech discussion will be continued on mailing list, launchpad, gerrit.
16:08:33 <yamahata> I request her to file RFE bug report and spec for detailed discussion.
16:08:56 <yamahata> vthapar: I suppose you can help with those procedure.
16:09:29 <vthapar> yamahata: yes. some other dev team will be driving it and I'll be helping the out with process.
16:09:43 <vthapar> I'll be more of a reviewer on this one.
16:09:54 <yamahata> I see.
16:10:15 <yamahata> Okay move on
16:10:23 <yamahata> #topic Neutron Stadium effort
16:10:40 <yamahata> For ocata we're okay. At PTG more for Pike will be discussed.
16:10:49 <yamahata> we'd like to stay in Neutron stadium.
16:10:53 <yamahata> Neutron Stadium effort
16:11:00 <yamahata> #topic patches/bugs
16:11:06 <yamahata> Okay, now patch review
16:11:16 <yamahata> Hopefully today I'd like to merge pending patches.
16:11:30 <yamahata> I uploaded one bug fix patch.
16:11:50 <vthapar> driver patches will need rebase and resolve conflict each time one gets merged.
16:11:50 <yamahata> regrading to v2 patch, we have qos/l2gw/vgpvpn/sfc.
16:12:02 <yamahata> Oh.
16:12:20 <vthapar> code will be in conflict in dependency_validations and test_dependency_validations
16:13:07 <vthapar> e.g. https://review.openstack.org/#/c/424064/
16:13:12 <vthapar> this shows other drivers in conflict.
16:13:46 <vthapar> I can resolve for l2gw and bgpvpn while am around.
16:13:47 <yamahata> Which patch l2gw or bgpvpn do you prefer to merge first?
16:13:58 <vthapar> I think l2gw is already +1 on review and Jenkins
16:14:33 <yamahata> So I'll merge l2gw first.
16:14:42 <mkolesni> sorry putting baby to sleep
16:14:55 <yamahata> So can you please rebase bgpvpn on top of it?
16:15:08 <vthapar> yamahata: yep, I'll do it as soon as it is merged.
16:15:30 <yamahata> I'll ask manjeet with qos patch.
16:15:44 <yamahata> So qos/l2gw/bgpvpn are okay.
16:15:57 <yamahata> What do you think about sfc patch? Is it ready to merge?
16:17:27 <yamahata> Silent. Hmm it would be early pike?
16:17:59 <vthapar> sfc is missing test_dependency_validations.
16:18:33 <vthapar> rest of comments are more nitpick, but I think those need to be there.
16:19:27 <yamahata> Okay.
16:19:53 <yamahata> I +2 on l2gw.
16:20:29 <yamahata> Please review bgpvpn and qos patch before merge.
16:20:43 <yamahata> This night, I'll upload patch to cut ocata branch.
16:21:20 <yamahata> I'll also merge 431894 and 432508 as bug fix.
16:21:54 <yamahata> If you'd like to review it, please hurry up.
16:22:01 <yamahata> any other patches for ocata?
16:22:18 <vthapar> what about patches by mkolesni for port status?
16:22:44 <mkolesni> theyre not ready yet
16:23:04 <vthapar> ok. will we be backporting them to Ocata?
16:23:29 <yamahata> If we file a bug for it, we have a chance for backport.
16:23:42 <mkolesni> maybe i have some problem there atm
16:24:21 <mkolesni> if i get it to work properly we can always backport
16:25:00 <vthapar> ok. and I was looking at sfc driver, will we be able to backport that too?
16:25:13 <vthapar> we would like to have all service drivers v2 in Ocata.
16:25:22 <yamahata> Yes, we can.
16:25:36 <vthapar> mkolesni: your thoughts in getting sfc in current form? it is missing test_dependency_validations
16:25:48 <vthapar> rest looks fine
16:25:49 <yamahata> I think it's necessary.
16:26:01 <yamahata> except tests, the code looks good to me.
16:26:11 <vthapar> yeah, I didn't find issues with my dependency validations till I wrote and ran tests for it.
16:26:24 <odp-gerritbot> Tomas Cechvala proposed a change to neutron: WIP Hostconfig for VPP  https://git.opendaylight.org/gerrit/50742
16:26:50 <vthapar> I'll chck with Anil, he might be ready with tests.
16:27:11 <yamahata> Good.
16:27:36 <yamahata> any other patches/bugs or move on?
16:27:37 <mkolesni> if its only tests we can merge it
16:28:06 <mkolesni> worst case fix bugs and backport
16:28:30 <vthapar> mkolesni, that is what I was thinking. somewhat broken driver better than none at all.
16:28:38 <vthapar> though code wise it does look good to go.
16:29:04 <yamahata> then, vthapar can you update sfc driver to address you comments?
16:29:16 <yamahata> then we can merge it.
16:29:21 <mkolesni> you can backport a few bug fixes but not the whole driver
16:29:29 <vthapar> yamahata, can't commit on it. if am still awake after rebasic bgpvpn, I'll take a shot at it.
16:29:33 <yamahata> (Or to have anil update it in hurry)
16:29:39 <vthapar> s/rebasic/rebasing
16:29:43 <mkolesni> since its not on the critical path i see no harm in merging it after the comments are fixed
16:29:45 <yamahata> vthapar: got it.
16:29:49 <mkolesni> and add tests in Pike
16:30:12 <yamahata> Okay let's file a bug to track it and merge the patch.
16:30:26 <vthapar> just realized, other than tests there is more work needed. currently delete dependencies will not work.
16:30:44 <vthapar> would be good if you could confirm/deny my comments on that.
16:30:51 <yamahata> sure.
16:31:01 <yamahata> #action yamahata review sfc driver more closely.
16:31:11 <yamahata> and file a bug if necessary.
16:32:12 <yamahata> we're done with ocata patches.
16:32:19 <yamahata> #topic open mike
16:32:48 <mkolesni> how do you find the new dependency validations?
16:32:53 <yamahata> The next week, I'll be absent from this meeting due to PTG.
16:32:54 <mkolesni> better?
16:33:24 <mkolesni> yamahata: obviously
16:33:25 <yamahata> In my case, basically gazing at API definitions.
16:33:37 <yamahata> I wouldn't say it a better way.
16:34:04 <yamahata> #link https://etherpad.openstack.org/p/neutron-ptg-pike
16:34:13 <yamahata> #link https://wiki.openstack.org/wiki/PTG/Pike/Etherpads
16:34:19 <mkolesni> unfortunately im not going to ptg
16:34:26 <mkolesni> vthapar: you going to ptg?
16:34:28 <yamahata> any input for PTG?
16:34:52 <vthapar> mkolesni: no.
16:35:10 <mkolesni> yamahata: i would still like to draft a move of dependency calculations to when journal entry is created
16:35:17 <yamahata> we'd like to start to plan for pike networking-odl
16:35:35 <vthapar> yamahata: haven't gone through agenda yet. had a couple of things for pike.
16:35:39 <mkolesni> i think currently is way too error prone
16:36:06 <mkolesni> other than that improve the status reflection from odl at least for port status
16:36:25 <yamahata> mkolesni: I see. Do you have sample document or code snippet to show idea?
16:36:47 <vthapar> yamahata: +1 to sample doc
16:36:57 <mkolesni> no not yet
16:37:00 <yamahata> Right now Ritu is working on websocket and the next step is to update port status.
16:37:22 <mkolesni> yes we have jhershbe already working on that direction
16:37:42 <mkolesni> i thought Ritu was more focused on the way to update the port binding data
16:37:44 <yamahata> testing/hardening fullsync and maintenance thread would be Pike candidate.
16:38:20 <yamahata> Ritu is working on both. Anyway we can coordinate to avoid duplication.
16:38:30 <mkolesni> not sure how much full sync is actually being done
16:38:54 <mkolesni> ok please let her know for now jhershbe is working on it
16:39:22 <yamahata> Sure. She knows it already.
16:39:26 <mkolesni> ok cool
16:39:48 <mkolesni> i think scale should be also a focus area on pike
16:40:27 <mkolesni> i think scale will show us the problem areas and then we need to focus on those
16:40:50 <mkolesni> are you moving the project to the cycles with milestones release schedule?
16:41:42 <yamahata> I'm wondering about it.
16:41:57 <mkolesni> seems logical were almost doing it anyway
16:42:46 <yamahata> The change would be that it would be more strict to cut branch.
16:43:30 <mkolesni> not necessarily bad
16:43:43 <mkolesni> but you still have to request the branch cut each time right?
16:43:46 <yamahata> So far I haven't seen any objections, so I'm going to switch it.
16:44:03 <yamahata> No. it's done by openstack release team. Or Neutron team.
16:44:03 <vthapar> +1 to aligning with milestones release schedule.
16:44:19 <mkolesni> ok then sounds good
16:45:44 <yamahata> any other topics?
16:46:06 <mkolesni> none from me
16:46:11 <mkolesni> so no meeting next week?
16:46:22 <yamahata> I won't chair it. It's up to you.
16:46:45 <vthapar> I'll be travelling, might be able to join in, depends on network.
16:46:47 <mkolesni> ok ill see if theres interest or not
16:46:56 <vthapar> one more thing I wanted to bring up for Pike...
16:47:05 <vthapar> filtering out columns we're not using in NN... why store then in journal and send across?
16:47:11 <yamahata> #action yamahata mkolesni coordinate next week meeting.
16:47:22 <yamahata> #action yamahata sent absence notice
16:47:35 <vthapar> we haven't done perf testing but it would help scale/perf better.
16:47:59 <yamahata> vthapar: There is no strong reason.
16:48:08 <mkolesni> we can see if its a problem as part of scale testing
16:48:17 <vthapar> fair enough.
16:48:17 <yamahata> it was easier to debug journal code with full infomation in db.
16:49:18 <vthapar> I forsee it being an issue for trunks at scale, but we'll cross that bridge when we get there.
16:50:46 <yamahata> anything else?
16:50:53 <mkolesni> nothing from me
16:50:55 <yamahata> or I'll return back 10mins to you.
16:51:02 <mkolesni> thanks Isaku!
16:51:07 <mkolesni> enjoy the PTG :)
16:51:10 <yamahata> thanks everyone!
16:51:19 <yamahata> #topic cookies
16:51:23 <yamahata> #endmeeting