16:03:36 <yamahata_> #startmeeting neutron_northbound
16:03:36 <odl_meetbot> Meeting started Mon Feb 27 16:03:36 2017 UTC.  The chair is yamahata_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:36 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:36 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
16:03:43 <yamahata_> #chair mkolesni vthapar
16:03:43 <odl_meetbot> Current chairs: mkolesni vthapar yamahata_
16:03:51 <yamahata_> #topic agenda bashing and roll call
16:03:53 <yamahata_> #info yamahata
16:03:55 <mkolesni> #info mkolesni
16:04:08 <yamahata_> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting agenda
16:04:09 <vthapar> #info vthapar
16:04:37 <yamahata_> today I'd like to summarise openstack PTG.
16:04:44 <jhershbe> yamahata_, Can I add the websocket thingy to the agenda?
16:05:24 <yamahata_> jhershbe: yes, off course. as patch/bug review.
16:05:43 <yamahata_> any other extra topics?
16:05:43 <mkolesni> ok so how was ptg?
16:05:50 <yamahata_> #topic Announcements
16:05:58 <yamahata_> Last week openstack ptg was held.
16:06:24 <yamahata_> There were several folks who are interested in contributing to networking-odl.
16:06:48 <mkolesni> thats great
16:06:48 <yamahata_> So we discussed on Pike cycle planning and come up with ether and and blueprint/rfe bugs
16:06:57 <yamahata_> #link #topic Announcements
16:07:02 <yamahata_> #undo
16:07:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1a00ed0>
16:07:11 <yamahata_> #link https://etherpad.openstack.org/p/Networking-odl-Pike
16:07:32 <mkolesni> i replied on the email
16:07:33 <yamahata_> It includes newly created blueprints/rfes.
16:07:55 <mkolesni> i think mostly missing focus on scale/perf and also funct tests improvements
16:07:57 <yamahata_> mkolesni: thanks. Can you please create blueprint or rfe for them? if missing.
16:08:03 <mkolesni> sure
16:08:43 <jhershbe> yamahata_, I updated the agenda on the wiki
16:08:55 <yamahata_> Regarding to neutron stadium, neutron subproject need to follow cycles-with-milestone.
16:09:02 <yamahata_> jhershbe: thanks
16:09:21 <mkolesni> yes when are we switching?
16:09:28 <yamahata_> It's fine with networking-odl team because that's our plan.
16:09:47 <yamahata_> It's already changed
16:09:53 <yamahata_> #link https://review.openstack.org/#/c/437699/
16:10:15 <mkolesni> ah ok so whats the implication, now neutron release team take care of the branch/tag whatnot?
16:10:21 <mkolesni> or we still need to do that
16:10:43 <yamahata_> Yes. When creating tag/branch, we should give +1 on patches as our team ack.
16:10:52 <mkolesni> ok
16:11:42 <yamahata_> Regadingto version number, technically it's possible to bump version from 4 to 11.
16:12:01 <mkolesni> ok
16:12:04 <yamahata_> But we need to talk with release team PTL, ttx more.
16:12:22 <yamahata_> and we should have good reason for it.
16:12:39 <mkolesni> i think line up is a good reason
16:12:55 <yamahata_> It means that if we bump the version, we need to do precommunication well.
16:13:17 <yamahata_> Personally I'm not sure it's worthwhile for the cost.
16:13:54 <yamahata_> Just we can go for 5 for Pike.
16:14:32 <mkolesni> i dont care very much but being out of sync makes it harder to understand what nodl version should be used with what neutron version
16:15:51 <yamahata_> thanks. Unless there is strong claim for version bump, let's stay with 5 for Pike.
16:15:54 <vthapar> agree with mkolesni, same version will clear out lots of confusion
16:17:19 <yamahata_> vthapar: do you have/observe issues with version number?
16:18:23 <vthapar> yamahata: not me, but I've had queries from those looking to install python packages... I had been tracking versions per release. but same numbers would make things much simpler.
16:19:23 <yamahata_> I see. let's communicate openstack release team and neutron.
16:19:31 <vthapar> in an ideal world neutron , n-odl and all services we have drivers for would be in sync.
16:19:38 <yamahata_> #action yamahata communicate with openstack release team and neutron.
16:19:46 <mkolesni> ok lets move on?
16:19:55 <yamahata_> let's move on
16:20:05 <yamahata_> #topic action items from last meeting
16:20:09 <yamahata_> I suppose nothing.
16:20:32 <yamahata_> pike planning was already discussed.
16:20:39 <yamahata_> #topic carbon planning
16:21:01 <yamahata_> I supose nothing new
16:21:05 <yamahata_> #topic patches/bugs
16:21:28 <yamahata_> Okay we have websocket issue.
16:21:42 <mkolesni> jhershbe, ur up
16:21:44 <jhershbe> ok
16:22:08 <jhershbe> I put some comments on the patch...I'm concerned about the lack of error handling in the loop
16:22:31 <jhershbe> and I wanted to offer to help if that seems appropriate
16:22:46 <yamahata_> #link https://review.openstack.org/#/c/421127/ websocket patch
16:23:03 <yamahata_> That's great.
16:23:18 <jhershbe> great? Help with coding the loop?
16:23:23 <yamahata_> Do you want to update the patch yourself?
16:23:27 <jhershbe> sure
16:23:30 <yamahata_> You can go for it.
16:23:32 <jhershbe> I can work on that tomorrow
16:23:33 <jhershbe> thanks
16:23:51 <yamahata_> Probably it would be better to discuss with Ritu on irc.
16:23:59 <jhershbe> where can I find her?
16:24:11 <yamahata_> Unfortunately she isn't online.
16:24:26 <yamahata_> Usually she attends ovsdb bluejeans meeting.
16:24:46 <jhershbe> I'll send her a message
16:24:48 <jhershbe> email
16:25:01 <yamahata_> So we can talk with tomorrow or after the ovsdb meeting, we can discuss.
16:25:14 <jhershbe> sure
16:25:17 <mkolesni> yamahata_, perhaps you can talk to her later today?
16:25:24 <yamahata_> Yes. Will do.
16:25:59 <mkolesni> ok great
16:26:14 <yamahata_> any patch patches/bugs?
16:26:24 <vthapar> I had one, updated the agenda
16:26:28 <vthapar> #link https://bugs.launchpad.net/networking-odl/+bug/1668162
16:26:30 <jhershbe> ok, I'll send an email to the two of you a little later and we can continue there
16:26:36 <mkolesni> basically jhershbe already sent status update patch to ODL side
16:26:37 <manjeets> o/
16:26:51 <vthapar> this is the PORT_ID one which is causing issues with vhostuser ports.
16:26:58 <yamahata_> Ritu is looking at 1668162.
16:27:23 <vthapar> only question I had was if we'll be backporting it to newton
16:27:29 <yamahata_> vthapar: your idea to use port prefix sounds reasonable way.
16:27:59 <yamahata_> It should be backported to newton and ocata.
16:28:09 <yamahata_> That's the reason why I asked you to file a bug.
16:28:25 <vthapar> do we need to mention target releases in bug?
16:29:02 <yamahata_> That's good. Let's mention it.
16:29:47 <vthapar> let me know if need any help with fix.
16:29:55 <yamahata_> Sure.
16:30:25 <yamahata_> any other bugs/patches?
16:30:48 <mkolesni> none from me
16:30:58 <yamahata_> let me raise two
16:31:03 <yamahata_> #link https://git.opendaylight.org/gerrit/#/c/52267/
16:31:09 <yamahata_> #link https://git.opendaylight.org/gerrit/#/c/52267/
16:31:17 <vthapar> was planning to bring up func tests for l2gw and bgpvpn but those are still WiP
16:31:24 <yamahata_> that's surely a bug and should be backported.
16:31:25 <mkolesni> thats the same one?
16:32:17 <vthapar> Achyuth is working on the change, he had some issue running E2E but seem to be resovled now
16:32:27 <yamahata_> ODL patch 52267 for ODL bug 7848 odl neutron northound spi bug.
16:32:47 <mkolesni> no u pasted the same link twice
16:33:09 <mkolesni> did u mean to paste 2 links?
16:33:10 <yamahata_> oh. my bad. my clicked chattered.
16:33:21 <yamahata_> Only one link.
16:33:43 <mkolesni> ok
16:34:08 <yamahata_> I have a question for jhershbe regarding to https://review.openstack.org/#/c/421127/
16:34:27 <yamahata_> Oops. wrong link
16:34:51 <yamahata_> #link https://git.opendaylight.org/gerrit/#/c/52173/ Option to receive only leaf nodes in websocket notifs
16:35:36 <yamahata_> Are you going to work on closing datachangelistenre rpc?
16:35:54 <vthapar> looks like jhershbe got disconnected.
16:36:33 <yamahata_> Oh. I'd like to make assignee clear to avoid duplication.
16:36:56 <yamahata_> anyway we will see.
16:37:07 <yamahata_> no other patches/bugs to discuss?
16:37:40 <yamahata_> move on
16:37:42 <yamahata_> #topic open mike
16:37:49 <yamahata_> anything else to discuss?
16:38:13 <jhershbe> I'm back...heard you were looking for me
16:38:15 <jhershbe> sorry
16:38:24 <yamahata_> no problem.
16:38:45 <yamahata_> Regarding to the patch https://git.opendaylight.org/gerrit/#/c/52173/ Option to receive only leaf nodes in websocket notifs
16:38:51 <yamahata_> What's your plan?
16:39:08 <yamahata_> Are you going to work on a patch to close/re-open datachangelistner?
16:39:17 <jhershbe> I put it on the agenda for the kernel call tomorrow.
16:39:18 <yamahata_> I'd like to make assignee clear to avoid duplication.
16:39:34 <jhershbe> I can also work on  close/re-open datachangelistner
16:39:35 <yamahata_> Oh Great.
16:40:02 <jhershbe> yes, please assign to me
16:40:42 <yamahata_> thanks
16:41:03 <yamahata_> that's it from me. anything else to discuss?
16:41:22 <vthapar> yamahata_: I wanted to bring up the mail John Woods sent...
16:41:32 <vthapar> let me get the link from mail list
16:41:36 <yamahata_> which mail?
16:42:10 <yamahata_> keystone token one?
16:42:14 <vthapar> #link https://lists.opendaylight.org/pipermail/neutron-dev/2017-February/001237.html
16:42:16 <vthapar> yeah.
16:42:52 <vthapar> any idea what would be better way to go about it?
16:43:26 <mkolesni> why do they need to call back to nodl?
16:43:31 <vthapar> today we only support basic auth on driver side, which means will have to fetch credentials for neutron service when creating client.
16:43:52 <yamahata_> I'm a bit unsure about the goal. Can you please elaborate on it?
16:44:00 <vthapar> I think it is for nodl calls to ODL.
16:44:35 <vthapar> goal is that instead of storing user/pass in a conf file, use keystone credentials alreay present in openstak for n-odl - ODL communication.
16:45:19 <yamahata_> With dedicated openstack user(usually service user with devstack), it's quite possible to implemented keyston backend with ODL AAA and enahnce networking-odl to use that credential.
16:45:30 <mkolesni> seems he wanted nodl to update data in restconf?
16:46:49 <mkolesni> from his email it didnt seem like he's talking about authentication but rather about configuring the credentials
16:47:08 <yamahata_> n-odl can use keystone library to send those tokens. So it wouldn't very difficult.
16:47:13 <vthapar> it is mainly authentication, that is why he mentions token too.
16:47:15 <yamahata_> I'm not sure about ODL AAA side.
16:47:48 <vthapar> keystone services use tokens and his plan was to use those tokens when we make rest calls from n-odl to ODL
16:48:02 <vthapar> ODL AAA he is already working with Ryan/Tom.
16:48:19 <vthapar> I was looking into how n-odl can get access to token [preferred] or credentials.
16:48:41 <mkolesni> what did u find?
16:49:00 <vthapar> is token present in context or plugin_context? I could get user_id, tenant_id etc but not token.
16:49:24 <vthapar> I am rebuilding my dev setup, once up will try out few things to see how far token goes.
16:49:26 <mkolesni> i dont know, yamahata_ said we dont have this data iiuc
16:49:34 <yamahata_> Probably new config for those user/pass in neutron conf will be added like nova user/pass.
16:50:02 <vthapar> mkolesni: yeah... I suspect so too. didn't find token in context.Context
16:50:34 <yamahata_> in networking-odl, we don't have user_id, teanant_id in principle when sending request to ODL.
16:50:40 <vthapar> other question is, will our client be able to support tokens? I remember we used to have JSessionIDs before we moved to basic auth
16:50:50 <yamahata_> So we need to define dedicated user for it.
16:51:16 <vthapar> yamahata_: I think plan was to use those to fetch credentials [user/pass] from db/keystone. but tokens would be preferred.
16:51:19 <mkolesni> yamahata_, thought we already have that..
16:51:25 <vthapar> yamahata_: what about neutron user as you mentioned?
16:52:01 <yamahata_> in devstack case, SERVICE_USER/SERVICE_PASSWORD
16:52:24 <mkolesni> im not sure whats the benefit here, if we just swap odl user with neutron service user, what do we gain?
16:52:58 <yamahata_> we can use neutron user/password that nova uses.
16:52:59 <mkolesni> i could see the benefit of tokens, though imho this is a bit low priority
16:53:39 <vthapar> mkolesni, tokens are the preferred means, but with user/pass aim is to avoid storing password in a text file.
16:53:47 <yamahata_> networking-odl can create/retrieve the token with keystone.
16:54:06 <mkolesni> yamahata_, but u still store user/pass in a textfile?
16:54:16 <yamahata_> yes in neutron config.
16:54:37 <mkolesni> so this def0e.
16:54:37 <mkolesni> a
16:54:43 <mkolesni> defeats the purpose..
16:54:55 <vthapar> when user makes an API call, it comes with a token, what about using that token?
16:55:11 <mkolesni> as u guys said the token is not available to us
16:55:55 <mkolesni> i would guess it gets it only to the rest api layer, not even to the neutron api layer
16:56:22 <vthapar> well, haven't ruled it out fully yet :) but agree, if we're still storing some user/pass somewhere in a clear text file then it doesn't help.
16:56:42 <vthapar> it just needs more investigation then.
16:57:02 <mkolesni> so if you can somehow reuse the token theres benefit, otherwise id say its not worth the hassle
16:57:18 <yamahata_> In that case, you'd like to see nova config. it stores neutorn user/pass in nova config.
16:57:19 <mkolesni> maybe this can be changed at the api level
16:57:42 <vthapar> mkolesni: agree. getting token on each call is not practically feasible.
16:57:47 <vthapar> yamahata_: will take a look
16:57:57 <mkolesni> yamahata_, i believe he intends to eliminate storing user/pass in the driver config, not solve the whole world problems :)
16:58:20 <yamahata_> I see. we don't have to boil the occian.
16:58:44 <mkolesni> sorry gtg
16:58:48 <mkolesni> thanks for the meeting
16:58:57 <yamahata_> anything else in short?
16:59:09 <vthapar> not from me.
16:59:16 <yamahata_> thank you everyone
16:59:19 <vthapar> thanks mkolesni, cya.
16:59:37 <yamahata_> #topic cookies
16:59:38 <vthapar> thank you all. cya next week.
16:59:42 <yamahata_> #endmeeting