15:02:50 <yamahata> #startmeeting neutron_northbound
15:02:50 <odl_meetbot> Meeting started Mon Jul 10 15:02:50 2017 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:50 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:50 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:03:02 <yamahata> #chair mkolesni
15:03:02 <odl_meetbot> Current chairs: mkolesni yamahata
15:03:06 <yamahata> #chair rajivk
15:03:06 <odl_meetbot> Current chairs: mkolesni rajivk yamahata
15:03:16 <yamahata> #topic agenda bashing and roll call
15:03:19 <mkolesni> #info mkolesni
15:03:22 <yamahata> #info yamahata
15:03:31 <rajivk_> #info rajivk
15:03:47 <mkolesni> id like to talk about Pike-3 and PTG/OS summit
15:03:50 <yamahata> #link https://wiki.opendaylight.org/view/NeutronNorthbound:Meetings meeting
15:04:09 <mkolesni> and of course reviews
15:04:20 <yamahata> any other topics?
15:04:37 <rajivk_> yeah there are some patches
15:04:51 <rajivk_> Xiao want su to merge in ocata branch
15:05:13 <mkolesni> bug fixes?
15:05:17 <rajivk_> yes
15:05:35 <mkolesni> are they backported yet?
15:05:46 <rajivk_> no
15:06:07 <rajivk_> resource ordering and full sync and recover of all the resources
15:06:11 <mkolesni> he should report the bugs on ocata as well i believe
15:06:28 <mkolesni> if it has db migration script it wont be backportable
15:06:49 <rajivk_> no, they don't have db migration scripts
15:07:26 <mkolesni> ok then afaik he should report the bugs on ocata and backport the patches
15:07:41 <rajivk_> should i discuss about them now
15:07:54 <rajivk_> or we can discuss at the end of meeting?
15:07:57 <yamahata> let's discuss at patches/bugs topics
15:08:10 <rajivk_> ok
15:08:18 <yamahata> do we have other topics? can we move on?
15:08:41 <mkolesni> lets move on
15:08:43 <yamahata> #topic Announcements
15:09:00 <yamahata> openstack summit RFP deadline is approaching
15:09:25 <mkolesni> yamahata, are you going to the upcoming summit and PTG?
15:09:42 <yamahata> For now, it's not decided unfortunately.
15:09:50 <mkolesni> even ptg?
15:09:51 <yamahata> It would take a while to decide.
15:09:54 <yamahata> Right.
15:09:59 <mkolesni> ok
15:10:07 <mkolesni> i will probably be going to ptg
15:11:22 <mkolesni> i know rajivk_ wants to go to summit
15:11:28 <mkolesni> at least send in papers
15:11:36 <rajivk_> I don't know yet.
15:11:55 <rajivk_> yes, i am planning to present something.
15:11:56 <yamahata> the deadline is less than a week. We need to be in hurry
15:12:01 <mkolesni> btw does ptg have some cfp equivalent?
15:12:14 <yamahata> No. ptg doesn't have presentation.
15:12:26 <mkolesni> but probably some planning?
15:12:36 <mkolesni> etherpad?
15:12:40 <yamahata> Right.
15:12:49 <mkolesni> do you know the details?
15:12:52 <yamahata> There would be discussion on the mailing list.
15:13:03 <mkolesni> ok
15:13:04 <yamahata> RIght now I don't see discussion started yet.
15:13:28 <mkolesni> yamahata, did you submit anything to summit?
15:13:41 <yamahata> I'm planning one proposal.
15:13:55 <yamahata> We can propose another jointly.
15:13:59 <mkolesni> what would you be proposing?
15:14:17 <mkolesni> we should sync up to avoid proposing the same things twice
15:14:32 <yamahata> about scalability evaluation.
15:14:35 <mkolesni> im not sure if i will go to summit but i might propose something
15:14:40 <yamahata> For details, we can discuss it offline.
15:14:53 <mkolesni> regarding ODL+OS or just OS?
15:14:56 <yamahata> #action yamahata sent out mail to discuss Openstack summit RFP
15:14:58 <yamahata> ODL + OS
15:15:04 <rajivk_> yamahata, can i join as well?
15:15:06 <yamahata> it's openstack summit.
15:15:18 <yamahata> rajivk_: off course.
15:16:06 <yamahata> any other announcement?
15:16:08 <mkolesni> ok if you have something in mind for proposal im open to suggestions
15:16:16 <mkolesni> can we talk about Pike-3?
15:16:19 <rajivk_> i want to propose something like, what are the parameter we should consider for openstack deployment
15:16:21 <yamahata> Pike-3 is Jul 24-28 as feature freeze
15:16:32 <yamahata> #topic Pike planning
15:16:49 <mkolesni> so we need to get all non-bugs done until then
15:17:09 <mkolesni> after that only bug fixes should be merged i.e. no more rfes
15:17:36 <mkolesni> we need to leave time for qe to test the driver
15:18:09 <yamahata> yeah. From Pike, networking-odl follows release-by-cycles
15:18:54 <mkolesni> ok so we have plenty of rfes still on the fly that we need to get in
15:19:23 <mkolesni> re rajivk_'s work on refactor its coming along nicely
15:19:38 <mkolesni> im concerned about https://review.openstack.org/#/q/status:open+project:openstack/networking-odl+branch:master+topic:bp/dep-validations-on-create
15:19:42 <yamahata> as big topic we have several v2driver staff, dhcp-port-creation, etc
15:20:27 <yamahata> Regarding to v2driver, we can drive optimistic lock patch and making the number of journal thread configurable
15:20:46 <yamahata> Regarding to pre-dependency calculation, we haven't reached consensus.
15:20:48 <mkolesni> i separated it from the branch as you requested
15:20:58 <mkolesni> https://review.openstack.org/467060
15:21:05 <mkolesni> i also found a bug when doing so
15:21:11 <mkolesni> https://review.openstack.org/482042
15:21:45 <mkolesni> the bug was due to an oversight on an earlier code refactor but it became very apperant in the optimistic locking patch
15:22:00 <mkolesni> so if you can review those 2 thats great
15:22:16 <yamahata> okay.
15:22:18 <mkolesni> i tested it locally with rally and there's no hinderance in performance
15:22:40 <yamahata> Regarding to 467060, rajis's review requests tests
15:23:00 <yamahata> The modification itself looks okay to me.
15:23:08 <mkolesni> yes i altered the test
15:23:15 <yamahata> Similar to 482042.
15:23:18 <mkolesni> there is no other way to test it besides using a mock
15:24:20 <yamahata> I see. then we can use mock.
15:24:25 <mkolesni> re 482042 there is no way to cause the bug to happen in a unit test, the only test that can be made is perhaps to prevent it in the future but if we change to dependency calculation it will become moot
15:24:31 <yamahata> anyway in detail we can continue discussion at gerrit.
15:24:44 <mkolesni> so i would rather not spend extra time on that if its not necessary
15:24:46 <mkolesni> sure
15:26:01 <yamahata> For Pike right now openstack CI is in very bad shape.
15:26:08 <yamahata> we need to address it for Neutron Stadium.
15:26:22 <yamahata> Especially tempest jobs are failing for long time.
15:26:39 <mkolesni> do we still need all the v1 tests?
15:26:39 <manjeets> timeouts in tempest job ?
15:26:55 <yamahata> ssh via floating ip is still failing.
15:27:11 <yamahata> timeout sometimes happens. but we can issue recheck.
15:27:25 <mkolesni> i think we should focus on fixing carbon v2
15:27:36 <mkolesni> im not sure we need to focus on v1 CI failure
15:27:38 <manjeets> from last 2 weeks the timeout failure frequency has increased
15:28:07 <yamahata> The reason for timeout is that testcases were enabled.
15:28:44 <yamahata> it added more test cases with ssh which added 5mins.
15:29:36 <yamahata> next one, networking-odl documentation needs to be reorganized.
15:29:42 <yamahata> to follow new standard
15:30:53 <yamahata> The topic name is doc-migration
15:31:04 <yamahata> #link https://review.openstack.org/#/q/topic:doc-migration
15:31:40 <yamahata> anything else for pike cycle?
15:31:44 <mkolesni> does this need to happen before Pike-3?
15:32:33 <yamahata> I suppose no. we can address it after Pike-3
15:32:59 <yamahata> and it's just to shuffle doc tree
15:32:59 <mkolesni> ok sounds reasonable
15:33:22 <mkolesni> btw do you know when the CI started failing?
15:33:52 <yamahata> very early in Pike
15:34:15 <yamahata> several bugs in ODL netvirt were fixed. but we're seeing failure still.
15:34:39 <mkolesni> i remember v2 carbon used to work fine
15:34:42 <mkolesni> and carbon isnt new
15:34:59 <manjeets> tempest smoke test for pinging an instance with fip is still failing
15:35:00 <yamahata> #link https://specs.openstack.org/openstack/docs-specs/specs/pike/os-manuals-migration.html
15:35:06 <yamahata> #link https://etherpad.openstack.org/p/doc-migration-tracking
15:35:23 <manjeets> but if I use same config locally and ping instance fip via cli it works fine
15:35:59 <mkolesni> might be a chain of events causing this
15:37:16 <yamahata> also we have intermittent failures of unit tests and functional tests.
15:37:20 <mkolesni> so you wont find it if you just try the one test
15:37:27 <yamahata> it's lower priority than tempest failure, though.
15:37:44 <mkolesni> i think functional tests of advanced services ala l2gw intermittently fails
15:37:57 <mkolesni> i rarely noticed that unit tests failed
15:38:04 <mkolesni> i.e. without a real cause
15:38:09 <yamahata> l2gw is the one I'd like to mention.
15:38:44 <yamahata> looks like we're talking patches/bugs
15:38:46 <yamahata> #topic patches/bugs
15:39:25 <yamahata> any other patches/bugs? rajivk?
15:39:42 <rajivk_> yes
15:39:59 <rajivk_> Xiao reported a few bugs
15:40:20 <rajivk_> on ocata and he wants us to merge in master well
15:40:44 <rajivk_> https://bugs.launchpad.net/networking-odl/+bug/1702417
15:41:27 <rajivk_> It was fixed after ocata release so i have raised a patch for the same
15:41:50 <yamahata> it sounds simple backport
15:41:53 <rajivk_> https://review.openstack.org/#/c/481820/
15:42:31 <yamahata> Is it backport of two patches?
15:42:36 <yamahata> not one-by-one?
15:43:35 <rajivk_> yes, of two patches. Currently sync of resources are not supported for all the drivers, may be he has some use case of l2gw but we can plan for all resources.
15:43:37 <rajivk_> https://bugs.launchpad.net/networking-odl/+bug/1701206
15:44:20 <yamahata> If you don't have special reasons to squash patches into one, please backport patchesper upstream patch.
15:44:58 <yamahata> If you have reasons, please mention it in the commit log.
15:45:11 <manjeets> yamahata, +1 unless it is killing ci then only squash
15:45:13 <rajivk_> Ok, actually second one is to correct order of router and port.
15:45:45 <rajivk_> ok, i will raise two different patch.
15:45:48 <mkolesni> i wouldnt squash for CI sake
15:46:11 <mkolesni> it makes it harder to track in history if its squashed
15:46:40 <manjeets> mkolesni, sometimes you have to squash if two combinely go through jenkins pass
15:46:54 <rajivk_> What do you think for sync of all resources?
15:47:31 <mkolesni> oh you mean that sure but i think its rarely necessary
15:48:09 <rajivk_> i am talking about https://bugs.launchpad.net/networking-odl/+bug/1701206
15:48:43 <yamahata> rajivk_: do you mean https://review.openstack.org/#/c/478803/ ?
15:49:18 <rajivk_> yes, but it has to be raise for ocata as well
15:49:23 <rajivk_> and recovery also
15:49:36 <yamahata> After fixing it in master, we can backport patches to ocata
15:50:08 <rajivk_> okay
15:50:23 <rajivk_> https://bugs.launchpad.net/networking-odl/+bug/1701209
15:50:43 <rajivk_> I want to have your opinion on this bug.
15:51:08 <mkolesni> i dont think this is backportable since you have a db migration
15:51:32 <rajivk_> Which one, the last one?
15:51:46 <mkolesni> yes
15:52:02 <rajivk_> Do you think, it will be a good idea to fix it by other means not by db migration?
15:53:10 <mkolesni> i dunno i didnt think about it
15:53:25 <mkolesni> do you have an alternative in mind
15:53:44 <rajivk_> may be we keep a window of 5 seconds or so for retrying or not trying at exactly the same time but with time +- 5 secons
15:54:28 <rajivk_> something similar may be we can come up with better approach after discussion.
15:55:38 <mkolesni> i dont think its a huge deal
15:56:19 <mkolesni> you can set for example the timer to 301 for maintenance so only 1 in every 300 might collide :)
15:56:52 <mkolesni> but we can have some retry there with some random backoff
15:56:53 <rajivk_> hmm, may be some nearest prime number
15:57:13 <yamahata> we have 3min left
15:57:25 <yamahata> do we have any other patches/bugs?
15:57:26 <rajivk_> ok, i will put a simple patch then we can discuss over that patch.
15:57:30 <rajivk_> no
15:57:41 <mkolesni> yamahata, id like to mention https://review.openstack.org/444648
15:58:01 <yamahata> mkolesni: please go ahead
15:58:17 <mkolesni> can we get it reviewed as a stop gap?
15:58:33 <mkolesni> also then rajivk_ can continue work on thread pool
15:58:53 <yamahata> The counter patches are https://review.openstack.org/#/q/status:open+project:openstack/networking-odl+branch:master+topic:bug/1683797
15:59:00 <yamahata> Do you have any issue with them?
15:59:10 <yamahata> It makes the number of journal thread configurable.
15:59:17 <yamahata> You can set it to 1 for your case.
16:00:04 <mkolesni> i havent seen them but im not sure they collide
16:00:17 <yamahata> maybe we need to implement threadpooling in our own instead of existing threadpool.
16:00:58 <yamahata> mkolesni: okay, then please review them.
16:01:00 <mkolesni> did you see my review on  https://review.openstack.org/#/c/452647/7?
16:01:10 <mkolesni> i talked with rajivk_ over it and he agrees
16:01:24 <mkolesni> so its not colliding with singleton approach
16:01:34 <mkolesni> again im not sure why the big push back against it
16:01:53 <mkolesni> we have an effective  singleton of maintenance thread
16:02:06 <mkolesni> so why not have one for journal thread?
16:02:07 <yamahata> openstack is using eventlet.
16:02:24 <yamahata> at socket io, they are multiplexed.
16:02:35 <mkolesni> please see my comment on https://review.openstack.org/#/c/452647/5 regarding this
16:02:49 <mkolesni> and see what actually benefits from multithreading
16:03:35 <mkolesni> im not against multithreading we just need to do it right
16:03:41 <mkolesni> now its just a mess
16:03:52 <mkolesni> theres no thought put into it
16:03:54 <yamahata> No, we can pick journal entry by mulitple threads/processes
16:04:12 <mkolesni> how? that code is atomic across the cloud
16:04:20 <yamahata> anyway if you stick to it, you can set the number of threads to 1.
16:04:51 <mkolesni> i gtg please see my comment and think about it seriously
16:05:04 <yamahata> sure, let's continue discussion at gerrit.
16:05:10 <mkolesni> ok
16:05:16 <mkolesni> thanks guys, bye
16:05:22 <yamahata> #topic open mike
16:05:30 <yamahata> thanks every one bye
16:05:36 <manjeets> thanks
16:05:39 <yamahata> #topic cookies
16:05:44 <yamahata> #endmeeting