15:01:31 <yamahata> #startmeeting neutron_northbound
15:01:31 <odl_meetbot> Meeting started Mon Oct 16 15:01:31 2017 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:31 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:01:37 <yamahata> #chair mkolesni mpeterson
15:01:37 <odl_meetbot> Current chairs: mkolesni mpeterson yamahata
15:01:47 <yamahata> #topic agenda bashing and roll call
15:01:52 <mkolesni> #info mkolesni
15:01:55 <yamahata> #info yamahata
15:02:20 <yamahata> any additonal topics?
15:02:33 <yamahata> From me, zuulv3 and bug.
15:02:36 <mpeterson> #info mpeterson
15:02:47 <mpeterson> full sync
15:02:52 <mpeterson> and +1 zullv3
15:03:43 <yamahata> anything else?
15:04:24 <yamahata> seems nothing else. move on
15:04:31 <yamahata> #topic Announcements
15:04:39 <yamahata> Last week there was ODL DDF for oxygen.
15:04:49 <mpeterson> oh, yes, the DB rework :)
15:04:59 <mpeterson> sorry I forgot that topic
15:05:11 <yamahata> For neutron, I had shared upcomming neutron features like multiple port binding
15:05:19 <yamahata> mpeterson: np
15:06:20 <yamahata> From netvirt/genius, there are several discussions on it.
15:06:30 <yamahata> the schedule can be found at https://docs.google.com/spreadsheets/d/1owZOnRXqQmpa5094mOmYfNvvdV-WkqVUGW8z2d0zXa8/edit#gid=556800807
15:06:53 <yamahata> https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum
15:07:03 <yamahata> There are several slides uploaded
15:07:30 <yamahata> next thing is that oxygen M1 is reached.
15:07:43 <yamahata> I need to send out status report for it today.
15:07:48 <mkolesni> oxygen is our target for Queens right?
15:07:56 <yamahata> yes.
15:08:19 <yamahata> There was a discussion on version combination.
15:08:30 <mkolesni> ?
15:08:58 <yamahata> which combination netvirt CSIT will work on.
15:09:10 <mkolesni> ah ok
15:09:42 <yamahata> Hmm they haven't uploaded the slide yet.
15:09:51 <yamahata> Anyway you can ask redhat ODL people for it.
15:10:06 <mkolesni> ok
15:10:57 <yamahata> any other announcement?
15:11:23 <yamahata> oh, also the next ODL DDF would be held at ONS in Los Angelse.
15:11:40 <yamahata> It's not fixed, but that's what Linux foundation people are planning.
15:12:28 <mkolesni> hmm on end of march?
15:12:28 <yamahata> move on
15:12:34 <yamahata> #topic action items from last meeting
15:12:46 <yamahata> I supose we don't have any as we skipped the meeting last week
15:12:52 <mpeterson> right
15:12:55 <yamahata> #topic Queens/Oxygen planning
15:13:17 <yamahata> okay Let's discuss additional topics
15:13:32 <yamahata> regarding to bug, we have several bugs
15:13:54 <yamahata> especially now CI has been broken.
15:14:00 <yamahata> and I uploaded several patches.
15:14:27 <mkolesni> mpeterson, has been trying to fix it as well
15:14:50 <mpeterson> yamahata: I am working on Zuul v3 changes
15:15:10 <mpeterson> yamahata: the patches I saw you commited were common for v2.5 and v3
15:15:14 <mpeterson> yamahata: right?
15:15:34 <yamahata> Yes. Oh the patch I uploaded was merged.
15:15:35 <yamahata> Good.
15:16:10 <mpeterson> yes, so basically the CI is currently broken because of Zuul v3 changes
15:16:11 <yamahata> and patch for project-config by Yamamoto was also merged.
15:16:21 <mpeterson> I already sent two patches to tackle this and one was merged
15:17:00 <mpeterson> I have the feeling that check and gate will be fixed by these changes, however post (like packaging and sending to pypi) will be broken still
15:17:25 <mpeterson> but the fix goes along the line
15:17:34 <mpeterson> next steps are:
15:17:46 <mpeterson> 1. commit the patches to move legacy jobs to our domain
15:18:03 <mpeterson> 2. migrate those to Zuul v3
15:18:41 <mpeterson> my idea is to make 1 and 2 non-blocking to normal workflow
15:18:43 <yamahata> Do you mean by 1, move job definitions into networking-odl repo,
15:18:49 <mpeterson> yes
15:18:50 <yamahata> by 2, make them zuulv3 native?
15:18:54 <mpeterson> exactly
15:18:58 <yamahata> Cool.
15:19:00 <mkolesni> probably tox install script can be removed with zuul v3
15:19:11 <mkolesni> like they did in neutron
15:19:26 <mpeterson> I already have more or less all in place for 1 and was starting on 2
15:19:44 <mpeterson> but I want to see if the patches submitted get merged and unblock check and gate
15:19:56 <mpeterson> mkolesni: indeed
15:20:18 <mkolesni> mpeterson, u also wanted to talk about the odl version matrix
15:20:43 <mpeterson> right, what jobs need to be deprecated and which should be added?
15:20:55 <mpeterson> we said boron should be deprecated for sure, any other?
15:21:09 <yamahata> Right.
15:21:17 <mkolesni> i think we will keep carbon for now right?
15:21:22 <yamahata> boron related job would be deprecated and
15:21:37 <mkolesni> though we need to add oxygen
15:21:38 <yamahata> oxygen(or master) would be added (as non-voting)
15:21:58 <mpeterson> okey
15:22:02 <mkolesni> also tempest jobs should be made back voting
15:22:21 <yamahata> yes.
15:22:37 <mpeterson> are they stable enough? I haven't been following that
15:22:50 <mkolesni> it seems theyre much more stable
15:22:56 <yamahata> Now we have a workaround to make it pass.
15:22:59 <mkolesni> especially nitrogen
15:23:10 <mpeterson> great, so I'll make them voting
15:23:13 <yamahata> in devstack script. we should remove it at some point.
15:23:22 <mkolesni> mpeterson, also probably grafana needs to be updated if it hasnt already
15:23:47 <mpeterson> mkolesni: for sure, but it's a dependency on these changes
15:23:53 <yamahata> oh, grafana is broken?
15:23:56 <mkolesni> yes of course
15:24:12 <mkolesni> no but im not sure they migrated it to zuul v3
15:24:14 <mpeterson> yamahata: yes, because it points to the jobs names of "Jenkins"
15:24:15 <mkolesni> if they did great
15:24:25 <yamahata> I see.
15:24:28 <mkolesni> if not, this needs to be fixed of course
15:24:41 <mpeterson> agreed, good catch
15:25:56 <yamahata> anything else related to zuulv3?
15:26:03 <mkolesni> yes i checked now the job names are the old ones
15:26:09 <mpeterson> #action mpeterson migrate legacy jobs to inside the project and to v3 native
15:26:20 <mpeterson> #action mpeterson update grafana
15:27:01 <mpeterson> yamahata: don't think so
15:27:42 <yamahata> Right now we have several bug reports.
15:27:46 <mkolesni> yes
15:27:47 <yamahata> Especially from Rajiv.
15:27:56 <yamahata> and some patches from Rajiv.
15:28:01 <mkolesni> once tox install script is removed we can simplify some jobs definitions
15:28:04 <yamahata> we should review his patches to help him.
15:28:16 <mkolesni> since now all have dependent-projects
15:28:35 <mkolesni> yamahata, the bugs are for pike?
15:29:03 <yamahata> His bug reports are for master. But I suppose it applies for pike.
15:29:13 <yamahata> You'd like to back-port them to pike.
15:29:20 <mkolesni> we should see if it is then yes
15:30:00 <yamahata> mkolesni: can you take care of backports?
15:30:18 <mkolesni> sure ill take a look
15:30:21 <yamahata> anyway we'll address master branch first.
15:30:49 <mpeterson> I guess in the bug topic would enter the first stage of the DB rework
15:30:51 <mkolesni> of course
15:30:56 <mpeterson> which is waiting to be reviewed
15:31:08 <mpeterson> and will serve as the base to start stage two
15:31:28 <yamahata> can you share link please?
15:31:34 <mkolesni> im in the process of reviewing it
15:31:48 <mpeterson> https://review.openstack.org/#/c/500584/ first stage of DB rework
15:32:16 <mpeterson> mkolesni: thanks :)
15:33:38 <yamahata> #link https://review.openstack.org/#/c/500584/ first stage of DB rework
15:33:44 <mkolesni> please review https://review.openstack.org/#/c/504043/
15:34:03 <mkolesni> #link https://review.openstack.org/#/c/504043/ Delete completed rows immediately when retention=0
15:34:31 <mkolesni> also this has many +1s please have a review https://review.openstack.org/#/c/503796/
15:34:37 <mpeterson> mkolesni: will do. I lagged behind on reviewing, I'll start being more active on it tomorrow.
15:34:47 <mkolesni> #link https://review.openstack.org/#/c/503796/ Don't sleep on exception
15:34:54 <mkolesni> thanks!
15:35:08 <yamahata> Does 503796 get Yamamoto's review?
15:35:11 <yamahata> opening
15:35:13 <yamahata> oh yes.
15:35:13 <mkolesni> yes
15:35:19 <mpeterson> #action all review linked reviews
15:35:36 <mkolesni> i will address his further comment on a follow up patch re the 404 itself
15:35:44 <yamahata> How about ODL 404 bug? mkolesni  are you looking into it?
15:36:22 <mkolesni> yes though that bug is not about the 404 but about the fact journal was stuck
15:36:24 <yamahata> packet crossed. Ok, great.
15:36:37 <mkolesni> the 404 is just a symptom and the bug doesnt have enoguh info
15:37:04 <mkolesni> but i will address it partially with a follow up patch taking into account yamamoto's new comment
15:37:31 <mkolesni> so if you guys are bored, have a go at https://review.openstack.org/#/c/508826/
15:37:38 <yamahata> I'm afraid that ODL 404 won't be addressed once 503796 is merged and your qa doesn't see issues except in log.
15:37:50 <mpeterson> re: 404 AFAIK we don't have a way to reproduce it yet
15:37:58 <mkolesni> #link https://review.openstack.org/#/c/508826/ Add command line tool to analyze logs
15:38:28 <mkolesni> the 404 itself is low priority since its a delete op
15:38:38 <mkolesni> we do have other more important bugs for 404 on update
15:38:48 <mkolesni> which i will take a look at next
15:38:58 <mpeterson> mkolesni: happens in other ops other than delete too
15:39:01 <mkolesni> but i dont think its the same scenario as this
15:39:02 <mpeterson> right, exactly
15:39:07 <yamahata> mportant bugs first makes sense.
15:39:30 <yamahata> anyway we should keep eyes on it.
15:39:41 <mkolesni> of course i have them assigned to me
15:40:28 <mpeterson> any other bug related thing we need to discuss?
15:40:38 <mkolesni> nothing on my side
15:40:57 <mpeterson> cool, so full sync triggering
15:41:01 <yamahata> regarding to Rajiv bug report, I think we can review his patches and make progress.
15:41:20 <mpeterson> agreed
15:41:25 <mkolesni> i will focus on code reviews tomorrow
15:41:31 <mpeterson> me too
15:41:33 <yamahata> Great.
15:41:50 <mpeterson> full sync triggering, the patches are there for review and approval
15:41:52 <yamahata> For past several weeks, patch review has stalled.
15:41:56 <mpeterson> let me link
15:42:18 <mpeterson> #link https://review.openstack.org/#/q/status:open+project:openstack/networking-odl+branch:master+topic:feature/force_maintenance_task full sync trigger
15:42:30 <mkolesni> this is medium priority IMO, we should focus on the high priority bug fixes first
15:42:35 <yamahata> After bug fix patches, I'll review full sync triggering.
15:42:35 <mkolesni> and of course CI
15:43:23 <yamahata> Yeah, bug fix and CI is first priority.
15:43:35 <mpeterson> sounds fair, just don't forget about it. I've been polled several times about it already, seems other people depend on it to further their work
15:44:31 <mkolesni> they need to be made aware this is a queens feature
15:44:39 <yamahata> Yeah, at ODL DDF michael discussed about ODL upgrade.
15:44:45 <mkolesni> so since were at the cycle start we have more pressing concerns
15:44:49 <yamahata> They assume fullsync triggering.
15:44:52 <mkolesni> IMHO
15:45:52 <mkolesni> what do u guys think?
15:46:47 <mpeterson> I agree. We had many interruptions in the past weeks and things accumulated
15:47:48 <yamahata> It's simply a matter of priority. I hope we can back to normal review cycle, those patches can be reviewed more smoothly
15:48:31 <yamahata> time check. we have 12 mins left.
15:48:43 <yamahata> do we have any other bugs/patches to be discussed?
15:48:52 <yamahata> or any other open items?
15:48:58 <rajivk_> i have
15:49:06 <mpeterson> oh, rajivk_ is here :)
15:49:17 <mkolesni> nice :)
15:49:31 <yamahata> rajivk_: hello.
15:49:37 <rajivk_> hello everyone
15:49:47 <rajivk_> https://review.openstack.org/#/c/504297/
15:49:55 <yamahata> rajivk_: unfortunately last week I didn't have time to review your patches. But this week I will.
15:50:14 <yamahata> now at least jenskins CI seems back. and mpeterson is looking into zuulv3.
15:50:29 <rajivk_> Currently, l3 things are not working with this patch but others seems to be ok
15:50:56 <rajivk_> I suspect "neutron.api.extensions [None req-46440f80-aeeb-4e9d-b2b4-cebd178df96e None None] Unable to process extensions (auto-allocated-topology) because the configured plugins do not satisfy their requirements. Some features will not work as expected." this as the cause.
15:51:33 <rajivk_> Do you have any idea about it?
15:52:14 <rajivk_> mkolesni, mpeterson, does red hat team also test sfc driver?
15:52:19 <yamahata> auto-allocated-topology can be dropped.
15:52:26 <mkolesni> no as far as i know
15:52:37 <mkolesni> sfc is future feature
15:52:42 <rajivk_> i can see https://review.openstack.org/#/c/509688/, https://review.openstack.org/#/c/509691/ these two problems
15:52:53 <yamahata> I suppose d redhat and ericsson are interested in sfc...
15:53:52 <rajivk_> yamahata, i will look into auto-allocated-topology things.
15:55:08 <rajivk_> did you guys discussed about enabling tests for drivers?
15:55:29 <yamahata> rajivk_: do you mean unit tests?
15:55:34 <rajivk_> yes
15:55:50 <mkolesni> what do you mean? arent they always enabled?
15:56:03 <yamahata> No today. So far It's matter of volunteers.
15:56:55 <yamahata> There are several unit tests in neutron (or netwokring-xxx) repo which assumes reference driver.
15:57:07 <yamahata> We would like to run those tests with odl driver.
15:57:39 <yamahata> rajivk_: you're refering to it, right?
15:57:49 <rajivk_> yes
15:58:30 <rajivk_> Now, i see, need for functional tests, as i found the most obvious bugs, which must be detected by CI/CD? I think, we should start working on them as well.
15:59:15 <mkolesni> sorry for interrupting but were at the top of the hour, i have to go
15:59:17 <yamahata> Yes. Now we don't have sfc functional test.
15:59:26 <yamahata> anything else urgent?
15:59:46 <rajivk_> no
15:59:53 <yamahata> thank you everyone.
15:59:59 <mkolesni> thanks!
16:00:00 <mkolesni> bye
16:00:13 <rajivk_> thanks everyone
16:00:21 <yamahata> #topic cookies
16:00:25 <yamahata> #endmeeting