15:03:35 <yamahata> #startmeeting neutron_northbound
15:03:35 <odl_meetbot> Meeting started Mon Nov 27 15:03:35 2017 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:03:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:35 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:03:45 <yamahata> #chair mkolesni rajivk_ manjeets_
15:03:45 <odl_meetbot> Current chairs: manjeets_ mkolesni rajivk_ yamahata
15:03:53 <yamahata> #topic agenda bashing and roll call
15:03:59 <yamahata> #info yamahata
15:04:01 <manjeets_> #info manjeets
15:04:07 <rajivk_> #info rajivk
15:04:13 <mkolesni> #info mkolesni
15:04:15 <mpeterson> #info mpeterson
15:04:23 <yamahata> #chair mpeterson
15:04:23 <odl_meetbot> Current chairs: manjeets_ mkolesni mpeterson rajivk_ yamahata
15:04:37 <yamahata> any additional agenda today?
15:04:45 <mkolesni> ptg?
15:06:10 <yamahata> okay ptg update. anyting else?
15:06:46 <rajivk_> we got new member working in networking-odl
15:07:02 <yamahata> #topic Announcements
15:07:08 <rajivk_> poothia will be working on networking-odl
15:07:08 <yamahata> rajivk_: cool.
15:07:19 <rajivk_> poothia, you are up
15:07:20 <mkolesni> nice, welcome poothia
15:07:27 <mpeterson> cool :) welcome, poothia
15:07:32 <poothia> Hello everyone
15:07:35 <manjeets_> welcome
15:08:14 <mpeterson> #info we have a new member working on the project. Welcome to poothia!
15:08:43 <rajivk_> Intro, poothia is a magician
15:08:51 <yamahata> Wow!
15:08:53 <mpeterson> poothia: wanna tell us something about yourself?
15:08:57 <rajivk_> he does some shows as well except development.
15:09:27 <poothia> Just a hobby...
15:09:34 <mkolesni> shows?
15:10:36 <poothia> Magic... :)
15:10:42 <yamahata> poothia: do you have any specific focus/topics in networking-odl?
15:11:02 <rajivk_> he will be working with me.
15:11:19 <rajivk_> he is from NEC only
15:11:41 <poothia> Not really I am new to networking, I am trying to explore this feild as well
15:11:56 <mpeterson> poothia: this is you? https://in.linkedin.com/in/shubhendu-poothia-67981a14
15:12:17 <poothia> Yes
15:12:37 <mkolesni> cool :)
15:12:37 <mpeterson> the stalker abilities are strong with mkolesni
15:12:58 <poothia> :D
15:13:25 <mkolesni> ok lets get rolling?
15:13:33 <yamahata> any other announcement?
15:14:19 <yamahata> yamahata:  will be absent on Dec 4 and Dec 11.
15:14:51 <yamahata> also Dec 25 and Jan 1 will be skipped due to holidays.
15:15:26 <mkolesni> so only meeting on Dec 18?
15:15:42 <yamahata> Yes.
15:16:12 <mkolesni> mpeterson can lead meetings on  Dec 4 and Dec 11
15:16:13 <yamahata> On Dec 4 and 11, If someone chair it, there can be a irc meeting.
15:16:39 <mkolesni> we will see if theres a need
15:16:39 <mpeterson> I guess
15:18:03 <yamahata> It's up to attendees.
15:18:24 <yamahata> I will follow meeting minutes and mailing list discussion.
15:19:52 <yamahata> rajivk_: manjeets_  will you attend?
15:20:12 <manjeets_> i'd be able to
15:20:15 <rajivk_> yamahata, 4th dec +1 not sure of 11th
15:20:49 <yamahata> Great. then mpeterson will chair on Dec 1 and dec 11 will be skipped.
15:20:57 <yamahata> Does it work for you?
15:21:07 <mkolesni> Dec 4th u mean
15:21:50 <yamahata> Oops. Yes, Dec 4th.
15:22:15 <mpeterson> #info From Dec 11 to Jan 1 there will be only one meeting on Dec 18
15:22:37 <mpeterson> #action mpeterson to chair the Dec 4th meeting
15:22:47 <yamahata> #topic action items from last meeting
15:23:02 <yamahata> there are three items.
15:23:14 <yamahata> manjeets to talk to qa folks about neutron-legacy in grenade
15:23:19 <yamahata> manjeets_: any updates?
15:23:54 <manjeets_> no I wasn't able to talk due to short week, I'll have some update this week
15:23:59 <mpeterson> #action mpeterson to create a task or bug to cleanup ODL between tests (pending from 2017-11-13 meeting)
15:25:18 <yamahata> mpeterson: cool. I forgot it. thanks.
15:25:35 <yamahata> other two item is patch review.
15:25:47 <yamahata> https://review.openstack.org/#/c/520339/
15:25:47 <yamahata> and
15:25:54 <yamahata> https://review.openstack.org/#/c/519001/
15:26:22 <yamahata> I think it can be discussed at bugs/patchs.
15:26:31 <yamahata> #topic patches/bugs
15:26:44 <manjeets_> yamahata, I replied to your comment on 519001 i guess it need another review from you
15:26:57 <yamahata> manjeets_:  sure. \
15:27:07 <yamahata> #action yamahata review https://review.openstack.org/#/c/519001/
15:27:53 <yamahata> On mailing list, there is two bug reports on OLD neutron northbound
15:28:08 <yamahata> One is related to ODL hostconfig
15:28:22 <yamahata> by Ran Xiao.
15:28:28 <yamahata> Isaku and Ritu will look into it.
15:28:46 <yamahata> Other is by A Vamsikrishna, on qos.
15:29:39 <yamahata> It's on newton branch with v1 qos driver.
15:29:44 <yamahata> so it won't be fixed.
15:30:45 <yamahata> If v2 qos driver in master has same issue, we will fix it.
15:31:41 <yamahata> those are what I'd like to share.
15:31:49 <yamahata> any bugs/patches to discuss?
15:31:56 <yamahata> receovery is a long standing issue
15:32:22 <yamahata> #link https://review.openstack.org/#/c/520339/ Design for full sync and recovery of resources
15:32:28 <mkolesni> it seems to be progressing now
15:32:47 <manjeets_> yamahata,  qos v2 works fine I tested last so week so that can be off the list
15:33:07 <yamahata> manjeets_: great. thanks for info.
15:33:27 <yamahata> so we can continue discussion on patch review on fullsync/recovery?
15:33:40 <mpeterson> rajivk_: there is a comment from me on that review, can you clarify it for me?
15:33:46 <yamahata> rajivk_: do you have anything to clarify/discuss?
15:33:58 <rajivk_> yamahata, no
15:34:05 <rajivk_> mpeterson, i will reply.
15:34:17 <rajivk_> I am waiting consensus on design patch
15:34:39 <rajivk_> and once we get it then i will push other patches, quickly
15:35:13 <mpeterson> rajivk_: but I don't know where we should, since there are two patches that are similar? https://review.openstack.org/#/c/520339/ https://review.openstack.org/521815
15:35:15 <rajivk_> i need to change method names as per yamahata, comment on https://review.openstack.org/#/c/523043/ https://review.openstack.org/#/c/521815/
15:36:10 <yamahata> I see. the patch was split into two patches.
15:36:16 <rajivk_> https://review.openstack.org/#/c/520339/, First design has to finish, i will make them WIP
15:36:34 <rajivk_> First let's freeze https://review.openstack.org/#/c/520339/
15:36:44 <rajivk_> then i will continue https://review.openstack.org/#/c/521815/
15:36:53 <rajivk_> https://review.openstack.org/#/c/523043/
15:37:35 <rajivk_> #520339 should get merged to be a part of docs.
15:37:47 <rajivk_> so that it can work as guide for writing new drivers.
15:38:25 <rajivk_> that's all
15:38:44 <yamahata> rajivk_: thanks.
15:39:15 <yamahata> any other patches/bugs to discuss?
15:39:42 <rajivk_> https://review.openstack.org/#/c/504297/
15:39:49 <mpeterson> there are a couple of pending reviews
15:39:58 <mpeterson> we are lagging behind, we should keep up doing them :)
15:40:21 <mpeterson> there is none that's particularly prioritary but just don't forget to review
15:41:12 <yamahata> Regarding to 504297, grenade is okay?
15:41:16 <yamahata> manjeets_: ?
15:42:03 <rajivk_> yamahata, i reported last week, for grenade there is no change
15:42:14 <manjeets_> yamahata, yes
15:42:18 <rajivk_> because grenade does not support lib/neutron
15:42:26 <rajivk_> grenade has to be migrated
15:42:31 <yamahata> Great. then let's make it progress. let's review.
15:42:51 <manjeets_> wait yamahata that's 519001
15:43:13 <manjeets_> and https://review.openstack.org/#/c/519759/
15:44:19 <yamahata> manjeets_:  I mean, lib/neutron and grenade. lib/neutorn doesn't support grenade yet, right?
15:44:21 <manjeets_> yamahata, i'll review 504297 and today and post my comments there
15:44:52 <yamahata> and eventually grenade also needs to migrate to lib/neutorn, but it's not ready yet at the moment.
15:45:04 <manjeets_> yes
15:45:15 <yamahata> Cool.
15:45:47 <yamahata> any other patches/bugs to discuss?
15:46:43 <yamahata> seems okay, move on
15:46:47 <yamahata> #topic open mike
15:46:53 <yamahata> one topic is ptg.
15:47:05 <yamahata> So far I don't have any update.
15:47:39 <mpeterson> just an update, unless there is no negative comment, I will enable OS_LOG_CAPTURE=1 for the tests
15:47:39 <yamahata> #link https://www.openstack.org/ptg/ openstack ptg
15:47:53 <mpeterson> so it won't show logging messages through the execution of tests
15:48:56 <mkolesni> rajivk_, yamahata, it would be good to know if youre going to ptg or not
15:49:26 <yamahata> OS_LOG_CAPTURE=1 makes sense. I've thought it's aready done.
15:49:51 <mkolesni> rajivk_, yamahata do you have an expectation on your planning for the ptg?
15:50:00 <rajivk_> mkolesni, my availability is not confirmed and seems to be difficult
15:50:51 <yamahata> mkolesni: schedule-wise I can attend.
15:51:23 <mkolesni> ok please try to find out :)
15:51:52 <yamahata> here is no concrete plan bug the week of Feb 26 and dublin at the moment. So it's difficult for me to get grant.
15:52:07 <yamahata> s/here/there/
15:52:16 <mkolesni> ok
15:52:19 <mkolesni> i have to go, bye guys
15:52:32 <yamahata> Okay anything else/urgent?
15:53:12 <mpeterson> nothing else
15:53:26 <rajivk_> nothing from me as well
15:53:26 <yamahata> okay give you 7mins back.
15:53:31 <yamahata> thanks everyone
15:53:40 <mpeterson> thanks
15:53:41 <mpeterson> cheers
15:53:42 <rajivk_> thanks all
15:53:43 <manjeets_> thanks
15:53:46 <yamahata> #topic cookies
15:53:49 <yamahata> #endmeeting