15:11:22 <mpeterson> #startmeeting neutron_northbound
15:11:22 <odl_meetbot> Meeting started Mon Jan 29 15:11:22 2018 UTC.  The chair is mpeterson. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:11:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:11:22 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:11:31 <mpeterson> #topic agenda bashing
15:11:34 <mpeterson> any topic?
15:11:37 <manjeet> #info manjeets
15:11:39 <mpeterson> *topics
15:11:49 <mkolesni> ptg?
15:11:55 <mkolesni> anyone going?
15:11:56 <mpeterson> #chair manjeet mkolesni jhershbe_ poothia___
15:11:56 <odl_meetbot> Current chairs: jhershbe_ manjeet mkolesni mpeterson poothia___
15:12:27 <yamahata> hello
15:12:29 <yamahata> sorry for late
15:12:30 <mpeterson> #info PTG
15:12:31 <yamahata> #info yamahata
15:12:32 <mpeterson> any more topics?
15:12:33 <yamahata> patches to merge for queens release.
15:12:36 <mpeterson> #chair yamahata
15:12:36 <odl_meetbot> Current chairs: jhershbe_ manjeet mkolesni mpeterson poothia___ yamahata
15:12:40 <poothia___> #info poothia
15:12:44 <mpeterson> #info patches to merge for queens release
15:13:08 <mkolesni> yamahata, i saw ur going to ptg, which days do you plan to be there?
15:13:19 <mpeterson> #info merged patches
15:13:35 <yamahata> mkolesni: all days.
15:13:38 <mpeterson> any other topic?
15:13:42 <mkolesni> yamahata, cool me too
15:13:50 <mpeterson> okey, moving on
15:13:51 <mpeterson> #topic announcements
15:14:07 <mpeterson> #info mkolesni and yamahata are going to the PTG
15:14:26 <mpeterson> yamahata: any announcement? branch cut is today right?
15:14:42 <yamahata> this week.
15:14:58 <mpeterson> do we have a specific date?
15:15:42 <yamahata> https://releases.openstack.org/queens/schedule.html
15:15:43 <mpeterson> yamahata: ^^
15:15:47 <yamahata> It's queens-3
15:16:11 <yamahata> It doesn't say specific date.
15:16:19 <yamahata> It's done by patch merge to release.
15:16:37 <mpeterson> #info Branch cut will happen sometime this week
15:16:51 <mpeterson> okey, can we move on?
15:17:08 <mkolesni> yes
15:17:12 <mpeterson> #topic PTG
15:17:12 <yamahata> ah, I'll need to skip next week again.
15:17:32 <mpeterson> #info yamahata won't be next weeek on the meeting, mkolesni will chair
15:17:41 <mpeterson> #action mkolesni to chair next meeting
15:17:42 <yamahata> sorry about that.
15:17:56 <mkolesni> i will chair if theres a need
15:18:03 <mpeterson> okey, mkolesni you brought the topic
15:18:25 <mkolesni> so anyone besides isaku & myself going to ptg?
15:18:34 <mkolesni> also we should start planning
15:18:35 <poothia___> i am not sure
15:18:54 <poothia___> my company might approve my budget...
15:18:57 <mpeterson> mkolesni: want to start an etherpad for the planning?
15:19:02 <mkolesni> poothia___, cool
15:19:15 <mkolesni> mpeterson, i dunno ask yamahata
15:19:31 <mpeterson> yamahata: what do you prefer?
15:19:31 <mkolesni> we can do it on the neutron pad for now
15:19:40 <mkolesni> and split if it gets too big
15:19:43 <yamahata> for neutron we can add it
15:19:50 <yamahata> for networking-odl we can have etherpad
15:20:06 <yamahata> https://etherpad.openstack.org/p/networking-odl-ptg-rocky
15:20:11 <yamahata> Now I've created it
15:20:11 <mkolesni> https://etherpad.openstack.org/p/neutron-ptg-rocky
15:20:26 <mkolesni> yamahata, can u add it to https://etherpad.openstack.org/p/neutron-ptg-rocky ?
15:20:46 <mpeterson> #action all please add topics for the ptg at https://etherpad.openstack.org/p/networking-odl-ptg-rocky and https://etherpad.openstack.org/p/neutron-ptg-rocky
15:20:58 <mpeterson> anything else mkolesni? yamahata? poothia___ ?
15:20:59 <yamahata> done.
15:21:01 <mpeterson> manjeet: ?
15:21:20 <mkolesni> i think we'll need to fill there goals we didnt attain during queens
15:21:56 <mpeterson> yes, agree
15:22:01 <manjeet> mpeterson, etherpad will be good I won't be coming to ptg
15:22:12 <mpeterson> ok
15:22:18 <mpeterson> okey, I'm moving on
15:22:22 <mpeterson> #topic patches to merge for queens release
15:22:31 <mpeterson> yamahata: you have the floor
15:22:47 <yamahata> Okay.
15:22:55 <yamahata> For now there are several patches floating around.
15:23:06 <yamahata> Some are important topics for Queens.
15:23:22 <yamahata> Bit topics was fullsync/recovery and L3.
15:23:43 <yamahata> For fullsync/recovery, basic patches were merged.
15:23:53 <yamahata> but several patches are remaining
15:23:59 <yamahata> https://review.openstack.org/#/c/527391/
15:23:59 <mpeterson> it's a shame rajiv is not here today
15:24:06 <yamahata> https://review.openstack.org/#/c/527624/
15:24:11 <yamahata> https://review.openstack.org/#/c/527654/
15:24:16 <yamahata> https://review.openstack.org/#/c/527676/
15:24:26 <yamahata> https://review.openstack.org/#/c/527391/
15:25:01 <yamahata> There four patches. As Rajiv isn't active recently, so we need volunteer to rebase them and drive them for Queens.
15:25:10 <yamahata> For L3 flavor
15:25:29 <yamahata> we have two patches for neutron. Fortunately we got FFE for them.
15:25:31 <yamahata> https://review.openstack.org/#/c/523257/
15:25:32 <mkolesni> poothia___, can u take rajiv's patches?
15:25:37 <yamahata> https://review.openstack.org/#/c/532993/
15:25:57 <yamahata> For networking-odl
15:25:57 <poothia___> that's what i wanted to ask you guys as well..
15:25:58 <yamahata> https://review.openstack.org/#/c/504182/
15:26:12 <mpeterson> yamahata: I think rajiv was still working on those patches, wasn't he? poothia___, why don't you mail him to be sure?
15:26:16 <yamahata> manjeet: and yamahata will drive them.
15:26:57 <mpeterson> great
15:27:05 <yamahata> poothia__: yeah, you can mail to him. And also as long as he doesn't show up, simply you can take them over.
15:27:24 <mpeterson> agree
15:27:28 <mpeterson> sounds good
15:27:30 <yamahata> Just we can ask him after the fact.
15:27:30 <poothia___> ok... i'll try my best...
15:28:10 <mkolesni> i think full sync and recovery might be a bit late in the cycle tho
15:28:34 <mkolesni> we dont have good testing for them unfortunately so if they break it'll be hard to know
15:29:19 <mkolesni> i guess we can merge them next cycle and have also better tests (functional esp) so that if they break we catch it
15:29:31 <mkolesni> thoughts?
15:30:14 <yamahata> that's unfortunate fullsync/recovery becomes late.
15:30:40 <yamahata> anyway that's the current situation.
15:30:46 <mkolesni> looking at the patches they seem half baked
15:30:59 <mpeterson> the thing it is still broken, so if it doesn't enter it will be broken as well
15:31:56 <yamahata> there are several bugs to be fixed.
15:31:59 <mkolesni> half broken basically l2 & l3 work fine
15:32:10 <mkolesni> the other stuff has bugs yeah
15:32:12 <mpeterson> so the question is do we want to keep the situation as it is where the basic works and some things don't? or bet for a potentially fix that might be more broken?
15:32:16 <yamahata> oxygen CI.
15:32:31 <yamahata> https://review.openstack.org/#/c/538352/
15:32:53 <mkolesni> i think it will be a problematic bet to make with the partial test coverage we have
15:33:21 <mkolesni> thats why i suggest we wait till we have better coverage and then we can know were fixing it properly
15:33:24 <mpeterson> yamahata: the link you sent is stable/pike
15:33:32 <yamahata> oops. wrong link
15:33:35 <manjeet> https://review.openstack.org/#/c/536935/
15:33:50 <mpeterson> mkolesni: okey, agree
15:34:13 <mpeterson> what do you guys think before you keep going on other topics?
15:34:34 <mpeterson> manjeet: and that one is already mergd
15:35:40 <mkolesni> yamahata, manjeet, poothia___ whats your thoughts on full sync/recovery refactor?
15:36:19 <poothia___> i guess the file with it's test case should be easy enough to review...
15:36:30 <yamahata> Given it's the size of modification, it's too daingerous for rush merge.
15:36:41 <manjeet> mkolesni, I think we should not merge those patches right away
15:37:01 <mpeterson> perfect
15:37:05 <manjeet> we should make sure it doesn't break anything critical and have enough tests before we merge
15:37:19 <mpeterson> #agree fullsync/recovery should not be merged for Queens
15:37:26 <yamahata> If we have volunteer to purse it, we can merge them now and backports them. But rajiv isn't active any more.
15:38:22 <manjeet> mkolesni, mpeterson oxygen CI is also broken, it fails on odl startup
15:38:24 <mpeterson> yamahata: like I said, last time I spoke with him he said he'll continue to contribute to networking-odl as much as he can during his free time
15:38:40 <mkolesni> ok so lets wait with full sync/recovery refactor for rocky cycle then
15:38:40 <mpeterson> manjeet: yes, it shouldn't have been merged in the first place...
15:38:53 <mkolesni> in the mean while we can focus on l3 flavors and the oxygen ci
15:39:20 <mpeterson> https://review.openstack.org/#/c/521692/
15:39:21 <yamahata> oxygen CI devstack fails because ODL config has been changed.
15:39:25 <yamahata> jetty.xml
15:39:37 <mpeterson> I think we should be revert this ^^
15:39:46 <mkolesni> also the tempest jobs are quite unstable now we need to give them some love
15:40:01 <mkolesni> yamahata, whats your proposition? can you fix this quickly?
15:40:06 <mpeterson> mkolesni: jhershbe_ will be helping with that
15:40:10 <yamahata> That's my position.
15:40:26 <yamahata> the cause of failure is known.
15:40:26 <mkolesni> yamahata, or should we revert it and merge once its actually working?
15:40:48 <yamahata> https://git.opendaylight.org/gerrit/#/c/51531/
15:41:18 <manjeet> mkolesni, mpeterson there's issue with openstack infra as well it wasn't dumping logs properly last week I checked
15:41:29 <mkolesni> yamahata, so do you have like a WIP fix?
15:41:41 <yamahata> networking-odl promis is to support networking-odl master + ODL master.
15:41:46 <yamahata> netvirt people depends on it.
15:41:46 <mkolesni> manjeet, do you know if its fixed already?
15:41:58 <yamahata> the fix will go to networking-odl/devstack.
15:42:01 <mpeterson> manjeet: they resolved it, their fs was full
15:42:21 <manjeet> mkolesni, ohk I haven't checked today
15:44:58 <manjeet> yamahata, with fix https://git.opendaylight.org/gerrit/#/c/51531/ if we force 8181 in networking-odl should it work ?
15:45:13 <yamahata> manjeet: yeah, that's my understanding.
15:45:42 <yamahata> oh no.
15:45:59 <manjeet> yamahata, I tried locally forcing 8181, it still didn't unless I messed up something else I think there are other issues as well than the port no
15:46:01 <yamahata> 8181 might be used by apache with horizon.
15:46:16 <mkolesni> 8081?
15:46:25 <yamahata> So we should add port 8087 to avoid port conflict
15:47:22 <yamahata> Ideally the port number shouldn't be changed unnecessarily because people depends on it.
15:47:35 <yamahata> or the change should be announce loudly.
15:48:07 <yamahata> In this case, we can just update jetty.xml to open port 8087.
15:48:24 <yamahata> simple sed like the current doesn't work, though.
15:48:25 <mpeterson> we are running out of time, who will take care of this and how?
15:49:10 <mpeterson> also, this means we will not revert the patch to re add it properly?
15:49:16 <yamahata> manjeet: will you do that? or I'll take care of it.
15:49:58 <manjeet> yamahata, sure I will submit a patch I guess I need to revert that patch https://git.opendaylight.org/gerrit/#/c/51531/ but it should have port 8087  instead of 8080
15:50:18 <mpeterson> #action manjeet will fix the oxygen jobs
15:50:27 <mpeterson> okey, moving on
15:50:51 <mpeterson> #action please review all links that were mentioned in this section that are important for queens and give them priority for review in the future
15:50:57 <mpeterson> #topic merged patches
15:51:22 <mpeterson> yamahata: there were a couple of patches that were merged with -1 or not fully polished
15:51:39 <mpeterson> https://review.openstack.org/#/c/523043/
15:51:39 <mpeterson> mkolesni asked for changes and -1, changes weren't made and the patch was accepted
15:51:43 <mpeterson> https://review.openstack.org/#/c/521692/
15:51:43 <mpeterson> Added the jobs in non-voting then why added them in the first place? Not to mention they are in a failing state...
15:51:46 <mpeterson> Also, there was a standing -1 at the time of merging.
15:51:46 <mpeterson> https://review.openstack.org/#/c/536502/
15:51:46 <mpeterson> mpeterson asked for tests and -1, the tests were not added and the patch was accepted
15:52:18 <mpeterson> yamahata: this kind of merge spree happens every once in a while and I think it's counterproductive
15:52:39 <mpeterson> as it is also +2 +W own patches
15:52:48 <mkolesni> we should avoid merging patches with inadequate testing
15:53:09 <yamahata> for fullsync/recovery, we decided not to merge them. let's revert them.
15:53:34 <yamahata> Now I issued reverts.
15:54:03 <mkolesni> i think theres no need since the changes were additive not disruptive
15:54:21 <mkolesni> unless you dont want the dead code there in which case we can revert and reintroduce
15:54:32 <mkolesni> but mpeterson was talking about something different
15:55:29 <mkolesni> https://review.openstack.org/#/c/538957/ <- this has a merge conflict?
15:55:32 <mpeterson> basically, I think we need to agree on no self approve patches nor patches that are pending -1
15:55:32 <yamahata> okay
15:56:01 <mkolesni> well at least if theres -1 we should give the original -1'ee a chance to reply
15:56:06 <mpeterson> obviously there might be exceptions and that's fine. But it can't be the commonality to have them
15:56:12 <mkolesni> like if we disagree with the -1
15:56:22 <mpeterson> mkolesni: exactly what I think
15:56:27 <mkolesni> lets say the -1 poster didnt answer the clain in a week then we can merge
15:56:30 <mkolesni> sounds fair?
15:56:36 <mkolesni> claim*
15:56:36 <mpeterson> obviously the commiters have the last decision and they can override that
15:56:47 <mpeterson> mkolesni: sounds fair
15:56:50 <yamahata> 1 week sounds fair.
15:56:55 <manjeet> +++
15:57:11 <yamahata> So I can expect your review/involvements, mkolesni ?
15:57:24 <mpeterson> #agree no more self approve patches nor patches that are pending -1 (with a 1 week grace period)
15:57:45 <mkolesni> ok then going forward if there's outstanding -1 we will reply to it and if its not replied in a week we can merge
15:58:16 <mkolesni> yamahata, yes of course
15:58:32 <mkolesni> last week i was sick but im catching up this week
15:58:55 <mkolesni> lets discuss at the ptg maybe we need more committers
15:59:25 <manjeet> 1 min left
15:59:34 <poothia___> mpeterson: i did not quite understand your comment.... on https://review.openstack.org/#/c/536392/ what direction should i prefer to patch this bug...
15:59:42 <mpeterson> yes, which topic should we tackle on that minute?
15:59:52 <mkolesni> cookies? :)
15:59:55 <mpeterson> poothia___: #topic patches/bugs
15:59:57 <mpeterson> oops
15:59:58 <mpeterson> #topic patches/bugs
16:00:09 <mpeterson> okey poothia___ I can continue with you on that after the meeting?
16:00:16 <mpeterson> I think we are done
16:00:16 <poothia___> sure...
16:00:20 <mpeterson> unless there is something urgent
16:00:26 <mpeterson> that you want to cover?
16:00:38 <poothia___> no i am free
16:00:42 <mkolesni> gtg
16:00:43 <mkolesni> bye
16:00:46 <mpeterson> yamahata, manjeet?
16:00:58 <manjeet> I think im done
16:01:00 <yamahata> none.
16:01:03 <mpeterson> #endmeeting