15:01:32 <yamahata> #startmeeting neutron_northbound
15:01:32 <odl_meetbot> Meeting started Mon Feb 12 15:01:32 2018 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:01:32 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:32 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:01:38 <yamahata> #chair poothia mkolesni
15:01:38 <odl_meetbot> Current chairs: mkolesni poothia yamahata
15:01:45 <yamahata> #topic agenda bashing and roll call
15:01:50 <yamahata> #info yamahata
15:01:59 <yamahata> Today what topics do we have?
15:02:11 <mkolesni> #info mkolesni
15:02:18 <yamahata> queens is rc and ODL is also rc.
15:02:35 <yamahata> so topics are final last minutes patch and planning for next cycles.
15:02:49 <mkolesni> sounds good
15:03:00 <yamahata> anything else?
15:03:02 <poothia_> #info poothia
15:03:59 <yamahata> seems nothing else.
15:04:01 <yamahata> move on
15:04:02 <rajivk> #info rajivk
15:04:07 <yamahata> hello rajivk
15:04:16 <rajivk> hello everyone
15:04:16 <yamahata> #topic Announcements
15:04:46 <yamahata> openstack queens is rc. and queens branch has been cut.
15:04:59 <yamahata> so only bug fixes will be backported to queens.
15:05:24 <yamahata> it also means that rocky branch is open. so we can merge holding patches.
15:05:43 <yamahata> ODL oxygen cycle is also RC. the branch isn't cut yet. but it's very near.
15:05:54 <yamahata> events.
15:06:26 <yamahata> openstack PTG is near. Feb 26 - Mar 2 in Dublin
15:06:36 <yamahata> the planning etherpad is at
15:06:45 <yamahata> https://etherpad.openstack.org/p/neutron-ptg-rocky  for neutron
15:06:55 <yamahata> https://etherpad.openstack.org/p/networking-odl-ptg-rocky for netwokring-odl
15:07:28 <yamahata> also for OpenDaylight Flourine, DDF(Developer Design Forum) will be held at ONS
15:07:49 <yamahata> Mar 25th in LA
15:07:58 <yamahata> the planning wiki page is at https://wiki.opendaylight.org/view/Events:Fluorine_Dev_Forum
15:08:22 <yamahata> If you're contributor to ODL, discount is available.
15:08:37 <yamahata> any other announcement?
15:09:20 <yamahata> Oh I forgot one more thing.
15:09:41 <yamahata> ODL Neutron northbound had new commiter. Michael and Josh.
15:09:49 <yamahata> So not it has three active committers.
15:10:59 <yamahata> it seems no other announcement. move on
15:11:00 <manjeetsb> Hi sorry for being late my laptop froze right after I logged in
15:11:24 <yamahata> manjeets: no problem. Now we have just annoucements. do you have any announcement?
15:11:25 <manjeetsb> Logged in from mobile
15:11:41 <manjeetsb> Not any
15:11:45 <yamahata> okay.
15:11:47 <yamahata> #topic action items from last meeting
15:12:08 <yamahata> Actually I skipped the last meeting. any action items? and anything to share?
15:12:35 <manjeetsb> I think last meeting was very quick
15:12:59 * yamahata trying to open the log. but can't find it.
15:13:34 <yamahata> mkolesni: any update?
15:13:52 <mkolesni> no there wasnt a formal meeting
15:14:05 <mkolesni> just request from rajivk to review his patche
15:14:08 <mkolesni> patches
15:14:30 <yamahata> I see. That's great. move on.
15:14:46 <yamahata> #topic queeens/oxygen RC
15:15:03 <yamahata> For queens/oxygen do we have any patches to backport?
15:15:39 <yamahata> we have openstack bot patches.
15:16:15 <yamahata> any critical patches?
15:16:32 <yamahata> For queens, we slipped fullsync/recovery and l3 flavor.
15:16:44 <rajivk> yamahata, so funll sync and recovery patches are not planned for this release?
15:16:48 <mkolesni> it will have to be implemented in rocky
15:16:50 <rajivk> okay
15:16:51 <yamahata> So I hope they will be merged early rocky cycle.
15:17:06 <rajivk> I hope so too.
15:17:14 <yamahata> Unfortunately we didn't made fullsync/recovery due to time.
15:17:27 <rajivk> We brought those patches because nec had use case
15:17:45 <rajivk> they wanted it in ocata and i communicated it earlier as well
15:18:19 <rajivk> now, if those are merged in rocky they won't be backported to ocata
15:18:41 <mkolesni> im not sure they couldve been backported its quite large changes anyway
15:18:47 <rajivk> Could they be backported by some means?
15:19:12 <rajivk> it was discussed earlier
15:19:25 <yamahata> It depends on weather they can be bug fixes or not.
15:19:27 <rajivk> that if there is no db migration they can be
15:19:51 <yamahata> Actually main patches were merged. so remaining parts are each fixing up each drivers, right?
15:20:07 <mkolesni> not quite just the base was merged
15:20:11 <rajivk> yes, i think.
15:20:36 <mkolesni> theres also patches to change the behavior of full_sync and recovery once everything is in
15:21:18 <rajivk> mkolesni, but they won't be merged?
15:21:44 <mkolesni> they will of course after the review is done
15:22:03 <rajivk> but ocata will be out of life, am i right?
15:22:10 <mkolesni> im just not sure stable maintainers will be keen to backport such big changes, thats all im saying
15:22:13 <yamahata> Let's respin/merge remaining patches into master(Rocky) and then see if they are back-portable or not.
15:22:58 <yamahata> It's up to neutron maintainer team. We need to persuade them that they're suitable for backport.
15:23:08 <rajivk> actually "if" show probability :)
15:23:40 <rajivk> okay, let's continue other topics
15:23:56 <mkolesni> sure
15:24:30 <manjeetsb> Tempest jobs are broken
15:24:51 <yamahata> manjeets: do you mean for queens branch?
15:25:28 <manjeetsb> Yes for master CI, tempest carbon and nitrogen failure is 100% now
15:25:50 <yamahata> manjeets: stable/queens branch has been cut. master=rocky now.
15:26:07 <manjeetsb> Ohk they were broken for queens as well
15:26:22 <yamahata> anyway please go ahead
15:27:13 <yamahata> Have you dig them down?
15:28:09 <manjeet> no i did n't get chance to dig them
15:28:41 <manjeet> its happening since we adopted neutron-tempest-plugin
15:29:22 <yamahata> mkolesni: do you have any chance on it? I rememver you two discussed about several test cases are unstable to disable.
15:29:22 <mkolesni> theres 2 i think are failing constantly, some others fail at random
15:29:45 <mkolesni> i commented on the patch to make it voting again, but i dont remember right now
15:29:49 <mkolesni> let me dig it up
15:29:54 <manjeet> mkolesni, that;s right
15:30:24 <yamahata> Cool.
15:30:47 <mkolesni> I see the constant failures are:
15:30:47 <mkolesni> neutron_tempest_plugin.api.test_revisions.TestRevisions.test_update_network_constrained_by_revision
15:30:47 <mkolesni> neutron_tempest_plugin.scenario.test_floatingip.DefaultSnatToExternal.test_snat_external_ip
15:30:47 <mkolesni> Perhaps these should be added to skip list with a TODO so that we can get back on track and these specific failures should be examined in parallel?
15:31:00 <mkolesni> thats my comment on https://review.openstack.org/#/c/532480/
15:31:15 <mkolesni> unfortunately mpeterso is on study trip right now so he isnt working on it
15:31:22 <mkolesni> he will be back to work next week
15:32:01 <manjeet> mkolesni, would it be possible to go for a fix rather than skipping them ?
15:32:19 <mkolesni> i think disabling will be faster
15:32:26 <mkolesni> then fix could take a while
15:32:29 <manjeet> ohk
15:32:42 <mkolesni> but if you have a fix in mind we can review it
15:33:20 <manjeet> i'll check if I got cycles i'll try to dig on the revision test
15:33:48 <manjeet> for meantime you can go ahead and add them to skip list
15:34:03 <mkolesni> ok
15:34:53 <yamahata> anything else? or move on?
15:35:01 <mkolesni> lets move on
15:35:22 <yamahata> #topic Rocky/Fluorine planning
15:35:34 <yamahata> we have several topic proposed for PTG
15:35:40 <yamahata> https://etherpad.openstack.org/p/neutron-ptg-rocky
15:35:44 <yamahata> https://etherpad.openstack.org/p/networking-odl-ptg-rocky
15:35:58 <yamahata> For neutron, we have l3 flavor
15:36:06 <yamahata> for networking-odl specific, we have several topics
15:36:27 <mkolesni> we need to remove v1 driver
15:36:48 <mkolesni> do we also want to rename everything to not have v2 suffix?
15:36:52 <yamahata> mkolesni: please put it into etherpad. Yes, we'd like to remove them.
15:37:08 <yamahata> yeah clean up to devstack config.
15:37:15 <mkolesni> i think renaming is nice to have but will have little gain and lots of work so generally im not for it
15:37:36 <mkolesni> no i mean like rename the modules/classes/etc
15:37:50 <yamahata> do you mean devstack config?
15:37:59 <mkolesni> no the code
15:38:21 <yamahata> v2 prefix in class name or module name?
15:38:27 <yamahata> s/prefix/postfix/
15:39:07 <mkolesni> i.e. s/OpenDaylightTrunkDriverV2/OpenDaylightTrunkDriver/
15:39:28 <mkolesni> git mv networking_odl/ml2/mech_driver_v2.py networking_odl/ml2/mech_driver.py
15:39:30 <mkolesni> and so on
15:39:48 <mkolesni> i think it will mostly create noise but not much gain so im not enthusiastic about it
15:39:50 <yamahata> sounds reasonable. please go create patches.
15:40:06 <mkolesni> but im asking because i want to hear opinions
15:40:11 <manjeet> +1
15:40:19 <mkolesni> ill add it to the ptg discussion and we can discuss this further there
15:40:20 <yamahata> I'm not so favor for it. but I have no strong opinion there.
15:40:22 <manjeet> would make sense to do that after removing v1
15:40:56 <manjeet> but no strong preference we can live with v2 postfixes as well
15:41:59 <yamahata> any other topics?
15:42:33 <mkolesni> i dont know if these were done
15:42:36 <mkolesni> (mpeterso) DB Transaction handling (move them away from the module, db.py)
15:42:36 <mkolesni> (mpeterso) DB migrate from legacy neutron pattern (use of sessions) to the new enginefacade pattern (use of contexts) ( http://specs.openstack.org/openstack/oslo-specs/specs/kilo/make-enginefacade-a-facade.html )
15:42:54 <mkolesni> so ill add them and check with mpeterso once hes back
15:43:03 <yamahata> Cool.
15:43:26 <mkolesni> More & better functional testing: cover more resources. e.g. QoS, other drivers, fullsync & recovery (mkolesni, mpeterso), port status update (jhershbe?)
15:43:52 <mkolesni> this is also remaining and also some other things related to testing/ci
15:44:32 <yamahata> #action mkolesni add several topics to planning etherpad
15:44:36 <jhershbe> mkolesni, I'm game just stuck in a different meeting right now
15:44:52 <mkolesni> i think we will need to evaluate and see whats missing
15:45:37 <mkolesni> https://etherpad.openstack.org/p/networking-odl-queens-ptg#L84
15:45:58 <mkolesni> theres probably more things we need from there
15:46:16 <yamahata> that's nice to check left-overs.
15:46:36 <mkolesni> (yamahata) removing v1 drivers after l3 flavor is done
15:46:54 <mkolesni> you mean the old l3 plugin right not related to v1 vs v2?
15:47:22 <mkolesni> i.e. the l3_odl_v2 module?
15:47:34 <yamahata> they will be deprecated/removed by l3 flavor driver.
15:47:57 <mkolesni> ok but not related to the v1 drivers deletion, correct?
15:48:00 <manjeet> i'd vote to still keep l3_odl_v2 atleast for rocky
15:48:06 <mkolesni> unless you want to keep it for l3?
15:48:28 <yamahata> Ah right l3_odl.py will be removed.
15:48:37 <mkolesni> manjeet, so do you suggest l3 flavor as sort of 'tech preview' in rocky?
15:49:02 <mkolesni> probably we would want to mark l3_odl_v2 deprecated to alert that flavors should be used
15:49:17 <manjeet> mkolesni, yes once confirmed it's better than we can remove l3_odl_v2 in next release
15:49:33 <mkolesni> +1
15:49:45 <rajivk> i think, there was one more task for ut. enabling other project's uts, something like this. Is that one added?
15:50:18 <yamahata> ut= unit tests? we should add it.
15:50:19 <mkolesni> rajivk, it was to run tempest from neutron but that was achieved (with failures, but still...)
15:50:44 <mkolesni> so in terms of CI would we want 2 CI one with flavors and one with l3_odl_v2?
15:50:45 <yamahata> neutron tempest yes. but not for neutron-xxx.
15:50:52 <mkolesni> or would it be just flavors in CI
15:51:31 <yamahata> mkolesni: do you want to keep two for comparison. you can go ahead.
15:51:38 <mkolesni> yamahata, im not aware of tempest tests in other projects that we will want, but if there are any please add an item
15:51:50 <rajivk> https://etherpad.openstack.org/p/networking-odl-queens-ptg#L64
15:51:55 <mkolesni> im just asking whats the opinion
15:52:31 <mkolesni> rajivk, ah thats a general point to add more tests, but i dont know if manjeet got to it or not
15:53:02 <yamahata> we can simply add l3 flavor setting with oxygen and see if it's stable.
15:53:19 <mkolesni> ok
15:53:38 <yamahata> I suppose version combination will be (oxygen and flourine) + rocky l3 flavor
15:53:50 <yamahata> We'd like to keep old combination untouched.
15:54:14 <mkolesni> ok i guess that sounds good
15:54:42 <mkolesni> i thought flourine?
15:54:50 <mkolesni> oxygen can probably not move
15:55:03 <mkolesni> but whatever i dont have a strong opinion here
15:55:11 <mkolesni> just its good to have a base line, you know
15:55:16 <yamahata> Probably only with flourine.
15:55:18 <mkolesni> some base line
15:55:30 <manjeet> actually we have to keep l3_odl_v2 because to enable flavors in tempest test it would need to modify existing tests
15:55:40 <yamahata> we will see show flourine is stable.
15:55:56 <yamahata> Historically netvirt early phase is unstable.
15:56:20 <manjeet> because flavors needs to specified explicitly into creation of fips and routers
15:57:14 <mkolesni> manjeet, thats a good point can u add it to the etherpad?
15:58:36 <yamahata> manjeet: you're adding old one.queens. please add it to rocky etherpad.
15:58:52 <manjeet> oh damn
15:59:08 <manjeet> thanks yamahata
15:59:18 <yamahata> we're running out of time.
15:59:23 <yamahata> any other topic?
15:59:26 <rajivk> I was thinking, networking-odl needs one more core reviewer. There are a lot of patches pending, it will speed up process. What do you guys think?
15:59:47 <yamahata> we'll have a meeting on Feb 19. Feb 26 will be skipped due to PTG.
16:00:03 <yamahata> rajivk: Yeah, actually I was planning to raise at PTG.
16:00:05 <mkolesni> yes that sounds like a good idea lets discuss it next time
16:00:11 <mkolesni> or at the ptg
16:00:36 <yamahata> okay last topics
16:00:37 <yamahata> #topic open mike
16:00:55 <yamahata> any topics or can we close?
16:01:11 <yamahata> going once
16:01:17 <yamahata> going twice
16:01:25 <yamahata> okay, thank  you everyone.
16:01:29 <yamahata> see you next week
16:01:38 <yamahata> #topic cookies
16:01:45 <yamahata> #endmeeting