15:02:41 <yamahata> #startmeeting neutron_northbound
15:02:41 <odl_meetbot> Meeting started Mon Mar 12 15:02:41 2018 UTC.  The chair is yamahata. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:41 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:41 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:02:49 <yamahata> #chair manjeets poothia
15:02:49 <odl_meetbot> Current chairs: manjeets poothia yamahata
15:02:57 <yamahata> #topic agenda bashing and roll call
15:02:59 <yamahata> #info yamahata
15:03:03 <manjeets> #info manjeets
15:03:06 <poothia> #info poothia
15:03:08 <rajivk> #info rajivk
15:03:15 <yamahata> #chair rajivk
15:03:15 <odl_meetbot> Current chairs: manjeets poothia rajivk yamahata
15:03:19 <mkolesni> hey, mpeterson is not here afaik
15:03:26 <mkolesni> i have to skip today's meeting
15:03:34 <mkolesni> please go on without me
15:03:36 <yamahata> mkolesni: okay.
15:03:45 <mkolesni> we will be in full attendance next week
15:04:03 <yamahata> today we'd like to follow up the PTG.
15:04:16 <yamahata> especially on project management.
15:04:26 <yamahata> any other topics?
15:05:11 <yamahata> seems nothing else. move on
15:05:16 <yamahata> #topic Announcements
15:05:44 <yamahata> there was openstack PTG. several discussion there.
15:05:56 <yamahata> ODL oxygen is RC. it's not released yet.
15:06:29 <yamahata> ODL DDF is planned at ONS in LA at the end of march.
15:06:37 <yamahata> any other annoucement?
15:07:42 <yamahata> seems nothing. move on
15:07:44 <yamahata> #topic action items from last meeting
15:07:52 <yamahata> actually we don't have irc meeting last week.
15:08:01 <yamahata> #topic PTG follow up
15:08:20 <yamahata> we had two topic on project managment.
15:08:35 <yamahata> one is to add core and another is to chair this irc meeting.
15:09:05 <yamahata> regarding to core, we discussed about adding mpeterson and manjeets for faster review.
15:09:53 <yamahata> on irc meeting, we'd like to experiment to have those two chair this irc meeting bi-weekly as experiment.
15:10:03 <yamahata> any thoughts/opinions?
15:10:21 <yamahata> Today unfortunately we don't have mpeterson. but how about manjeets ?
15:10:51 <manjeets> yamahata, +1 for bi weekly chair thing
15:11:23 <yamahata> cool. then next week, will you chair this meeting?
15:11:44 <manjeets> sure ~
15:12:03 <rajivk> yamahata, are you leaving planning to leave the project?
15:12:37 <yamahata> rajivk: Right now I'm split into many project not only openstack, odl, but also ONAP. so I need to off-load.
15:12:48 <yamahata> I'm shifting.
15:12:57 <yamahata> But I'll stay in the community.
15:13:13 <rajivk> Openstack community?
15:13:17 <yamahata> yes.
15:13:24 <yamahata> and ODL.
15:13:37 <rajivk> okay
15:14:47 <yamahata> any other comments?
15:15:16 <rajivk> no
15:15:30 <yamahata> we've done project mgmt part. next is tech discussion.
15:15:36 <yamahata> the result can be found at etherpad.
15:15:42 <yamahata> https://etherpad.openstack.org/p/neutron-ptg-rocky
15:15:54 <yamahata> https://etherpad.openstack.org/p/networking-odl-ptg-rocky
15:16:09 <yamahata> at neutron session, we had discussion about
15:17:04 <yamahata> unit test, l3 flavor, and sharing code with other project(OVN and dragon flow)
15:17:27 <yamahata> unit test and l3 flavor, I suppose you know about it. Just to ask the community for help.
15:17:50 <yamahata> for L3 flavor, callback priority is the direction. so let's drive patches for the direction.
15:18:08 <yamahata> for unit test, no clear conclusion. just to raise the issue in the community.
15:18:29 <yamahata> for sharing code, mkolesni raised that we can share syncing code with ovn(and other projects.)
15:18:47 <manjeets> yamahata, so where will code reside in neutron-lib ?
15:19:00 <yamahata> yes, maybe.
15:19:13 <rajivk> are we planning to change approach of syncing journal?
15:19:38 <rajivk> could someone describe what part has to be planned to share and what projects?
15:19:43 <yamahata> maybe if the code sharing goes well.
15:20:13 <yamahata> It would take time. and long term. So I think the current WIP patches should be completed anyway.
15:20:51 <yamahata> Now  ovn has its own logic to track the diff between neutron db and backend by using revision number.
15:21:04 <yamahata> So mkolesni is thinking that we can utilise it.
15:21:24 <yamahata> mkolesni: he'd like to go for that direction.
15:21:58 <yamahata> this week we don't have mkolesni. he can explain it next week.
15:21:58 <rajivk> pros and cons have been discussed in PTG?
15:23:02 <yamahata> Actually no. There only ovn guys explained their design and how the logic can be shared.
15:23:31 <yamahata> and mkolesni stepped up to drive it in networking-odl. It's his responsibility to persuade others in networking-odl.
15:23:51 <manjeets> yamahata, wouldn't it make sense to figure put pros and cons before just start using it ?
15:24:02 <yamahata> Yes, it makes sense.
15:24:31 <yamahata> manjeets: you're a chair next week. so can you please have the topic next week with him.
15:24:44 * manjeets takes a note
15:25:59 <yamahata> any other thoughts/comments?
15:27:12 <yamahata> oh also we scrubbed bug reports.
15:27:17 <yamahata> move on
15:27:24 <yamahata> #topic Rocky/Fluorine planning
15:27:29 <yamahata> any patches/bugs to discuss?
15:28:11 <rajivk> yamahata, i would like to get your comment on ML2 driver full sync
15:28:28 <yamahata> #action yamahata review https://review.openstack.org/#/c/527391/
15:28:30 <yamahata> sure
15:28:30 <rajivk> there are two things being discussed from manjeets and mpeterson
15:29:45 <yamahata> gotcha. I'll look at it.
15:30:31 <yamahata> any other patches/bugs to discuss?
15:31:04 <yamahata> seems nothing else. move on
15:31:09 <yamahata> #topic open mike
15:31:12 <yamahata> anything else?
15:31:22 <yamahata> or I'll give you back 30mins.
15:31:54 <yamahata> thank you everyone.
15:31:56 <manjeets> thanks
15:31:59 <poothia> thanks
15:32:00 <yamahata> see you next week.
15:32:05 <rajivk> thanks
15:32:06 <yamahata> #topic cookies
15:32:10 <yamahata> #endmeeting