15:00:48 <manjeets> #startmeeting neutron_northbound
15:00:48 <odl_meetbot> Meeting started Mon Mar 19 15:00:48 2018 UTC.  The chair is manjeets. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:00:48 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:48 <odl_meetbot> The meeting name has been set to 'neutron_northbound'
15:00:49 <mpeterson> hi!
15:01:30 <manjeets> #topic announcements
15:01:30 <rajivk> Hi
15:01:47 <manjeets> #chair mkolesni rajivk yamahata mpeterson
15:01:47 <odl_meetbot> Current chairs: manjeets mkolesni mpeterson rajivk yamahata
15:01:59 <poothia> hi
15:02:33 <manjeets> only announcement I have is we are working on l3 flavors and patch in neutron-lib to implement callback priority is close
15:02:43 <manjeets> reviews are very welcome
15:03:02 <jhershbe> #info jhershbe
15:03:07 <manjeets> any announcements from PTG yamahata ?
15:03:32 <yamahata> no additional announcements
15:03:39 <mkolesni> whos going to ons?
15:03:46 <manjeets> mkolesni, Im going
15:03:50 <yamahata> Oh, Isaku will.
15:04:34 <manjeets> we have ODL dev forum on sunday, march 25th
15:04:56 <manjeets> #chair jhershbe poothia
15:04:56 <odl_meetbot> Current chairs: jhershbe manjeets mkolesni mpeterson poothia rajivk yamahata
15:05:28 <mkolesni> cool
15:05:41 <mkolesni> im not going unfortunately, but i wish you a good conference
15:05:52 <mkolesni> so are we skipping next monadys meeting?
15:05:56 <manjeets> :( mkolesni thanks !
15:06:03 <manjeets> we can unless someone can chair
15:06:59 <manjeets> lets move on to patches
15:06:59 <mkolesni> i think we can skip it since people will be at ons and also it's the cycle start in openstack so there's no pressure
15:07:17 <manjeets> ok
15:07:30 <manjeets> #topic patches_networking_odl
15:07:41 <manjeets> any notable patches or bugs ?
15:08:01 <rajivk> yes, https://review.openstack.org/#/c/527391/
15:08:44 <manjeets> there are couple of things to this first is we need consensus on tests
15:08:49 <manjeets> right mpeterson  ?
15:09:10 <rajivk> yes, i also need it. Because it is delaying the patch.
15:09:14 <manjeets> second can we get reviews mkolesni, yamahata on this ^^ to move forward
15:09:22 <mpeterson> manjeets: yes, I have put some comments because I think the complexity of the tests is high
15:09:41 <mpeterson> rajivk is currently blocked because he needs more input
15:09:51 <rajivk> +1
15:09:56 <mpeterson> because my view might be subjective
15:09:58 <mkolesni> i will take a look this week
15:10:15 <mpeterson> and thus I'd like manjeets mkolesni and yamahata to review and comment
15:10:23 <mpeterson> also with ideas on how to unblock it
15:10:26 <yamahata> sure, will review it.
15:10:39 <mkolesni> ok
15:10:43 <manjeets> #action mkolesni, yamahata , manjeets  to review Ml2 for new full sync
15:10:51 <rajivk> please review it because it has been pending for a long time
15:11:04 <manjeets> ok lets move on !
15:11:09 <manjeets> #topic bugs
15:11:12 <mpeterson> yeah, and specially now that rajivk is giving up his free time to do it. THat's even more loable
15:11:26 <manjeets> any notable bugs which we should care about
15:11:27 <manjeets> ?
15:11:53 <rajivk> yes
15:12:03 * manjeets thinks networking-odl team should spend some time on giving feedback on bugs reported to launchpad
15:12:20 <rajivk> One of the guy contacted me for dscp marking rule patch
15:12:23 <manjeets> like triaging or marking them with proper label
15:12:30 <manjeets> rajivk, patch link ?
15:12:43 <mkolesni> yamahata and i did some bug triage on the ptg
15:12:44 <rajivk> https://review.openstack.org/#/c/529537/2/doc/source/contributor/odl_feature.rst
15:13:08 <mkolesni> however we can dedicate the Apr 2nd meeting to do a group bug triage
15:13:30 <rajivk> this patch https://review.openstack.org/#/c/460470/ worked for him.
15:13:31 <manjeets> mkolesni, sounds like a good idea !
15:14:21 <mkolesni> #action Apr 2nd meeting will be bug triage (mkolesni, mpeterson, manjeets, yamahata, rajivk, poothia)
15:14:49 <manjeets> rajivk, https://review.openstack.org/#/c/529537/2 got some feedback, I'll review it today
15:15:00 <manjeets> #action manjeets to review https://review.openstack.org/#/c/529537/
15:15:24 <rajivk> mkolesni, could you please look again into https://review.openstack.org/#/c/460470/ and comment on it. of course everyone's review is required because at later stage changing everyhing waste a lot of time.
15:15:47 <rajivk> sorry this one https://review.openstack.org/#/c/529537/2/doc/source/contributor/odl_feature.rst
15:17:21 <mkolesni> rajivk, you mean https://review.openstack.org/#/c/519513/ ?
15:18:15 <mkolesni> rajivk, re https://review.openstack.org/#/c/529537/2/doc/source/contributor/odl_feature.rst i see you wrote you understood but theres no new patch set
15:18:24 <rajivk> they are all the same thing, this patch is duplicating everything
15:18:34 <mkolesni> rajivk, what is it you need there?
15:19:15 <rajivk> I want you to look into it again, let me know what do you mean by "list inside the list".
15:19:35 <rajivk> I have some understanding but it might be wrong, which will result in waste of my effort
15:19:51 <manjeets> afaik they sounds similar the idea is to fetch supported qos rules from ODl instead of hard coding in networking-odl
15:19:56 <manjeets> right rajivk ?
15:20:40 <mkolesni> rajivk, theres already an api to fetch supported features from odl
15:20:56 <mkolesni> rajivk, these capabilities should be represented there
15:21:03 <mkolesni> rajivk, that was the meaning
15:21:04 <rajivk> yes, but there is more discussion on how to do it. Please go through it.
15:21:46 <rajivk> sorry this one was for manjeets
15:21:59 <mkolesni> sure
15:22:54 <rajivk> mkolesni, there is discussion on ds for the features
15:23:12 <rajivk> i want comment on that
15:24:11 <rajivk> please provide comment on patch. We can continue discusison other patches
15:24:25 <mkolesni> ok
15:25:10 <manjeets> ok lets move onto CI health
15:25:16 <manjeets> #topic CI_health
15:25:33 <manjeets> mpeterson, whats the progress on making tempest jobs voting ?
15:25:50 <mpeterson> manjeets: I actually stopped working on that one for now...
15:26:15 <poothia> i have a question... is pep8 failing in some cases or in every case?
15:26:25 <mpeterson> poothia: every case
15:26:37 <poothia> ok thanks
15:26:45 <manjeets> mpeterson, is it delayed or postponed for some other work ?
15:26:54 <mpeterson> poothia: I think it's an issue with six that got updated
15:26:59 <manjeets> oh pep8 is broken
15:28:20 <mpeterson> manjeets: I postponed while I continue migrating DB usage to the enginefacade
15:28:42 <manjeets> mpeterson, ok !
15:28:47 <mpeterson> manjeets: there were issues with the overall infra and got fed up a bit, so I moved into another task
15:29:28 <manjeets> mpeterson, agree on infra wasn't nice last couple of weeks !
15:29:55 <manjeets> ok ! once infra is green are we still targeting go get tempest jobs voting ?
15:30:33 <mpeterson> manjeets: I'll pick that up when I'm done with the enginefacade migration... shouldn't be too far away in time...
15:30:47 <manjeets> mpeterson, sounds good thanks !
15:30:47 <mpeterson> manjeets: and enginefacade is also quite important
15:30:52 <manjeets> mpeterson, +1
15:31:27 <mkolesni> what about the pep8?
15:32:03 <manjeets> I haven't looked at that yet, mpeterson might have better idea
15:32:52 <mpeterson> mkolesni: either the linter or six doesn't like the way we import things
15:33:17 <manjeets> http://logs.openstack.org/47/549847/2/check/openstack-tox-pep8/6937c30/job-output.txt.gz#_2018-03-19_13_44_17_319161
15:33:29 <mpeterson> mkolesni: I think it's six, but I started talking with Mike Bayer and got distracted
15:34:25 <manjeets> lets figure this pep8 out today and unbreak CI
15:34:50 <mpeterson> manjeets: that's something else, unrelated to the general problem
15:35:38 <manjeets> mpeterson, ohk so are we dependent on some other fix then ?
15:36:06 <mpeterson> manjeets: something not commited, volunteers are accepted or I'll try to fix it in a while
15:36:52 <manjeets> mpeterson, if I get chance today I'll also look into that and notify in this channel if I did
15:37:45 <manjeets> I also proposed a patch to retire carbon jobs https://review.openstack.org/#/c/545473/ I need to revise this though
15:37:59 <mpeterson> manjeets: it's actually a really trivial patch but I'm focused on a problem with the patch I'm working on and don't want to lose the concentration
15:38:15 <poothia> https://www.irccloud.com/pastebin/z0L9QsMb/
15:38:17 <manjeets> mpeterson, ok !
15:38:22 <mpeterson> on a different topic, yamahata I need you to review the comments here https://review.openstack.org/#/c/538977
15:38:24 <mkolesni> manjeets, are you going to add flourine job?
15:38:37 <yamahata> mpeterson: sure. will do
15:38:47 <manjeets> yamahata, has a patch proposed I'll review it today
15:38:48 <mpeterson> poothia: yup, that's exactly the thing that needs fixing...
15:39:09 <poothia> so if we fix this... it should work right?
15:40:05 <manjeets> poothia, give it a try, are you volunteering to fix this ?
15:40:32 <poothia> yup, i'll put a patch in half an hour
15:40:43 <manjeets> cool thanks poothia
15:40:50 <mpeterson> poothia: basically they moved things around in six and fixing it is as easy as just modifying the import to the new location
15:41:11 <poothia> yeah, i thought so too but i was not sure
15:41:42 <manjeets> #action poothia to fix pep8 import issues
15:41:54 <manjeets> alright lets move on !
15:42:18 <manjeets> do you guys think we should make oxygen (fullstack/functional) voting sometime soon ?
15:43:00 <mkolesni> manjeets, they stable?
15:43:10 <mpeterson> yamahata: re https://review.openstack.org/#/c/538977/ I answered why they are hardcoded... they don't make any sense to be configurable
15:43:27 <yamahata> mpeterson: why not?
15:43:49 <mpeterson> yamahata: because the debugger don't work if you configure that to anything else than those values... it basically breaks functionality
15:44:09 <manjeets> mkolesni, they look green on many patches yet I need to look grafana for them
15:45:09 <mkolesni> manjeets, i look the last 30 days, they look good
15:45:12 <yamahata> mpeterson: with remote-pdb, debugger can work and quite helpful.
15:45:53 <manjeets> mkolesni, so we can make them voting ?
15:46:02 <mkolesni> manjeets, +1 from me
15:46:30 <mpeterson> yamahata: and with those hardcoded values it would break the remote-pdb functionality?
15:47:06 <mpeterson> yamahata: for example, the timeout would affect remote-pdb as well
15:47:32 <yamahata> then, the timeout should also be configurable.
15:48:36 <mpeterson> yamahata: I don't think you are paying attention to what I'm saying... with timeout != 0 then you won't be able to properly debug... that's why it has to be hard coded...
15:49:19 <yamahata> we can set timeout very large value.
15:49:41 <yamahata> and log, stdout, stderr are also sometimes useful. those shouldn't be discarded unconditionally.
15:50:04 <mpeterson> yamahata: they are not being discarded... it's hardcoded to 0 which means SHOW THEM TO ME
15:50:16 <mpeterson> yamahata: not discarded at all...
15:50:32 <mpeterson> yamahata: timeout = 0 means unlimited (as in NO TIMEOUT)
15:50:35 <yamahata> or they are too noisy sometimes. in that case we'd like to discard them.
15:50:48 <mkolesni> yamahata, i believe that mpeterson means that if you capture those then a local debugger will not work properly since it won't output anything to the console, etc
15:51:06 <mpeterson> it's debugging, you don't want to discard them
15:51:41 <yamahata> it depends.
15:53:41 <mpeterson> I propose we merge them hardcoded and then when and if someone needs that then it can be refactored
15:53:55 <mkolesni> yamahata, mpeterson i was just about to say the same thing
15:53:59 <mpeterson> because it seems to me that is adding a feature that's never going to be used
15:54:15 <yamahata> it's quite easy to make the configurable.
15:54:17 <mpeterson> and minimalist code and then refactoring is healthy
15:54:39 <yamahata> You can just make them configurable.
15:55:22 <mpeterson> yamahata: I know it is, but it's missing the point of not introducing features that aren't needed... we follow that philosophy in the code in python all the time... why not here?
15:56:13 <yamahata> they are necessary as I've claimed from the begining.
15:56:44 <manjeets> ohk lets continue discussion on patch itself ! we're almost on time
15:56:58 <manjeets> #topic open_mic
15:57:10 <manjeets> anything else from anyone ?
15:58:00 <mkolesni> manjeets, maybe you can review that patch?
15:58:08 <mkolesni> manjeets, mediate
15:58:55 <manjeets> mkolesni, added to review list ! i'll try to do it today
15:59:04 <mkolesni> cool thanks :)
15:59:25 <manjeets> alright ! thanks guys you can continue discussion after meeting
15:59:31 <manjeets> #end meeting
15:59:41 <mkolesni> thanks manjeets !
15:59:48 <manjeets> yamahata, how do you end meeting with bot ?
15:59:50 <poothia> thanks :)
15:59:57 <mpeterson> #end_meeting
16:00:02 <mpeterson> nope
16:00:03 <mpeterson> haha
16:00:05 <mkolesni> lol
16:00:10 <manjeets> haha
16:00:15 <mkolesni> only isaku knows :)
16:00:21 <mpeterson> #endmeeting