15:06:11 <manjeets> #startmeeting opendaylight neutron
15:06:11 <odl_meetbot> Meeting started Mon May  7 15:06:11 2018 UTC.  The chair is manjeets. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:06:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:06:11 <odl_meetbot> The meeting name has been set to 'opendaylight_neutron'
15:06:30 <manjeets> #topic Agenda
15:07:02 <manjeets> any items you guys like to discuss ?
15:07:22 <mpeterson> CI carbon/flourine
15:07:24 <manjeets> i have one retiring carbon jobs and adding fluorine jobs
15:07:33 <mpeterson> haha great minds think alike
15:07:41 <manjeets> :D
15:08:02 <manjeets> alright #topic CI carbon/fluorine jobs
15:08:08 <manjeets> #topic CI carbon/fluorine jobs
15:08:16 <mpeterson> and obviously the spec, which we need to discuss again :)
15:08:29 <manjeets> for sure
15:08:33 <mpeterson> so... basically carbon is failing and I've disabled it...
15:08:51 <manjeets> patch to retire carbon jobs is already proposed
15:09:02 <mpeterson> yes, but it's after flourine is added
15:09:56 <mpeterson> and also now that we are at it, oxygen is non-voting
15:09:59 <manjeets> yes, isaku mentioned it would be great to keep up master on ODL side
15:10:18 <manjeets> so can we add non voting for fluorine as well ?
15:10:27 <mpeterson> so... do you think we can make oxygen voting and also add flourine and voting?
15:10:46 <mpeterson> why non-voting? that uses resources from the CI and it doesn't make a difference
15:10:47 <mkolesni> mpeterson, how does grafana for oxygen look?
15:11:13 <manjeets> i think oxygen functional and fullstack can be made voting
15:11:13 <mkolesni> if grafana seems reasonable then it should be voting
15:11:29 <manjeets> oxygen-tempest is not ready for sure
15:12:34 <mpeterson> mkolesni: same as the others as far as I'm concerned... http://grafana.openstack.org/dashboard/db/networking-odl-failure-rate
15:13:06 <mpeterson> manjeets: yeah, tempest is not working at all for any of the jobs
15:13:40 <mpeterson> manjeets: oxygen doesn't seem to be in the Gate queue?
15:14:33 <manjeets> its non voting right ?
15:15:21 <manjeets> manjeets, should we first add it to gate queue ?
15:16:13 <mpeterson> manjeets: mmm weird, I see it in the gate queue but not information on grafana about it.... probably it was forgoten by whoever add the oxygen jobs
15:17:08 <mpeterson> manjeets: can you 0) retire carbon; 1) add it to grafana; 2) make them voting; 3) same for flourine;
15:17:11 <mpeterson> ?
15:17:45 <manjeets> fullstack/functional looks good enough
15:18:09 <manjeets> retiring carbon is already there https://review.openstack.org/#/c/545473/
15:18:34 <mkolesni> tempest tests seem to be failing all the time now, has somebody looked at it?
15:18:35 <manjeets> adding oxygen to grafana gate queue and making fullstack/functional voting
15:18:47 <mpeterson> manjeets: perhaps putting it before the flourine? :)
15:19:06 <manjeets> mpeterson, sure i'll do that
15:19:20 <mpeterson> mkolesni: no, until we take the time to stabilize tempest correctly and make it reliable there is no point in even looking at them
15:20:29 <manjeets> looking at oxygen logs there are 2 tests failing atm
15:20:31 <manjeets> http://logs.openstack.org/42/565842/1/check/networking-odl-tempest-oxygen/2d16476/testr_results.html.gz
15:20:44 <manjeets> any volunteers to take a look ?
15:21:28 <mkolesni> mpeterson, i disagree i beleive the tempest tests currently provide the most value and as such should be voting
15:22:04 <mkolesni> theyre the only tests that actually tests openstack+ODL end to end
15:22:05 <mpeterson> mkolesni: you misunderstood me... I also believe they provide the most value but they haven't been stable for a long time...
15:22:12 <mkolesni> at least the scenario tests
15:22:22 <mpeterson> mkolesni: I guess they are now stable at always failing, if you want to be technically correct XD
15:22:48 <mkolesni> fine so lets skip the constantly failing ones, and open them as bugs that should be fixed
15:23:16 <mpeterson> okey, I'll do that... I started that anyways...
15:23:54 <manjeets> #action manjeets to retire carbon jobs, add oxygen jobs to gate queue
15:24:15 <manjeets> #action mpeterson to add a patch to skip failing tempest tests
15:24:23 <mpeterson> great
15:24:26 <manjeets> lets move on
15:25:02 <manjeets> #topic SBI database consistency
15:25:33 <mpeterson> okey, so it seems to have gotten quite some comments
15:25:41 <mpeterson> so far I've addressed all of them
15:25:48 <mpeterson> any doubts? anything you want to discuss?
15:25:58 <manjeets> I think I need to review the revised version
15:26:16 <manjeets> #action manjeets to review the revised version of SBI database consistency spec
15:27:18 <manjeets> mpeterson, it mostly looked good to me, i'll review it either today or tomorrow again
15:27:50 <manjeets> others any questions and concerns on spec ?
15:28:02 <mpeterson> manjeets: perfect
15:28:42 <manjeets> #topic open mic
15:29:06 <manjeets> do you guys have anything else to discuss
15:29:23 <poothia___> as we have still got some time left can we pickup bug triaging from where we left!
15:29:27 <manjeets> actually I have one
15:29:50 <manjeets> https://review.openstack.org/#/c/504182/ is almost unblocked now, patches in neutron-lib are merged already
15:30:16 <manjeets> there's one in neutron to add notifications for l3 events which is also very close
15:30:30 <manjeets> neutron patch https://review.openstack.org/#/c/523257/
15:30:44 <manjeets> l3 flavors patch is passing CI now
15:31:35 <manjeets> mkolesni, mpeterson it would be great to get your reviews on it
15:33:47 <mkolesni> manjeets, will look at it
15:33:54 <manjeets> thanks !
15:34:15 <manjeets> mkolesni, mpeterson you guys down for bug triaging now ?
15:34:37 <mkolesni> sure why not
15:34:39 * manjeets opens bug list
15:35:03 <manjeets> mpeterson, can you recall where we left last time ?
15:35:31 <poothia___> https://bugs.launchpad.net/networking-odl/+bug/1660911
15:35:42 <poothia___> it was the last bug discussed
15:35:51 <manjeets> thanks poothia___
15:35:55 <rajivk> manjeets, Sorry to interrupt, you guys can have meeting time as per mkolesni convenience.
15:36:47 <manjeets> rajivk, you mean moving to an hour early ?
15:37:24 <rajivk> yeah, anytime that suits mkolesni
15:37:47 <mkolesni> huh?
15:37:47 <manjeets> mkolesni, so current meeting time doesn't work for you ?
15:38:18 <rajivk> manjeets, i will go through meeting logs, if i could not attend. However i will make it most of the time.
15:38:19 <mkolesni> i dont mind.. it would be more convenient an hour earlier but i understand for us west coast its too early
15:39:30 <manjeets> so lets keep it same for few weeks then ?
15:39:42 <manjeets> rajivk, do you have any time preference ?
15:40:03 <rajivk> you mean time zone?
15:40:05 <rajivk> IST
15:40:32 <mkolesni> i think he means a time slot preference
15:40:56 <rajivk> no such time preference
15:41:03 <manjeets> yes time slot
15:41:16 <manjeets> ok then lets keep it same for now ?
15:41:34 <manjeets> moving back to bugs
15:41:40 <manjeets> #topic bugs
15:41:59 <manjeets> https://bugs.launchpad.net/networking-odl/+bug/1660911
15:42:00 <rajivk> atleast make it one hour earlier for mkolesni convenience
15:42:34 <manjeets> rajivk, mkolesni he said he don't mind current time either ?
15:42:52 <mkolesni> yeah i dont care
15:43:24 <rajivk> okay
15:43:32 <manjeets> ohk looking at this https://bugs.launchpad.net/networking-odl/+bug/1660911 mkolesni you reported it
15:43:47 <manjeets> is there something still needs to be done in networking-odl ?
15:44:21 <manjeets> i see a comment from mpeterson that https://jira.opendaylight.org/browse/NEUTRON-158 will handle it
15:44:34 <mkolesni> i beleve so, we can close this
15:44:57 <mkolesni> changed it to wontfix
15:45:27 <manjeets> cool thanks mkolesni
15:46:05 <manjeets> next on list is https://bugs.launchpad.net/networking-odl/+bug/1686625
15:46:25 <manjeets> wait wrong copy
15:46:29 <manjeets> next on list is https://bugs.launchpad.net/networking-odl/+bug/1667588
15:47:33 <manjeets> i think it needs update to add placement-api/client onto conf
15:47:53 <mkolesni> seems like a low priority one
15:48:05 <mkolesni> anyone even using this vagrant box?
15:48:07 <manjeets> yea https://review.openstack.org/#/c/437826/5/vagrant/integration/multinode/control.conf patch was there but abandoned
15:48:29 <mkolesni> rather we dont spend time if nobody using it
15:49:04 <manjeets> make sense, i run direct devstack onto vms never used vagrant script from networking-odl
15:49:24 <mpeterson> if no one is using it then we should even remove it from the repo
15:49:36 <mkolesni> sounds good to me
15:49:40 <mkolesni> also close the bug wontfix
15:49:42 <manjeets> yea maintenance overhead
15:49:58 <mkolesni> i think generally some clean up is necessary
15:50:13 <mkolesni> for different tools there, devstack, etc
15:50:15 <manjeets> mkolesni, ++ to make maintenance easy
15:50:30 <mkolesni> some of it is already part if zuul v3 migration obviously
15:51:35 <manjeets> next is https://bugs.launchpad.net/networking-odl/+bug/1674553
15:51:59 <manjeets> rajivk, are you still after it ? i see you reported and its assigned to you
15:53:06 <rajivk> mangeets, let me check
15:53:06 <rajivk> my network is slow, could you let, which one is this?
15:53:06 <rajivk> Got it
15:53:16 <rajivk> I guess, it required changes from neutron side as well
15:53:34 <rajivk> but those changes got rejected.
15:53:50 <rajivk> Could you follow up and let me know. Then i can take this up? :)
15:54:11 <manjeets> rajivk, was there any patch in neutron ?
15:54:36 <rajivk> There was some discussion on launchpad, hunch.
15:55:45 <mkolesni> i gtg
15:55:48 <mkolesni> see you guys next week
15:55:55 <manjeets> thanks mkolesni
15:56:14 <manjeets> rajivk, i see only a comment by isaku
15:56:29 <manjeets> i'll check it.
15:56:57 <manjeets> as we are running out of time, lets start it next week from where we left today
15:57:11 <manjeets> thank you guys ! have a great week
15:57:17 <poothia___> thanks
15:57:20 <manjeets> #endmeeting