15:04:07 <manjeets> #startmeeting opendaylight neutron
15:04:07 <odl_meetbot> Meeting started Mon Jun  4 15:04:07 2018 UTC.  The chair is manjeets. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:04:07 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:07 <odl_meetbot> The meeting name has been set to 'opendaylight_neutron'
15:04:20 <manjeets> #topic agenda
15:04:35 <manjeets> what are the items we want to discuss todays
15:04:52 <manjeets> there are one or two items I have from OS summit
15:05:02 <poothia___> i wanted to discuss this...
15:05:03 <poothia___> https://bugs.launchpad.net/networking-odl/+bug/1772866
15:05:54 <manjeets> I attended two neutron forum at the summit
15:06:11 <poothia___> okay...
15:06:14 <manjeets> one was cross project session b/w nova and neutron
15:06:30 <manjeets> here are the things that were discussed https://etherpad.openstack.org/p/YVR18-novaneutron-ops-cross-project-session
15:06:51 <manjeets> dhcp_domain option and bandwidth based scheduling
15:07:16 <manjeets> https://etherpad.openstack.org/p/neutron-ryu-future-plans other session I attended
15:07:46 <manjeets> ryu team will stop maintenance after some times, neutron team has to address this issue
15:08:09 <manjeets> by either forking openflow controller into neutron repo or taking ownership of existing repo
15:08:19 <manjeets> they need volunteers to help with
15:08:49 <poothia___> oh!!
15:09:07 <poothia___> did you guys discuss about graphQL?
15:09:29 <manjeets> i don't think so
15:09:50 <poothia___> they are planning neutron to do POC on... right?
15:10:44 <manjeets> I am not aware of that
15:10:55 <poothia___> okay!
15:10:56 <manjeets> what are they doing poc for ?
15:11:22 <poothia___> they are plaaning to replace existing REST APIs with GraphQL
15:12:19 <manjeets> ohk, I didn't hear about that on two neutron sessions I attended
15:12:36 <manjeets> will get to know if that's going on in community
15:12:49 <manjeets> lets move on to bugs
15:12:54 <manjeets> #topic bugs
15:13:06 <manjeets> https://bugs.launchpad.net/networking-odl/+bug/1772866
15:13:14 <poothia___> https://etherpad.openstack.org/p/YVR18-API-SIG-forum
15:14:51 <manjeets> looks like for entire openstack projects not just limited to neutron
15:15:47 <poothia___> in the mailchain they were discussing about neutron for POC
15:16:13 <manjeets> ohk ! I need to catchup with emails
15:16:17 <manjeets> thanks poothia___ for info
15:17:25 <poothia___> yeah... i am facing this bug...
15:17:29 <manjeets> the bug you listed could be a high priority bug
15:17:41 <poothia___> i suppose so...
15:17:44 <manjeets> need to reproduce it and mark it
15:17:50 <manjeets> are you working on a fix ?
15:18:23 <poothia___> i am trying but i couldn't find a appropriate solution
15:18:53 <manjeets> can you assign it to yourself, i don't think I have time today to look at it
15:19:10 <manjeets> but in case i get free cycles I'll try and post comments on launchpad
15:19:47 <poothia___> i am working on it without assigning it to myself... i'll assign it if i solve it...
15:20:08 <manjeets> anyway you're working on it right ?
15:20:13 <poothia___> yes
15:20:20 <manjeets> cool !
15:20:55 <manjeets> #topic blueprints
15:21:05 <poothia___> does your devstack env setup without any problems?
15:21:29 <manjeets> yes it wwas successful last thursday I did
15:21:49 <poothia___> whenever i do, i stuck at this same bug
15:22:15 <poothia___> i am using example local.conf
15:22:45 <manjeets> I have little different than that, its on my github
15:22:52 <poothia___> i also found the mixture of q* services and neutron* services at the same time
15:23:02 <manjeets> that could be an issue
15:23:57 <manjeets> poothia___, https://github.com/manjeetbhatia/useful_files/blob/master/devstack_configs/oxygen.conf
15:24:03 <manjeets> this is what i used last week
15:24:32 <poothia___> i'll try with this tommorrow
15:25:19 <manjeets> lets discuss about blueprints
15:25:34 <manjeets> SBI database consistency spec looks very close
15:25:44 <manjeets> https://review.openstack.org/#/c/565463/
15:26:08 <poothia___> yes!!
15:26:22 <manjeets> mpeterson_, also submitted patches for SBI in networking-odl itself
15:26:29 <manjeets> we need to review them
15:26:43 <poothia___> i'll do that this week...
15:26:45 <manjeets> #action everyone to review SBI related patches
15:26:47 <odp-gerritbot> A change was merged to neutron: Fixup Augmentable and Identifiable methods changing  https://git.opendaylight.org/gerrit/72527
15:27:07 <manjeets> https://review.openstack.org/#/c/570767/
15:27:13 <manjeets> https://review.openstack.org/#/c/570773/
15:27:26 <manjeets> https://review.openstack.org/#/c/571192/
15:27:33 <manjeets> https://review.openstack.org/#/c/569754/
15:27:58 <manjeets> mike also reviewed the L3 flavors patch, I need to address his comments
15:29:36 <manjeets> and there are some patches related to QoS feature fetch which also needs attention and reviews
15:30:21 <manjeets> #topic open mic
15:30:27 <poothia___> https://review.openstack.org/#/c/527624/
15:30:40 <poothia___> full sync and recovery as well
15:31:08 <manjeets> oh yes enabling full sync
15:31:24 <manjeets> #action to review enabling of full sync for L3
15:31:37 <manjeets> #action everyone to review enabling of full sync for L3
15:32:08 <poothia___> one last question is setting destack up in a VM fine? are their certain requirements such as number of adapters?nature of adapters? like primary adapter should be bridge or Nat??
15:33:01 <manjeets> all you need is one vnic, and it should has outside world access
15:33:09 <manjeets> I always use vm's
15:33:32 <poothia___> cool... will do it tommorrow and share my results...
15:33:33 <manjeets> as long as they have internet access on one VNIC, it should be fine
15:33:52 <manjeets> anything else or we can close this meeting
15:34:21 <poothia___> https://review.openstack.org/#/c/571442/
15:34:37 <poothia___> should i change the path?
15:35:13 <poothia___> because neutron patch didn't work after changing the path...
15:36:02 <manjeets> it actually depends if tox.ini overwrites or how is it
15:36:14 <manjeets> let me check on that, I'll post feedback on it
15:36:20 <poothia___> ok thanks
15:36:34 <poothia___> nothing more from my side
15:36:38 <manjeets> cool !
15:36:46 <manjeets> #endmeeting