15:04:35 <manjeets> #startmeeting opendaylight neutron
15:04:35 <odl_meetbot> Meeting started Mon Jun 11 15:04:35 2018 UTC.  The chair is manjeets. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:04:35 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:35 <odl_meetbot> The meeting name has been set to 'opendaylight_neutron'
15:04:49 <manjeets> #topic Agenda
15:05:00 <manjeets> what all we have to discuss today ?
15:05:19 * manjeets need to catch up on reviews
15:05:26 <mkolesni> i dont have anything particular
15:05:30 <manjeets> 1. SBI data base consistency
15:06:11 <manjeets> 2. L3 flavors
15:06:25 <manjeets> #Info SBI db consistency
15:06:42 <manjeets> that spec looked mostly good to me last time I reviewed
15:06:53 <manjeets> looked good**
15:07:04 <mpeterson> hey
15:07:11 <mpeterson> sorry, I was caught up in some code
15:07:42 <mpeterson> manjeets: yeah, mkolesni commented something on the spec that's very true and needs fixing
15:07:44 <manjeets> np
15:07:47 <manjeets> https://review.openstack.org/#/c/565463/
15:08:05 <mpeterson> which is that we need to always yield
15:08:16 <manjeets> ok #action mpeterson to revise the spec
15:08:20 <mpeterson> so how do we skip in case there is no need to call the SBI
15:08:32 <mpeterson> #action mpeterson to revise the spec
15:08:43 <mpeterson> actuall I'm not the chair, I think you'll have to do it :)
15:08:52 <manjeets> #action mpeterson to revise the spec
15:09:49 <manjeets> #topic L3 flavors
15:10:05 * manjeets has read the comments from mkolesni
15:10:21 * mpeterson hasn't reviewed because those comments have not been addressed yet :)
15:10:23 <manjeets> I'll address those this week
15:10:29 <mkolesni> ok
15:10:49 <manjeets> i was caught up with other stuff
15:11:14 <manjeets> #action manjeets to revise L3 flavors patch by addressing comments
15:11:38 <mkolesni> we need to review sbi impl patches if we want it to land in rocky
15:11:51 <mkolesni> start before the spec is approved
15:12:16 <manjeets> i know mpeterson has one patch to add the required table
15:12:28 <manjeets> are there other patches too ?
15:12:49 <mpeterson> manjeets: what do you mean? what table?
15:12:55 <mkolesni> there is a series, mpeterson can provide the link
15:13:17 <mkolesni> im reviewing today enginefacade patch set, will get to that also
15:13:19 <mpeterson> https://review.openstack.org/#/q/status:open+project:openstack/networking-odl+branch:master+topic:bp/s
15:13:22 <mpeterson> that ^^
15:13:53 <manjeets> https://review.openstack.org/#/c/569754/6
15:14:12 <manjeets> I see there are multiple patches
15:14:38 <manjeets> all are in conflict rn
15:15:22 <manjeets> #action mpeterson to resolve conflicts on SBI patches
15:15:38 <manjeets> #action everyone to review SBI patches https://review.openstack.org/#/q/status:open+project:openstack/networking-odl+branch:master+topic:bp/s
15:15:40 <mpeterson> yeah, they can be reviewed nevertheless
15:15:52 <manjeets> added that action too
15:15:54 <mpeterson> :)
15:16:22 <manjeets> note: nitrogen has been marked EOL from nexus
15:16:36 <manjeets> thanks to mpeterson for removing all the nitrogen related gate stuff
15:16:46 <manjeets> nitrogen is no longer supported
15:17:44 <mpeterson> manjeets: oh, which brings about a problem...
15:17:55 <mpeterson> all the stable branches are failing
15:18:00 <mpeterson> because of the same issue...
15:18:16 <mpeterson> I started working on fixing it but I sincerly don't have the bandwidth to do it
15:18:23 <manjeets> can we just remove the nitrogen jobs from stable branches too ?
15:18:36 <mpeterson> manjeets: then they are not tested against anything
15:18:48 <mpeterson> manjeets: or you propose to test it to current versions of ODL?
15:18:58 <manjeets> mpeterson, oxygen ?
15:19:21 <mpeterson> manjeets: stable/pike only had nitrogen and carbon, for example
15:19:36 <manjeets> mpeterson, is carbon still there ?
15:19:59 <manjeets> we can have just carbon then and remove nitrogen ?
15:20:08 <mpeterson> manjeets: nope, everything from nitrogen and back has been removed from snapshots.. they only exist in release
15:20:27 <mpeterson> manjeets: which means the logic needs to be refactored to install them differently
15:20:42 <mpeterson> manjeets: and we can't rely on the xmls to discover the latest versions either
15:21:09 <manjeets> oh ok ! any volunteers ? i doubt i'll have bandwidth this week
15:21:34 <mpeterson> to understand better, nitrogen and back are here: https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/integration/distribution-karaf/
15:21:46 <mpeterson> while newer stuff is here: https://nexus.opendaylight.org/content/repositories/opendaylight.snapshot/org/opendaylight/integration/karaf/
15:22:05 <mpeterson> as you can see the first one doesn't have the maven-metadata.xml
15:22:51 <manjeets> https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/integration/distribution-karaf/ doesn't have nitrogen ?
15:23:04 <manjeets> what would be the source of nitrogen ?
15:24:06 <mpeterson> no, because nitrogen moved to https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/integration/karaf/
15:24:13 <mpeterson> 3 locations, basically
15:24:16 <mpeterson> sucks
15:24:38 <mkolesni> we could hard code
15:24:50 <mkolesni> if we want
15:25:10 <mpeterson> yes, I think that might be the best idea... and then refactor all the shell scripts that are really cumbersome \
15:25:16 <mkolesni> since it's eol the last version can be hard coded
15:25:21 <mkolesni> yes
15:25:45 <mpeterson> okey
15:25:48 <mpeterson> I'm good with that
15:26:03 <manjeets> we can temporarily change the url for nitrogen as mkolesni said
15:26:12 <manjeets> that'd be easy one
15:26:32 <manjeets> but we still need volunteers for that
15:26:40 <mkolesni> i meant the version can be hard coded but ok
15:27:26 <manjeets> version hardcoding and use different url if it is nitrogen ?
15:28:25 <mkolesni> no just generally instead of trying to figure out the version from the nexus data it can be hard coded
15:28:39 <mkolesni> it can be for any version
15:30:12 <manjeets> ok, any volunteers for this ?
15:30:58 <mkolesni> im unfortunately taken up with other work so ill focus my efforts on reviewing patches
15:31:05 <mpeterson> I think it shouldn't be too hard
15:31:12 <mpeterson> because there is an override of the URL
15:31:21 <poothia_> sorry my system froze
15:31:30 <mpeterson> if noone volunteers I'll look into it
15:31:34 <poothia_> i can do it
15:31:42 <manjeets> cool thanks poothia_
15:32:17 <manjeets> #action poothia_ to fix the CI jobs on stable branches by version hard coding
15:32:32 <manjeets> lets move on
15:32:37 <manjeets> any other items ?
15:32:49 <manjeets> I don't think I have anything else
15:34:03 <poothia_> please review full sync  and recovery like https://review.openstack.org/#/c/527624/, i just saw there is a merge conflict, i'll resolve it ASAP...
15:34:29 <manjeets> #action team to review full sync and recovery patches
15:35:27 <manjeets> anything else or we can get back to work ?
15:36:09 <mkolesni> i've nothing to add
15:36:52 <manjeets> btw anyone going to ptg ?
15:37:20 <manjeets> does anyone know if developers or ATC's also have to buy 399$ ticket ?
15:37:40 <mkolesni> thats usually the case
15:38:24 <manjeets> ohk, i'll putup a travel request today !
15:38:45 <manjeets> ok thank you every one have a great week
15:38:52 <manjeets> #endmeeting