15:08:28 <manjeets> #startmeeting opendaylight_neutron
15:08:28 <odl_meetbot> Meeting started Mon Jul 16 15:08:28 2018 UTC.  The chair is manjeets. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:08:28 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:08:28 <odl_meetbot> The meeting name has been set to 'opendaylight_neutron'
15:09:15 <manjeets> #topic Agenda
15:09:21 <manjeets> what do we have today,
15:09:23 <manjeets> ?
15:09:39 <manjeets> CI, SBI consistency and L3 flavors ?
15:09:45 <mpeterson> also tempest
15:09:55 <mpeterson> and fluorine tests
15:09:59 <mkolesni_> tempest narrowing
15:10:05 <mkolesni_> fullstack
15:10:11 <manjeets> #topic CI
15:10:58 <mpeterson> okey, so if no one is starting I will
15:11:05 <mpeterson> two things with it
15:11:13 <manjeets> I almost got stable/queens CI fixed last week, there was only failure left
15:11:15 <mpeterson> 1) the fullstack tests were disabled
15:11:32 <mpeterson> 2) stable/* are broken
15:11:51 <mpeterson> manjeets: cool
15:12:08 <manjeets> mpeterson, this https://review.openstack.org/#/c/579915/ will stable queens I need to fix requirements jobs
15:12:31 <manjeets> before last run it was all passing except requirements
15:13:07 <mpeterson> manjeets: let's recheck it
15:13:21 <mpeterson> manjeets: there was a CI general error
15:13:31 <mpeterson> manjeets: recheck sent
15:13:37 <manjeets> thanks mpeterson
15:13:51 * manjeets hand mic to mpeterson to continue other CI stuff
15:14:14 <mpeterson> so for (1) is just informative, and when we move to that topic mkolesni_ can expand
15:14:34 <mpeterson> (2) we'll need someone to fix it but right now it's not a priority nor a requirement
15:14:50 <mpeterson> so if anyone wants to take it upon themselves, be my guest
15:14:55 <mkolesni_> mpeterson, manjeets is fixing queens
15:15:10 <mpeterson> mkolesni_: yeah, I figured :)
15:15:41 <mkolesni_> as for fullstack
15:15:43 <mkolesni_> it broke
15:15:47 <mkolesni_> but i dont know why
15:15:59 <mkolesni_> anyway i dont see any value in these tests
15:16:25 <mkolesni_> theyre too white box, and mimic ODL behavior that can be different
15:16:31 <manjeets> mkolesni_, they're just bunch of tests inherited from neutron ?
15:16:38 <mkolesni_> so i disabled them
15:16:48 <mkolesni_> no i think you and/or isaku wrote them?
15:17:06 <manjeets> mkolesni_, It wasn't me
15:17:29 <mkolesni_> ok
15:17:32 <mpeterson> I'm super okey with just removing them altogether
15:17:36 <mkolesni_> anyway theyre broken now
15:17:46 <mkolesni_> so i suggest to delete them as they add no value
15:17:55 <manjeets> mkolesni_, If I recall at that time it was done for stadium requirement
15:18:01 <mkolesni_> i have to go for a coyuple of minutes, please discuss and ill be back promptly
15:18:46 <mpeterson> this is what the requirement says: exhaustive OpenStack CI coverage (unit, functional, tempest), using OpenStack CI (upstream) resources (this means using infra CI, not just downstream CI, as Grafana support will be required);
15:19:36 <mpeterson> manjeets: from that I gather that we are okey with just leaving the functional and deleting fullstack which IMHO is just an useless invention
15:20:11 <mkolesni_> yes afaik theres no such requirement
15:20:17 <manjeets> mpeterson, before I can say anything, I'd  like to read code at least once before I give my opinion, so can we wait until next week for removal ?
15:20:21 <mpeterson> manjeets: actually, if we talk about stadium requirements, currently the most pressing is getting granade to work
15:20:28 <mpeterson> manjeets: I'm super okey with that
15:20:34 <mkolesni_> fullstack may fit neutron native drivers where the implementation is known
15:20:44 <mkolesni_> manjeets, sure
15:21:15 <mkolesni_> manjeets, anyway for now theyre non voting to unbreak the ci
15:21:42 <mkolesni_> shall we move on?
15:21:52 <manjeets> ok, making them non voting would give me some time
15:21:54 <manjeets> sure
15:21:57 <mpeterson> yeah, the only thing is what I just say and we can make it #3\
15:22:09 <mpeterson> 3) we need to fix grenade as it is part of the stadium reqs
15:22:13 <mkolesni_> mpeterson, ok
15:22:16 <mkolesni_> tempest narrowing - https://review.openstack.org/582176
15:22:26 <mkolesni_> so i did some thinking with mpeterson last week
15:22:31 <mkolesni_> and then some investigation
15:22:47 <mkolesni_> after a battle to get devstack to work :)
15:23:02 <manjeets> mpeterson, I fixed it several times with hacks but not kept up, If someone wants to take over I'd be happy to help
15:23:10 <mkolesni_> i tested what happens to tempest tests when the ODL is down
15:23:11 <manjeets> grenade I mean in this ^^
15:23:29 <mpeterson> manjeets: okey, I'll see if I have bw, for now let's say I'm assigned to it
15:23:37 <mkolesni_> so turns out only a few dozens are failing and almost all from the scenario suites
15:24:15 <mkolesni_> so in order to have a more stable ci, and less interference from api tests (we dont even touch the api in any way)
15:24:30 <mkolesni_> i have this patch to narrow down the tests to just the scenario tests
15:25:05 <manjeets> mkolesni_, so volume api tests are disabled ?
15:25:07 <mkolesni_> and api.compute which have quite a few cases that bring up a vm so they're also relevant
15:25:21 <mkolesni_> yes that's still disabled by the blacklist anyway
15:25:43 <mkolesni_> http://git.openstack.org/cgit/openstack/networking-odl/plain/tempest-blacklist.txt
15:25:58 <mkolesni_> but now only the more interesting tests will run
15:26:18 <mkolesni_> it's still circa 300 tests, but at least 700 irrelevant ones wont run
15:26:47 <mkolesni_> i feel this is a good compromise, but we can further investigate and narrow down the list some more
15:27:00 <manjeets> mkolesni_, it will save us time and some life ... lol
15:27:07 <mpeterson> and on the plus side, it seems that now tempest will be stable and thus we can enable it
15:27:07 <mkolesni_> yes also :)
15:27:15 <mkolesni_> run time seems to reduce by ~30 mins
15:27:25 <mkolesni_> well, more stable :)
15:28:03 <manjeets> cool thanks mkolesni_ for working on it
15:28:19 <mkolesni_> sure np i just want to have a good env :)
15:28:39 <mkolesni_> so if it looks good lets merge and next we can reenable the stable of the tempest tests
15:29:28 <mkolesni_> also the blacklist was trimmed but if i missed something obviousl let me know
15:29:41 <manjeets> mkolesni_, its very important to run useful ones and keep it stable rather than running every single scenario and burn ourselves
15:30:00 <mkolesni_> yes
15:30:21 <mkolesni_> generally lets start with this and if we see unuseful ones lets trim thre fat
15:30:32 <mpeterson> +1
15:30:34 <manjeets> +1
15:30:40 <mpeterson> what's next in the agenda?
15:30:53 <manjeets> SBI consistency
15:30:55 <mpeterson> oh, related to this
15:30:55 <mpeterson> wait
15:30:57 <mpeterson> don't change
15:31:04 <mkolesni_> ?
15:31:12 <mpeterson> there are 2 more things related to CI that I want to introduce
15:31:17 <manjeets> sure
15:31:27 <mkolesni_> please
15:31:29 <mpeterson> 5) can we reenable rally? why was that disabled?
15:32:18 <mkolesni_> actually u know rally doesnt test odl is working right? we only should have there tests that launch a vm and ping it
15:32:26 <mkolesni_> i think theres a lot of fat there also
15:32:50 <mkolesni_> i can investigate this on my env and push a patch to reduce to the interesting tests
15:33:39 <mkolesni_> then we can make them voting again :)
15:34:07 <mpeterson> mkolesni_: sounds good to me
15:34:16 <mkolesni_> manjeets, ?
15:34:23 <manjeets> sounds good to me as well
15:34:28 <mkolesni_> cool
15:34:31 <mkolesni_> ill get on it then
15:34:34 <mpeterson> 6) can we enable the fluorine tests? they were introduced but never made voting
15:34:45 <mkolesni_> #action mkolesni_ will trim down rally and renable it
15:35:01 <manjeets> is the pass rate good enough to be voting ?
15:35:02 <mkolesni_> mpeterson, how stable are they?
15:37:07 <mpeterson> mkolesni_: they are stable IMHO
15:37:33 <mkolesni_> mpeterson, check grafana and if it seems stable make them voting
15:37:58 <manjeets> #action mpeterson to check fluorine and make them voting
15:38:12 <mpeterson> I've just checked, they are stable
15:38:16 <mpeterson> I'll commit a patch
15:38:19 <mkolesni_> cool
15:38:30 <mkolesni_> lets also discuss l3 flavor
15:38:41 <mpeterson> okey, we can move to either SBI or L3
15:38:50 <manjeets> #topic L3_flavors
15:39:20 <manjeets> I addressed most of the comments over the patch, I guess i need to address couple more and it will be close to go then ?
15:39:25 <manjeets> mkolesni_, ^
15:39:50 <mkolesni_> manjeets, u missed these left at PS35
15:39:50 <mkolesni_> PS29, Line 128: I don't see it in PS#35, did you miss to submit it maybe?
15:39:51 <mkolesni_> PS29, Line 217: I don't see it in PS#35, did you miss to submit it maybe?
15:40:24 <mkolesni_> also mpeterson had a few
15:40:34 <mkolesni_> but i think its close to merge
15:40:40 <manjeets> mkolesni_, I'll read them and address it today
15:40:45 <mkolesni_> cool
15:40:52 <manjeets> #action manjeets to address comments on l3 flavors
15:40:57 <manjeets> lets move on
15:41:03 <manjeets> #topic SBI consistency
15:41:32 <manjeets> sorry, I must admit I didn't get bw to review it last week
15:41:40 <mpeterson> okey, so re that, enginefacade was merged so that's good
15:41:44 <mkolesni_> im reviewing it as much as i can, would like your opinion also
15:41:50 <mpeterson> now we need to put as much effort as possible on SBI too
15:42:07 <manjeets> mpeterson, yes
15:42:09 <mpeterson> the first and perhaps the most important patch has been already +2 by mkolesni_
15:42:44 <mkolesni_> indeed it looks good to me
15:43:29 <mpeterson> and with tempest narrowed down that will help a lot with the v3 driver
15:43:29 <manjeets> mkolesni_, and mpeterson I'd like to bring one thing in to your notice
15:43:33 <manjeets> https://review.openstack.org/#/c/578225/
15:43:47 <mpeterson> so SBI (all commited AFAIC) and v3 are my priorities now
15:43:49 <manjeets> would this make sense for n-odl ?
15:43:59 * mpeterson is looking at the review
15:44:20 <manjeets> it claims to remove the need to sync db
15:45:36 <mkolesni_> what need exactly? the polling/websocket?
15:46:43 <manjeets> mkolesni_, I haven't investigated it much, but it was just FYI, we can discuss it later sometime
15:47:53 <mpeterson> manjeets: I'm not sure I understand the need either... let's review the concept and talk this again next week
15:48:40 <manjeets> ok lets move on
15:49:09 <manjeets> i think we discussed all the topics
15:49:15 <manjeets> #topic open_mic
15:49:21 <mkolesni_> i have nothing else to add
15:49:28 <mkolesni_> we have a big plate :)
15:49:38 <mkolesni_> btw feature freeze is next week right?
15:50:03 <manjeets> mkolesni_, i think so rocky-3 is week away
15:50:18 <mkolesni_> also do u have confirmation re PTG yet?
15:50:55 <mpeterson> nothing to add either :) and +1 to mkolesni_ 's question
15:51:04 <manjeets> mkolesni_, my manager said he's working on it, most likely i'll go but you never know until final confirmation
15:51:17 <mkolesni_> of course
15:51:21 <mkolesni_> i have no news either
15:51:23 <manjeets> mpeterson, mkolesni_ you guys ?
15:51:25 <manjeets> ok
15:51:27 <mkolesni_> will update if i do
15:51:46 <mpeterson> same status
15:52:03 <manjeets> cool thanks then have good rest of the week :)
15:52:08 <mkolesni_> thank you too
15:52:13 <mkolesni_> cya guys!
15:52:20 <manjeets> #endmeeting