15:02:36 <manjeets> #startmeeting opendaylight_neutron
15:02:36 <odl_meetbot> Meeting started Mon Aug  6 15:02:36 2018 UTC.  The chair is manjeets. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:36 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:36 <odl_meetbot> The meeting name has been set to 'opendaylight_neutron'
15:02:43 <manjeets> #topic Agenda
15:02:57 <manjeets> what do we have today ?
15:03:07 <manjeets> SBI
15:03:13 <manjeets> CI (fullstack)
15:03:29 <manjeets> what else ?
15:03:40 <mkolesni> mpeterson is on a work trip this week so he probably won't be joining
15:03:52 <mkolesni> nothing else from me
15:04:24 <manjeets> ok
15:04:34 <manjeets> we merged L3 flavors last week
15:04:50 <mkolesni> ok very nice :)
15:04:59 <manjeets> #topic SBI database
15:05:03 <mkolesni> you also need to add a tempest job to test it
15:05:18 <manjeets> I reviewed some patches last week
15:05:54 <manjeets> mkolesni, sure ! just enable the l3 flavors and use one of existing job ?
15:06:19 <mkolesni> manjeets, no i think a new job with latest stable ODL release would be best for now
15:06:36 <manjeets> mkolesni, ok !
15:06:50 <mkolesni> just so we have a baseline with existing jobs and the new job will test the new code, and if we see its stable enopugh we switch it
15:07:32 <manjeets> make sense
15:07:46 <mkolesni> problem is now tempest is almost stable
15:07:58 <mkolesni> but for some reason this test is running and failing
15:07:58 <mkolesni> neutron_tempest_plugin.scenario.test_internal_dns.InternalDNSTest
15:08:36 <mkolesni> we can manually blacklist it for now and submit a fix for neutron to have it not run i guess
15:08:38 <manjeets> mkolesni, is it always failing or intermittent ?
15:08:43 <mkolesni> manjeets, always
15:08:55 <mkolesni> we dont have dns support yet :)
15:09:19 <mkolesni> i know theoretically its there in ODL but nobody made it work in n-odl
15:09:22 <mkolesni> afaik
15:10:24 <manjeets> mkolesni, there's the extension check decorator if extension is not enabled it won't run the test
15:11:00 <manjeets> dns-integration (i guess is the extension you're talking about) ?
15:11:20 <mkolesni> manjeets, its there but its not working i think you also need to do something in the test set up
15:12:03 <mkolesni> im actually not 100% sure but we saw it handled also in setup in other dns tests (but i dont think it makes much sense that this decorator doesnt work)
15:12:29 <mkolesni> if you want to take a look at it then send the findings on email
15:12:53 <mkolesni> anyway shortest term solution would be to simply blacklist it, which i can do right now anyway
15:12:56 <manjeets> mkolesni, i'll take a look btw i'll be out of office for next two weeks
15:13:09 <mkolesni> enjoy :)
15:13:24 <mkolesni> ill be on PTO 17-24 this month FYI
15:13:26 <manjeets> either you or mpeterson have to chair the meetings
15:13:48 <manjeets> i'll be back on 24 august
15:13:54 <mkolesni> me 2
15:14:26 <manjeets> mkolesni, can you review SBI patches ?, I approved initial patch it looks good to me
15:14:41 <mkolesni> yeah sure ill try to take a look this week
15:14:49 <manjeets> however I have one question, should we follow neutron's way of doing db
15:14:55 <mkolesni> anyway were part the milestone so it wont make it into rocky :(
15:15:00 <manjeets> like adding an OVO layer ?
15:15:25 <mkolesni> i think OVO is for external API
15:15:33 <mkolesni> for backwards compatibility there
15:15:51 <mkolesni> for internal API it doesn't make much sense, but maybe I'm mis-understanding OVO
15:16:48 <manjeets> mkolesni, yes mostly it is, but most of the models (external and interface) are now using OVO
15:17:01 <mkolesni> lets start simple for now
15:17:14 <mkolesni> i guess we can always migrate it to OVO no?
15:17:48 <manjeets> mkolesni, yes, if it is a couple of model its not a big deal but neutron is doing that for over 2 cycles still not there yet
15:18:09 <manjeets> but neutron has over 160 models (tables)
15:18:26 <mkolesni> lets discuss this with mpeterson when he's back
15:18:56 <manjeets> mkolesni, I approved the patch, but I didn't workflow it so i'll set a hold
15:19:29 <mkolesni> ok
15:19:58 <manjeets> ok lets move on
15:20:10 <manjeets> #topic CI (fullstack, tempest)
15:20:33 <manjeets> mkolesni, I spent some time looking at fullstack jobs
15:20:49 <mkolesni> ok
15:21:06 <manjeets> my understanding is its just patching a machine and testing connectivity
15:21:20 <manjeets> which is actually tested in tempest
15:21:39 <mkolesni> yes
15:21:58 <manjeets> the other test case is port plugging
15:22:50 <manjeets> I am still not 100% sure but I guess we can move forward with the removal of jobs
15:23:08 <manjeets> the other thing is we need to check with neutron stadium requirements
15:23:13 <mkolesni> ok ill submit a patch
15:23:31 <mkolesni> there no requirement for fullstack jobs afaik but i can verify
15:23:44 <manjeets> ok sounds good
15:24:08 <manjeets> #action mkolesni to verify fullstack job for stadium requirements
15:24:22 <manjeets> #action manjeets to look at tempest failure for dns integration
15:24:44 <manjeets> mkolesni, I guess we already discussed tempest jobs ?
15:24:53 <mkolesni> Exhaustive OpenStack CI coverage: unit, functional, and tempest coverage using OpenStack CI (upstream) resources so that Grafana and OpenStack Health support is available
15:25:06 <manjeets> anything else other than failing dns intergration case ?
15:25:09 <mkolesni> https://docs.openstack.org/neutron/latest/contributor/stadium/governance.html#checklist
15:25:14 <mkolesni> no mention of fullstack
15:25:20 <mkolesni> :)
15:25:26 <mkolesni> no i didnt notice anything else
15:25:43 <mkolesni> without the dns test we should be seeing tempest a lot greener
15:26:42 <manjeets> oh so fullstack isn't needed for stadium
15:27:36 <mkolesni> nope
15:27:44 <mkolesni> ill send patches to remove those jobs this week
15:27:46 <manjeets> ohk, anything else ?
15:28:05 <manjeets> #topic open mic
15:28:38 <mkolesni> for the ptg
15:28:42 <mkolesni> i booked flights
15:29:09 <mkolesni> i'm arriving at 11th sep and leaving afternoon on 14th
15:29:15 <savoir-faire18> Christel just posted this "denial" on the freenode blog https://freenode.net/news/spam-shake
15:29:19 <savoir-faire18> This blog is essentially an ad for the Handshake ICO scam with a one-line "denial" of involvement mixed in there. It's obviously very unethical of Christel to not mention her own involvement in the scam which the blog post promotes.
15:29:23 <savoir-faire18> Consider Andrew Lee's involvement, Andrew Lee is Christel's boss at London Trust Media and he also controls the majority of freenode voting rights. Andrew Lee also heads the handshake ICO scam. Coincidence?
15:29:26 <savoir-faire18> Oh, and about those donations she speaks of: https://twitter.com/ISCdotORG/status/1025461692132519936
15:29:28 <mkolesni> so ill be there for 12,13 and till noon on 14th
15:29:30 <savoir-faire18> Don't support freenode and their ICO scam, switch to a network that hasn't been co-opted by corporate interests. OFTC or efnet might be a good choice. Perhaps even https://matrix.org/
15:29:59 <manjeets> mkolesni, can you chair next meeting or we can cancel it ?
15:30:26 <mkolesni> mpeterson will be here but since you sont be here i think we can cancel it
15:30:41 <manjeets> ok
15:30:46 <manjeets> http://git.openstack.org/cgit/openstack/neutron-tempest-plugin/tree/neutron_tempest_plugin/scenario/test_internal_dns.py#n28
15:30:55 <mkolesni> so for ptg which days will u be there?
15:30:58 <manjeets> mkolesni, the check is there I guess its just not working
15:31:05 <manjeets> sun - fri
15:32:03 <mkolesni> ok cool so ill see you there on wed-fri noon
15:32:17 <manjeets> mkolesni, may be we should check if it enables dns-integration by default ? if it does we can modify config to disable it ?
15:32:34 <mkolesni> unfortunately i cant come earlier than that since it a holiday
15:32:45 <mkolesni> umm i checked the log and the extension isn't loaded
15:32:52 <mkolesni> i guess this checker is bogus
15:34:28 <manjeets> ohk, lets figure it out.
15:34:36 <manjeets> anything else ?
15:34:59 <manjeets> mkolesni, we need to create stein etherpad for networking-odl
15:35:23 <mkolesni> yes i need to gather info here what are the plans for Stein
15:35:30 <mkolesni> you can do the honors if you want :)
15:36:31 <mkolesni> manjeets, i opened a bug for the dns test - https://bugs.launchpad.net/neutron/+bug/1785656
15:37:05 <manjeets> cool mkolesni !
15:37:07 <manjeets> https://etherpad.openstack.org/p/networking-odl-stein-ptg
15:37:26 <manjeets> we can add topics here ^^
15:37:52 <mkolesni> ok great, i think it's also a good idea to send this to the msiling list
15:38:16 <mkolesni> *mailing
15:38:37 <manjeets> mkolesni, I confirmed the bug you reported !
15:38:59 <mkolesni> manjeets, cool
15:39:24 <manjeets> ok i don't have anything else
15:39:31 <mkolesni> me neither :)
15:39:46 <manjeets> see you after 2 weeks :)
15:39:48 <mkolesni> have a nice week and a good vacation :)
15:39:58 <manjeets> thanks you too
15:40:01 <mkolesni> thanks!
15:40:04 <mkolesni> bye :)
15:40:04 <manjeets> #endmeeting