#opendaylight-neutron: weekly meeting

Meeting started by mpeterson at 15:00:42 UTC (full logs).

Meeting summary

  1. Agenda (mpeterson, 15:00:53)
    1. poothia (poothia__, 15:01:03)
    2. added topics: v3 driver, bug triage (mpeterson, 15:06:41)

  2. Action items from last meeting (mpeterson, 15:06:49)
    1. ACTION: mkolesni, yamahata, manjeets to review Ml2 for new full sync (mpeterson, 15:07:20)
    2. ACTION: manjeets to review https://review.openstack.org/#/c/529537/ (mpeterson, 15:07:35)

  3. Announcements (mpeterson, 15:08:46)
    1. no announcements (mpeterson, 15:10:44)

  4. Patches (mpeterson, 15:10:53)
    1. https://review.openstack.org/#/c/504182/ (manjeets, 15:11:37)
    2. https://review.openstack.org/#/c/544116/2 (manjeets, 15:11:44)
    3. ACTION: all to review L3 ( https://review.openstack.org/#/c/504182/ and https://review.openstack.org/#/c/544116/2 ) (mpeterson, 15:12:35)
    4. ACTION: all to review bp/enginefacade-switch ( https://review.openstack.org/#/q/status:open+project:openstack/networking-odl+branch:master+topic:bp/enginefacade-switch ) (mpeterson, 15:13:48)
    5. ACTION: all to review the feature negotiation patch https://review.openstack.org/#/c/558554/ (mpeterson, 15:17:37)

  5. v3 driver (mpeterson, 15:18:18)
    1. we are looking to implement OVN's spec in neutron in a more generic way, mpeterson is working on it (ovn implementation: https://github.com/openstack/networking-ovn/blob/master/doc/source/contributor/design/database_consistency.rst ) (mpeterson, 15:21:56)
    2. ACTION: all make yourselves familiar with the design and if you have any ideas/questions/contributions, you can contact me so I can included/answer them (mpeterson, 15:24:16)
    3. mkolesni will list many of the benefits, you can read the irclogs of the meeting to have an idea (mpeterson, 15:25:26)
    4. ACTION: mpeterson to ask OVN's maintainer for scale data on this solution, so it can be added to the spec (mpeterson, 15:37:54)
    5. https://github.com/openstack/networking-ovn/blob/f3f5257fc465bbf44d589cc16e9ef7781f6b5b1d/networking_ovn/db/revision.py (mpeterson, 15:44:47)
    6. ACTION: all to read the OVN spec to familiarize, will be a topic next week's meeting for more input from everyone (mpeterson, 15:51:08)

  6. Bug triage (mpeterson, 15:51:22)
    1. skipped, lack of time (mpeterson, 15:51:29)


Meeting ended at 15:51:41 UTC (full logs).

Action items

  1. mkolesni, yamahata, manjeets to review Ml2 for new full sync
  2. manjeets to review https://review.openstack.org/#/c/529537/
  3. all to review L3 ( https://review.openstack.org/#/c/504182/ and https://review.openstack.org/#/c/544116/2 )
  4. all to review bp/enginefacade-switch ( https://review.openstack.org/#/q/status:open+project:openstack/networking-odl+branch:master+topic:bp/enginefacade-switch )
  5. all to review the feature negotiation patch https://review.openstack.org/#/c/558554/
  6. all make yourselves familiar with the design and if you have any ideas/questions/contributions, you can contact me so I can included/answer them
  7. mpeterson to ask OVN's maintainer for scale data on this solution, so it can be added to the spec
  8. all to read the OVN spec to familiarize, will be a topic next week's meeting for more input from everyone


Action items, by person

  1. manjeets
    1. mkolesni, yamahata, manjeets to review Ml2 for new full sync
    2. manjeets to review https://review.openstack.org/#/c/529537/
  2. mkolesni
    1. mkolesni, yamahata, manjeets to review Ml2 for new full sync
  3. mpeterson
    1. mpeterson to ask OVN's maintainer for scale data on this solution, so it can be added to the spec
  4. UNASSIGNED
    1. all to review L3 ( https://review.openstack.org/#/c/504182/ and https://review.openstack.org/#/c/544116/2 )
    2. all to review bp/enginefacade-switch ( https://review.openstack.org/#/q/status:open+project:openstack/networking-odl+branch:master+topic:bp/enginefacade-switch )
    3. all to review the feature negotiation patch https://review.openstack.org/#/c/558554/
    4. all make yourselves familiar with the design and if you have any ideas/questions/contributions, you can contact me so I can included/answer them
    5. all to read the OVN spec to familiarize, will be a topic next week's meeting for more input from everyone


People present (lines said)

  1. mpeterson (91)
  2. mkolesni (62)
  3. manjeets (31)
  4. rajivk (11)
  5. odl_meetbot (3)
  6. poothia__ (2)


Generated by MeetBot 0.1.4.