15:02:30 <mpeterson> #startmeeting weekly meeting
15:02:30 <odl_meetbot> Meeting started Mon Apr 30 15:02:30 2018 UTC.  The chair is mpeterson. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:30 <odl_meetbot> The meeting name has been set to 'weekly_meeting'
15:02:32 <poothia__> hello
15:02:38 <mpeterson> #topic Agenda
15:02:45 <mpeterson> #info Regular topics: action items from last meeting, announcements, patches
15:02:48 <mpeterson> Any other topics to discuss?
15:03:02 <manjeets> anyone going to openstack summit ?
15:03:23 <mpeterson> I don't think so
15:03:34 <mpeterson> but I'd ask on the mailing list
15:03:41 <manjeets> I might be going, would be good to meet n-odl team there
15:04:09 <mpeterson> I can't travel because of company policy
15:04:44 <mpeterson> since I'm a part-time worker until I finish my studies
15:04:58 <mkolesni> hi
15:05:10 <mpeterson> mkolesni: hi, are you going to the summit?
15:05:19 <mpeterson> mkolesni: manjeets was asking
15:05:40 <mkolesni> vancouver?
15:05:44 <manjeets> yes
15:06:12 <mkolesni> no, generally only going to ptgs now
15:06:39 <mpeterson> #info another topic: review of v3 spec
15:06:45 <mpeterson> moving on...
15:06:55 <mpeterson> #topic Action items from last meeting
15:07:04 <mpeterson> #info no pending items
15:07:17 <mpeterson> #topic Announcements
15:07:23 <mpeterson> any announcements?
15:07:53 <mpeterson> manjeets, mkolesni, poothia__ ?
15:08:04 <poothia__> none from my side
15:08:07 <mkolesni> sorry was sick last week, didnt get much done
15:08:08 <manjeets> not any
15:08:13 <mpeterson> #info no announcements
15:08:25 <mpeterson> #topic Patches
15:08:35 <mpeterson> before we get into the spec of v3
15:08:47 <mpeterson> any patch that should be taken into our attention?
15:09:00 <mpeterson> *brought
15:09:43 <mpeterson> I'm still waiting for you guys to review my implementation of enginefacade
15:09:50 <mpeterson> so I'm going to add that as a pending item
15:10:12 <mpeterson> #action all to review the implementation of the enginefacade db pattern ( https://review.openstack.org/#/q/status:open+project:openstack/networking-odl+branch:master+topic:bp/enginefacade-switch )
15:10:48 <mpeterson> any other patches you'd like to discuss? manjeets, mkolesni, poothia__
15:11:06 <mkolesni> none from me
15:11:22 <manjeets> l3 flavors patch (currently blocked by neutron but very close to completion in networking-odl)
15:11:34 <manjeets> https://review.openstack.org/#/c/504182/
15:12:54 <mpeterson> okey, I'll review it soon... I've been postponing it for long enough
15:13:13 <mpeterson> #action all to review the L3 flavors patch ( https://review.openstack.org/#/c/504182/ )
15:13:19 <mkolesni> ok
15:13:25 <manjeets> thanks !
15:13:33 <poothia__> is there a gate failure in networking-odl-fullstack-carbon?
15:13:45 <mpeterson> poothia__: it is failing randomly :/
15:13:58 <poothia__> okey...
15:14:07 <mpeterson> poothia__: if it persists we should look into it
15:14:23 <mpeterson> #topic v3 Spec
15:14:34 <mpeterson> okey, so did you get time to review the spec?
15:15:15 <mkolesni> not yet, was sick
15:15:27 <mpeterson> manjeets, poothia__ ?
15:16:00 <mpeterson> unless there is a big pushback on it, my idea is to publish it this wednesday for broader review
15:16:02 <manjeets> mpeterson, I reviewed it most of it looked good and but haven't completed review yet
15:16:12 <manjeets> mpeterson, +1
15:16:34 <poothia__> i reviewed it, i found it plausible...
15:16:57 <mpeterson> any doubts ?
15:17:52 <manjeets> mpeterson, I guess its time to get eyes of more audience ?
15:18:00 <mpeterson> manjeets: yes it is :)
15:18:09 <mpeterson> manjeets: I'll do that in my next working day
15:18:16 <manjeets> cool sounds good
15:18:18 <mkolesni> sounds good to me
15:18:19 <mpeterson> perhaps even tomorrow morning
15:18:24 <mpeterson> otherwise wednesday
15:18:35 <mkolesni> we can obviously continue on the gerrit
15:18:55 <mpeterson> yup, it's going to be even easier to review
15:20:01 <mpeterson> awesome
15:20:13 <mpeterson> okey, I close this topic
15:20:40 <mpeterson> mkolesni, manjeets, poothia__: any other topic you'd want to discuss? or should I end the meeting?
15:20:57 <manjeets> mpeterson, mkolesni wanna go over bugs list ?
15:20:59 <manjeets> https://bugs.launchpad.net/networking-odl
15:21:03 <poothia__> if we have time today, we can do some bug triaging...
15:21:09 <mpeterson> #topic bug triage
15:21:15 <mpeterson> okey, let's do it
15:21:28 <mpeterson> manjeets: guide us through :)
15:22:05 <manjeets> first bug is marked critical and incomplete ?
15:22:30 <manjeets> it was for networking-ovn mostly but seems like was added to n-odl too
15:23:33 <manjeets> multinode CI is still a dream for networking-odl
15:24:06 <manjeets> couple of times I was very close to fix but other issues and work always got my attention
15:24:10 <mpeterson> manjeets: yes, the first one I think we could close it... anyways it's a tempest test so if we see it again we can re-open
15:24:54 <manjeets> mpeterson, makes sense to close it for now
15:25:34 <mkolesni> +1
15:25:36 <mpeterson> mmm I don't have permissions to close it
15:25:46 <manjeets> neither do I
15:25:57 <mpeterson> mkolesni: :)
15:27:01 <mkolesni> trying
15:27:23 <mkolesni> i marked it invalid
15:27:43 <mpeterson> okeyt
15:27:46 <manjeets> next one is grenade job, I got it passing twice but it again broke due to changes in devstack code way it handles legacy neutron-lib
15:28:10 <mpeterson> manjeets: but we are not using legacy neutron-lib anymore, are we?
15:28:41 <manjeets> mpeterson, for grenade jobs yes even neutron and other networking-* project are use using it
15:29:13 <manjeets> the reason was grenade code wasn't updated so we have to stick with it and grenade jobs are the only exception afaik
15:30:02 <mpeterson> manjeets: mmm and the fix in devstack is a difficult one? perhaps you can even contribute the fix to grenade ;)
15:30:45 <manjeets> i started with a patch in grenade, but almost no response from grenade team
15:31:16 <manjeets> https://review.openstack.org/#/c/546745/
15:32:25 <manjeets> if i get time this week i'll see if I can do a work around in networking-odl
15:32:54 <mpeterson> manjeets: I added two cores of grenade as reviewers
15:34:02 <manjeets> thanks
15:34:23 <manjeets> next are full_sync I see one of them just got closed
15:34:51 <manjeets> is rajiv still working on https://bugs.launchpad.net/networking-odl/+bug/1711114 ?
15:34:57 <mpeterson> re: full sync and recovery, I expect those to be addressed by rajiv as part of the refactor
15:35:13 <mpeterson> so I'd just make sure he has them assigned and skip them over
15:35:53 <manjeets> ok https://bugs.launchpad.net/networking-odl/+bug/1713697 journal recovery is also assigned to him
15:36:25 <mpeterson> re: https://bugs.launchpad.net/networking-odl/+bug/1376563 I think we should create more functional tests, should we re-define it?
15:36:36 <mkolesni> yes please
15:37:48 <mpeterson> manjeets: I'll remove you as assignee because I doubt you are working on that
15:38:02 <manjeets> i removed already
15:39:34 <mpeterson> continuing https://bugs.launchpad.net/networking-odl/+bug/1686625 what to do with this one?
15:40:07 <mpeterson> mkolesni: and are you working on this one still? https://bugs.launchpad.net/networking-odl/+bug/1713487
15:40:44 <mkolesni> not right now
15:40:54 <mpeterson> I'll put it as triaged and unassigned
15:41:33 <mkolesni> ok
15:41:45 <manjeets> mpeterson, https://review.openstack.org/#/c/558554/ for https://bugs.launchpad.net/networking-odl/+bug/1686625
15:42:24 <mpeterson> manjeets: oh, great
15:42:55 <manjeets> I think feature fetch from odl for qos will cover it
15:43:21 <mpeterson> indeed
15:43:50 <mpeterson> now https://bugs.launchpad.net/networking-odl/+bug/1738246 I think it's related to https://bugs.launchpad.net/networking-odl/+bug/1713487 and https://bugs.launchpad.net/networking-odl/+bug/1713487
15:44:33 <mkolesni> this one will be fixed by l3 flavors
15:45:03 <mkolesni> dont think its related to the other ones, but maybe
15:45:44 <mpeterson> great, so let's leave them as they are
15:46:34 <mkolesni> ok
15:46:48 <mpeterson> next is https://bugs.launchpad.net/networking-odl/+bug/1738247
15:47:00 <mkolesni> manjeets, can we assign https://bugs.launchpad.net/networking-odl/+bug/1738246 to you?
15:47:09 <mkolesni> since it will be fixed by l3 flavor
15:47:32 <manjeets> mkolesni, sure
15:48:14 <mkolesni> mpeterson, this one might be related to l3 flavor as well but im not sure
15:50:44 <mpeterson> okey, next https://bugs.launchpad.net/networking-odl/+bug/1627749
15:50:49 <mpeterson> manjeets: you are assigned?
15:52:08 <manjeets> mpeterson, I did some fixes to qos driver last not sure if this bug is still valid but i'll check
15:53:22 <mpeterson> manjeets: great
15:53:33 <manjeets> actually mpeterson it can closed it was reported when notification driver was used which is no longer in use with qos_v2
15:53:49 <mpeterson> manjeets: even more great
15:54:55 <manjeets> mpeterson, i remember patch for adapting new driver for qos https://review.openstack.org/#/c/454300/
15:55:38 <mpeterson> next https://bugs.launchpad.net/networking-odl/+bug/1660911 mkolesni tells me it's going to be handled in ODL's side
15:56:11 <mpeterson> https://jira.opendaylight.org/browse/NEUTRON-158
15:56:18 <mpeterson> I'll add that to the bug
15:56:44 <mkolesni> yes
15:57:21 <mpeterson> should I close the n-odl bug then or just leave it open until that's fixed?
15:58:22 <mpeterson> okey, I think that's as far as we can reach today
15:59:21 <manjeets> cool ! we got some bugs off the list
15:59:51 <mkolesni> i think it can be closed
15:59:58 <mkolesni> thanks mpeterson !
16:00:01 <mkolesni> cya guys
16:00:03 <manjeets> thank you everyone !!
16:00:13 <poothia__> thank you all...
16:00:43 <poothia__> we can continue this in next meetings as well, if we have time!
16:00:56 <poothia__> thanks
16:01:21 <mpeterson> awesome
16:01:23 <mpeterson> thanks
16:01:28 <mpeterson> see you next week
16:01:29 <mpeterson> #endmeeting