15:13:33 <mpeterson> #startmeeting weekly meeting
15:13:33 <odl_meetbot> Meeting started Mon May 14 15:13:33 2018 UTC.  The chair is mpeterson. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:13:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:13:33 <odl_meetbot> The meeting name has been set to 'weekly_meeting'
15:13:53 <poothia___> hello
15:14:06 <mpeterson> #topic Agenda
15:14:08 <mpeterson> #info Regular topics: action items from last meeting, announcements, patches
15:14:09 <mpeterson> Any other topics to discuss?
15:14:18 <mpeterson> #info v3 driver
15:14:44 <mpeterson> Anything else?
15:14:54 <manjeets> l3 flavors !
15:15:05 <mpeterson> #info l3 flavors
15:15:08 <mpeterson> Great
15:15:12 <mpeterson> #topic Action items from last meeting
15:15:32 <mpeterson> Okey mostly reviews including l3 ... I think we didn’t do much on that
15:15:57 <mpeterson> #action all to review pending reviews and do them
15:16:12 <mpeterson> A side from that maintenance tasks
15:16:15 <mkolesni> hi
15:16:26 <mpeterson> manjeets: you had those
15:16:39 <mpeterson> manjeets: did you progress?
15:17:28 <manjeets> mpeterson, I didn't do much last week on reviews as I working on l3 flavors and some patches in neutron to make functional tests work
15:17:45 <mpeterson> manjeets: okey
15:18:18 <mpeterson> #action manjeets to review last meeting notes for the tasks to be done to maintain the CI
15:18:26 <mpeterson> #topic announcements
15:18:31 <mpeterson> Any?
15:18:42 <manjeets> mpeterson, but i did send some patches for CI
15:18:58 <mkolesni> mpeterson, when do u want to discuss v3 driver?
15:19:02 <mpeterson> manjeets: oh I must have not seen them yet, my backlog is quite big
15:19:17 <mpeterson> Let’s jump to that, mkolesni
15:19:26 <mpeterson> #topic v3 driver
15:19:45 <mpeterson> mkolesni: wanna elaborate?
15:19:52 <mkolesni> sure mpeterson
15:19:59 <mpeterson> mkolesni: my internet died and I’m chatting from my phone
15:20:28 <mkolesni> i talked to mpeterson today about the v3 driver work to move to revision based system same as ovn and other drivers do it
15:20:54 <mkolesni> the thing is mpeterson is currently driving this work as part of his internship in Red Hat
15:21:36 <mkolesni> that period will end in end June and there's no certainty yet he will continue to work on it after that
15:22:19 <mkolesni> so to move things along we though it would be better to focus on adapting the v3 driver code to work on n-odl and as second priority work on getting this code into neutrobn
15:22:51 <mkolesni> of course mpeterson will base his work on existing ovn work so there wont be any starting from scratch and in fact its not expected to diverge
15:23:14 <manjeets> mkolesni, you mean rather than waiting on neutron we should start changing n-odl ?
15:23:37 <mpeterson> Exactly, basically it will be some remaining and some updating to the enginefacade pattern
15:23:41 <mkolesni> so to sum up, in order to make mpeterson's time left the most effective we propose that we start working on n-odl forst
15:23:45 <mpeterson> manjeets: correctly
15:24:01 <mkolesni> first
15:24:17 <manjeets> okay !
15:24:31 <mkolesni> also rocky cycle is already ongoing and if we want this to be usable we need to rapm up
15:24:33 <mkolesni> rapm
15:24:35 <mkolesni> ramp
15:24:51 <mpeterson> Agreed
15:25:07 <mpeterson> So basically are you okey with that?
15:25:15 <mpeterson> manjeets: poothia___ ?
15:25:29 <poothia___> i am fine with it...
15:25:31 <manjeets> sounds good !
15:25:41 <mkolesni> manjeets, btw isaku is off the project?
15:25:53 <mkolesni> i dont see him
15:26:15 <mpeterson> #info we will implement v3 on n-odl first and then move to neutron codebase
15:26:27 <manjeets> mkolesni, he's still there but not fully dedicated to n-odl now ! he is moving away from it slowly to other things i guess
15:26:35 <mpeterson> #info this is due to time and resources constraints
15:26:39 <mkolesni> so just the spec we will be woking on it on neutron repo right?
15:27:00 <mpeterson> mkolesni: for now it seems that way
15:27:04 <mkolesni> ok
15:27:20 <mpeterson> #topic l3
15:27:22 <manjeets> spec can go parallely, as patch in neutron can be time consuming
15:27:28 <mpeterson> manjeets: the floor is yours
15:27:36 <manjeets> alright !
15:27:38 <mkolesni> mpeterson, would u ewant to notify lucas about this?
15:27:47 <mpeterson> mkolesni: I did already
15:27:50 <mkolesni> i dont know whats his expectation here
15:27:53 <mkolesni> ah ok u quick
15:28:01 <mkolesni> let me know what he said
15:28:04 <mkolesni> off-line
15:28:17 <mkolesni> ok, l3
15:28:18 <manjeets> l3 flavors is almost close https://review.openstack.org/#/c/504182/
15:28:40 <manjeets> functional tests are also passing except one https://review.openstack.org/#/c/544116/
15:28:44 <mkolesni> i am reviewing it right now
15:28:49 <manjeets> i'll fix failing test soon
15:29:15 <manjeets> I had send couple of patches in neutron to make functional tests work
15:29:25 <manjeets> https://review.openstack.org/#/c/566736/
15:29:35 <manjeets> https://review.openstack.org/#/c/567086/
15:31:05 <manjeets> and on side note: I have a presentation at openstack summit next week regarding l3 flavors ! which will explain flavors framework and give little bit of idea how to write driver for any backend
15:31:33 <mkolesni> can u add those to meeting info so we track them?
15:31:46 <mkolesni> ah very nice i wish you good luck there
15:32:34 <manjeets> #info reviews needed for l3_flavors https://review.openstack.org/#/c/566736/, https://review.openstack.org/#/c/504182/, https://review.openstack.org/#/c/544116/
15:32:41 <manjeets> thanks mkolesni !
15:32:57 <mkolesni> :)
15:33:06 <manjeets> that's all I had for l3 !
15:33:13 <poothia___> all the best for the summit @manjeets
15:33:17 <mkolesni> unfortunately i wont be there but hope ill get to go to ptg
15:33:44 <manjeets> thanks poothia___
15:34:01 <manjeets> mkolesni, :(, hopefully i'll be able to make it to next ptg
15:34:22 <mkolesni> manjeets, i thought u live in us?
15:34:56 <manjeets> mkolesni, yes ! but you never know budget constraints ! so, its never sure
15:35:20 <mkolesni> for sure, but should be easier
15:35:39 <manjeets> yea ! it should be .
15:35:50 <mkolesni> ok hope ull get there as well
15:36:08 <manjeets> ok I have changes on CI too I can give a quick update on that
15:36:16 <mkolesni> sure
15:36:18 <manjeets> #info CI patches
15:36:49 <manjeets> https://review.openstack.org/#/c/566690/ I proposed to make oxygen fullstack/functional jobs voting
15:37:33 <manjeets> also a patch in project-config to add fullstack/functional oxygen stats to gate queue
15:37:52 <mkolesni> looks good
15:37:56 <manjeets> removing carbon jobs from grafana https://review.openstack.org/#/c/567317/
15:38:15 <manjeets> retiring carbon jobs from n-odl ci https://review.openstack.org/#/c/545473/
15:39:04 <manjeets> that's all I had
15:39:10 * manjeets passes the mic back to mpeterson
15:39:47 <mkolesni> ill look at those tomorrow
15:39:57 <manjeets> cool ! thanks mkolesni !
15:41:01 <mkolesni> i approved the functional voting one, seems simple
15:41:29 <mpeterson> I have to understand just how it works, any quick reference as to that?
15:41:39 <mpeterson> A reliable one I mean
15:41:44 <manjeets> yes others are simple too just retiring carbon and removing grafana boards for it
15:41:48 <mpeterson> Because most of them are a bit outdated
15:42:15 <mpeterson> manjeets: would love to watch that presentation
15:42:29 <manjeets> mpeterson, are you going to summit ?
15:42:37 <mpeterson> manjeets: sadly no
15:42:50 <manjeets> oh no !
15:43:29 <manjeets> mpeterson, for what are you asking quick reference ? I didn;t get that
15:43:52 <mpeterson> manjeets: l3 so I can review the patches properly
15:44:32 <manjeets> mpeterson, https://specs.openstack.org/openstack/neutron-specs/specs/newton/multi-l3-backends.html
15:45:15 <manjeets> so basically driver_controller in neutron should handle all the flavors ( or backend) instead of legacy L3 service plugin which allowed only single driver
15:45:49 <mkolesni> basically its based on the notifications and u filter out the ones not related to your flavor
15:45:54 <mkolesni> iiuc
15:46:06 <mpeterson> manjeets: great
15:46:15 <mpeterson> Thanks
15:46:35 <manjeets> mkolesni, ++
15:47:03 <mkolesni> the important part is u get bot pre and post commit notifications
15:47:16 <mkolesni> this will solve our problems with the existing driver
15:47:27 <mkolesni> the l3 flavors is more like icing on the cake :)
15:47:59 <mpeterson> Haha okey
15:48:00 <manjeets> its like you can see all the candy on the cake but only one is yours :)
15:48:02 <manjeets> lol
15:48:08 <manjeets> candies**
15:48:10 <mpeterson> I’ll need to leave at this moment, sorry
15:48:15 <mpeterson> #chair manjeets
15:48:15 <odl_meetbot> Current chairs: manjeets mpeterson
15:48:31 <mpeterson> Cheers! And thanks!
15:48:38 <manjeets> alright fellas ! do we have anything else to discuss ?
15:48:48 <mkolesni> nothing from me
15:48:52 <mkolesni> bye mpeterson
15:48:59 <manjeets> thanks mpeterson !
15:49:01 <poothia___> nothing from my side
15:49:23 <manjeets> see you week after next, i'll be out next week for summit
15:49:38 <manjeets> thanks y'all
15:49:43 <manjeets> #endmeeting