15:16:05 <mpeterson> #startmeeting weekly meeting
15:16:05 <odl_meetbot> Meeting started Mon Jul 23 15:16:05 2018 UTC.  The chair is mpeterson. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:16:05 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:16:05 <odl_meetbot> The meeting name has been set to 'weekly_meeting'
15:16:16 <mpeterson> #topic Agenda
15:16:21 <mpeterson> what do we have for today?
15:16:28 <mpeterson> #info SBI
15:16:35 <mpeterson> #info L3
15:16:55 <mpeterson> anything else?
15:17:11 <mpeterson> manjeets, poothia___, shague ?
15:17:21 <manjeets> CI ?
15:17:26 <mpeterson> #info CI
15:17:52 <mpeterson> okey, if you have any other let me know and we'll add it
15:18:04 <mpeterson> oh one more
15:18:24 <mpeterson> #info removal of fullstack and useless tests
15:18:30 <mpeterson> #topic SBI
15:18:49 <mpeterson> okey, we wanted to try to get this in for rocky
15:19:01 <mpeterson> but I don't think this will happen at the current pace
15:19:28 <mpeterson> the freeze is REALLY soon
15:19:59 <mpeterson> and the most important patch would be the first one, as it has the DB migrations and thus is not a backport candidate
15:20:13 <mpeterson> can we put an effort in merging that at least?
15:20:45 <manjeets> i'll take a look at it today or tomorrow
15:20:47 <mpeterson> NOTE: it's missing the migrations now that I say that out loud... I'll add them tomorrow...
15:20:50 <mpeterson> but please review the code
15:21:08 <mpeterson> because if we have that, perhaps the driver v3 could be backported once done
15:21:15 <mpeterson> as it shouldn't have any migrations at all
15:21:27 <mpeterson> manjeets: thanks!
15:21:47 <mpeterson> #action all to review SBI before the freeze!
15:21:53 <mpeterson> #info L3
15:22:02 <mpeterson> same for this, we want this before the freeze
15:22:13 <mpeterson> that one already has my +2
15:22:29 <manjeets> we need mike's review there
15:22:37 <mpeterson> so mkolesni should review and approve as soon as he is back from his sick leave
15:22:44 <mpeterson> he's got a virus or something
15:23:02 <mpeterson> if not, worst case scenario we'll +W anyways
15:23:11 <mpeterson> manjeets: I do have a question though
15:23:23 <manjeets> manjeets, suure
15:23:32 <mpeterson> do you think the patches on neutron that allow this to work could be backported in the future?
15:23:51 <mpeterson> because this is supposed to fix L3 in a better way than the current fixes
15:24:04 <mpeterson> so we could ditch the old L3 and replace with L3 flavors
15:24:05 <manjeets> mpeterson, all the patches in neutron and neutron-lib are already merged
15:24:19 <manjeets> which were required for this to work
15:24:28 <mpeterson> manjeets: right, but if we would want to backport queens for instance
15:25:06 <mpeterson> as not everyone that uses OS will rush to use rocky once it's out
15:25:13 <manjeets> manjeets, couple of bug fixes were backported, but we added callback priority mechanism which I doubt can be backported
15:25:31 <mpeterson> manjeets: that's what I thought :/
15:25:46 <mpeterson> manjeets: that's a pitty
15:25:55 <manjeets> mpeterson, I won't recommend backporting a new driver tbh
15:26:41 <mpeterson> manjeets: yeah, but if it's the only solution for bugs that might arise then perhaps it's the last resort
15:26:52 <mpeterson> manjeets: we'll cross that bridge when and if it presents
15:27:34 <mpeterson> okey, ready to continue to the next topic, manjeets ?
15:27:46 <manjeets> mpeterson, neutron i guess only need one backport of patch, callback mechanism was added to neutron-lib, so using that version of lib with backported to neuton in worst case ?
15:28:17 <mpeterson> manjeets: yeah, I guess we need to analyse feasability
15:28:46 <mpeterson> manjeets: let's move on
15:28:49 <manjeets> anyway i'll create a list of patches that were done in neutron-lib and neutron and send it to you
15:28:50 <mpeterson> #topic CI
15:28:56 <mpeterson> manjeets: awesome! thanks!
15:29:26 <mpeterson> #action manjeets (for the previous topic) to create a list of patches needed for in neutron(-lib) for L3 flavors
15:29:33 <mpeterson> okey, CI
15:29:38 <manjeets> stable/queens is fixed
15:29:43 <mpeterson> manjeets: thanks for that
15:30:33 <manjeets> openstack/requirements merged a patch which broke everything (required zuulv3) when we got close to getting zuul v3 in queens team reverted that patch
15:30:53 <manjeets> so minor fixes to mkolesni's existing patch made it pass
15:31:02 <mpeterson> awesome
15:31:46 <mpeterson> do you reckon the same would apply to pike as well? do we even care about pike?
15:31:49 <mpeterson> :)
15:32:30 <manjeets> mpeterson, I have to look into reason for pike failure, if it is just nexus odl url failure then it could fix pike as well
15:33:00 <manjeets> wait someone cherrypicked it to pike
15:33:15 <manjeets> https://review.openstack.org/#/c/584872/
15:33:42 <manjeets> but it is still failing
15:33:44 <mpeterson> manjeets: and it's -1 :)
15:33:56 <mpeterson> manjeets: I wouldn't put an effort to fix it now TBH
15:34:04 <mpeterson> manjeets: we have more pressing matters
15:34:22 <manjeets> yea stable/pike is the lowest priority
15:35:21 <mpeterson> manjeets: great
15:35:22 <manjeets> manjeets, looked at logs seems like url is still the issue, since there's difference b/w queens ci and pike ci job definition so just cherrypick may not work
15:35:27 <manjeets> need some extra tweaking
15:35:58 <manjeets> mpeterson, ^^
15:36:06 <mpeterson> just a FYI, your local tox environments are probably broken and require https://review.openstack.org/#/c/584791/
15:36:51 <mpeterson> manjeets: support for it will be dropped once rocky is released so let's not wait a second on it
15:37:16 <manjeets> manjeets, beta versions are allowed in requirements or lower-constraints.txt ?
15:37:18 <mpeterson> manjeets: at least not now, now let's focus on the FF for SBI and L3
15:37:40 <manjeets> mpeterson, why I am referring myself, sorry the m + tab is messing it
15:37:41 <mpeterson> manjeets: the requirements job didn't complain
15:37:51 <mpeterson> manjeets: yeah, don't worry
15:38:06 <manjeets> ohk, i'll look at it
15:38:42 <mpeterson> manjeets: and if they don't want beta versions then they should change the job ;)
15:38:53 <mpeterson> manjeets: other projects also merged beta versions anyways
15:39:21 <mpeterson> manjeets: I actually tried 13.0.0 but pip ignores beta versions unless it is actually a beta in the requirements
15:39:23 <manjeets> mpeterson, fair enough ! assuming requirements jobs should complain if that's not allowed
15:40:11 <mpeterson> manjeets: okey, I think that covers CI and related
15:40:39 <manjeets> mpeterson, whats the situation with fullstack ?
15:40:49 <mpeterson> #topic removal of fullstack and other useless tests
15:41:08 <mpeterson> manjeets: fullstack we'd love to remove the job and the code associated with it
15:41:21 <mpeterson> manjeets: as we talked in the previous meeting, IDK if you had time to review it's code
15:41:24 <mpeterson> *its
15:41:57 <manjeets> oh yes, I totally forgot, I've added a reminder to review it this week
15:42:28 <mpeterson> manjeets: thanks, I appreciate it
15:42:43 <mpeterson> manjeets: and please review the patch from mike to narrow down tempest
15:42:58 <mpeterson> manjeets: which I think it's quite a useful patch
15:43:02 <manjeets> mpeterson, sure !
15:43:26 <mpeterson> manjeets: with it tempest is way more stable and we could consider enabling it
15:43:38 <mpeterson> that's the end of it
15:43:43 <manjeets> https://review.openstack.org/#/c/582176/ ?
15:43:53 <mpeterson> manjeets: correct
15:44:27 <mpeterson> any other topics to discuss? if not I'll give you 15' of your life so you can go and review review and review :)
15:45:00 <manjeets> mpeterson, i have a question its also disabling api.network tests ?
15:45:14 <manjeets> api.network is relevant to ODL right ?
15:46:34 <mpeterson> manjeets: we would need to check.. you could comment that
15:47:09 <mpeterson> manjeets: although what I think he did is run tempest with ODL off and the tests that passed anyways were removed from the test list
15:47:38 <mpeterson> manjeets: so it could be that those tests are only testing the neutron api and not the interaction with ODL
15:47:47 <manjeets> I just asked over patch, will wait for his reply to +w
15:48:12 <mpeterson> manjeets: I think it's a good way to go
15:48:18 <mpeterson> okey, guys
15:48:23 <mpeterson> thanks a lot for your participation
15:48:27 <mpeterson> I think we can call it a day
15:48:34 <manjeets> thank you mpeterson :)
15:48:36 <mpeterson> go review! (or drink a coffee)
15:48:45 <mpeterson> #endmeeting