15:05:49 <mpeterson> #startmeeting weekly meeting
15:05:49 <odl_meetbot> Meeting started Mon Aug 27 15:05:49 2018 UTC.  The chair is mpeterson. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:05:49 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:49 <odl_meetbot> The meeting name has been set to 'weekly_meeting'
15:05:50 <mkolesni> mpeterson, ?
15:06:04 <mpeterson> #topic Agenda
15:06:13 <mpeterson> anything you want to discuss?
15:07:14 <mkolesni> ptg?
15:07:21 <mpeterson> #info PTG
15:07:24 <mpeterson> what else?
15:07:26 <mkolesni> what's the plan basically
15:07:39 <mkolesni> nothing else from me as i was on PTO last week
15:07:48 <manjeets> python3 migration of jobs which I see happening in neutron ?
15:07:57 <mpeterson> #info py3 goal
15:08:13 <mpeterson> anything else manjeets ?
15:08:33 <manjeets> hmm not any I could think of right now
15:08:37 <mpeterson> okey
15:08:40 <mpeterson> #topic PTG
15:08:51 <mpeterson> mkolesni: the floor is yours
15:09:11 <mkolesni> basically lets see whats the plan for ptg
15:09:17 <mkolesni> https://etherpad.openstack.org/p/networking-odl-stein-ptg
15:09:23 <mkolesni> currently there's two topics there
15:09:39 <mkolesni> I added bug scrubbing now
15:09:59 <mkolesni> do we want to discuss the py3 on ptg or is irc enough?
15:10:53 <manjeets> I've added there we can have a discussion for long term plan there but we can start over irc anyways ?
15:10:59 <mkolesni> we @RH plan to work on QoS and IPv6 but I'm not sure that IPv6 required anything in n-odl
15:11:19 <mpeterson> IRC should be enough and you can take it to the PTG if not
15:11:55 <mkolesni> also perhaps if we have enough time we can do some work on the CI?
15:12:16 <mpeterson> mkolesni: what kind of CI work?
15:12:41 <mkolesni> basically we need to stabilize the multinode & grenade jobs
15:12:56 <mkolesni> maybe i can sit with manjeets closely on this in our spare time and get it moving
15:13:06 <mkolesni> also consider https://etherpad.openstack.org/p/networking-odl-ptg-rocky
15:13:12 <manjeets> mkolesni,  +1
15:13:13 <mkolesni> probably some left overs there
15:13:46 <mpeterson> mkolesni: multinode and grenade is actually you should talk with afrittoli
15:13:58 <mkolesni> i also added -
15:13:59 <mkolesni> L3 Flavors stabilization
15:13:59 <mkolesni> Old L3 plugin deprecation
15:13:59 <mpeterson> mkolesni: he was porting them to zuulv3
15:14:07 <mkolesni> mpeterson, who dat?
15:14:18 <mpeterson> mkolesni: a tempest core
15:14:42 <mkolesni> mpeterson, ok and he's porting our jobs? or generally?
15:15:00 <mkolesni> also rally is not really testing anything, that still needs work
15:15:06 <mpeterson> mkolesni: he did the tempest zuulv3 porting and was working on grenade and multinode
15:15:14 <mpeterson> mkolesni: I was assisting him with reviews
15:15:30 <mkolesni> you mean in tempest repo?
15:15:37 <mpeterson> mkolesni: tempest and grenade repo
15:15:59 <manjeets> there's one other issue with grenade job
15:16:02 * mpeterson looks for the email
15:16:03 <mkolesni> mpeterson, ok
15:16:19 <manjeets> neutron-lib is not adopted in grenade repo so there are some hacks already
15:16:23 <mpeterson> mkolesni: http://lists.openstack.org/pipermail/openstack-dev/2018-February/127588.html
15:16:48 <mpeterson> manjeets, mkolesni: I think grenade is a good topic to discuss in the PTG
15:17:11 <manjeets> I tried patching that but there was no response from grenade community if I recall
15:17:27 <mpeterson> manjeets: that's what makes it a good topic
15:17:36 <mpeterson> because I had the same when I was looking into it
15:17:50 <mpeterson> and it seems no one cares about it, so why should we?
15:17:50 <mkolesni> let's try to catch these guys there then
15:18:13 <manjeets> yea, or move the entire logic to project repos
15:18:23 <mpeterson> right
15:18:30 <manjeets> otherwise its very hard to keep up tbh
15:19:18 <mkolesni> what about these items from rocky ptg planning?
15:19:18 <mpeterson> ok, anything else PTG related? there is one extra week until you fly there. Let's make an action to revise this list by next week?
15:19:18 <mkolesni> (yamahata) fullsync/recovery continued. We've worked on it for two cycles so that we'd like to close it in early Rocky cycle.
15:19:19 <mkolesni> (yamahata) networking-sfc NSH
15:19:19 <mkolesni> (mpeterson) UT of ML2 Mechanism drivers
15:19:19 <mkolesni> (manjeets) clean and organize bash configuration scripts in networking-odl (https://bugs.launchpad.net/networking-odl/+bug/1751344)
15:19:49 <mkolesni> as long as everyone whos anyone is here lets try to close it as much as we can
15:19:50 <mpeterson> #action all to add topics and review the list at https://etherpad.openstack.org/p/networking-odl-stein-ptg
15:20:22 <mpeterson> can you refresh me the n-sfc NSH thingy?
15:20:26 <mpeterson> mkolesni: ^
15:20:41 <mpeterson> my topic is resolved by now
15:20:49 <mkolesni> mpeterson, that one is from yamahata but maybe manjeets knows
15:21:10 <mpeterson> manjeets' topic is still relevant IMHO
15:21:17 <manjeets> mpeterson, we wanted to enable n-sgc with NSH
15:21:21 <manjeets> sfc**
15:21:48 <mpeterson> manjeets: it's something that's still relevant for you?
15:21:57 <manjeets> so OVS 2.9 released some new features related to NSH and we wanted to make sure they're enabled with ODL
15:22:14 <manjeets> mpeterson, I tested the driver itself needs no update in n-odl
15:22:24 <manjeets> because co-relation NSH is accepted
15:22:48 <manjeets> but we need to do end to end testing to make sure ODL side is not incomplete or work as intended
15:23:09 <mkolesni> manjeets, are there tempest tests for that?
15:23:20 <manjeets> mkolesni, I don't think so
15:23:34 <mkolesni> manjeets, maybe its something you'd like to add?
15:23:42 <manjeets> there are in neutron but i don't think those are work in n-odl
15:23:51 <mkolesni> in case of E2E testing this sounds like a good way to me
15:24:14 <mkolesni> maybe you can get them to work in odl gate?
15:24:29 <manjeets> mkolesni, sure, but need more investigation to figure out what can be done
15:24:55 <manjeets> there are testcases already in tempest but we need to figure out what to enable or what not
15:24:56 <mkolesni> ok sure
15:25:20 <mkolesni> btw do we also need to migrate to storyboard?
15:25:40 <mkolesni> idk whats the state of that with neutron i guess we'll follow their lead on this
15:28:27 <mpeterson> mkolesni: yes, we should migrate to SB
15:28:43 <mkolesni> exciting indeed
15:29:01 <manjeets> story board ? you mean for tickets I didn't get that ?
15:30:39 <mkolesni> theres a general migration of openstack from launchpad to storyboard
15:30:42 <mkolesni> god knows why
15:30:52 <mkolesni> at least one god :)
15:31:09 <manjeets> ohk but what's wrong with launchpad
15:31:11 <manjeets> ?
15:31:50 <mpeterson> manjeets: this is the openstack in-house system... why? well...
15:32:32 <mpeterson> mkolesni: re that https://docs.openstack.org/infra/storyboard/migration.html
15:33:04 <mpeterson> from there... Why are we using Storyboard? It was designed for the OpenStack use case and the ability to manage cross project efforts. It is managed by OpenStack and so it can be fixed and changed quickly.
15:33:08 <mpeterson> manjeets: ^^
15:33:47 <manjeets> ok, I'll read it and get myself lighted on that thanks mpeterson
15:34:12 <mpeterson> manjeets: more for your reading pleasure https://wiki.openstack.org/wiki/StoryBoard
15:35:28 <mkolesni> like it really matters
15:35:44 <mkolesni> anyway we need to follow the herd, and the closes sheep is neutron core :)
15:35:49 <mkolesni> closest*
15:37:06 <mpeterson> anyways... anything else on this?
15:37:12 <mpeterson> if not let's move to the next topic
15:37:25 <mkolesni> manjeets, mpeterson, please look at "left overs from Queens cycle" and tell me if anything there is still relevant
15:37:48 <mpeterson> #action manjeets and mpeterson to look at "left overs from Queens cycle" and tell mkolesni
15:37:55 <mpeterson> #topic py3 goal
15:37:58 <manjeets> sure !
15:38:06 <mkolesni> mpeterson, manjeets even dont tell me just add it to the stein ptg doc
15:38:26 <mpeterson> mkolesni: IDK the action is quite specific... wouldn't want to be a rebel...
15:38:38 <manjeets> mkolesni, you mean queens left overs or rocky left overs ?
15:38:47 * mkolesni smacks mpeterson
15:39:02 <mkolesni> the one named 'queens leftovers' from the rocky ptg plan
15:39:06 * mpeterson rubs his face with a WTF face
15:39:06 <mkolesni> i know, confusing :)
15:39:13 <manjeets> lol
15:39:15 <mkolesni> tf.. tf..
15:40:32 <mpeterson> okey manjeets py3 goal
15:40:55 <manjeets> so neutron have many voting jobs for py3 already
15:41:03 <manjeets> I guess we only have unit tests one
15:41:25 <manjeets> should we have tempest-py3 , functional-py3 jobs as well ?
15:41:36 <manjeets> I think those atleast those two should be done
15:41:42 <mkolesni> guys i have to go
15:41:47 <mkolesni> ill see u next week
15:41:48 <manjeets> mkolesni, mpeterson what do you guys think ?
15:42:01 <mkolesni> sounds good all jobs need to move to py3
15:42:03 <mpeterson> manjeets: we will inherit the py3 jobs from the infra team, there are some champions working on it
15:42:05 <mkolesni> bye
15:42:35 <manjeets> mpeterson, we still need some fixes in n-odl code while adding those jobs ?
15:42:44 <mpeterson> manjeets: we need to, at some point, change tox to use py3 ...
15:43:03 <mpeterson> manjeets: our code is py3 compatible with the exception of the functional tests
15:43:10 <mpeterson> mkolesni: bye
15:43:27 <mpeterson> manjeets: the rest there are some modifications once py2 is dropped
15:43:41 <mpeterson> manjeets: but we are one cycle away at least from py2 droppage
15:44:09 <manjeets> agree
15:44:24 <mpeterson> manjeets: but for now we are quite on track with the py3 goal
15:44:37 <manjeets> but we need to add jobs definitions in.zuul.d/
15:45:00 <mpeterson> manjeets: we could ask doug hellman that we volunteer to be one of the first to migrate, I'd be okey with that
15:45:42 <mpeterson> manjeets: whatever actions in the projects will be done by the goal champions and once done we need to pick up what's broken and fix it
15:45:52 <manjeets> so do me
15:45:57 <manjeets> ok
15:46:14 <manjeets> lets keep close eye on champions
15:46:18 <mpeterson> manjeets: but we are not the ones to start the work, we just wait and then fix when the automated migration fails (if it does)
15:46:44 <mpeterson> manjeets: I'm following doug's updates weekly
15:47:00 <manjeets> is it emails or something ?
15:47:07 <manjeets> I need to follow them too
15:47:35 <mpeterson> manjeets: yeah, he sends on openstack-dev emails with [goal][python3]
15:47:45 <mpeterson> or [goals]
15:48:10 <mpeterson> == Reference Material ==
15:48:13 <mpeterson> Goal description: https://governance.openstack.org/tc/goals/stein/python3-first.html
15:48:15 <mpeterson> Open patches needing reviews: https://review.openstack.org/#/q/topic:python3-first+is:open
15:48:17 <mpeterson> Storyboard: https://storyboard.openstack.org/#!/board/104
15:48:18 <manjeets> yea I need a mailbox cleanup or better filters so that I don't miss important details
15:48:19 <mpeterson> Zuul migration notes: https://etherpad.openstack.org/p/python3-first
15:48:21 <mpeterson> Zuul migration tracking: https://storyboard.openstack.org/#!/story/2002586
15:48:23 <mpeterson> Python 3 Wiki page: https://wiki.openstack.org/wiki/Python3
15:48:25 <mpeterson> manjeets: ^^
15:48:33 <manjeets> thanks manjeets !
15:48:44 <manjeets> mpeterson, ^^ I mean
15:49:10 <mpeterson> manjeets: this is a good read to start with http://lists.openstack.org/pipermail/openstack-dev/2018-August/133232.html
15:49:17 <mpeterson> manjeets: sure thing
15:49:31 <mpeterson> manjeets: want to wrap this meeting up?
15:49:45 <manjeets> ohk cool ! yea I need to catch up a lot
15:49:49 <manjeets> lets meet next week
15:50:02 <mpeterson> manjeets: awesome! good luck and welcome back!
15:50:04 <manjeets> see you next week have a good one
15:50:15 <mpeterson> #endmeeting